ubuntu/+source/nvidia-prime:ubuntu/trusty-devel

Last commit made on 2016-11-22
Get this branch:
git clone -b ubuntu/trusty-devel https://git.launchpad.net/ubuntu/+source/nvidia-prime
Members of Ubuntu Server Dev import team can upload to this branch. Log in for directions.

Branch merges

Branch information

Name:
ubuntu/trusty-devel
Repository:
lp:ubuntu/+source/nvidia-prime

Recent commits

0326c82... by Alberto Milone on 2016-11-21

Import patches-unapplied version 0.6.2.1 to ubuntu/trusty-proposed

Imported using git-ubuntu import.

Changelog parent: e5d27735dd72784e49da2d5aa7ce1e709363a331

New changelog entries:
  * debian/postrm.in, prime-select: backport from yakkety's 0.8.4:
    - Add support for EGL alternatives (LP: #1642662).
    - Simplify the logic for enablement by getting rid of legacy code
      that is only relevant to Ubuntu <= 12.04. This is now possible
      thanks to the fact that we allow installing only one binary
      driver at the time.
    - Do not try to remove the old xorg.conf.

e5d2773... by Alberto Milone on 2014-03-31

Import patches-unapplied version 0.6.2 to ubuntu/trusty-proposed

Imported using git-ubuntu import.

Changelog parent: 6fb38ee5b2c8c315df59905225d64674a819cb84

New changelog entries:
  * prime-supported:
    - Check /var/lib/ubuntu-drivers-common/requires_offloading to
      know if we need to offload rendering. There's no need to do
      hardware detection again when the gpu-manager already does
      all the work.

6fb38ee... by Alberto Milone on 2014-03-13

Import patches-unapplied version 0.6.1 to ubuntu/trusty-proposed

Imported using git-ubuntu import.

Changelog parent: 671400eb997cccd2c0fb86874815aff9ebb421f4

New changelog entries:
  * debian/preinst.in, debian/rules:
    - Move the lightdm configuration file from /etc to /usr/share.

671400e... by Alberto Milone on 2014-03-06

Import patches-unapplied version 0.6 to ubuntu/trusty-proposed

Imported using git-ubuntu import.

Changelog parent: b2d0d4ea1a7a268f8baf84fc9b107a1844af0385

New changelog entries:
  * debian/control:
    - Breaks: ubuntu-drivers-common (<< 1:0.2.89).
  * Add support for the new ubuntu-drivers-common. The gpu-manager
    will take care of most of the work. We only need to tell
    lightdm that we want to offload rendering, and to run the
    gpu-manager on log out.

b2d0d4e... by Alberto Milone on 2014-02-21

Import patches-unapplied version 0.5.7 to ubuntu/trusty-proposed

Imported using git-ubuntu import.

Changelog parent: dc37f94e4ecf5795b0204a68b931e01a7a0ec704

New changelog entries:
  * debian/preinst.in:
    - Do not remove the lightdm configuration file.

dc37f94... by Alberto Milone on 2014-02-21

Import patches-unapplied version 0.5.6 to ubuntu/trusty-proposed

Imported using git-ubuntu import.

Changelog parent: 3e2440695f6e933c3e3e3ace97d6926d45174cd6

New changelog entries:
  [ Daniel Dadap ]
  * prime-xconfig:
    - Format the BusID string correctly (LP: #1282796).
      The BusID string created by prime-xconfig had several problems:
      1) It was missing the bus type "PCI", as recommended by
         xorg.conf(5).
      2) Values were written in hexadecimal, as reported by lspci,
         instead of decimal, as expected by the server. (See the
         comment at the top of xf86ParsePciBusString().)
      3) The PCI domain was not specified.
      Giving the BusID string in the wrong format could cause the X
      server to fail to parse the BusID, or to parse numbers in the
      wrong base. On systems with more than one PCI domain, `lspci -n`
      output would include the domain number, which is omitted by
      default on systems with only one PCI domain. nv_get_id()
      expects the bus number to be the first field, which would not be
      correct when `lspci -n` reports the domain, as it does on
      systems with multiple domains.
      Fix these issues by always reporting the domain with `lspci -Dn`
      and using it in the BusID string, prepending "PCI:" to the
      BusID string, and printing all numeric values in decimal.

3e24406... by Alberto Milone on 2014-01-31

Import patches-unapplied version 0.5.5 to ubuntu/trusty-proposed

Imported using git-ubuntu import.

Changelog parent: 7c65a88957904e44f4bcd83c4f9e1ee5b119cdd8

New changelog entries:
  * debian/rules:
    - Fix path to lightdm configuration files.

7c65a88... by Alberto Milone on 2014-01-28

Import patches-unapplied version 0.5.4 to ubuntu/trusty-proposed

Imported using git-ubuntu import.

Changelog parent: cdb09ec0a991a731d48754d28c9f2ff00db193b8

New changelog entries:
  * Do not touch lightdm.conf any more on anything newer than Precise.
    90-nvidia.conf now contains only the relevant settings for PRIME
    (LP: #1267442).
  * Also remove any previous lightdm.conf that nvidia-prime might
    have messed up.
  * Major packaging clean-up. The variable in debian/rules and in
    templates have clearer names now.
  * Clean up the old 90-nvidia.conf that we used to ship in /etc.

cdb09ec... by Alberto Milone on 2014-01-10

Import patches-unapplied version 0.5.3 to ubuntu/trusty-proposed

Imported using git-ubuntu import.

Changelog parent: 2eba0c88f5acbf38e1ed5d4bdb75591d68fb70e8

New changelog entries:
  * debian/postrm.in, debian/rules:
    - Avoid calling dpkg-architecture (LP: #1264611).
  * prime-xconfig:
    - Properly format hexadecimal parameters (LP: #1252667).

2eba0c8... by Alberto Milone on 2013-12-20

Import patches-unapplied version 0.5.2 to ubuntu/trusty-proposed

Imported using git-ubuntu import.

Changelog parent: 8fe7c8e4aa17d09e13351c0434d8986e57286b18

New changelog entries:
  * debian/control:
    - Add an alternative dependency on gdm and kdm
      so that gdm or kdm users are not forced to install
      lightdm now that nvidia depends on nvidia-prime.
      This fixes only the single graphics card use case
      (hybrid graphics won't still work without lightdm)
      but it's a step in the right direction (LP: #1262068).
  * debian/preinst.in:
    - Set the lightdm configuration bits only if lightdm
      is the default display manager.