ubuntu/+source/nut:ubuntu/wily

Last commit made on 2015-10-12
Get this branch:
git clone -b ubuntu/wily https://git.launchpad.net/ubuntu/+source/nut
Members of Ubuntu Server Dev import team can upload to this branch. Log in for directions.

Branch merges

Branch information

Name:
ubuntu/wily
Repository:
lp:ubuntu/+source/nut

Recent commits

b6d96c7... by Robie Basak on 2015-10-12

Import patches-unapplied version 2.7.1-1ubuntu5 to ubuntu/wily-proposed

Imported using git-ubuntu import.

Changelog parent: c938deb77a72a36254ae7cb762f880db3e799294

New changelog entries:
  * Fix dep8 test failures:
    - Drop python-unit from dep8 dependencies since the python-test
      package has now been removed. The unittest module has shipped with
      Python since 2.1.
    - Add dep8 test dependency on python, since Python 2 is required and
      is not necessarily installed by default any more.

c938deb... by Tuomas Heino on 2014-12-26

Import patches-unapplied version 2.7.1-1ubuntu4 to ubuntu/vivid-proposed

Imported using git-ubuntu import.

Changelog parent: 33fab007bcee39561ece93bf868956761870be48

New changelog entries:
  * debian/patches/0006-ups-conf-reorder.patch: Move maxretry setting
    above Examples section, closer to the "outside of a driver definition"
    comment. (LP: #1405822)

33fab00... by Martin Pitt on 2014-07-07

Import patches-unapplied version 2.7.1-1ubuntu3 to ubuntu/utopic-proposed

Imported using git-ubuntu import.

Changelog parent: 2247addb4831a01e98c1c5c04d5040f075b6ed39

New changelog entries:
  * debian/tests/test-nut.py: in the CVE_2012_2944 test, give nut at most 5
    seconds to shut down, instead of expecting it to be shut down immediately
    after sending the killall. (LP: #1291378)

2247add... by Martin Pitt on 2014-05-12

Import patches-unapplied version 2.7.1-1ubuntu2 to ubuntu/utopic-proposed

Imported using git-ubuntu import.

Changelog parent: f27e9a0110ceb575235f0f7cf69e20294d6c0efe

New changelog entries:
  * Disable systemd unit; it does not check nut.conf whether nut is
    configured, and thus fails to start (and the package install). The init.d
    script works well enough for the time being. (LP: #1313231)

f27e9a0... by Matthias Klose on 2013-12-30

Import patches-unapplied version 2.7.1-1ubuntu1 to ubuntu/trusty-proposed

Imported using git-ubuntu import.

Changelog parent: 0b91a423791382dd91080e97d79ba42604751979

New changelog entries:
  * Merge with Debian; remaining changes:
    - debian/control:
      + remove Build-Depends on libpowerman0-dev
      + remove nut-powerman-pdu
    - debian/nut-powerman-pdu.{install,manpages}: dropped for now
    - debian/{nut-cgi,nut-server}.postinst: add nut to the dialout and nut
      groups unconditonally to handle the upgrade from hardy release.
    - debian/source_nut.py, debian/{nut,nut-server,nut-client}.install,
      debian/rules: Install apport hooks for all top-level nut packages.
    - debian/rules: Use udev version for Ubuntu
    - debian/series, debian/patches/backport-fix-lp753661.patch: re-enabled
  * Fix linking libupsclient.
  * Patch libtool.m4 and configure to support ppc64le.

0b91a42... by Laurent Bigonville on 2013-11-24

Import patches-unapplied version 2.7.1-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 4935cc58cd24d158d5f5c72dcbaeec1a64427b10

New changelog entries:
  * New upstream release (Closes: #730183)
    - Refresh debian/patches/0004-fix-systemd-service.patch
    - Rename libupsclient1 to libupsclient3 following the soname bump, rename
      libupsclient1-dev to libupsclient-dev, the package is not co-installable
      anyway
  * debian/rules, debian/control: Enable SSL support using libnss3
  * d/p/0005-Provide-retry-options-for-upsdrvctl-and-drivers.patch,
    d/p/0006-ups-conf-maxretry.patch: By default, retry to start the drivers
    up-to three times, this should mitigate races with slow devices
    (Closes: #694717)
  * debian/nut-server.install, debian/nut-server.manpages: Install new drivers
  * Move bash-completion file to /usr/share/bash-completion/
  * debian/patches/0007-killpower-path.patch: Revert POWERDOWNFLAG back to
    /etc/killpower
  * debian/nut-client.lintian-overrides: Add override for
    systemd-no-service-for-init-script ups-monitor
  * debian/rules: Drop static ordering for the initscripts and pass
    --restart-after-upgrade option to dh_installinit and dh_systemd_start to
    minimize the downtime of the daemons

4935cc5... by Laurent Bigonville on 2013-07-11

Import patches-unapplied version 2.6.5-4 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 0ba193effcf3a409184da8ce3303f5936fd11eda

New changelog entries:
  * debian/control: Do not build nut-ipmi on hurd-i386 as freeipmi is not
    available on that platform.

0ba193e... by Laurent Bigonville on 2013-07-10

Import patches-unapplied version 2.6.5-3 to debian/sid

Imported using git-ubuntu import.

Changelog parent: e01f59937e5f4e99d21621e5d76b11305e0a2273

New changelog entries:
  [ Laurent Bigonville ]
  * debian/control:
    - Move libupsclient1 package to libs Section
    - Add libgd-dev to the Build-Depends, keep the other alternatives to ease
      the backports
    - Bump Standards-Version to 3.9.4 (no further changes)
    - Add autotools-dev to the build-dependencies so config.{guess,sub} are
      getting updated during build
    - Use canonical URL for the VCS-* fields
    - Add build-dependency against dh-systemd and bump minimal cdbs version so
      systemd helpers are called during build.
  * Added dep-8-tests to improve QA (from Ubuntu, closes: #708130)
  * debian/nut-monitor.menu, nut-monitor.xpm: Add Debian menu entry (Closes:
    #708813)
  * debian/rules: Drop manual creation of .service files symlink, this should
    be handled by dh_systemd now
  * debian/patches/0004-fix-systemd-service.patch: Also add Wants/Before for
    systemd-udev-settle.service in the nut-driver.service as it got renamed
    after udev merge
  * debian/patches/0004-fix-systemd-service.patch: Fix path for upsdrvctl in
    scripts/systemd/nutshutdown.in
  [ Ivo De Decker ]
  * debian/nut-client.preinst: also revert /etc/nut/nut.conf mangling done
    by postinst during upgrade from lenny to squeeze (Really closes: #677054)
    Thanks to Andreas Beckmann for the review.

e01f599... by Laurent Bigonville on 2013-01-31

Import patches-unapplied version 2.6.5-2 to debian/experimental

Imported using git-ubuntu import.

Changelog parent: 656d80b13371db013e65532b4a1a3b128bccb13e

New changelog entries:
  [ Laurent Bigonville ]
  * debian/control: Move the nut-monitor Suggests from nut-server to
    nut-client
  * Restore proper SELinux context for runtime created /var/run/nut directory
  * debian/control: Fix typo in package description
  * debian/watch: Update watch file URL (Thanks to Bart Martens)
  * debian/rules: Alias systemd nut-monitor service file to nut-client to
    prevent it from running twice
  * d/p/0004-fix-systemd-service.patch: Fix systemd service file for Debian
  * Install tmpfiles conf files to create /run/nut directory during boot
  [ S├ębastien Villemot ]
  * debian/nut-client.preinst: revert /etc/nut/nut.conf mangling done by older
    versions of the postinst (Closes: #677054)
  [ Ivo De Decker ]
  * Only fix permissions of configfiles on first install.
  * Only remove /etc/init.d/nut from previous versions of nut in nut-server
    postinst if there are no local changes.
  * Also remove /etc/init.d/nut in nut-client postinst. Thanks to
    Laurent Bigonville for the hint.

656d80b... by Laurent Bigonville on 2012-08-12

Import patches-unapplied version 2.6.5-1 to debian/experimental

Imported using git-ubuntu import.

Changelog parent: 0e3166762426ad7702928398a6daed90411e8e03

New changelog entries:
  [ Arnaud Quette ]
  * debian/control, debian/nut-ipmi.{install,manpages}: create IPMI
    support package
  * debian/nut-server.install: only install USB udev rules
  [ Laurent Bigonville ]
  * New upstream release
    - Drop debian/patches/0001-fix-upsmon-regression.patch, applied upstream
  * Follow multi-arch policy
  * Install systemd .service files (Closes: #679450)
  * debian/nut-server.install: Drop newmge-shut, renamed upstream to mge-shut
    and install the old implementation (oldmge-shut) instead
  * debian/control: Drop ancient Conflicts/Provides/Replaces
  * Install all development files under /usr