ubuntu/+source/nut:ubuntu/trusty-devel

Last commit made on 2017-08-31
Get this branch:
git clone -b ubuntu/trusty-devel https://git.launchpad.net/ubuntu/+source/nut
Members of Ubuntu Server Dev import team can upload to this branch. Log in for directions.

Branch merges

Branch information

Name:
ubuntu/trusty-devel
Repository:
lp:ubuntu/+source/nut

Recent commits

5d1f6e3... by Christian Ehrhardt  on 2017-08-28

Import patches-unapplied version 2.7.1-1ubuntu1.2 to ubuntu/trusty-proposed

Imported using git-ubuntu import.

Changelog parent: 6e8804072247e5f5e09eac318b1ee04652ef7b1a
Upload parent: c0c7f209a99a0eb8d883a3ad3db27280a0d6d293

New changelog entries:
  * Drop d/p/Fix-USB-permission-issues-related-to-Linux-udev.patch: this issue
    seems fixed via other updates and is no more reproducible (LP 1099947).

c0c7f20... by Christian Ehrhardt  on 2017-08-28

changelog: 2.7.1-1ubuntu1.2 - refresh SRU to drop non repro issue

Signed-off-by: Christian Ehrhardt <email address hidden>

a2acf9c... by Christian Ehrhardt  on 2017-08-28

Revert "make udev rule apply correctly (LP: #1099947)."

This reverts commit 59ff69bae8e81580ba4710f29ee3799f4379075b.

6e88040... by Christian Ehrhardt  on 2017-08-17

Import patches-unapplied version 2.7.1-1ubuntu1.1 to ubuntu/trusty-proposed

Imported using git-ubuntu import.

Changelog parent: f27e9a0110ceb575235f0f7cf69e20294d6c0efe
Upload parent: cf891ef1a3cad5b5372ecb9330e85fa3aded7b96

New changelog entries:
  * debian/nut-server.postinst: The udevd process is called systemd-udevd for
    quite sometimes already, properly detect whether it's running or not, this
    should fix the devices permissions for USB UPS's (LP: #1540008)
  * d/p/Fix-USB-permission-issues-related-to-Linux-udev.patch: make udev
    rule apply correctly (LP: #1099947).

cf891ef... by Christian Ehrhardt  on 2017-08-17

changelog: make udev rule apply correctly (LP: #1099947).

Signed-off-by: Christian Ehrhardt <email address hidden>

59ff69b... by Christian Ehrhardt  on 2017-08-17

make udev rule apply correctly (LP: #1099947).

Signed-off-by: Christian Ehrhardt <email address hidden>

3749e6c... by Christian Ehrhardt  on 2017-08-17

changelog: d/nut-server.postinst: use correct udevd name (LP: #1540008)

Signed-off-by: Christian Ehrhardt <email address hidden>

025a4df... by Christian Ehrhardt  on 2017-08-17

d/nut-server.postinst: use correct udevd name (LP: #1540008)

Signed-off-by: Christian Ehrhardt <email address hidden>

f27e9a0... by Matthias Klose on 2013-12-30

Import patches-unapplied version 2.7.1-1ubuntu1 to ubuntu/trusty-proposed

Imported using git-ubuntu import.

Changelog parent: 0b91a423791382dd91080e97d79ba42604751979

New changelog entries:
  * Merge with Debian; remaining changes:
    - debian/control:
      + remove Build-Depends on libpowerman0-dev
      + remove nut-powerman-pdu
    - debian/nut-powerman-pdu.{install,manpages}: dropped for now
    - debian/{nut-cgi,nut-server}.postinst: add nut to the dialout and nut
      groups unconditonally to handle the upgrade from hardy release.
    - debian/source_nut.py, debian/{nut,nut-server,nut-client}.install,
      debian/rules: Install apport hooks for all top-level nut packages.
    - debian/rules: Use udev version for Ubuntu
    - debian/series, debian/patches/backport-fix-lp753661.patch: re-enabled
  * Fix linking libupsclient.
  * Patch libtool.m4 and configure to support ppc64le.

4a5c015... by Matthias Klose on 2013-12-30

Import version 2.7.1-1ubuntu1 to ubuntu/trusty-proposed

Imported using usd-importer.

Publish parent: f3cf6af791125c4d0869fde7a897b633b560db7d
Changelog parent: 43573a0800cb681e1624ce8a307152511efbd25a

New changelog entries:
  * Merge with Debian; remaining changes:
    - debian/control:
      + remove Build-Depends on libpowerman0-dev
      + remove nut-powerman-pdu
    - debian/nut-powerman-pdu.{install,manpages}: dropped for now
    - debian/{nut-cgi,nut-server}.postinst: add nut to the dialout and nut
      groups unconditonally to handle the upgrade from hardy release.
    - debian/source_nut.py, debian/{nut,nut-server,nut-client}.install,
      debian/rules: Install apport hooks for all top-level nut packages.
    - debian/rules: Use udev version for Ubuntu
    - debian/series, debian/patches/backport-fix-lp753661.patch: re-enabled
  * Fix linking libupsclient.
  * Patch libtool.m4 and configure to support ppc64le.