ubuntu/+source/nut:applied/ubuntu/yakkety

Last commit made on 2016-01-27
Get this branch:
git clone -b applied/ubuntu/yakkety https://git.launchpad.net/ubuntu/+source/nut
Members of Ubuntu Server Dev import team can upload to this branch. Log in for directions.

Branch merges

Branch information

Name:
applied/ubuntu/yakkety
Repository:
lp:ubuntu/+source/nut

Recent commits

b8a4fdd... by Louis Bouchard on 2015-12-03

Import patches-applied version 2.7.2-4ubuntu1 to applied/ubuntu/xenial-proposed

Imported using git-ubuntu import.

Changelog parent: 4e393a24217253257648e6e4083d415cec698917
Unapplied parent: ec16d2c4619da7e3a6b8d7c4a61af9d322e0f94d

New changelog entries:
  * Merge with Debian; remaining changes (LP: #1522346) :
    - debian/control:
      + remove Build-Depends on libpowerman0-dev
      + remove nut-powerman-pdu
    - debian/nut-powerman-pdu.{install,manpages}: dropped for now
    - debian/{nut-cgi,nut-server}.postinst: add nut to the group
      unconditonally, for compatibility with UPSes connected by serial port.
    - debian/source_nut.py, debian/{nut,nut-server,nut-client}.install,
      debian/rules: Install apport hooks for all top-level nut packages.
    - Patch libtool.m4 and configure to support ppc64le.
    - Disable systemd unit; it does not check nut.conf whether nut is
      configured, and thus fails to start (and the package install). The
      init.d script works well enough for the time being.
    - debian/tests/test-nut.py: in the CVE_2012_2944 test, give nut at most
      + 5 seconds to shut down, instead of expecting it to be shut down
        immediately after sending the killall.
      + Additional indication on how to run tests for oneiric, precise to
        vivid and wily+
    - debian/patches/0006-ups-conf-reorder.patch: Move maxretry setting
      above Examples section.
    - debian/tests/control : Fix dep8 test failures:
       + Drop python-unit from dep8 dependencies since the python-test
         package has now been removed. The unittest module has shipped with
         Python since 2.1.
       + Add dep8 test dependency on python, since Python 2 is required and
         is not necessarily installed by default any more.
   * Dropped changes:
     - Fix linking libupsclient : Superseded upstream
     - debian/patches/backport-fix-lp753661.patch: extraneous end-of-line now
       fixed differently upstream.
     - debian/rules: Use udev version for Ubuntu; delta no longer needed as
       both versions are earlier than the earliest supported udev in Ubuntu.
  [ Steve Langasek ]
  * debian/nut-{cgi,server}.postinst: fix 'adduser' logic to be
    unconditional, since adduser is guaranteed to be idempotent.

ec16d2c... by Louis Bouchard on 2015-12-03

ppc64el.diff

No DEP3 Subject or Description header found

Gbp-Pq: ppc64el.diff.

345105b... by Louis Bouchard on 2015-12-03

0009-fix-favorites-permissions.patch

No DEP3 Subject or Description header found

Gbp-Pq: 0009-fix-favorites-permissions.patch.

57f6d02... by Louis Bouchard on 2015-12-03

0008-drop-w3c-icons.patch

No DEP3 Subject or Description header found

Gbp-Pq: 0008-drop-w3c-icons.patch.

b918847... by Louis Bouchard on 2015-12-03

0007-killpower-path.patch

No DEP3 Subject or Description header found

Gbp-Pq: 0007-killpower-path.patch.

5976685... by Louis Bouchard on 2015-12-03

0006-ups-conf-maxretry.patch

No DEP3 Subject or Description header found

Gbp-Pq: 0006-ups-conf-maxretry.patch.

3314fdf... by Louis Bouchard on 2015-12-03

Fix systemd service file for Debian

Gbp-Pq: 0004-fix-systemd-service.patch.

0fcf799... by Louis Bouchard on 2015-12-03

0002-nut-monitor-paths.patch

No DEP3 Subject or Description header found

Gbp-Pq: 0002-nut-monitor-paths.patch.

ff825df... by Louis Bouchard on 2015-12-03

Adjust .pc paths to install development files to /usr

Gbp-Pq: 0003-install-dev-files-in-usr.patch.

b3381a5... by Louis Bouchard on 2015-12-03

Import patches-unapplied version 2.7.2-4ubuntu1 to ubuntu/xenial-proposed

Imported using git-ubuntu import.

Changelog parent: d9a56a4b50e1e8b884cc362971b5fe07fee12832

New changelog entries:
  * Merge with Debian; remaining changes (LP: #1522346) :
    - debian/control:
      + remove Build-Depends on libpowerman0-dev
      + remove nut-powerman-pdu
    - debian/nut-powerman-pdu.{install,manpages}: dropped for now
    - debian/{nut-cgi,nut-server}.postinst: add nut to the group
      unconditonally, for compatibility with UPSes connected by serial port.
    - debian/source_nut.py, debian/{nut,nut-server,nut-client}.install,
      debian/rules: Install apport hooks for all top-level nut packages.
    - Patch libtool.m4 and configure to support ppc64le.
    - Disable systemd unit; it does not check nut.conf whether nut is
      configured, and thus fails to start (and the package install). The
      init.d script works well enough for the time being.
    - debian/tests/test-nut.py: in the CVE_2012_2944 test, give nut at most
      + 5 seconds to shut down, instead of expecting it to be shut down
        immediately after sending the killall.
      + Additional indication on how to run tests for oneiric, precise to
        vivid and wily+
    - debian/patches/0006-ups-conf-reorder.patch: Move maxretry setting
      above Examples section.
    - debian/tests/control : Fix dep8 test failures:
       + Drop python-unit from dep8 dependencies since the python-test
         package has now been removed. The unittest module has shipped with
         Python since 2.1.
       + Add dep8 test dependency on python, since Python 2 is required and
         is not necessarily installed by default any more.
   * Dropped changes:
     - Fix linking libupsclient : Superseded upstream
     - debian/patches/backport-fix-lp753661.patch: extraneous end-of-line now
       fixed differently upstream.
     - debian/rules: Use udev version for Ubuntu; delta no longer needed as
       both versions are earlier than the earliest supported udev in Ubuntu.
  [ Steve Langasek ]
  * debian/nut-{cgi,server}.postinst: fix 'adduser' logic to be
    unconditional, since adduser is guaranteed to be idempotent.