ubuntu/+source/ntp:applied/ubuntu/wily-proposed

Last commit made on 2016-02-11
Get this branch:
git clone -b applied/ubuntu/wily-proposed https://git.launchpad.net/ubuntu/+source/ntp
Members of Ubuntu Server Dev import team can upload to this branch. Log in for directions.

Branch merges

Branch information

Name:
applied/ubuntu/wily-proposed
Repository:
lp:ubuntu/+source/ntp

Recent commits

1fb77f4... by Eric Desrochers on 2016-01-25

Import patches-applied version 1:4.2.6.p5+dfsg-3ubuntu8.2 to applied/ubuntu/wily-proposed

Imported using git-ubuntu import.

Changelog parent: a043e96eacf6422878718b0f9ec975b8107acacd
Unapplied parent: 0473e70b4eb4e4ccf801f505a15796abbc7abc2d

New changelog entries:
  * ntpd rejects source UDP ports less than 123 as bogus (closes: #691412)
    - d/p/reject-UDP-ports-less-than-123-as-bogus.patch (LP: #1479652)

0473e70... by Eric Desrochers on 2016-01-25

[Bug 2174] ntpd rejects source UDP ports less than 123 as bogus.

Gbp-Pq: reject-UDP-ports-less-than-123-as-bogus.patch.

4606746... by Eric Desrochers on 2016-01-25

[PATCH] [Bug 2941] NAK to the Future: Symmetric association

Gbp-Pq: CVE-2015-7871.patch.

305b321... by Eric Desrochers on 2016-01-25

[PATCH] [Sec 2922] decodenetnum() will ASSERT botch instead of

Gbp-Pq: CVE-2015-7855.patch.

99d124a... by Eric Desrochers on 2016-01-25

[PATCH] [TALOS-CAN-0064] signed/unsiged clash could lead to buffer

Gbp-Pq: CVE-2015-7853.patch.

1871f73... by Eric Desrochers on 2016-01-25

[PATCH] [TALOS-CAN-0063] avoid buffer overrun in ntpq

Gbp-Pq: CVE-2015-7852.patch.

054ee3e... by Eric Desrochers on 2016-01-25

[PATCH] [TALOS-CAN-0055] Infinite loop if extended logging enabled

Gbp-Pq: CVE-2015-7850.patch.

5e9a0e2... by Eric Desrochers on 2016-01-25

fix denial of service by spoofed KoD

Gbp-Pq: CVE-2015-7704.patch.

9a430d5... by Eric Desrochers on 2016-01-25

fix file overwrite via remote pidfile and driftfile

Gbp-Pq: CVE-2015-5196.patch.

e9acf9d... by Eric Desrochers on 2016-01-25

[PATCH] [Bug 2909] - Slow memory leak in CRYPTO_ASSOC - added

Gbp-Pq: CVE-2015-7701.patch.