ubuntu/+source/nginx:applied/ubuntu/zesty-devel

Last commit made on 2017-07-13
Get this branch:
git clone -b applied/ubuntu/zesty-devel https://git.launchpad.net/ubuntu/+source/nginx
Members of Ubuntu Server Dev import team can upload to this branch. Log in for directions.

Branch merges

Branch information

Name:
applied/ubuntu/zesty-devel
Repository:
lp:ubuntu/+source/nginx

Recent commits

014045a... by Steve Beattie on 2017-07-12

Import patches-applied version 1.10.3-1ubuntu3.1 to applied/ubuntu/zesty-security

Imported using git-ubuntu import.

Changelog parent: 0ada9ea728d44ddf723ecbc7f0a4e9fe7cbdbc31
Unapplied parent: 2521b7c4cf565443e9e1079055cb816f08317953

New changelog entries:
  * SECURITY UPDATE: integer overflow in range filter leading to
    information exposure
    - debian/patches/CVE-2017-7529.patch: add check to ensure size does
      not overflow
    - CVE-2017-7529

2521b7c... by Steve Beattie on 2017-07-12

Fix integer overflow in the range filter

Gbp-Pq: CVE-2017-7529.patch.

1500383... by Steve Beattie on 2017-07-12

Add Ubuntu token to NGINX_VER

Gbp-Pq: ubuntu-branding.patch.

1771370... by Steve Beattie on 2017-07-12

Use linker flags from environment for perl (dpkg-buildflags).

Gbp-Pq: perl-use-dpkg-buildflags.patch.

f632255... by Steve Beattie on 2017-07-12

SSL: support for multiple curves (ticket #885).

Gbp-Pq: 0006-SSL-support-for-multiple-curves-ticket-885.patch.

20f0a33... by Steve Beattie on 2017-07-12

SSL: style.

Gbp-Pq: 0005-SSL-style.patch.

2622a5f... by Steve Beattie on 2017-07-12

SSL: error messages style.

Gbp-Pq: 0004-SSL-error-messages-style.patch.

2717078... by Steve Beattie on 2017-07-12

Use _GNU_SOURCE on GNU/kFreeBSD

Gbp-Pq: 0003-define_gnu_source-on-other-glibc-based-platforms.patch.

fb11157... by Steve Beattie on 2017-07-12

Make sure signature stays the same in all nginx builds

Gbp-Pq: 0002-Make-sure-signature-stays-the-same-in-all-nginx-buil.patch.

3c5afd4... by Steve Beattie on 2017-07-12

Import patches-unapplied version 1.10.3-1ubuntu3.1 to ubuntu/zesty-security

Imported using git-ubuntu import.

Changelog parent: b5ced53961ab41280cf0abd561a0da02c549d74f

New changelog entries:
  * SECURITY UPDATE: integer overflow in range filter leading to
    information exposure
    - debian/patches/CVE-2017-7529.patch: add check to ensure size does
      not overflow
    - CVE-2017-7529