ubuntu/+source/nginx:applied/ubuntu/trusty-updates

Last commit made on 2017-07-13
Get this branch:
git clone -b applied/ubuntu/trusty-updates https://git.launchpad.net/ubuntu/+source/nginx
Members of Ubuntu Server Dev import team can upload to this branch. Log in for directions.

Branch merges

Branch information

Name:
applied/ubuntu/trusty-updates
Repository:
lp:ubuntu/+source/nginx

Recent commits

264bf00... by Steve Beattie on 2017-07-12

Import patches-applied version 1.4.6-1ubuntu3.8 to applied/ubuntu/trusty-security

Imported using git-ubuntu import.

Changelog parent: 0cd0c0a840c6cda51418b4ae8610e641d16a2f60
Unapplied parent: 47d0e38969c7b4ad47b8501337d9ea9e9a0574a2

New changelog entries:
  * SECURITY UPDATE: integer overflow in range filter leading to
    information exposure
    - debian/patches/CVE-2017-7529.patch: add check to ensure size does
      not overflow
    - CVE-2017-7529

47d0e38... by Steve Beattie on 2017-07-12

Fix integer overflow in the range filter

Gbp-Pq: CVE-2017-7529.patch.

7b585a9... by Steve Beattie on 2017-07-12

Fix NULL Pointer Dereference in CVE-2016-4450

Gbp-Pq: cve-2016-4450.patch.

4a8a1ae... by Steve Beattie on 2017-07-12

CVE-2016-074x-6.patch

No DEP3 Subject or Description header found

Gbp-Pq: CVE-2016-074x-6.patch.

bc3cef2... by Steve Beattie on 2017-07-12

CVE-2016-074x-5.patch

No DEP3 Subject or Description header found

Gbp-Pq: CVE-2016-074x-5.patch.

1fc1e24... by Steve Beattie on 2017-07-12

CVE-2016-074x-4.patch

No DEP3 Subject or Description header found

Gbp-Pq: CVE-2016-074x-4.patch.

99c34bb... by Steve Beattie on 2017-07-12

CVE-2016-074x-3.patch

No DEP3 Subject or Description header found

Gbp-Pq: CVE-2016-074x-3.patch.

742c93f... by Steve Beattie on 2017-07-12

CVE-2016-074x-2.patch

No DEP3 Subject or Description header found

Gbp-Pq: CVE-2016-074x-2.patch.

fbbb6be... by Steve Beattie on 2017-07-12

CVE-2016-074x-1.patch

No DEP3 Subject or Description header found

Gbp-Pq: CVE-2016-074x-1.patch.

a1881fd... by Steve Beattie on 2017-07-12

fix incorrect cached SSL session reuse

Gbp-Pq: CVE-2014-3616.patch.