ubuntu/+source/nginx:applied/ubuntu/precise-security

Last commit made on 2015-01-06
Get this branch:
git clone -b applied/ubuntu/precise-security https://git.launchpad.net/ubuntu/+source/nginx
Members of Ubuntu Server Dev import team can upload to this branch. Log in for directions.

Branch merges

Branch information

Name:
applied/ubuntu/precise-security
Repository:
lp:ubuntu/+source/nginx

Recent commits

ad36ebf... by Lev Lazinskiy

1.1.19-1ubuntu0.7 (patches applied)

Imported using git-ubuntu import.

e9eb664... by Lev Lazinskiy

Patch derived from upstream patch, to fix CVE-2014-3616.

Gbp-Pq: cve-2014-3616.diff.

e6acfda... by Lev Lazinskiy

CVE-2013-4547 - Fix an issue in which an attacker may be able to bypass security restrictions on certain configurations with specially crafted requests.

Gbp-Pq: cve-2013-4547.patch.

9d2d9a9... by Lev Lazinskiy

Patch derived from upstream patch, to fix CVE-2013-2070, which identified a vulnerability in proxy_pass

Gbp-Pq: cve-2013-2070.patch.

a6d471b... by Lev Lazinskiy

This patch applies upstream changes to fix a segfault bug when the first URI in try_files is shorter than the request URI. The patch was derived from upstream.

Gbp-Pq: uri_segfault_fix_LP1065555.patch.

95776e3... by Lev Lazinskiy

Use build flags from environment for perl (dpkg-buildflags).

Gbp-Pq: perl-use-dpkg-buildflags.patch.

77be3ca... by Lev Lazinskiy

1.1.19-1ubuntu0.7 (patches unapplied)

Imported using git-ubuntu import.

cb9045e... by Thomas Ward

1.1.19-1ubuntu0.6 (patches applied)

Imported using git-ubuntu import.

3ac0db5... by Thomas Ward

1.1.19-1ubuntu0.6 (patches unapplied)

Imported using git-ubuntu import.

988e58d... by Thomas Ward

CVE-2013-4547 - Fix an issue in which an attacker may be able to bypass security restrictions on certain configurations with specially crafted requests.

Gbp-Pq: cve-2013-4547.patch.