ubuntu/+source/network-manager-openvpn:applied/ubuntu/artful-devel

Last commit made on 2017-10-01
Get this branch:
git clone -b applied/ubuntu/artful-devel https://git.launchpad.net/ubuntu/+source/network-manager-openvpn
Members of Ubuntu Server Dev import team can upload to this branch. Log in for directions.

Branch merges

Branch information

Name:
applied/ubuntu/artful-devel
Repository:
lp:ubuntu/+source/network-manager-openvpn

Recent commits

1dde3f7... by Jeremy Bicha on 2017-10-01

Import patches-applied version 1.2.10-0ubuntu2 to applied/ubuntu/artful-proposed

Imported using git-ubuntu import.

Changelog parent: 6b31f2bc6ad615ee812d0539c3503d6aa8ea2b04
Unapplied parent: 693ded733fc5c9b0a724b12fa7de4b85bd1b097a

New changelog entries:
  * debian/network-manager-openvpn-gnome.install:
    - Install appstream metadata (LP: #1720539)

693ded7... by Jeremy Bicha on 2017-10-01

Support-IPv6-Servers.patch

No DEP3 Subject or Description header found

Gbp-Pq: Support-IPv6-Servers.patch.

76adeba... by Jeremy Bicha on 2017-10-01

Import patches-unapplied version 1.2.10-0ubuntu2 to ubuntu/artful-proposed

Imported using git-ubuntu import.

Changelog parent: bdf19b5c28b97f15e3fb0c57cc704c30afd2d644

New changelog entries:
  * debian/network-manager-openvpn-gnome.install:
    - Install appstream metadata (LP: #1720539)

6b31f2b... by Sebastien Bacher on 2017-09-01

Import patches-applied version 1.2.10-0ubuntu1 to applied/ubuntu/artful-proposed

Imported using git-ubuntu import.

Changelog parent: 8414fa9a3aa48bbe53b4424aff9f680159a7f472
Unapplied parent: e1a202838801577e4b4214f93e754471dad9b85b

New changelog entries:
  * New upstream version (ffe lp: #1714509)
    - Allow choosing Adaptive or None LZO compression methods in the
      connection properties dialog (lp: #1714509)
    - Add support for dynamic challenge-response protocol
    - Avoid passing the obsolete "tls-remote" option to OpenVPN versions
      that no longer support it and discourage its use in the properties
      dialog (lp: #1666912)

bdf19b5... by Sebastien Bacher on 2017-09-01

Import patches-unapplied version 1.2.10-0ubuntu1 to ubuntu/artful-proposed

Imported using git-ubuntu import.

Changelog parent: bee433cda48aa2b84b137e559c2761546e4aeedd

New changelog entries:
  * New upstream version (ffe lp: #1714509)
    - Allow choosing Adaptive or None LZO compression methods in the
      connection properties dialog (lp: #1714509)
    - Add support for dynamic challenge-response protocol
    - Avoid passing the obsolete "tls-remote" option to OpenVPN versions
      that no longer support it and discourage its use in the properties
      dialog (lp: #1666912)

e1a2028... by Sebastien Bacher on 2017-09-01

Support-IPv6-Servers.patch

No DEP3 Subject or Description header found

Gbp-Pq: Support-IPv6-Servers.patch.

8414fa9... by Sebastien Bacher on 2017-08-31

Import patches-applied version 1.2.6-2ubuntu3 to applied/ubuntu/artful-proposed

Imported using git-ubuntu import.

Changelog parent: 761028154648290e98fc8f50ae0f00394d2f746b
Unapplied parent: 037aa8161eb257100d626cd36b3cb25d6b581570

New changelog entries:
  * debian/control, debian/rules:
    - build with dh_translations

bee433c... by Sebastien Bacher on 2017-08-31

Import patches-unapplied version 1.2.6-2ubuntu3 to ubuntu/artful-proposed

Imported using git-ubuntu import.

Changelog parent: 79e8c621e42758d68de4815ffd8363353db2bd4f

New changelog entries:
  * debian/control, debian/rules:
    - build with dh_translations

037aa81... by Sebastien Bacher on 2017-08-31

Support-IPv6-Servers.patch

No DEP3 Subject or Description header found

Gbp-Pq: Support-IPv6-Servers.patch.

7610281... by Aron Xu on 2016-10-05

Import patches-applied version 1.2.6-2ubuntu1 to applied/ubuntu/yakkety-proposed

Imported using git-ubuntu import.

Changelog parent: fe64402580ad4e3118170cbb6c3bb813de54e923
Unapplied parent: 356aea24cbbbd23c3000636e2f39be01a92a7e71

New changelog entries:
  * Merge with Debian (LP: #1629132) Remaining changes:
    - Allow the "udp6" and "tcp6" protocols to be passed through to OpenVPN.
  * Don't run the tests in parallel for now until bgo#772464 is fixed.
    (Closes: #839848)
  * New upstream release.
    - Fix recent change in behavior for "comp-lzo=no" setting.
      (Closes: #833166)
  * Bump debhelper compat level to 10.
  * Drop Use-user-nobody-group-nogroup-when-exporting-an-OpenVPN-c.patch. This
    patch is no longer necessary as we now create a nm-openvpn system user in
    postinst. So we use that instead of nobody / nogroup when exporting an
    OpenVPN connection.
  * Imported Upstream version 1.2.4
  * Bump Build-Depends on libsecret-dev to (>= 0.18) as per configure.ac
  * Refresh patches
  * New upstream release.
  * Bump network-manager related build dependencies to >= 1.2.0.
  * Add Depends on network-manager (>= 1.2.0) to network-manager-vpnc. This
    ensures we have a version that can handle plugin paths which are not
    absolute. (Closes: #823062)
  * Bump Standards-Version to 3.9.8.
  * New upstream release.