ubuntu/+source/network-manager-applet:ubuntu/zesty-devel

Last commit made on 2017-03-08
Get this branch:
git clone -b ubuntu/zesty-devel https://git.launchpad.net/ubuntu/+source/network-manager-applet
Members of Ubuntu Server Dev import team can upload to this branch. Log in for directions.

Branch merges

Branch information

Name:
ubuntu/zesty-devel
Repository:
lp:ubuntu/+source/network-manager-applet

Recent commits

6c3b317... by Mathieu Trudel-Lapierre on 2017-03-08

Import patches-unapplied version 1.4.2-1ubuntu4 to ubuntu/zesty-proposed

Imported using git-ubuntu import.

Changelog parent: 4891431867567f4a1f8b8183a50392147cf4b40c

New changelog entries:
  * debian/patches/git_fix_libnma_pygobject_symbols.patch: fix symbol linking
    for libnma, so as to not mix libnm-util/libnm-glib and libnm code.
    (LP: #1667129)

4891431... by Marc Deslauriers on 2017-03-08

Import patches-unapplied version 1.4.2-1ubuntu3 to ubuntu/zesty-proposed

Imported using git-ubuntu import.

Changelog parent: 759cb782c0a53873be51aad4750cc0b41bd12738

New changelog entries:
  * SECURITY UPDATE: file access from login screen (LP: #1668321)
    - debian/patches/applet-Check-the-user-has-permission-to-modify-befor.patch:
      check permissions before showing dialog in src/applet-device-wifi.c.
    - No CVE number

759cb78... by Aron Xu on 2017-01-13

Import patches-unapplied version 1.4.2-1ubuntu2 to ubuntu/zesty-proposed

Imported using git-ubuntu import.

Changelog parent: b71bcbffb3c08fd4fd7d478857831027a669d7ea

New changelog entries:
  * Add patches for wwan options after logout/in (LP: #1651019):
     - device-broadband-use-define-for-devinfo-tag.patch
     - applet-re-add-broadband-devices-when-MM-becomes-avai.patch
     - device-broadband-check-that-the-ModemManager-is-actu.patch
  * debian/rules: allow parallel building

b71bcbf... by Jeremy Bicha on 2016-12-16

Import patches-unapplied version 1.4.2-1ubuntu1 to ubuntu/zesty-proposed

Imported using git-ubuntu import.

Changelog parent: acc57d3b7e593269c865a537454c34ae75c50f9e

New changelog entries:
  * Merge with Debian (LP: #1649045). Remaining changes:
    - lp341684_device_sensitive_disconnect_notify.patch:
      show correct notification messages for disconnect events, to be in
      line with the other *connect*text patches.
    - lp460144_correctly_update_notification.patch: cleaner notification
      messages, and allow for messages to be updated instead of cleared.
    - applet-wifi-menu-before-vpn.patch:
      show Create New and Connect to Hidden wifi menu items with the other
      Wifi items, rather than separated by the VPN menus.
    - Always-center-dialogs-on-the-screen.patch:
      position dialogs to the center of the screen.
    - Allow-to-create-and-connect-to-Ad-Hoc-RSN-networks.patch:
      Enable Ad-Hoc using WPA RSN
    - reorder-indicator-items.patch:
      Make sure devices show before networking toggles
    - Have-the-appindicator-enabled-by-default.patch:
      Enable the indicator by default
    - On-Ubuntu-we-use-premade-icons-for-the-indicator-VPN.patch:
      use '-secure'-suffixed icons when connected to the VPN, since we can't
      composit icons on the fly.
    - Make-sure-the-behavior-for-policykit-restricted-acti.patch,
      Implement-support-for-hiding-rather-than-desensitizi.patch:
      provide a method to desensitize or hide menu items which are useless
      given the current policykit policy level of the user.
    - debian/rules: ship extra icons, use --with-indicators, export
      translations for Launchpad
    - debian/control: Build-Depend on dh-translations, libappindicator3-dev,
      and libdbusmenu-gtk3-dev
  * Dropped changes:
    - debian/control: Breaks gnome-bluetooth << 3.0, not needed since 12.04 LTS
    - lower_dbusmenu_requirement.patch: No longer needed
    - applet-fix-handling-of-802.1x-secrets-for-ethernet-c.patch:
      Applied in new release

acc57d3... by Michael Biebl on 2016-10-04

Import patches-unapplied version 1.4.2-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 8ce31baf43656262f8a111913349cd85303306a3

New changelog entries:
  * New upstream release.
  * Drop override for dh_auto_test. We don't explicitly need to dump the log
    files as dh_auto_test runs with VERBOSE=1 by default.

8ce31ba... by Michael Biebl on 2016-08-30

Import patches-unapplied version 1.4.0-2 to debian/sid

Imported using git-ubuntu import.

Changelog parent: bed7097492f861df3562c974a26f3ca73cb7d06a

New changelog entries:
  * Replace Depends: dbus-x11 with Depends: default-dbus-session-bus |
    dbus-session-bus so that either dbus-user-session or dbus-x11 can be used.
    (Closes: #836037)

bed7097... by Michael Biebl on 2016-08-26

Import patches-unapplied version 1.4.0-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 3093fbd8fb8746b046dfcc54268ff6ecfab81546

New changelog entries:
  * New upstream release.
  * Rebase patches.
  * Bump network-manager related (build-)dependencies to >= 1.4.
  * Enable team and team-port configuration support. Requires Jansson for
    handling JSON data.

3093fbd... by Michael Biebl on 2016-08-04

Import patches-unapplied version 1.2.4-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: c6958d9b04e11082154a88571722f166c0ccc39c

New changelog entries:
  * New upstream release.
  * Rebase patches.

c6958d9... by Laurent Bigonville on 2016-06-05

Import patches-unapplied version 1.2.2-2 to debian/sid

Imported using git-ubuntu import.

Changelog parent: b0cb488c141dae971df3e6164bb4e2e51a972a69

New changelog entries:
  * Team upload.
  * debian/control:
    - Drop gnome-icon-theme dependency, this icon theme is deprecated
    - Switch from polkit-1-auth-agent to 'policykit-1-gnome |
      polkit-1-auth-agent', polkit-1-auth-agent is a virtual package

b0cb488... by Michael Biebl on 2016-05-11

Import patches-unapplied version 1.2.2-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 4f88d5f832fbd224219a44374b789839f066e1aa

New changelog entries:
  * New upstream release.
  * Rebase patches.
  * Bump Standards-Versiont to 3.9.8.
  * Bump network-manager related (build-)dependencies to >= 1.2.