ubuntu/+source/network-manager-applet:ubuntu/bionic-devel

Last commit made on 2019-01-08
Get this branch:
git clone -b ubuntu/bionic-devel https://git.launchpad.net/ubuntu/+source/network-manager-applet
Members of Ubuntu Server Dev import team can upload to this branch. Log in for directions.

Branch merges

Branch information

Name:
ubuntu/bionic-devel
Repository:
lp:ubuntu/+source/network-manager-applet

Recent commits

55f6ab2... by Sebastien Bacher on 2018-12-11

Import patches-unapplied version 1.8.10-2ubuntu2 to ubuntu/bionic-proposed

Imported using git-ubuntu import.

Changelog parent: eac47bbcc8489021a05edafba88e32035fcca694

New changelog entries:
  * debian/patches/git_certificate_escaping.patch:
    - 'libnma: unescape certificate paths in URIs', that fixes
       selecting files with a space in their name (lp: #1807460)

eac47bb... by Jeremy Bicha on 2018-01-22

Import patches-unapplied version 1.8.10-2ubuntu1 to ubuntu/bionic-proposed

Imported using git-ubuntu import.

Changelog parent: ac264dc6ef866fa5d11da48a1925e35fbe28c863

New changelog entries:
  * Sync with Debian. Remaining changes:
    - debian/icons/, debian/rules, debian/source/include-binaries:
      + Add "secure" icons
    - debian/control, debian/rules:
      + Build appindicator support
      + Run dh_translations
    - Add lp341684_device_sensitive_disconnect_notify.patch:
      + Show correct notification messages for disconnect events, to be in
        line with the other *connect*text patches.
    - Add lp460144_correctly_update_notification.patch: cleaner notification
        messages, and allow for messages to be updated instead of cleared.
    - Add applet-wifi-menu-before-vpn.patch:
      + Show Create New and Connect to Hidden wifi menu items with the other
        Wifi items, rather than separated by the VPN menus.
    - Allow-to-create-and-connect-to-Ad-Hoc-RSN-networks.patch:
      + Enable Ad-Hoc using WPA RSN
    - Have-the-appindicator-enabled-by-default.patch:
      + Enable the indicator by default
    - On-Ubuntu-we-use-premade-icons-for-the-indicator-VPN.patch:
      + use '-secure'-suffixed icons when connected to the VPN, since we
        can't composit icons on the fly.
    - Make-sure-the-behavior-for-policykit-restricted-acti.patch,
      Support-hiding-rather-than-desensitizing-disallowed-items.patch,
      + provide methods to desensitize and hide menu items which are useless
        given the current policykit policy level of the user.

ac264dc... by Michael Biebl on 2018-01-16

Import patches-unapplied version 1.8.10-2 to debian/sid

Imported using git-ubuntu import.

Changelog parent: c961252b54c57e8eafde3f7e200d8cd5a0eb1c79

New changelog entries:
  * shared/compat: Fix memory handling of nm_setting_vpn_get_*_keys
    (Closes: #885525)

c961252... by Michael Biebl on 2017-12-25

Import patches-unapplied version 1.8.10-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: f6a42b9d6e70c17c9b9d6f56a855708f31476d36

New changelog entries:
  * New upstream version 1.8.10
  * Rebase patches
  * Bump Standards-Version to 4.1.2
  * Bump debhelper compat level to 11

f6a42b9... by Michael Biebl on 2017-11-07

Import patches-unapplied version 1.8.6-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: abb2389403732ebc55324b675462f8360ee094b5

New changelog entries:
  * New upstream version 1.8.6
  * Don't use Unicode in patch header
  * Bump Build-Depends on libgtk-3-dev to (>= 3.10)
  * Bump Standards-Version to 4.1.1

abb2389... by Michael Biebl on 2017-09-20

Import patches-unapplied version 1.8.4-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 6209e360966c561bd21f44ccab45b675b081c18b

New changelog entries:
  * New upstream version 1.8.4
  * Update Build-Depends as per configure.ac
  * Rebase patches
  * Switch to dh_missing
  * Bump Standards-Version to 4.1.0
  * Don't build static libraries

6209e36... by Michael Biebl on 2017-06-17

Import patches-unapplied version 1.8.2-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 62dcbd71d2b31045264dcba0cd0f01e3b18a0451

New changelog entries:
  * New upstream version 1.8.2
  * Rebase patches
  * Drop migration code from pre-wheezy

62dcbd7... by Michael Biebl on 2017-05-12

Import patches-unapplied version 1.8.0-1 to debian/experimental

Imported using git-ubuntu import.

Changelog parent: d877d4b012c22c5a3d6f382a14832abb3b821a25

New changelog entries:
  * New upstream version 1.8.0
  * Switch URLs to https
  * Bump network-manager related (build-)dependencies to >= 1.8
  * Enable support for adjusting SELinux labels in configuration editor
  * Enable PKCS#11 capable certificate chooser for EAP-TLS
  * Drop obsolete Breaks from pre-jessie
  * Rebase patches
  * Update symbols file for libnm-gtk and libnma
  * Use architecture.mk provided by dpkg-dev to retrieve DEB_HOST_MULTIARCH

d877d4b... by Michael Biebl on 2017-03-07

Import patches-unapplied version 1.4.6-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 3b62f3dbcd5d645ba06164432e5a1981fdd2a730

New changelog entries:
  * New upstream version 1.4.6
  * Rebase patches
  * Enable and install gtk-doc API documentation for libnma

3b62f3d... by Michael Biebl on 2017-01-25

Import patches-unapplied version 1.4.4-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: acc57d3b7e593269c865a537454c34ae75c50f9e

New changelog entries:
  * New upstream release.
  * Bump debhelper compat level to 10.
  * Update Vcs-* according to the latest recommendation.
  * Rebase patches.
  * Drop libnma-common and libnm-gtk-common.
    The .ui files and icons are now compiled in using GResource.
  * Bump network-manager related (build-)dependencies to >= 1.6.
    This enables support for editing the Proxy setting which requires
    NetworkManager 1.6 or newer.