ubuntu/+source/nettle:ubuntu/oneiric

Last commit made on 2011-03-20
Get this branch:
git clone -b ubuntu/oneiric https://git.launchpad.net/ubuntu/+source/nettle
Members of Ubuntu Server Dev import team can upload to this branch. Log in for directions.

Branch merges

Branch information

Name:
ubuntu/oneiric
Repository:
lp:ubuntu/+source/nettle

Recent commits

1c7b412... by Magnus Holmgren on 2011-03-20

Import patches-unapplied version 2.1-2 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 597ff73b9119aca18e5fab0ba7699ff3b976c0d0

New changelog entries:
  * Upload to unstable.
  * Increase Debhelper compat level to 7.
  * debian/rules: Add build-indep and build-arch targets.
  * debian/copyright: Add entry for dsa2sexp.c.
  * No longer suggest lsh-utils-doc as an alternative to lsh-doc.

597ff73... by Magnus Holmgren on 2011-01-18

Import patches-unapplied version 2.1-1 to debian/experimental

Imported using git-ubuntu import.

Changelog parent: 2a1587d17edc077ea233f81a63d5c282e5627618

New changelog entries:
  * New upstream release (Closes: #594386). Thanks to Sedat Dilek for
    sorting things out.
    - Drop rsa2sexp_algorithm_name.dpatch, 20_link_with_gmp.dpatch;
      incorporated upstream.
    - The SOVERSIONs of libnettle and libhogweed have changed to 4 and 2,
      respectively; update and rename debian/control, debian/libnettle3.*,
      debian/libhogweed1.*, and debian/nettle-bin.links accordingly.
  * Build-depend on the new libgmp10-dev instead of libgmp3-dev.
  * Convert to source package format 3.0 (quilt), using
    dh_autotools-dev_*config to update config.sub and config.guess files.
  * Handle the parallel DEB_BUILD_OPTIONS option.
  * Pass --libdir=/usr/lib to ./configure since it will otherwise try to
    be smart and pick /usr/lib32 or /usr/lib64 on certain platforms.
  * General tidying of debian/rules:
    - Remove handling of noopt option (dpkg-buildpackage sets CFLAGS).
    - Remove remnants of nostrip option handling.
    - Only pass --host to ./configure if HOST != BUILD, as is recommended.
    - Remove redundant compiler and configure flags.
  * Bump Standards-Version to 3.9.1.

2a1587d... by Magnus Holmgren on 2009-10-11

Import patches-unapplied version 2.0-2 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 6a7d3bebdda5949d198dac9928dd167f06d9ea93

New changelog entries:
  * rsa2sexp_algorithm_name.dpatch (new): Use a default algorithm name
    that LSH understands in the sexp representation of an RSA key, so that
    pkcs1-conv can be used to convert existing OpenSSH private keys.
  * debian/control: Add ${misc:Depends} to all packages lacking it.
  * debian/control: nettle-dev: Depend on dpkg (>= 1.15.4) | install-info
    as recommended for the transition to triggerized install-info.
  * Upgraded to Standards-Version 3.8.3 with the previous change.

6a7d3be... by Magnus Holmgren on 2009-08-02

Import patches-unapplied version 2.0-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: d9c190c2048cc2d6ea8d37ea60bb77389f737356

New changelog entries:
  * Merge with experimental branch.
    - There was no lsh-utils 2.0.3-2 in Debian, so the conflict is with
      lsh-utils < 2.0.4-dfsg-1.
    - Drop the transitional libnettle-dev package that was in experimental.
      Due to the split, depending packages will need sourceful uploads anyway.
  * New upstream version.
    - Drop 30_sparc_aes_include.dpatch; incorporated upstream.
  * Add debug package.
  * nettle-dev.doc-info: Correct Section and Document.
  * Bump Standards-Version to 3.8.2.

d9c190c... by Magnus Holmgren on 2007-09-08

Import patches-unapplied version 1.16~cvs20070603-2 to debian/experimental

Imported using git-ubuntu import.