ubuntu/+source/mono:ubuntu/karmic-devel

Last commit made on 2009-09-09
Get this branch:
git clone -b ubuntu/karmic-devel https://git.launchpad.net/ubuntu/+source/mono
Members of Ubuntu Server Dev import team can upload to this branch. Log in for directions.

Branch merges

Branch information

Name:
ubuntu/karmic-devel
Repository:
lp:ubuntu/+source/mono

Recent commits

248140e... by Mirco Bauer on 2009-09-07

Import patches-unapplied version 2.4.2.3+dfsg-2 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 14f56277f7ddc3eb15a8ae59301f29f63de89737

New changelog entries:
  * debian/control:
    + Add missing cli:Suggests to libmono-bytefx0.7.6.1-cil and
      libmono-bytefx0.7.6.2-cil.
  * debian/rules:
    + Removed mono:upversion and mono:next-version from dh_gencontrol -s
      call as those are unused for arch:any packages.
  * debian/patches/fix_metadata_dup.dpatch:
    + Remove duplicate appdomain.h, fixing FTBFS.
      (thanks to Stefan Siegl for the investigation, Closes: #543010)
  * debian/patches/fix_CreateDelegate_ArgumentException.dpatch:
    + Fixed ArgumentException in System.Delegate.CreateDelegate() which broke
      IronPython 2.6 Beta 2.

14f5627... by Mirco Bauer on 2009-07-30

Import patches-unapplied version 2.4.2.3+dfsg-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 8101907d07fecf1faeada694e5bd487b0e412708

New changelog entries:
  * New upstream release:
    + Fixes XML signature HMAC truncation authentication bypass.
      (CVE-2009-0217)
    + Shipping the RabbitMQ.Client library now as the non-free bits were
      removed.
    + Includes ASP.NET MVC.
    + Updated xbuild.
  * debian/patches/disable_unavailable_cpu_optimizations_r133647.dpatch
    debian/patches/fix_disabling_aot_r131940.dpatch
    debian/patches/fix_null_funcptr_marshalling_r127347.dpatch
    debian/patches/fix_ppc_build_using_gcc-4.4_r131472.dpatch
    debian/patches/fix_recursive_unmanaged_types.dpatch
    debian/patches/fix_sparc_support_r134797.dpatch:
    + Dropped, as already applied upstream.
  * debian/rules:
    + Bumped clilibs where needed.
  * debian/rules
    debian/mono-devel.install
    debian/mono-api-diff.cs:
    + As mono-api-diff was dropped from Mono 2.4 and we need it to track API
      changes we bundle it now in the source package.
      (thanks to C.J. Adams-Collier for this)
  * debian/copyright:
    + Updated for ASP.NET MVC.
  * debian/control:
    + Moved libmono-firebirdsql1.7-cil from Depends to Recommends of
      mono-complete, as libfbclient2 as not available on s390.
    + Added libmono-system-web-mvc1.0-cil package.
    + Added libmono-messaging-rabbitmq2.0-cil and libmono-rabbitmq2.0-cil
      package.
  * debian/patches/fix_array_compare.dpatch:
    + Fix in the compiler needed for IronRuby.
      (thanks goes to C.J. Adams-Collier for providing the patch)
  * debian/control
    debian/mono-runtime.install
    debian/libmono-profiler.install:
    + Moved the libmono-profiler-* libraries to the new libmono-profiler
      package, as they pull libmono0 in which is unneeded for normal usage.
  * debian/control
    debian/mono-devel.install
    debian/mono-mcs.install
    debian/mono-gmcs.install:
    + Moved mcs to mono-mcs and gmcs to mono-gmcs from mono-devel, as that
      caused a lot of confusion. (closes: #525279 and #537081)
    + Added mono-csc to mono-devel in preparation to drop csc in the future as
      it conflicts with the chicken compiler, see #509367.

8101907... by Mirco Bauer on 2009-07-05

Import patches-unapplied version 2.4+dfsg-6 to debian/sid

Imported using git-ubuntu import.

Changelog parent: b66c30e5aa5e926c087f221cc0909927d9d2858a

New changelog entries:
  * debian/rules:
    + Force pthread for armel as __thread FTBFS.
    + Build Mono.Simd in test target, which hopefully fixes the failing
      mono/mini tests.
  * debian/control:
    + Removed dh_installxsp and monodiet from the package description of
      mono-utils. (Closes: #534906)
    + Bumped Standards-Version to 3.8.2 (no changes needed)
  * debian/rules:
    + Let the build system decide if sigaltstack() will be used and which TLS
      instead of passing explicitly --with-sigaltstack and --with-tls to
      the ./configure script.
    + Run also the JIT (mono/mini) tests.
  * debian/patches/fix_disabling_aot_r131940.dpatch:
    + Fixes the build of kfreebsd-amd64 and kfreebsd-i386.
  * debian/rules:
    + Removed the config.make hack as that broke AMD64 builds and instead let
      the ./configure script from the configure-indep target create that file.
  * debian/control:
    + Change Section of prj2make-sharp to devel to match archive overrides.
    + Added replaces libmono-cairo1.0-cil to libmono-cairo2.0-cil, as the
      pkg-config file was moved from that. (Closes: #531006)
    + Added conflicts mono-{1,2}.0-runtime to mono-runtime to ensure
      aptitude is proposing a happy upgrade path.
  * debian/libmono-wcf3.0-cil.install:
    + Added missing System.IdentityModel development symlink.
      (Closes: #531496)
  * debian/shlibs.local
    debian/update-shlibs.local.sh:
    + Removed libgda-2 entry for the benefit of dh_clideps not picking that as
      Suggests for libmono-system-data{1,2}.0-cil up. (Closes: #531870)
  * debian/patches/fix_ppc_build_using_gcc-4.4_r131472.dpatch:
    + Fixes the build on PPC when using GCC 4.4.
  * debian/patches/disable_unavailable_cpu_optimizations_r133647.dpatch:
    + Disable CPU optimizations which might be unavailable (like SSE2 on
      Pentium 3).
  * debian/patches/fix_sparc_support_r134797.patch:
    + Fixes the hang for all applications when running on SPARC.
      (Closes: #531566)
  * debian/rules:
    + Implemented test target and run basic runtime tests as part of the build
      if nocheck wasn't passed via DEB_BUILD_OPTIONS.
  [ Jo Shields ]
  * debian/rules:
    + Implement workaround to force removal of /usr/share/doc symlinks
      on Ubuntu systems when upgrading from pre-2.4 packages
  * debian/control:
    + Add dependency on lsb-release to allow distro detection
  [ Mirco Bauer ]
  * Upload to unstable.
  * debian/update-shlibs.local.sh:
    + Fixed shlibs line of libMonoPosixHelper, was causing incorrect
      dependencies on libmono0 instead of mono-runtime.
    + Added shlibs line for libMonoSupportW.
  * debian/monodoc-base.install:
    + Added missing monodoc development symlink.
  * debian/mono-1.0-devel.install
    debian/mono-2.0-devel.install:
    + Added installutil.exe.
  * debian/mono-csharp-shell.install:
    + Added missing Mono.CSharp development symlink.
  * debian/libmono-messaging2.0-cil.install:
    + Really install library and development symlink of Mono.Messaging.
  * debian/libmono-management2.0-cil.install:
    + Added missing Mono.Management development symlink.
  * debian/mono-devel.install:
    + Install mcs mo-files.
  * New upstream release.
    + For release highlights see the NEWS.Debian file
  * debian/NEWS:
    + Updated for Mono 2.4, Mono 2.2 and Mono 2.0.
  * DFSG edition of Mono 2.4 as the source taball contained a binary that is
    not part of the bootstrapping process (docs/AgilityPack.dll) and is CC
    Share-alike 2.5 licensed (non-free). Also it contained non-free
    specification files needed by the RabbitMQ.Client library.
  * debian/README.source:
    + Mention which files we removed and how to create the tarball we use.
    + Document which binaries are required to bootstrap the C# compiler.
  * debian/rules:
    + Made get-orig-source policy conform (by using . as output path).
    + Dropped --with-oprofile from configure call as debian doesn't ship the
      needed header files for it.
    + Pass --with-moonlight=no to configure call as the moon source package
      will ship the assemblies with the release containing Silverlight 2.0
      support.
    + Build MonoGetAssemblyName using gmcs instead of mcs.
    + Don't allow dh_clideps to add mono-runtime dependencies to
      mono-1.0/2.0-gac to prevent circular dependency hell. (Closes: #528090)
    + Added missing non-stamp/files targets to .PHONY.
    + Only pass mono/2.0 to MONO_PATH in RUN_MONO variable, else gmcs.exe
      picks up the 1.0 corlib.
    + Bumped clilibs of libmono-cairo{1.0,2.0}-cil, libmono-data{1.0,2.0}-cil,
      libmono-data-tds{1.0,2.0}-cil, libmono-oracle2.0-cil,
      libmono-posix{1.0,2.0}-cil, libmono-relaxng{1.0,2.0}-cil,
      libmono-system2.0-cil, libmono-system-runtime2.0-cil, libmono-web2.0-cil,
      libmono-winforms2.0-cil and libmono-webbrowser0.5-cil.
    + Install upstream changelog and debian news only in the mono-runtime
      package.
  * debian/cli-wrapper.c
    + Dropped as this wrapper is obsolete since mono 1.1.6-1.
  * debian/patches/kfreebsd_support.dpatch
    debian/patches/build_genxs_2.0.dpatch:
    + Updated to cleanly apply again.
  * debian/patches/fix_wsdl2_duplicate_keys_r117243.dpatch
    debian/patches/fix_NetworkInterface_exception_r120282.dpatch
    debian/patches/fix_TcpClient_IPv6_r122598.dpatch:
    + Dropped, already applied upstream.
  * debian/patches/armel_fix_configure_fpu_check.dpatch:
    + Only patch configure.in, autoreconf takes care of configure.
  * debian/patches/armel-glibc-2.8.dpatch:
    + Dropped, fixed upstream in a different way.
  * debian/patches/fix_NetworkInterface_endless_loop.dpatch:
    + Fix loop by setting next item. (Closes: #519480)
  * debian/libmono-system-web2.0-cil.install:
    + Added system.web.extensions_1.0.pc and
      system.web.extensions.design_1.0.pc.
  * debian/libmono2.0-cil.install:
    + Added mono.web.pc.
  * debian/control:
    debian/patches/99_autoreconf.dpatch:
    + Added autoconf to build-deps, as we autoreconf in debian/rules now.
    + Dropped autoreconf dpatch.
  * debian/control:
    + Updated Vcs-* fields for the migrated git repository.
    + Added new mono-csharp-shell package.
    + mono-devel recommends mono-csharp-shell now (very useful for
      debugging).
    + Added new libmono-management2.0-cil, libmono-messaging2.0-cil,
      libmono-simd2.0-cil and libmono-wcf3.0-cil packages.
    + Merged monodoc-base and monodoc-manual packages from the monodoc source
      package.
    + Dropped mono-smcs, libmono-corlib2.1-cil and libmono-system2.1-cil as
      those will be shipped by the moon source package.
    + Removed transition dependencies from libmono1.0-cil, libmono2.0-cil
      mono-devel, as the Mono 2.0 transition has been completed some weeks ago.
    + Renamed libmono-nunit2.2-cil to libmono-nunit2.4-cil and only ship a
      symlink to nunit.pc with a binary dependency on libnunit2.4-cil.
    + Added mono-complete metapackage to make ISVs and users installing
      non-Debian applications happy.
    + Changed Section of all packages to cli-mono except *-dbg to match
      archive overrides.
    + Added automake to build-deps needed for autoreconf.
  * debian/libmono-cairo1.0-cil.install
    debian/libmono-cairo2.0-cil.install
    debian/patches/fix-mono-cairo.pc.in.dpatch:
    + Moved mono-cairo.pc from libmono-cairo1.0-cil to libmono-cairo2.0-cil
      and reference the CLI 2.0 version in the pkg-config file now.
  * debian/mono-devel.install:
    + Added mono-cil-strip
    + Added getline.cs, mono-lineeditor.pc, Options.cs and mono-options.pc
    + Removed CorCompare.exe and mono-api-diff(.exe) as dropped by upstream.
    + Updated mono-shlib-cop and sqlsharp as they are now CLI 2.0
  * debian/patches/fix_recursive_unmanaged_types.dpatch:
    + Fixes recursive structs regression as seen with OpenOffice.org.
  * debian/copyright:
    + Added Lucene.Net, RabbitMQ.Client and HtmlAgilityPack licenses.
  * debian/patches/build_cecil_as_2.0.dpatch
    debian/patches/build_firebirdsql_as_2.0.dpatch
    debian/patches/build_permview_as_2.0.dpatch
    debian/patches/build_linker_tuner_cil-strip_as_2.0.dpatch:
    + Build Mono.Cecil, FirebirdSql.Data.Firebird, permview, tuner, linker and
      cil-strip for CLI 2.0.
  * debian/control
    debian/rules
    debian/mono-jt.*
    debian/mono-common.*
    debian/libmono0.*
    debian/mono-runtime.*:
    + Merged mono-jit, mono-common and libmono0 (except libmono.so.*)
      packages into mono-runtime. libmono0 was pulled in by
      libmono-system2.0-cil as it pinvokes libMonoPosixHelper.so for
      compression stream APIs. Since the interpreter (mint) was dropped long
      time ago and is unmainained upstream, there is no reason to keep those
      3 domains (VM, config / binfmt support, helper libraries) split.
    + Renamed mono-jit-dbg package to mono-runtime-dbg.
  * debian/shlibs.local:
    + Updated using the debian/update-shlibs.local.sh script.
  * debian/watch:
    + Mangle +dfsg version.
  * debian/control
    debian/libmono1.0-cil.install
    debian/libmono-cecil-private-cil.install:
    + Moved Mono.Cecil from libmono1.0-cil to libmono-cecil-private-cil, as
      it's now build for CLI 2.0.
  * debian/libmono-system-web2.0-cil.install:
    + Added System.ComponentModel.DataAnnotations, System.Web.Abstractions,
      System.Web.DynamicData and System.Web.Routing.
  * debian/control
    debian/libmono-i18n1.0-cil.install
    debian/libmono-i18n2.0-cil.install
    debian/libmono-i18n-west1.0-cil.install
    debian/libmono-i18n-west2.0-cil.install:
    + Moved I18N.dll and I18N.West.dll from libmono-i18nX.Y-cil to
      libmono-i18n-westX.Y-cil, as this is the only code page that is really
      needed in 90% of the cases.
  * debian/compat
    debian/control:
    + Bumped debhelper to 7.
  * debian/control
    debian/mono-1.0-devel.install
    debian/mono-2.0-devel.install
    debian/mono-devel.install:
    + Removed mono-api-info1 as dropped by upstream and moved
      2.0/mono-api-info.exe from mono-2.0-devel to mono-devel.
  * debian/control
    debian/libmono0.install
    debian/libmono-dev.install
    debian/mono-devel.install:
    + Moved dotnet.pc and dotnet35.pc from libmono-dev to mono-devel.
    + Removed libmono-profiler-*.a as unused and unneeded.
  * debian/mono-runtime.docs
    debian/changelog
    debian/changelog.1:
    + Moved all entries older than the version in lenny (1.9.1) to
      changelog.1
    + Install changelog.1 only in mono-runtime.

b66c30e... by Sebastian Dröge on 2009-05-01

Import patches-unapplied version 2.0.1-6 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 2ba5b5edbc3298baa77c0942b6f7d95f1139688f

New changelog entries:
  [ Jo Shields ]
  * debian/control:
    + Update package descriptions to make it clearer what is what, and
      avoid multiple packages with identical short descriptions
      (Closes: #519404)
  [ Sebastian Dröge ]
  * debian/patches/fix_null_funcptr_marshalling_r127347.dpatch:
    + Fix marshalling for NULL function pointers, they should be mapped
      to managed null delegates and vice versa. Patch from upstream SVN.

2ba5b5e... by Mirco Bauer on 2009-02-24

Import patches-unapplied version 2.0.1-5 to debian/sid

Imported using git-ubuntu import.

Changelog parent: d43919ca773f97a0d87c3ac0ecad86f59f56c9f5

New changelog entries:
  * The "Let the show begin!" release
    + Upload to unstable starting the Mono 2.0 transition, status available at:
      http://wiki.debian.org/Teams/DebianMonoGroup/Mono20TransitionTODO
  * debian/control:
    + The compilers (mono-mcs and mono-gmcs) are not forward compatible with
      newer upstream versions, thus added stronger dependencies.
    + Removed libgamin-dev, libcups2-dev, librsvg2-dev, libgtk2.0-dev and
      libgnomeui-dev from build-deps-indep as those packages are only needed
      to generate the debian/shlibs.local file using the
      debian/update-shlibs.local.sh script (the script checks now if those
      are installed). This extended hack is needed as shared-mime-info in
      unstable conflicts with gnome < 2.24 and gnome 2.24 is blocked by
      the Mono 2.0 transition.
  * debian/shlibs.local:
    + Updated using the debian/update-shlibs.local.sh script.
  * debian/rules:
    + Pass internal-mono instead of --internal-mono if the debhelper version
      is older than 7.1, as that one doesn't support custom parameters via
      init(). This ensures backwards compatibility with older debhelper
      versions, as found in Ubuntu.
  * debian/control:
    + Lowered debhelper build-dep to >= 5.
  * debian/dh_clideps
    debian/dh_makeclilibs:
    + Re-synced from cli-common 0.6.0, needed for dh 7.0 backwards
      compatibilty.
  * Rebuilt against libc6 and glib from unstable.
  [ Jo Shields ]
  * debian/patches/fix_wsdl2_duplicate_keys_r117243.dpatch:
    + Fix bug in wsdl2 preventing parsing of Amazon Web Services
      wsdl file (thanks to Iain Lane <email address hidden> for help
      isolating this bug)
  * debian/patches/fix_NetworkInterface_exception_r120282.dpatch:
    + Warn, rather than fail, on "funny" network interfaces
      (Closes: #507297)
  [ Mirco Bauer ]
  * debian/mono-1.0-devel.{postinst,prerm}
    debian/mono-mcs.{postinst,prerm}
    debian/mono-devel.{postinst,prerm}:
    + Moved update-alternatives calls to mono-devel.{postinst,prerm}.
  * debian/mono.links
    debian/mono.postinst
    + Removed, those are just left-overs.
  * debian/mono-jit.postinst:
    + Lowered alternative priority to 10 like all other alternative we install.
  * debian/control:
    + Moved cli-* Provides from mono-1.0-devel, mono-mcs and mono-gmcs to
      mono-devel, as thats where the cli-* alternatives now lives.
    + Added many strong versioned binary dependencies to mono-devel as hack
      to make experimental buildds happy, else everything needing
      mono-devel >= 2.0 will FTBFS in experimental (e.g. KDE4).
      (thanks goes to Modestas Vainius for the investigation)
    + Made dependency on libmono0, libmono-corlib2.0-cil and
      libmono-corlib1.0-cil strong for mono-utils to ensure that the correct
      versions are pulled in (else we might confuse APT or funny buildds).
    + Bumped debhelper build-dep to >= 7.1, as needed for the bundled
      debian/dh_* scripts.
  * debian/dh_clideps
    debian/dh_makeclilibs:
    + Synced from cli-common 0.6.0, needed for dh 7.1 support.
   [ David Paleino ]
   * debian/patches/fix_TcpClient_IPv6_r122598.dpatch:
     + Fix bug in TcpClient() implementation preventing IPv6 connections
       from working
  [ Mirco Bauer ]
  * New upstream (bugfix) release.
  * debian/mono-1.0-devel.manpages:
    + Removed mcs1 as it's already shipped in mono-mcs.
  * debian/patches/99_autoreconf.dpatch:
    + Updated
  * debian/mono-devel.links:
    + Make csc a symlink to gmcs, a runtime version neutral default
      compiler.
  * debian/patches/armel_fix_configure_fpu_check.dpatch:
    + Forward ported patch from 1.2.4 to fix FTBFS on linux/armel.
  * debian/patches/99_autoreconf.dpatch:
    + Updated
  * debian/mono-common.install:
    + Name the /etc files and directories explicitly to make sure not to
      install /etc/mconfig by accident when doing a binary-indep binary-arch
      (in that order) build.
  [ Jo Shields ]
  * debian/patches/armel-glibc-2.8.dpatch:
    + Fix build failure on armel architecture on libc6 2.8 (Thanks
      to Michael Casadevall <email address hidden> for the patch)
  [ David Paleino ]
  * Group Policy:
    + implemented get-orig-source target in debian/rules
  * New upstream release.
    + System.Web.Extensions is included in the debian source and binary
      packages now, as JSON.NET was relicensed to MIT/X11 and thus no DFSGing
      needed anymore! (Closes: #497213)
    + With this release, we changed the default development stack from 1.0 to
      2.0. This has no influence to the runtime nor existing binary packages,
      for more details see:
      http://wiki.debian.org/Teams/DebianMonoGroup/Mono20Transition
  * debian/copyright:
    + Updated license info of JSON.NET
  * debian/control:
    + Removed libgda2-dev from buid-deps as debian/update-shlibs.local.sh
      takes already care of it.
    + mono-utils depends on libmono-corlib2.0-cil and only suggests
      libmono-corlib1.0-cil now as the default runtime was changed to 2.0.
    + Updated libcupsys2-dev build-dependency to libcups2-dev.
    + Updated Standards-Version to 3.8.0 (no changes needed).
  * debian/rules:
    + Pass --enable-quiet-build=no to configure call, else we get a less
      verbose build log.
    + Bumped clilibs to 2.0 of libmono{1,2}.0-cil, libmono-cairo{1,2}.0-cil,
      libmono-data-tds{1,2}.0-cil, libmono-system2.0-cil,
      libmono-system-runtime2.0-cil, libmono-security{1,2}.0-cil,
      libmono-web2.0-cil, libmono-winforms2.0-cil and libmono-system2.1-cil.
  * debian/mono.runtime-script:
    + Call the script of gacutil instead of passing the application filename
      directly to mono, as we rely on the default gacutil now provided by the
      mono-gac package.
  * debian/patches/method-signature-testing.dpatch
    debian/patches/pass_CPPFLAGS_nicely_r98803.dpatch
    debian/patches/fix_bound_checking_r98524_r98527.dpatch
    debian/patches/fix_softfloat_r105848.dpatch
    debian/patches/fix_stack_alignment_r105650_r105651.dpatch
    debian/patches/fix_xen_support_r103474_r103475.dpatch
    debian/patches/fix_Dictionary_preventing_GC_r102114.dpatch
    debian/patches/fix_TdsConnectionPool_svn.dpatch
    debian/patches/fix_Assembly.LoadFrom_deadlock.dpatch:
    + Removed, already applied upstream.
  * debian/patches/dont_build_System.Web.Extensions.dpatch:
    + Disabled, JSON.NET was re-licensed to MIT/X11.
  * debian/libmono-system-web2.0-cil.install:
    + Added System.Web.Extensions.dll and System.Web.Extensions.Design.dll.
  * debian/update-shlibs.local.sh:
    + Fixed grep calls so it doesn't match udeb lines.
  * debian/shlibs.local:
    + Updated
  * debian/control
    debian/libmono-mozilla0.2-cil.install
    debian/libmono-webbrowser0.5-cil.install:
    + Renamed libmono-mozilla0.2-cil to libmono-webbrowser0.5-cil and
      removed Replaces.
  * debian/control
    debian/libmono{1,2}.0-cil.install
    debian/libmono-posix{1,2}.0-cil.install:
    debian/libmono-getoptions{1,2}.0-cil.install:
    debian/libmono-data{1,2}.0-cil.install:
    + Moved the Mono.Posix, Mono.GetOptions and Mono.Data.* libraries into
      extra packages to support smaller install sizes of typical applications
      (e.g. tomboy or gnome-do).
    + Added libmono-posix{1,2}.0-cil, libmono-getoptions{1,2}.0-cil and
      libmono-data{1,2}.0-cil as dependency of libmono{1,2}-cil to aid a smooth
      runtime transition.
  * debian/libmono-system-data2.0-cil.install:
    + Added System.Data.DataSetExtensions.dll and System.Data.Linq.dll.
  * debian/rules
    debian/libmono{1,2}.0-cil.install:
    + Dropped Mono.Security.Win32.dll as the library is only useful on
      Windows.
  * debian/patches/build_genxs_2.0.dpatch:
    + Enables compiling genxs for CLI 2.0 as upstream provided a genxs2 script
      but forgot to build the actual application.
  * debian/mono-2.0-devel.install
    debian/mono-2.0-devel.manpages:
    + Added xsd2 and genxs2
  * debian/mono-devel.install
    debian/mono-devel.manpages
    debian/mono-1.0-devel.install
    debian/mono-1.0-devel.manpages:
    + Moved all unversioned tools and default scripts (with their manpages) to
      mono-devel.
  * debian/mono-mcs.install
    debian/mono-mcs.manpages
    debian/mono-gmcs.install
    debian/mono-gmcs.manpages
    debian/mono-devel.install
    debian/mono-devel.manpages
    debian/control:
    + Moved gmcs script and manpage from mono-gmcs to mono-devel.
    + Added Replaces for mono-mcs and mono-gmcs to mono-devel.
    + Added gmcs2 script and manpage to mono-gmcs
    + Added mcs1 script and manpage to mono-mcs.
      This changes are needed to get a default compiler target using a single
      package that depends on the current default which is 2.0 (gmcs2).
  * debian/System.Windows.Forms.dll.config:
    + Added dll-map for libgdk_pixbuf-2.0.so
  * debian/control:
    + Improved many package descriptions by adding the names of the
      libraries they contain with a brief description of what they do.
  * debian/control
    debian/mono-gac.install
    debian/mono-{1,2}.0-gac.install:
    + The default script "gacutil" is still shipped in mono-gac but
      "gacutil1" and "gacutil2" are now in mono-1.0-gac and mono-2.0-gac.
      mono-gac pulls in mono-2.0-gac by default.
      This is needed to make a 2.0-only install possible.
  * debian/control:
    + Added mono-1.0-runtime and mono-2.0-runtime package, which pull in the
      runtime stack of the specific runtime version in.
      mono-runtime pulls in mono-2.0-runtime as the new default runtime.
      This is needed to make a 2.0-only install possible.
  * debian/libmono-dev.install:
    + Added dotnet35.pc
  * debian/mono-smcs.install:
    + Added smcs.pc
  * debian/control:
    + s/meta package/metapackage/ as lintian says so.

d43919c... by Jo Shields on 2008-10-13

Import patches-unapplied version 1.9.1+dfsg-4 to debian/lenny

Imported using git-ubuntu import.