ubuntu/+source/modemmanager:ubuntu/vivid-proposed

Last commit made on 2014-09-17
Get this branch:
git clone -b ubuntu/vivid-proposed https://git.launchpad.net/ubuntu/+source/modemmanager
Members of Ubuntu Server Dev import team can upload to this branch. Log in for directions.

Branch merges

Branch information

Name:
ubuntu/vivid-proposed
Repository:
lp:ubuntu/+source/modemmanager

Recent commits

275491d... by Michael Biebl on 2014-09-17

Import patches-unapplied version 1.4.0-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: c74d2f56f78feb69aaefe6a513c3f0efd1a45950

New changelog entries:
  * New upstream release.
    - Fixes conflicting definitions of mm_manager_new. (Closes: #749387)
  * Refresh patches.
  * Bump Build-Depends on libmbim-glib-dev to (>= 1.10).
  * Install NEWS file which includes the relevant upstream changes.
    (Closes: #641467)
  * Update symbols file for libmm-glib0.
  * Add Build-Depends on dbus, required to run the test suite.

c74d2f5... by Michael Biebl on 2014-06-25

Import patches-unapplied version 1.2.0-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 31c8fd9426885bdbbface95d74adb315538e45b0

New changelog entries:
  [ Guido Günther ]
  * New upstream version 1.2.0 (Closes: #731851)
  * Update patches
  * Install locale files
  * Require newer libqmi
  * Update symbols file
  * Ship gobject introspection data
  * Ship vala bindings
  [ Michael Biebl ]
  * Use canonical URI for Vcs-Git
  * Use gir dh addon
  * Update extendend package description (Closes: #744180)

31c8fd9... by Martin Pitt on 2014-06-03

Import patches-unapplied version 1.0.0-5 to debian/sid

Imported using git-ubuntu import.

Changelog parent: fd4543ffdd2938a9ebea4208cbca72e9c31b85cb

New changelog entries:
  [ Michael Biebl ]
  * Fix typo in package description (Closes: #745140)
  [ Martin Pitt ]
  * libmm-glib: Initialize result array
  * Add systemd unit link to shadow upstart job (LP: #1314795)
  * Fix systemd/upstart job on upgrades on Ubuntu
  * Avoid cancelling of systemd unit stop on remove (Closes: #745621)

fd4543f... by Michael Biebl on 2014-03-28

Import patches-unapplied version 1.0.0-4 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 13e8c638ff96f10e72d6b528cc7160d248fdcb74

New changelog entries:
  * Kill old modem-manager process when upgrading from pre 1.0.0 versions.

13e8c63... by Michael Biebl on 2014-03-27

Import patches-unapplied version 1.0.0-3 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 657a1454ad6903037f078b274c0b7a1bbd9f8119

New changelog entries:
  [ Michael Biebl ]
  * Upload to unstable.
  * Refresh patches to apply cleanly.
  [ Guido Günther ]
  * Update VCS- URLs
  * Add homepage URL
  * Enable PolicyKit support (Closes: #736475, #736900)
  [ Michael Biebl ]
  * Update Standards Version to 3.9.5
  * Drop link to Git repository from package descriptions
  * Build-Depend on the latest automake version
  * Fix D-Bus service file generation (Closes: #733752)
  * Add gbp.conf and enable pristine-tar
  * Install systemd service file
  * Use dh-systemd to enable the systemd service and restart it on upgrades
  * Set <email address hidden> as Maintainer
  * Remove obsolete D-Bus policy conffile on upgrades (Closes: #733305)
  * Update debian/copyright using machine-readable copyright format 1.0

657a145... by Mathieu Trudel-Lapierre on 2014-01-14

Import patches-unapplied version 1.0.0-2 to debian/experimental

Imported using git-ubuntu import.

Changelog parent: 7c4f8fb7913325a98cb9973e460709fa4894f202

New changelog entries:
  * Sync more changes from Ubuntu:
    - changelog for 0.6.0.0.really-0ubuntu4 (all changes dropped, they are
      patches included in the current upstream version).
    - changelog for 0.6.0.0.really-0ubuntu5 (all changes dropped, they are
      patches included in the current upstream version).
    - changelog for 0.6.0.0.really-0ubuntu6.
    - Build-Depend on automake1.11.
    - changelog for 0.6.0.0.really-0ubuntu7.
    - lp1229748_bluegiga_blacklist.patch: don't reset BLED112B.

7c4f8fb... by Mathieu Trudel-Lapierre on 2013-12-20

Import patches-unapplied version 1.0.0-1 to debian/experimental

Imported using git-ubuntu import.

Changelog parent: 90c50ab212e3e090bfc5e357ea93908ffa36c9ed

New changelog entries:
  * New upstream release. (Closes: #728214, #728215)
  * debian/control: add a versioned dependency for libqmi -- we need at least
    version 1.4.
  * debian/control: build-depends on libmbim-glib-dev 1.4
  * debian/rules: run the local autogen.sh rather than gnome-autogen.sh.
  * debian/rules: drop --with-tests.
  * debian/rules: clean up after gtk-doc files left around.
  * debian/patches/glib_fixes.patch: link against glib explicitly for the
    huawei modem helper tests.
  * debian/libmm-glib0.symbols: updated symbols.
  * debian/watch: update watch file for new location of upstream source.

90c50ab... by Mathieu Trudel-Lapierre on 2013-06-11

Import patches-unapplied version 0.7.991-1 to debian/experimental

Imported using git-ubuntu import.

Changelog parent: 47fbd07cb75ba913ffb5331412531d908f360d7f

New changelog entries:
  [ Mathieu Trudel-Lapierre ]
  * New upstream release.
  * debian/patches/handle_data07_capabilities_probing.patch,
    debian/patches/git_skip_add_utf8_check_219424a.patch,
    debian/patches/git_lte_etsi_mode_0af47c7.patch,
    debian/patches/git_lte_4g_parsing_90489ae.patch,
    debian/patches/git_lp1015328_segfault_in_clck_parser_318aaa0.patch,
    debian/patches/git_better_handle_ucs2_convert_e07c216.patch: Dropped,
    these patches were cherry-picks; included upstream
  * debian/patches/ericsson_h5321gw_usbids.patch: dropped, included upstream.
  * debian/control:
    - clean up build-depends: remove xsltproc, bump
      libglib2.0-dev to (>= 2.30.2), libgudev-1.0-dev to (>= 147).
    - Add gtk-doc-tools to Build-Depends.
    - Add libqmi-glib-dev to Build-Depends.
    - Add gnome-common to Build-Depends.
    - Bump debhelper Build-Depends to >= 9.
    - Make sure libmm-glib0 pre-depends on multiarch-support (lintian).
    - Make libmm-glib0 Multi-Arch: same.
    - Make sure all binary packages (except modemmanager-dbg) are priority
      optional.
    - Update short descriptions.
    - Breaks network-manager (<< 0.9.8.2-1) since otherwise NetworkManager
      will not see ModemManager with its new API.
  * debian/compat: bump to compat level 9.
  * debian/rules:
    - Replace --with-docs with --enable-gtk-doc.
    - Fix autoreconf to run gnome-autogen.sh.
    - Drop the override for installdocs; docs/spec.html isn't being built
      anymore.
    - Run dh_install with --fail-missing.
    - Remove test pppd plugin which we shouldn't install.
    - Drop old cruft for getting git snapshots.
    - We don't need to exclude the pppd path from makeshlibs, since nothing
      gets installed there.
  * debian/patches/lp700316_usb_blacklist.patch: refreshed.
  * debian/patches/arduino-blacklist.patch: refreshed.
  * debian/patches/linux-default-usb-id.patch: refreshed.
  * debian/*.install: make sure the files are properly installed given the new
    packages, also take into account multiarch paths.
  * debian/modemmanager.install: install the new mmcli binary.
  * debian/ubuntu/modemmanager.upstart: fix the name for the ModemManager
    binary, since it was changed upstream.
  * debian/patches/dbus_remove_max_replies_per_connection_limit.patch: dropped,
    included upstream.
  [ Michael Biebl ]
  * Add symbols file for libmm-glib0.
  [ Marius B. Kotsbak ]
  * Added binary packages modemmanager-doc and libmm-glib-doc for gtk-docs.
  * Split out modemmanager-dev package containing header files and .pc file.
    - add dependency on modemmanager-dev from libmm-glib-dev
      as stated in "mm-glib.pc"
    - add proper replaces/breaks for modemmanager-dev because of moved files
  * Build-depends: added "libglib2.0-doc" for the cross references in the doc
    to work.
  * debian/rules: make dh_makeshlibs override multiarch aware.
  * Update standards version to current 3.9.4.
  * debian/patches/linux-default-usb-id.patch: blacklist the USB-Gadget default
    USB ID (the module actually allows you to set a custom one). The default ID
    is re-used by the Nexus 7 with Ubuntu images to expose a tty you can use
    to login to the system; but if it's not ignored ModemManager will
    harass it for some time trying to probe it. (LP: #1105352)
  * debian/patches/handle_data07_capabilities_probing.patch: properly handle
    probing for the Huawei Data07 modem. (LP: #1071492)
  * Upload the right tarball for 0.6.0.0 from upstream, which I somehow
    mishandled before. Thanks to Marius B. Kotsbak for pointing out the issue.
  * debian/patches/git_fall_back_to_csq_cind_8bd6903.patch: fallback to +CSQ if
    +CIND reports a signal level of 0. (LP: #1060831)
  * debian/patches/git_move_cind_process_func_1dee45e.patch: moving the CIND
    processing function down a bit to make the above change cleaner. Cherry-pick
    from upstream.
  * debian/patches/ericsson_h5321gw_usbids.patch: Add another known USB ID for
    the Ericsson H5321gw. (LP: #1057956)
  * debian/patches/git_lte_4g_parsing_90489ae.patch,
    debian/patches/git_lte_etsi_mode_0af47c7.patch: cherry-pick the patches
    to properly handle and display LTE/4G technology modes. (LP: #1044744)
  * debian/patches/git_lp1015328_segfault_in_clck_parser_318aaa0.patch: avoid
    crashing when parsing +CLCK responses. (LP: #1015328)
  * debian/patches/git_better_handle_ucs2_convert_e07c216.patch,
    debian/patches/git_skip_add_utf8_check_219424a.patch: fix UCS2 conversion
    for some Huawei devices which return "garbage" along with the response for
    the +COPS command. (LP: #1049426)
  * New upstream release. (LP: #1043486)
  * debian/patches/fix-format-string.patch: dropped, applied upstream.
  * debian/patches/qdl-blacklist.patch: replaced with installing the rules file
    directly to the udev rules directory.
  * debian/77-mm-qdl-device-blacklist.rules, debian/rules: additional rules
    file from the qdl-blacklist.patch; we now install it directly to the udev
    rules directory. This fixes daily builds.
  * debian/rules: build with --with-tests.

47fbd07... by Michael Biebl on 2012-09-06

Import patches-unapplied version 0.5.2.0-2 to debian/sid

Imported using git-ubuntu import.

Changelog parent: b223457b53657bf1c427df5f0cdcb363ac0fa340

New changelog entries:
  * debian/patches/dbus_remove_max_replies_per_connection_limit.patch: Remove
    'max_replies_per_connection' limit from D-Bus configuration which sets it
    to 512. It was intended to increase the limit from its historical value of
    32. However, since 2007 the default limit has been 8192, so this is actually
    a reduction. (Closes: #678964)

b223457... by Michael Biebl on 2012-03-24

Import patches-unapplied version 0.5.2.0-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 9b8511982911a01b622fbe220382fe153e6ee19a

New changelog entries:
  * Upload to unstable.
  * debian/watch: Track .xz tarballs.
  * New upstream bugfix release (stable release 0.5.2).
    - hso: disable echo removal (LP: #953294)
    - gsm: retry sending SMS in PDU mode if text fails and PDU is supported
  * New upstream bugfix release.
    - release: update NEWS
    - cdma: fix crash on NULL error (bgo #670145)
    - Revert "huawei: rework probing and detection" (LP: #868034)
    - core: fix loop limits in echo removal
    - at-serial-port: implement built-in echo/garbage removal (LP: #916038)
  * debian/ubuntu/modemmanager.upstart: Remove unnecessary expect fork as
    this does the same thing as just exec'ing. Also check for existence of
    modemmanager in case it has been removed but not purged. (LP: #942908)
  * debian/ubuntu/modemmanager.upstart: fix stop condition to make sure we stop
    only when NetworkManager is stopped as much as possible, to avoid being
    respawned by it via DBus. (LP: #869635, #919071)
  * upstream snapshot 2012-02-08 18:07:13 (GMT)
    + 635fce193ff3a1dbbdee2abab9aa3ab121df25f0
  * debian/rules: as for NetworkManager, drop a few characters from the version
    number for git snapshots.
  [ Mathieu Trudel-Lapierre ]
  * upstream snapshot 2011-12-31 17:44:44 (GMT)
    + 1e332abc957d7eea4521c95d1e28b097de5427e5
  [ Artem Popov ]
  * debian/patches/arduino-blacklist.patch: add Arduino devices to blacklist
    to prevent managing Arduino devices. (LP: #910736)
    - [0403:6001] FT232 USB-Serial (UART) IC.
    - [03eb:204b] Atmel Corp. LUFA USB to Serial Adapter Project.
    - Anything with the Arduino VID (2341).
  * debian/patches/qdl-blacklist.patch: add more devices to the blacklist of
    Gobi QDL devices. (LP: #842702, #807889)
    - [1410:a014] Novatel Gobi found in the Google CR-48.
    - [03f0:241d] HP un2420 Gobi found in the HP Mini 5102 and Mini 5103.