ubuntu/+source/maas:ubuntu/trusty-devel

Last commit made on 2017-12-14
Get this branch:
git clone -b ubuntu/trusty-devel https://git.launchpad.net/ubuntu/+source/maas
Members of Ubuntu Server Dev import team can upload to this branch. Log in for directions.

Branch merges

Branch information

Name:
ubuntu/trusty-devel
Repository:
lp:ubuntu/+source/maas

Recent commits

2c00d6e... by Andres Rodriguez on 2017-12-13

Import patches-unapplied version 1.9.5+bzr4599-0ubuntu1~14.04.3 to ubuntu/trusty-proposed

Imported using git-ubuntu import.

Changelog parent: 0eb76c61aa247b410ee9a6e93d20787af1167b13

New changelog entries:
  * Stable Release Update.
    - debian/patches/harcode-upstart-lp1732703.patch: Running snapd or
      livepatch in Trusty installs systemd. Due to a systemd regressions,
      this causes MAAS to incorrectly detect the init system. As such,
      hardcode the init system to upstart (as systemd is not supported
      in Ubuntu) (LP: #1732703).

0eb76c6... by Andres Rodriguez on 2017-08-31

Import patches-unapplied version 1.9.5+bzr4599-0ubuntu1~14.04.2 to ubuntu/trusty-proposed

Imported using git-ubuntu import.

Changelog parent: 837f189e7b5b90fb3c3152056b10e10e0653273e

New changelog entries:
  * Stable Release Update.
    - debian/patches/fix-shim-name-lp1713795.patch: Grub package in Trusty
      has changed the name of the shim and has caused MAAS to being unable
      to import new images. (LP: #1713795)
    - debian/control: Bump depends on grub-common to ensure latest is
      always installed.

837f189... by Andres Rodriguez on 2017-03-02

Import patches-unapplied version 1.9.5+bzr4599-0ubuntu1~14.04.1 to ubuntu/trusty-proposed

Imported using git-ubuntu import.

Changelog parent: 43d69b0bb7dc712c35107d8f377dc2d8069abfd1

New changelog entries:
  * Stable Release Update. New MAAS upstream bugfix release 1.9.5 (LP: #1669591):
    - MAAS 1.9.5 is a new upstream bugfix release that fixes several bugs
      present on MAAS 1.9.4. This is solely a bugfix release. To see what
      issues this release fixes, please refer to the CHANGELOG
  * debian/control: Recommends bind9 (>= 1:9.9.5.dfsg-3ubuntu0.12~).

43d69b0... by Andres Rodriguez on 2016-07-13

Import patches-unapplied version 1.9.4+bzr4592-0ubuntu1~14.04.1 to ubuntu/trusty-proposed

Imported using git-ubuntu import.

Changelog parent: 97e1c8311dd7938cbdc850386f30d25847bc10e0

New changelog entries:
  * New Upstream Release, 1.9 (LP: #1509147):
    - Support for Advanced Networking and Node Network Configuration:
      + Ability to declare Fabrics, Spaces, Subnets, VLANs and FANs.
      + Ability to assign subnets, fabrics and IP's to node interfaces.
      + Ability to create VLAN interfaces for nodes.
      + Ability to create Bond interfaces for nodes.
      + Ability to create interface names.
    - Support for Advanced Storage Configuration.
      + Ability to configure LVM.
      + Ability to configure BCache.
      + Ability to configure Software RAID Levels 0, 1, 5, 6, 10.
      + Ability to perform advanced partitioning.
    - Support for Curtin & Cloud-init status reporting.
    - Minimal config files for maas-regiond and maas-clusterd.
    - Better support for Hardware Enablement Kernels (HWE).
    - Support for Commissioning Actions.
    - Warn users about missing power tools.
    - Switch away from shell scripts to Python Power Drivers.
    - CentOS images can now be imported.

97e1c83... by Andres Rodriguez on 2016-05-09

Import patches-unapplied version 1.7.6+bzr3376-0ubuntu3~14.04.1 to ubuntu/trusty-proposed

Imported using git-ubuntu import.

Changelog parent: 1ae9c6a741fbc17db3576e9d5141425e64dc4b1a

New changelog entries:
  * debian/patches/lp1573046.patch: No longer use distro-info --lts to
    detect the commissioning release, as it returns 'xenial' for LTS.
    MAAS 1.7 only supports trusty. (LP: #1573046)

1ae9c6a... by Andres Rodriguez on 2015-07-10

Import patches-unapplied version 1.7.6+bzr3376-0ubuntu2~14.04.1 to ubuntu/trusty-proposed

Imported using git-ubuntu import.

Changelog parent: 93b32a8b15d92ae74a45e4f4b19f92a2fbecc1e0

New changelog entries:
  * debian/control: Make maas-dns a Dependy of maas-region-controller.
  * debian/maas-region-controller.postinst: Ensure DNS config migration is
    always run. (LP: #1413388)

93b32a8... by Andres Rodriguez on 2015-07-03

Import patches-unapplied version 1.7.6+bzr3376-0ubuntu1 to ubuntu/wily-proposed

Imported using git-ubuntu import.

Changelog parent: 091f7005bcf3b370c999d59123afea786a1f1c8f

New changelog entries:
  * New upstream release 1.7.6 bzr3376:
    - Accept list of forwarders for upstream_dns rather than just
      one. (LP: #1470585)
    - Fix upgrade issue where it would remove custom DNS config,
      potentially breaking DNS. (LP: #1413388)
  [ RaphaĆ«l Badin ]
  * Drop dependency on python-iscpy: the code has been integrated into
    MAAS. (LP: #1413388).
  [ Andres Rodriguez ]
  * Refactor maas-dns upgrade code so it doesn't break local DNS config
    and it gets migrated (LP: #1413388)
  * New upstream release, MAAS 1.7.5 bzr3369 (LP: #1460737):

091f700... by Andres Rodriguez on 2015-05-11

Import patches-unapplied version 1.7.5+bzr3369-0ubuntu1 to ubuntu/wily-proposed

Imported using git-ubuntu import.

Changelog parent: f46e42a7891389bf62a113c4c1e646ac16d9ff2c

New changelog entries:
  * New upstream release, MAAS 1.7.5 bzr:
    - MAAS cli/API: missing option set use-fast-installer /
      use-debian-installer (LP: #1456969)

f46e42a... by Andres Rodriguez on 2015-05-09

Import patches-unapplied version 1.7.4+bzr3366-0ubuntu1 to ubuntu/wily-proposed

Imported using git-ubuntu import.

Changelog parent: f3144f68864ae727f93c4da40202bbd9fee26268

New changelog entries:
  * New upstream release, MAAS 1.7.4 bzr3365:
    - When MAAS has too many leases, and lease parsing fails, MAAS fails
      to auto-map NIC with network. (LP: #1387859)
    - Alert a command-line user of `maas` when their local API description
      is out-of-date. (LP: #1329267)

f3144f6... by Andres Rodriguez on 2015-04-22

Import patches-unapplied version 1.7.3+bzr3363-0ubuntu2 to ubuntu/vivid-proposed

Imported using git-ubuntu import.

Changelog parent: c3189d8393bc6d20bb026be78c9a793084fcccd9

New changelog entries:
  * Use python-django16 instead of python-django ( 1.7). MAAS does not
    support django 1.7 due to having a new migration system. (LP: #1447573)
  * Adding systemd units and packaging support. (LP: #1423613)
  * debian/control: Add missing dependency on python-apt. (LP: #1446878)