ubuntu/+source/lvm2:ubuntu/intrepid

Last commit made on 2008-09-01
Get this branch:
git clone -b ubuntu/intrepid https://git.launchpad.net/ubuntu/+source/lvm2
Members of Ubuntu Server Dev import team can upload to this branch. Log in for directions.

Branch merges

Branch information

Name:
ubuntu/intrepid
Repository:
lp:ubuntu/+source/lvm2

Recent commits

a3a3610... by Colin Watson on 2008-09-01

Import patches-unapplied version 2.02.39-0ubuntu2 to ubuntu/intrepid

Imported using git-ubuntu import.

Changelog parent: 11f36eeee78de6959fcbbe718453663f02e8cd7c

New changelog entries:
  * Backport from Debian unstable (Bastian Blank):
    - Disable readline support in udeb. (closes: #491203, LP: #263558)

11f36ee... by James Westby on 2008-07-01

Import patches-unapplied version 2.02.39-0ubuntu1 to ubuntu/intrepid

Imported using git-ubuntu import.

Changelog parent: e055a4788adfaf2585d735592daed3a282c86e41

New changelog entries:
  * New upstream release (LP: #239460).
  * Merges 2.02.35-1 from Debian.
  * Increase devmapper dependency to (>> 2:1.02.27) due to new API.
  * Re-add quilt to Build-Depends.
  * Add missing Build-Depends on autoconf and libtool.
  * New upstream version.
  * Fix LSB header of init script.
  * New upstream version.
  * Remove loading of additional modules from init script.
  * New upstream version.
  * Readd clvm.
  * Add LSB header to lvm2 init script. (closes: #426108)
  * New upstream version.
  * Load modules.
  * Don't longer directly link libncurses, libselinux and librt.
  * Drop lvm1 support in lvm2-udeb.
  * Force modprobe path to enable module loading.

e055a47... by Fabio Massimo Di Nitto on 2008-08-26

Import patches-unapplied version 2.02.26-1ubuntu11 to ubuntu/intrepid

Imported using git-ubuntu import.

Changelog parent: 147d042c3da9dd1ab47c81a75d23ecae778bbaee

New changelog entries:
  * debian/control: build-deps on newer libcman and libdlm to guarantee a
    build against new libcman3 and libdlm3 soname.

147d042... by Kees Cook on 2008-07-28

Import patches-unapplied version 2.02.26-1ubuntu10 to ubuntu/intrepid

Imported using git-ubuntu import.

Changelog parent: 2ae4cf9d9b934945fc460679cebd3c62971617bf

New changelog entries:
  * debian/initramfs-tools/scripts/init-premount/lvm2:
    - use new named mountroot-fail hook ordering
    - silently detect array failures
  * lib/locking/cluster_locking.c, daemons/clvmd/{refresh_,}clvmd.c:
    add include for sys/param.h to catch limits, where PIPE_BUF went to live.

2ae4cf9... by James Westby on 2008-04-18

Import patches-unapplied version 2.02.26-1ubuntu9 to ubuntu/hardy

Imported using git-ubuntu import.

Changelog parent: 5ba36b5e5af9308b0d70a418189e6be94f2c6208

New changelog entries:
  * Include virtio block type in the filters. (LP: #218574)
    This change is included upstream in 2.02.34.

5ba36b5... by Luke Yelavich on 2008-02-18

Import patches-unapplied version 2.02.26-1ubuntu8 to ubuntu/hardy

Imported using git-ubuntu import.

Changelog parent: 544d1190c6eb47a5849d66060c83ba862ebe100a

New changelog entries:
  * debian/initramfs-tools/scripts/init-premount/lvm2: Ensure we exit if
    the script is called with mountfail.

544d119... by Luke Yelavich on 2008-02-15

Import patches-unapplied version 2.02.26-1ubuntu7 to ubuntu/hardy

Imported using git-ubuntu import.

Changelog parent: 79cea9db8a8a0e832430587208d96ee4227f8c8d

New changelog entries:
  * debian/initramfs-tools/scripts/init-premount/lvm2:
    /sbin/mdadm -> /sbin/lvm (Thanks Kees.)

79cea9d... by Luke Yelavich on 2008-02-05

Import patches-unapplied version 2.02.26-1ubuntu6 to ubuntu/hardy

Imported using git-ubuntu import.

Changelog parent: e37e4862b5d2a0d51722a4d05533677a50584779

New changelog entries:
  * Create init-premount hook script for the initramfs, to provide
    information at boot, if the root device is not functional.
  * Tighten initramfs-tools dependency.

e37e486... by Scott James Remnant (Canonical) on 2007-12-12

Import patches-unapplied version 2.02.26-1ubuntu5 to ubuntu/hardy

Imported using git-ubuntu import.

Changelog parent: e440d165c36a97eac5001f856f15a6886a429d29

New changelog entries:
  * Changes from Debian audited, remaining changes:
    - Recognise SUN's LDOM virtual block devices.
      (forwarded upstream and to Debian #455975).
    - Drop build-dependencies on libccs-dev and libgulm-dev since gulm
      locking is obsolete.
      (forwarded to Debian #455976).
    - Separate clvm package.
      (forwarded to Debian #455978).
    - Use udev to activate new LVM physical volumes, and thus volume groups
      and logical volumes.
      (forwarded to Debian #455979).
    - Copy lvm2.po to lvm2.pot for Rosetta.
    - Migrate configuration files from earlier Ubuntu versions.
  * Drop compilation without stack protector, no bugs are referenced as
    justification for that change.
  * Drop higher build requirements on libdlm-dev since we don't actually
    seem to have any patch that necessitates it (it builds fine with either,
    so just build with whatever we have).

e440d16... by Martin Pitt on 2007-07-19

Import patches-unapplied version 2.02.26-1ubuntu4 to ubuntu/gutsy

Imported using git-ubuntu import.

Changelog parent: 5ca7575837f26ab3f80f7336dc614ec9d2e13050

New changelog entries:
  * Bump dmsetup Suggests: to a Depends:, since without it we do not get
    /dev/disks/by-uuid/ and thus cannot mount anything. (LP: #126776)