ubuntu/+source/lintian:ubuntu/gutsy-devel

Last commit made on 2007-06-28
Get this branch:
git clone -b ubuntu/gutsy-devel https://git.launchpad.net/ubuntu/+source/lintian
Members of Ubuntu Server Dev import team can upload to this branch. Log in for directions.

Branch merges

Branch information

Name:
ubuntu/gutsy-devel
Repository:
lp:ubuntu/+source/lintian

Recent commits

17c76fa... by Arthur Loiret on 2007-06-27

Import patches-unapplied version 1.23.32ubuntu1 to ubuntu/gutsy

Imported using git-ubuntu import.

Changelog parent: 46c2c529bb48e06e93f439cef71bb2bfb83093d2

New changelog entries:
  * Merge from Debian unstable. Remaining Ubuntu changes:
    + If version contains "ubuntu", only accept Ubuntu distributions
      (#120040)
    + checks/lintian.desc: add "bad-ubuntu-distribution-in-changes-file" tag
    + checks/nmu: avoid NMU warning on Ubuntu uploads
    + frontend/lintian: check Ubuntu distribution if changelog contains "ubuntu"
    + Update Maintainer field to match Debian-Maintainer-Spec
  The "stability of output" release.
  * checks/binaries:
    + [RA] Sort the package SONAMEs to provide more stable lintian tags.
      Patch from Cyril Brulebois. (Closes: #428681)
  * checks/files{.desc,}:
    + [RA] Limit the Zope license exception to only .dtml, .pt, and .cpt
      files. Thanks, Bernd Zeimetz.
    + [RA] Sort the files listed in package-contains-hardlink so that the
      lintian output is stable regardless of the hash order of the
      directory when the tar file was built.
    + [RA] Don't incorrectly skip all other file location checks for hard
      links.
    + [RA] Check for files installed in /usr/lib/sgml. This transition
      was probably completed long ago, but checking for regression can't
      hurt. (Closes: #90019)
  * checks/manpages{.desc,}:
    + [RA] Check for dh_make man page templates (by looking for the
      template whatis entry). Thanks, Bill Allombert. (Closes: #173583)
  * checks/menus:
    + [RA] Avoid a quadratic search of the files in the package on
      doc-base files that list tons of files individually. This speeds up
      a lintian check of openoffice.org-dev-doc enormously.
  * checks/po-debconf:
    + [RA] Close the template file handle between files so that the line
      numbers for translated default fields are correct.
  * checks/rules{.desc,}:
    + [RA] Check for ignoring all errors from make clean or make distclean
      and recommend skipping the call if there's no Makefile instead.
      Thanks, Branden Robinson. (Closes: #325372)
  * checks/scripts{.desc,}:
    + [RA] Add Octave as an interpreter, and allow both versioned and
      unversioned forms. Thanks, Sebastian Harl. (Closes: #428403)
    + [RA] Check for deprecated install-sgmlcatalog usage.
  * checks/shared_libs:
    + [RA] Report the correct file for shlib-with-nonpic-code rather than
      the last shlib in the package. (Closes: #429840, #429528)
  * frontend/lintian:
    + [RA] Don't require -v in order to report unused overrides; they're
      already info-level tags, which is enough hiding.
    + [RA] Remove old dead unused override code.
  * reporting/html_reports:
    + [RA] Fix a Perl warning when generating the clean maintainer pages.
  * unpack/unpack-binpkg-l1:
    + [RA] Sort the output of tar tfv by filename so that the lintian
      output will be stable regardless of the hash order of the directory
      when the tar file was built.

46c2c52... by Soren Hansen on 2007-06-12

Import patches-unapplied version 1.23.31ubuntu2 to ubuntu/gutsy

Imported using git-ubuntu import.

Changelog parent: 835865a9e436db4e99ee8b3f61065e29039a7b52

New changelog entries:
  * If version contains "ubuntu", only accept Ubuntu distributions
    (LP: #120040).

835865a... by LaserJock on 2007-06-07

Import patches-unapplied version 1.23.31ubuntu1 to ubuntu/gutsy

Imported using git-ubuntu import.

Changelog parent: 338bea74b3eddca7da7064f2663aa7adf9ea7427

New changelog entries:
  * Resynchronise with Debian. Remaining changes:
    - frontend/lintian: Allow warty, hoary, breezy, dapper, edgy, feisty,
      gutsy, *-proposed, *-updates, and *-backports distributions.
  * checks/nmu:
    - Don't set nmu flag if version has "ubuntu"
  The "back under 100 open bugs" release.
  * checks/changelog-file:
    + [RA] Only check for missing colons in bug closers in the most recent
      changelog entry. Thanks, Thijs Kinkhorst. (Closes: #423171)
  * checks/common_data.pm:
    + [RA] Update architectures to dpkg 1.14.1. Remove all linux-*
      architectures and add armel. (Closes: #421995)
  * checks/control-files.desc:
    + [RA] Change unknown-control-file to a warning, since Policy only
      discourages it and doesn't outlaw it. (Closes: #287209)
  * checks/cruft:
    + [RA] Allow any automake package to satisfy the autotools-dev build
      dependency for suppressing warnings about out of date autotools
      helper files. (Closes: #417067)
  * checks/fields:
    + [RA] Require libmodule-build-perl in Build-Depends if the clean rule
      runs perl Build. Hopefully this isn't too aggressive. Thanks, Ian
      Beckwith. (Closes: #421549)
  * checks/files:
    + [RA] Don't warn about LICENSE files in Zope products, since they may
      be used for runtime display. (Closes: #424164)
  * checks/manpages:
    + [RA] Avoid false positives on binaries with X11 in the name. Patch
      from Kevin B. McCarty. (Closes: #423229)
  * checks/menu-format.desc:
    + [RA] Improve the pkg-not-in-package-test long description and add a
      manual reference. (Closes: #423519)
  * checks/menus:
    + [RA] Allow multiple blank lines between doc-base sections and
      trailing blank lines in the file. doc-base is fine with this.
      Reported by Luis Rodrigo Gallardo Cruz. (Closes: #423096)
  * checks/scripts:
    + [RA] Add pagsh, provided by openafs-client and heimdal-clients.
    + [RA] Diagnose removal of device files in maintainer scripts per
      Policy 10.6. (Closes: #268688)
    + [RA] Add jruby1.0. Thanks, Sebastien Delafond. (Closes: #426950)
    + [RA] Add jed and friends. Thanks, Jörg Sommer. (Closes: #426469)
    + [RA] Move several maintainer script checks specific to shell scripts
      inside the conditional so that they won't run on maintainer scripts
      not written in shell.
    + [RA] Diagnose maintainer scripts looking at /var/lib/dpkg/status
      directly. Thanks, Guillem Jover. (Closes: #426628)
    + [RA] Diagnose direct modifications to /etc/services, /etc/protocols,
      /etc/rpc, and /etc/inetd.conf in maintainer scripts. (Yes, an
      eight-year-old bug!) (Closes: #32532)
  * checks/version-substvars{.desc,}:
    + [RA] Add a check for deprecated ${Source-Version} substvars. Patch
      from Guillem Jover. (Closes: #427577)
  * frontend/lintian-info:
    + [CW] Fix uninitialized value warning after reading a blank line.
  The "beating false positives off with a stick" release.
  * checks/common_data.pm:
    + [RA] Add mktemp and sysvinit-utils as known essential packages.
    + [RA] Add Vcs-Mtn and Vcs-Browser to the known source package
      fields.
    + [RA] Add Kernel-Version to known udeb control fields.
  * checks/control-files:
    + [RA] Allow clilibs, but don't try to check the syntax of it yet.
      Thanks, Sebastian Dröge. (Closes: #378088)
  * checks/copyright-file:
    + [RA] Exclude the Affero General Public License from the check for
      references to the shared GPL copy. (Closes: #420077)
    + [RA] Replace yet another hand-rolled dependency parser with Dep.
  * checks/cruft{.desc,}:
    + [RA] Check for svk commit message files.
  * checks/debconf{.desc,}:
    + [RA] Remove the dependency check for SETTITLE since all debconf
      implementations back to oldstable support it.
    + [RA] Reduce the dependency check for error templates to info since
      all debconf implementations back to stable support it.
  * checks/debhelper{.desc,}:
    + [RA] Downgrade the dependency check for dh_python and the Python
      policy to info since all debhelpers back to stable support it.
    + [RA] Downgrade the dependency check for compatibility level V5 to
      info since all debhelpers back to stable support it.
  * checks/fields{.desc,}:
    + [RA] The CDBS Python rules only call pycentral or pysupport during
      the binary targets, so those dependencies can be safely moved to
      Build-Depends-Indep. Still allow them in Build-Depends, though,
      since that's where CDBS likes to put them. Thanks, Tristan
      Seligmann. (Closes: #420526)
    + [RA] Allow the Python core packages themselves to depend on
      python-minimal.
    + [RA] Remove the version constraints for python-central and
      python-support dependencies since stable released with a working
      version and they weren't in oldstable.
    + [RA] Remove the dependency check on dh_installxfonts for the X.Org
      transition since the debhelper released with stable does the right
      thing and this dependency is not useful for backports to oldstable.
    + [RA] Remove the version on the quilt dependency check. It's not
      worth the effort to maintain a separate version check for oldstable
      backports. (Closes: #420160)
  * checks/files{.desc,}:
    + [RA] Check for svk commit message files.
    + [RA] Don't consider {copying,license}.dtd extra license files; the
      Mozilla suite uses them for non-licenses. (Closes: #420558)
    + [RA] Use $pkg rather than reading fields/package for the x11-common
      pre-depend check.
    + [RA] Allow x11-common to install /usr/X11R6/bin.
    + [RA] Downgrade the pre-depends on x11-common requirement for
      packages installing into /usr/include/X11 or /usr/lib/X11 to info
      since it's only needed for upgrades from sarge or early etch.
  * checks/md5sums:
    + [RA] Don't warn about a missing md5sums file if the package contains
      nothing for which we would generate an MD5 checksum. Thanks,
      Andreas Beckmann. (Closes: #420465)
  * checks/manpages:
    + [RA] Cope with more uses of - in *roff escapes that don't need
      hyphen warnings.
    + [RA] Don't consider a binary an X binary if it's a symlink into
      /etc/X11. (seyon does something weird but probably legitimate.)
    + [RA] Fix manpage-for-non-x11-binary-in-wrong-directory and
      manpage-for-x11-binary-in-wrong-directory output. (Closes: #295072)
  * checks/menus{.desc,}:
    + [RA] In doc-base control files, check for Index fields for HTML and
      Info documents and require that each section after the header have a
      Format field. Thanks, Bernhard R. Link. (Closes: #419847)
  * checks/rules:
    + [RA] Listing a rule as a dependency of .PHONY is sufficient to mark
      it as present for GNU make and hence sufficient for Policy's
      requirement. Thanks, Peter Eisentraut. (Closes: #419446)
  * checks/scripts{.desc,}:
    + [RA] Packages calling update-xmlcatalog must depend on xml-core.
      Also avoid false positives when a package itself provides the
      program its maintainer scripts use. Thanks, Daniel Leidert.
      (Closes: #419461)
    + [RA] Check for maintainer scripts calling read (but exclude those
      that include /usr/share/debconf/confmodule on the grounds that
      they're probably only using it as a fallback). Based on a patch by
      Luk Claes. (Closes: #231770)
    + [RA] Add pike7.6 and ruby1.9 as valid interpreters.
    + [RA] Diagnose use of /bin/env with a more specific message than the
      generic unusual interpreter tag.
    + [RA] Remove the version constraint on the gconf-schemas check since
      all versions of gconf2 back to stable provide this script and it's
      not worth maintaining a separate check for oldstable backports.
  * checks/shared-libs{.desc,}:
    + [RA] Warn if a package declares dependencies in its shlibs control
      file that cannot be satisfied by that package (including via
      Provides). (Closes: #56440)
  * reporting/harness:
    + [RA] Include overridden tags in the lintian output so that we can do
      statistical reporting on them and see them in lintian.log.
  * reporting/html_reports:
    + [RA] Create stub pages for maintainers with only lintian-clean
      packages. (Closes: #305173)
    + [RA] Sort packages on each maintainer's page.
    + [RA] Report statistics on info tags as well.
    + [RA] Generate better file names for maintainer pages with weird
      characters.
    + [RA] Fix Perl warnings.

338bea7... by Colin Watson on 2007-04-20

Import patches-unapplied version 1.23.29ubuntu1 to ubuntu/gutsy

Imported using git-ubuntu import.

Changelog parent: e87e131fddbb51d6f94f56e509126030020bcbdc

New changelog entries:
  * Resynchronise with Debian. Remaining changes:
    - frontend/lintian: Allow warty, hoary, breezy, dapper, edgy, feisty,
      *-proposed, *-updates, and *-backports distributions.
  * frontend/lintian: Allow gutsy distribution.
  The "look at all the stuff that accumulated during the etch freeze"
  release.
  * COPYING:
    + [CW] Update to current text of GPL v2 (which talks about the GNU
      Lesser General Public License rather than Library, etc.; no functional
      changes).
  * checks/changelog-file{.desc,}:
    + [RA] Check for bug closers without a colon after closes, but only if
      there are at least six digits in the bug number and no non-digits.
      Suggestion from Jari Aalto. (Closes: #373918)
  * checks/copyright-file{.desc,}:
    + [JA] Update usr-doc-* test to report user-share-doc-* instead.
      New tests added: postinst-should-not-set-usr-doc-link,
      doc-base-file-references-usr-doc.
      Patch from Thijs Kinkhorst. (Closes: #406349).
  * checks/common_data.pm:
    + [JA] Perl syntax corrections.
    + [JA] Support the Autobuild: and Vcs-* fields in .dsc files.
      Applied patch to implement this by Ian Beckwith. (Closes: #403553).
  * checks/control-file:
    + [RA] Allow source in main to generate contrib packages. Thanks,
      Bdale Garbee. (Closes: #401881)
  * checks/cruft{.desc,}:
    + [RA] Use Dep to check autotools-dev build dependency rather than
      rolling our own dependency parsing, thus avoiding problems when it's
      the first dependency. Thanks, Tilman Koschnick. (Closes: #412406)
    + [RA] Mention that including CVS or .svn directories in a release
      tarball should generally be reported as an upstream bug. Qualify
      the statement that export should be used instead of checkout to
      refer to snapshot packaging. Thanks, Jari Aalto. (Closes: #373668)
    + [RA] Allow a build dependency on automake to satisfy the
      autotools-dev requirement since users may use autoreconf to update
      config.{sub,guess}. Thanks, Jordà Polo. (Closes: #417067)
  * checks/debconf:
    + [RA] Rather than munging dependencies to cope with the various
      implementations of debconf, take advantage of our new dependency
      comparison routines and check the full correct dependency. This
      should really fix problems with checking the dependencies for
      settitle. Patch from Damyan Ivanov. (Closes: #349616)
    + [RA] Check that an appropriate versioned dependency on debconf
      and/or cdebconf is present if error template types are used.
      Thanks, Christian Perrier. (Closes: #416140)
  * checks/debhelper.desc:
    + [RA] Use consistent file naming when diagnosing possibly conflicting
      debhelper compat settings. Thanks, Jari Aalto. (Closes: #409122)
  * checks/fields{.desc,}:
    + [RA] Add an exception to maintainer-not-full-name for Wookey and a
      comment to consider removing the check if we get more false
      positives. Thanks, Neil Williams. (Closes: #406731)
    + [RA] Rename build-depends-indep-should-be-build-depends to
      clean-should-be-satisfied-by-build-depends to make the reason for
      the message clearer without running lintian -i. Thanks to Osamu
      Aoki for the suggestion. (Closes: #405840)
    + [RA] Recognize the +bX convention for binary NMUs. Warn about use
      of the old three-part version numbers.
  * checks/files{.desc,}:
    + [RA] Diagnose creation of subdirectories of /usr/bin other than mh
      and the legacy X11 directory. (Closes: #417912)
  * checks/manpages:
    + [RA] When checking for hyphen used as a minus sign, avoid false
      positives on \s-1 (small font) and \*(-- (pod2man long dash).
    + [RA] Display the full path for binary-without-manpage tags to make
      it easier to track down problems.
    + [RA] Ignore binaries in subdirectories of the normal binary
      directories (other than /usr/bin/X11 and /usr/bin/mh). These should
      be caught by other checks and the man page warnings would likely be
      confusing noise.
  * checks/menu-format{.desc,}:
    + [RA] If a menu icon isn't an absolute path, only look for it in
      /usr/share/pixmaps, not in the old X11R6 paths. Update the long tag
      description accordingly.
  * checks/menus:
    + [JA] Perl syntax corrections. Removed extra empty newlines.
  * checks/lintian.desc:
    + [RA] List emergency as a valid urgency.
  * checks/nmu{.desc,}:
    + [RA] List the exact phrases recognized by lintian as marking an NMU.
      Reported by Jari Aalto. (Closes: #409108)
    + [RA] Recognize the +bX convention for binary NMUs.
  * checks/po-debconf:
    + [RA] Now that we're passing --use-untranslated to msgcmp, we have to
      compare the generated pot file with the one in the package both
      directions to catch all out of date errors. Thanks, Thomas
      Huriaux. (Closes: #402662)
  * checks/rules{.desc,}:
    + [RA] Fix the policy section for debian-rules-missing-required-target
      and debian-rules-not-a-makefile. Thanks, Daniel Kahn Gillmor.
      (Closes: #414964)
    + [RA] Warn about use of $(PWD) instead of $(CURDIR).
    + [RA] Setting DH_COMPAT globally in debian/rules is now deprecated in
      favor of debian/compat. Patch from Luk Claes. (Closes: #330025)
  * checks/scripts{.desc,}:
    + [RA] update-inetd is now its own package and netbase may not always
      depend on it. Update the check to require a dependency on
      update-inetd, inet-superserver, or one of the inet-superserver
      packages that provides update-inetd. Reported by Tatsuya Kinoshita.
      (Closes: #402319)
    + [RA] Mention SUSv3 in the bashism and non-posix tag descriptions,
      note that use of test -a/-o and local aren't bugs but may still be
      worth avoiding, and mention short circuiting of && and ||. (Thanks
      to Jari Aalto for the latter).
    + [RA] Add /usr/bin/gbr2, provided by gambas2-runtime. Thanks, José
      "L. Redrejo" Rodríguez. (Closes: #403515)
    + [RA] Add /usr/bin/jruby0.9, provided by jruby0.9. Thanks, Sebastien
      Delafond. (Closes: #418105)
  * doc/README:
    + Document --color option. Based on a patch from Loïc Minier.
  * depcheck/deppages.pl:
    + [JA] Perl syntax corrections.
  * depcheck/report2html.pl:
    + [JA] Perl syntax corrections.
  * frontend/lintian:
    + [JA] Removed trailing spaces and other perl syntax corrections.
    + [RA] Add --color option to optionally colorize lintian tags based on
      their severity. Based on a patch from Loïc Minier.
    + [RA] Accept emergency as a valid urgency and check urgencies
      case-insensitively since that's what Policy specifies. Thanks, Joey
      Hess. (Closes: #412577)
  * frontend/lintian-info:
    + [RA] Ignore ANSI color sequences when parsing lintian tags.
  * lib/Checker.pm
    + [JA] Perl syntax corrections.
  * lib/Lab.pm
    + [JA] Perl syntax corrections.
  * lib/Tags.pm
    + [JA] Perl syntax corrections.
    + [RA] Support for colorizing lintian tags based on their severity.
      Based on a patch from Loïc Minier. (Closes: #399714)
  * man/lintian.1:
    + [RA] Document --color. Based on a patch from Loïc Minier.
  * unpack/unpack-*pkg*
    + [JA] Perl syntax corrections.
  * collection/objdump-info:
    + [RA] Remove unsafe temporary file creation in left-over debugging
      code added accidentally when fixing #399456. Thanks, Josh
      Triplett. (Closes: #414237)

e87e131... by Colin Watson on 2006-12-20

Import patches-unapplied version 1.23.27ubuntu1 to ubuntu/feisty

Imported using git-ubuntu import.

Changelog parent: 669d5be71076f5538a3b00487f64e3e0805500c6

New changelog entries:
  * Resynchronise with Debian. Remaining changes:
    - frontend/lintian: Allow warty, hoary, breezy, dapper, edgy, feisty,
      *-proposed, *-updates, and *-backports distributions.
  The "we haven't run this against the whole archive in a while" release
  * checks/binaries{.desc,}:
    + [RA] Tag unrecognized ELF binaries as apparently corrupted rather
      than failing with a note that binutils-multiarch is required. Some
      packages have had ELF binaries recognized by file but unreadable.
      Reported by Bill Allombert. (Closes: #399456)
  * checks/infofiles:
    + [RA] Don't consider /usr/share/infon to be an info directory.
      Reported by Joachim Breitner. (Closes: #399857)
  * checks/md5sums:
    + [RA] Also don't complain about missing md5sums for files in
      /var/lib/ispell as they're changed after installation. Thanks,
      Agustin Martin. (Closes: #401070)
  * checks/po-debconf:
    + [RA] gettext 0.16's msgcmp requires --use-untranslated when checking
      for newer templates than PO files or it gives false positives for
      every package. Thanks, Damyan Ivanov. (Closes: #400957)
    + [RA] Don't consider directories to be stray template files even if
      named template. Thanks, Thomas Huriaux. (Closes: #401442)
  * checks/shared-libs:
    + [RA] Don't report shlib-with-non-pic-code unless we're sure that
      we're looking at a shared library. Otherwise, we get many false
      positives on some platforms where text relocations are normal for
      binaries. Reported by Bill Allombert. (Closes: #399525)
  * collection/file-info:
    + [RA] Unescape non-ASCII characters escaped by tar before running
      file on the resulting filename. Otherwise, file can't find the
      file, exits with an error, and lintian aborts. Reported by Bill
      Allombert. (Closes: #399392)
  * collection/objdump-info:
    + [RA] Include unrecognized format errors from objdump in the output
      rather than aborting; some packages contain apparently corrupt ELF
      binaries.
  * debian/control:
    + [RA] Depend on gettext 0.16 or later for --use-untranslated.
  * lib/Lab.pm:
    + [RA] Preserve the old package lists when setting up a static lab so
      that the unpack programs can build a list of changed packages and
      incremental mode works. Thanks, Bill Allmobert. (Closes: #400342)
  * unpack/list-udebpkg:
    + [RA] Handle compressed udeb Packages files. Thanks, Bill
      Allombert. (Closes: #400338)
  * checks/binaries{.desc,}:
    + [RA] Add a policy reference for unstripped-binary-or-object.
      Thanks, Bas Wijnen. (Closes: #394419)
    + [RA] Add a special exception to the shared library dependency check
      for the dynamic loader itself.
  * checks/changelog-file.desc:
    + [RA] Downgrade to a warning several errors with changelog files,
      including compression and a text version of HTML changelogs, that
      are only shoulds in Policy. (Closes: #289723)
    + [RA] Cleaned up language and use of unbalanced single quotes in
      numerous descriptions.
  * checks/control-file{.desc,}:
    + [RA] Diagnose a control file that creates binary packages in a
      different archive category from the source package or the other
      binary packages. Idea from Yann Dirson. (Closes: #394720)
    + [RA] Close opened files.
    + [RA] Add info-level check for Section in the source section of the
      control file. (Closes: #322244)
  * checks/cruft{.desc,}:
    + [RA] Tighten the timestamp check on config.{sub,guess} to look for
      files dated 2004 or newer, since that's when x86_64 was added.
      Increase to an error at the request of Ryan Murray since we already
      suppress this warning of config.{guess,sub} are modified by the
      Debian patch or if the package build-depends on autotools-dev.
      (Closes: #190897)
  * checks/debconf{.desc,}:
    + [RA] Take into account comma escaping when checking the number of
      translated choices. Reported by Frans Pop. (Closes: #395028)
    + [RA] Only require debconf be loaded in the postinst script if a
      config script exists. Reported by Josselin Mouette.
    + [RA] Require pre-depends on debconf if debconf is used in the
      preinst script. Update the long description to deprecate only
      depending on debconf and falling back on another configuration
      system. Reported by Josselin Mouette. (Closes: #395468)
    + [RA] Warn of debconf notes displayed with low or medium priority,
      with an exception for Policy-required device file warnings. Based
      on a patch by Thomas Huriaux. (Closes: #389070)
    + [RA] Close files after opening them, fixing incorrect line numbers
      when reporting problems with config scripts.
  * checks/debdiff{.desc,}:
    + [RA] Check for creation of ~ and .xxx.swp backup files in the Debian
      diff, but only at the info level for now since they cause no harm.
      (Closes: #332770)
  * checks/fields{.desc,}:
    + [RA] Clarify in missing-build-dependency why lintian does not take
      into account transitive build dependencies. (Closes: #393975)
    + [RA] Avoid Perl warning when diagnosing a Python-Version of the form
      "all, >= 2.4". Thanks, Thijs Kinkhorst. (Closes: #394104)
    + [RA] Teach the debian/rules parsing about make conditionals and
      don't require build dependencies for lines encountered inside a
      conditional (in other words, assume people using conditionals know
      what they're doing). Fixes a false positive due to the unusual
      arch-specific build dependencies for openoffice.org, reported by
      Rene Engelhard. (Closes: #380286)
  * checks/files{.desc,}:
    + [RA] Check for vim .swp files in the package.
    + [RA] Split the warning for NFS temporary files into a separate tag
      from the warning for editor backup files.
  * checks/infofiles:
    + [RA] Close opened files.
    + [RA] debhelper no longer adds a --section flag to install-info, so
      don't warn about any install-info invocation without --section.
      Instead, check each info file for INFO-DIR-SECTION and diagnose
      calling install-info without --section if any info file is missing
      this information. (Closes: #97502, #398670)
    + [RA] Checks for the compression and suffixes of info files were not
      being run due to a mistake in specifying either /usr/info or
      /usr/share/info as an info directory. Re-enable them.
  * checks/md5sums{.desc,}:
    + [RA] Add a tag for a missing md5sums control file, but only at info
      level, at least for now. (Closes: #133027)
    + [RA] Do better syntax checking of the md5sums control file and
      report malformed lines as a tag rather than aborting lintian.
    + [RA] Downgrade file-missing-in-md5sums to a warning since it doesn't
      break the package or debsums and may be intentional.
  * checks/menu.desc:
    + [RA] Remove stray commas in Ref strings since the reporting code
      considers commas to be separating two different references.
  * checks/menu-format{.desc,}:
    + [RA] Support the sux, gksu, and kdesu wrappers in menu commands as
      well as su-to-root. (Closes: #360227)
    + [RA] Fix tag name for menu-icon-cannot-be-parsed. Thanks, Bill
      Allombert. (Closes: #399245)
  * checks/po-debconf{.desc,}:
    + [RA] Check for misnamed PO files in debian/po, which cause
      translations to be merged into the template with the wrong names and
      not found. Based on a patch by Thomas Huriaux. (Closes: #387360)
  * checks/shared-libs:
    + [RA] Calling ldconfig is also required for libraries installed in
      various subdirectories of its standard search path based on hardware
      capabilities. Reported by Aurelien Jarno. (Closes: #396278)
  * debian/rules:
    + [RA] Exclude testset/diffs/binary.c~ from dh_clean.
  * frontend/lintian:
    + [RA] Add --fail-on-warning option to exit with non-zero status if
      any warnings were found. Thanks, Daniel Bonniot. (Closes: #189656)
  * man/lintian.1:
    + [RA] Document --fail-on-warning.

669d5be... by Colin Watson on 2006-10-27

Import patches-unapplied version 1.23.25ubuntu1 to ubuntu/feisty

Imported using git-ubuntu import.

Changelog parent: e38f16e5bf8db6d1fb6982c14f427d00f34c0406

New changelog entries:
  * Resynchronise with Debian.
  * debian/control: Drop dpkg-dev versioned dependency change; lintian now
    requires Edgy's dpkg-dev.
  * frontend/lintian: Allow feisty and *-proposed distributions.
  The "dependency and debconf" release
  * checks/debconf:
    + [CW] Don't trigger partially-translated-question when Choices-C exists
      but not Description-C.
    + [RA] Remove select-with-translated-default-field since there are
      cases where this is correct and we can perform a better check
      against the source package. Patch from Thomas Huriaux.
    + [RA] Fix Perl warnings when a template has no type.
  * checks/debdiff:
    + [RA] Remove the source-tar-is-posix-tar tag. This was only a
      problem for woody and earlier, and woody support is no longer
      needed. Reported by Loïc Minier. (Closes: #385833)
  * checks/fields{.desc,}:
    + [RA] Improve the long descriptions of the warnings about dependencies
      on essential or build-essential packages to make it clearer that the
      correct resolution is normally to omit the dependency and why.
    + [RA] Add a check for duplicate build dependencies. (Closes: #359178)
  * checks/files:
    + [RA] Don't consider files named license.rb to be extraneous
      licenses. Patch from NIIBE Yutaka. (Closes: #387269)
  * checks/init.d:
    + [RA] Correctly handle LSB keywords which are present but have an
      empty value. Reported by Erich Schubert. (Closes: #386968)
  * checks/lintian.desc:
    + [RA] Add tags for missing and bad Urgency fields in *.changes files.
    + [RA] Improve the no-description-in-changes-file information.
  * checks/md5sums:
    + [RA] aspell dictionary packages may ship files in /var/lib/aspell
      that should not have MD5 checksums in md5sums because they change
      after installation. Don't complain that those files are missing.
  * checks/po-debconf:
    + [RA] Avoid Perl warnings on .po files that don't contain msgstr
      lines. Patch from Thomas Huriaux. (Closes: #387357)
    + [RA] Check templates for a translatable Default or DefaultChoice
      field and warn if there isn't a translator comment. Patch from
      Thomas Huriaux. (Closes: #388824)
  * checks/scripts:
    + [RA] Add /usr/bin/gosh from the gauche package to the list of valid
      interpreters. Thanks, Tatsuya Kinoshita. (Closes: #386798)
    + [RA] Add a separate tag for tclsh dependencies to explain about the
      virtual package and improve the description of the wish virtual
      package in its tag. Fix inverted logic that got the wish dependency
      backwards. Reported by Hamish Moffatt. (Closes: #387845)
    + [RA] Allow tcsh to satisfy a csh dependency. Reported by Yann
      Dirson. (Closes: #389615)
    + [RA] Improve the check for shell scripts that are actually exec
      wrappers around scripts written in another language.
    + [RA] Allow update-inetd to fulfill the dependency requirements for
      the update-inetd script. Thanks, Michael Holzt. (Closes: #389960)
  * frontend/lintian:
    + [RA] Check the existence and value of the Urgency field in *.changes
      files. (Closes: #384219)
  * lib/Dep.pm:
    + [RA] Improve the dependency resolution engine so that it can prove
      aa|bb implies aa|bb|cc. Fix the comparison of dependencies for
      inverse implication to catch many more cases. (The latter code
      isn't currently used in lintian.)
    + [RA] Add an unparse function to take an internal representation and
      convert it back to human-readable text.
    + [RA] Significantly improve and rewrite the get_dups function to only
      find relations that imply each other and to return the complete
      duplicate dependencies in sets.
  * man/lintian.1:
    + [RA] Document setting TMPDIR to change the location of lintian's
      temporary lab. (Closes: #388786)
  The "LSB init script" release
  * checks/control-files:
    + [RA] perm2oct definition moved to Util.pm.
  * checks/cruft{.desc,}:
    + [RA] Remove the (info-level) check for .cvsignore files in the
      source tarball. This isn't an error; those files contain metadata
      that may be useful for people making modifications and it's quite
      common to distribute them.
  * checks/debconf{.desc,}:
    + [RA] Diagnose unknown priorities in db_input and db_text
      invocations. Patch from Thomas Huriaux. (Closes: #386014)
  * checks/fields{.desc,}:
    + [RA] Depending on versioned variants of python-minimal is also an
      error. Thanks, Adeodato Simó. (Closes: #384476)
  * checks/files:
    + [RA] perm2oct definition moved to Util.pm.
  * checks/init.d{.desc,}:
    + [RA] Added a warning for init scripts missing an LSB keyword
      section, checks of the syntax of such a section if present, and
      some basic semantic checks of the easiest fields. Based on initial
      work by Carlos Villegas. (Closes: #377740)
  * checks/menus:
    + [RA] perm2oct definition moved to Util.pm.
  * checks/scripts:
    + [RA] Properly concatenate the dependencies for a package when
      checking whether the dependency for an interpreter is included.
      Thanks, Vincent Danjean. (Closes: #385178)
  * checks/shared-libs:
    + [RA] perm2oct definition moved to Util.pm.
  * lib/Util.pm:
    + [RA] Move perm2oct to here and improve recognition of s, S, t, and T
      characters. Thanks to Justin B. Rye for patch. (Closes: #376119)
  The "new Python policy" release
  * checks/binaries.desc:
    + [RA] Greatly expand the binary-or-shlib-defines-rpath long
      description based on recent discussion in debian-policy. Add a
      reference to the wiki page. (Closes: #378054, #378055)
  * checks/changelog-file{.desc,}:
    + [RA] Diagnose changelog files that are symlinks, using the new way
      the changelog-file collection script processes them.
  * checks/common_data.pm:
    + [RA] Add Python-Version as a known source and binary field.
  * checks/copyright-file:
    + [RA] Catch "<fill in http/ftp site>" as well as the string without
      "http/". Thanks, Jari Aalto. (Closes: #374167)
  * checks/deb-format{.desc,}:
    + [RA] Remove deb-created-with-broken-tar; the bug was actually in
      dpkg, and the dpkg in stable has been fixed. Thanks Jari Aalto and
      Thijs Kinkhorst. (Closes: #375638, #376030)
  * checks/debconf:
    + [RA] Diagnose a missing template description only once and avoid
      Perl warnings. Thanks, Thomas Huriaux. (Closes: #377654)
  * checks/debhelper:
    + [RA] Use the standard control file parser rather than a custom
      parser that can't handle continuation lines.
    + [RA] Warn if dh_python is used without debian/pycompat in non-CDBS
      packages and check for the debhelper version required for Python
      policy. Thanks, Raphaël Hertzog. (Closes: #375318)
  * checks/fields{.desc,}:
    + [RA] Don't warn virtual-package-depends-without-real-package-depends
      for Recommends and rewrite the tag description to be more accurate.
      Thanks to Martin F. Krafft for the report. (Closes: #370720)
    + [RA] ~ is now permitted in version numbers. (Closes: #381965)
    + [RA] Catch and check dependencies correctly for debconf-updatepo run
      from the clean target. Thanks, James Westby. (Closes: #380399)
    + [RA] Warn when encountering an aspell dictionary package that isn't
      arch: all. Thanks, Piotr Engelking. (Closes: #374899)
    + [RA] Check the syntax of the new Python-Version field.
    + [RA] Check for missing build dependencies on python-central or
      python-support. Thanks, Raphaël Hertzog.
    + [RA] Check for old << dependencies on Python in Python packages that
      lack a Python-Version control field, as these are probably packages
      that don't follow the new Python policy. Thanks, Raphaël Hertzog.
  * checks/files{.desc,}:
    + [RA] Provide a better explanation of why Debian packages shouldn't
      ship files in /srv. (Closes: #379176)
    + [RA] Warn about files installed into /etc/gconf/schemas.
    + [RA] Warn about files in /usr/lib/site-python. Thanks, Thomas
      Viehmann and Raphaël Hertzog. (Closes: #372748)
  * checks/manpages{.desc,}:
    + [RA] Warn about manpage short descriptions of the form "manual page
      for program" (usually generated by help2man).
  * checks/menu:
    + [RA] Ignore trailing whitespace in doc-base files. Patch from Bas
      Zoetekouw. (Closes: #379749)
  * checks/nmu{.desc,}:
    + [RA] When checking for an NMU changelog entry, require "NMU" be
      surrounded by word boundaries.
    + [RA] Warn if the changelog incorrectly indicates an NMU. Thanks to
      George Danchev for the report.
  * checks/scripts{.desc,}:
    + [RA] Except mkstemp from possibly-insecure-handling-of-tmp-files for
      maintainer scripts written in Perl.
    + [RA] Mention [[ ]] explicitly in the possible-bashism long
      description as requiring a Korn shell and make it clearer that the
      primary arbiter of this test is the POSIX shell specification.
      (Closes: #381800 by clarification)
    + [RA] Use the Dep library to check dependencies. Add php5 to the
      interpreter list and correctly handle the dependencies for
      version-less PHP scripts. (Closes: #379558)
    + [RA] Check for proper dependencies if gconf-schemas is called in
      maintainer scripts and diagnose calling gconftool(-2) directly.
      Thanks, Josselin Mouette. (Closes: #333311)
  * checks/version-substvars{.desc,}:
    + [RA] New check from Adeodato Simó for proper use of substvars for
      versioned dependencies between packages built from the same source
      package so that NMUs will work properly. Also catch use of such a
      substvar for a versioned dependency on a package not built from the
      same source. (Closes: #377141, #376596)
  * collection/changelog-file:
    + [RA] Be much more careful about changelog files that are symlinks.
      Don't skip over changelog symlinks just because they point to
      non-existant files, mark unsafe symlinks or symlinks to non-existent
      files by creating copyright as a symlink to a non-existent file in
      the lab, and don't create an empty dummy changelog if we couldn't
      find a changelog. Correctly handle changelog files that are
      symlinks to other files in the same directory.
  * debian/copyright:
    + [RA] Add Subversion repository location.
  * frontend/lintian:
    + [JvW] Give error if there is no "Description" field in .changes, this is
      required by dak
  * frontend/lintian-info:
    + [RA] Add the -t or --tags option that, given a tag name, prints out
      the description. (Closes: #376109)
  * lib/Tags.pm:
    + [RA] If a tag has been overriden via any mechanism, do not add it to
      any of the statistics (tag, severity, or significance). Before, the
      override only suppressed a record for the specific statistic the
      override was based on, meaning that classic tag-based overrides
      didn't suppress severity statistics. Overridden error tags would
      therefore cause lintian to exit with non-zero status. Thanks,
      Andree Leidenfrost and Martin F. Krafft. (Closes: #377182, #374314)
  * man/lintian.1:
    + [RA] Better document the --archivedir and --dist options and how
      lintian constructs the path to an archive. (Closes: #383203)
    + [RA] Document new version-substvars check script.
  * man/lintian-info.1:
    + [RA] Document the new -t or --tags option.
  * reporting/html_reports:
    + [RA] Include the lintian version in HTML page footers. Thanks,
      Thijs Kinkhorst. (Closes: #377616)

e38f16e... by Reinhard Tartler on 2006-07-09

Import patches-unapplied version 1.23.22ubuntu1 to ubuntu/edgy

Imported using git-ubuntu import.

Changelog parent: e8e8b0a1eab4ab93a3ce2db14eaca8885581208f

New changelog entries:
  * Merge from debian unstable.
  * checks/debconf:
    + [JvW] Teach lintian to know about the 'error' debconf template
      question type. (Closes: #374399)
    + [RA] Exclude debconf templates with "for internal use" in the short
      description from style checks and document this in the log
      description of the tags most likely to trigger on internal
      templates. (Closes: #368206)
  * checks/common_data.pm:
    + [RA] Add amd64 to the standard architectures. (Closes: #367324)
  * checks/debhelper:
    + [RA] Use the Dep library to check debhelper build dependencies
      rather than parsing Build-Depends with regexes. This avoids false
      positives due to matching package names ending in debhelper.
      Reported by Fabio Tranchitella. (Closes: #366531)
  * checks/fields:
    + [RA] Allow build-depend on quilt if clean depends on the xsfclean
      rule, for packages maintained by the X Strike Force.
    + [RA] CDBS packages that use the python-distutils class should list
      Python in Build-Depends, not Build-Depends-Indep, since CDBS wants
      to use it in debian/rules clean. Thanks, Jan Lübbe.
    + [HE] Add check for build-deps on build-essential. Yes, people do that.
    + [RA] Recognize direct invocations of quilt in clean rules and allow
      Build-Depends on quilt in that case. Reported by Sam Hocevar.
      (Closes: #374878)
    + [RA] Fix handling of versioned Build-Depends to avoid spurious
      build-depends-without-arch-dep warnings. Reported by Marcus
      Better.
    + [RA] Don't require Build-Depends on perl even if run explicitly in
      debian/rules clean, since perl-base may be sufficient. Catch more
      ways perl could be run, including the common idiom for packages that
      use Build.PL.
    + [RA] Downgrade build-depends-without-arch-dep to info from warning.
      Policy doesn't require using Build-Depends-Indep for
      arch-independent packages and the test has a lot of false positives.
    + [RA] Require ant in Build-Depends when using the CDBS ant rule.
    + [RA] Bypass the build-depends-without-arch-dep check entirely when
      using ant, since determining which Java dependencies are then
      permissible in Build-Depends is too complex to do a proper job.
      Reported by Peter Eisentraut. (Closes: #372190)
    + [RA] Only allow patch in Build-Depends for yada unpatch, don't
      require it, since yada depends on patch. (Closes: #375479)
  * checks/po-debconf:
    + [RA] Don't consider templates.in to be a stray translated template
      file. Thanks, Thomas Huriaux. (Closes: #367534)
  * lib/Util.pm:
    + [RA] Pass the --wildcards option to tar, now required by a change in
      the default tar semantics. (Closes: #375246)

e8e8b0a... by Reinhard Tartler on 2006-06-28

Import patches-unapplied version 1.23.21ubuntu1 to ubuntu/edgy

Imported using git-ubuntu import.

Changelog parent: a9ec9c456808b468e8798d57a4707cef5e23bea4

New changelog entries:
  * Merge from debian unstable.
  * add edgy to frontend
  * checks/menus:
    + [RA] Tell Perl where common_data.pm is since we're now including it.
      Doh. Thanks, Nelson A. de Oliveira. (Closes: #366481)
  The "Policy backlog clearing is a wonderful sight" release
  * checks/debconf{.desc,}:
    + [RA] Add checks for the Developer's Reference guidelines for debconf
      templates. Based on a patch by Thomas Huriaux. (Closes: #362145)
  * checks/fields{.desc,}:
    + [RA] xfonts-encodings is also not an xfont package. Thanks, Drew
      Parsons. (Closes: #365503)
    + [RA] Report errors for dependencies on python-minimal. Thanks to
      Steve Langasek for the analysis.
    + [RA] Allow a build-dependency on patchutils when using CDBS with one
      of the patch systems, as patchutils may be optionally used to check
      for bad patches. Thanks, Marc Dequènes (Duck). (Closes: #365466)
    + [RA] Since some packages should be in Build-Depends and some should
      be in Build-Depends-Indep, report all of the misplaced ones rather
      than just the first one. That way, users know which to move.
    + [RA] Allow perl in Build-Depends if invoked in clean rules.
    + [RA] Allow patch in Build-Depends if yada unpatch is invoked in
      clean rules.
  * checks/files{.desc,}:
    + [RA] Add an explicit check for non-world-readable executables to
      provide a more detailed explanation and tighten the accepted
      permissions of setuid and setgid executables to just the permissions
      mentioned in Policy 10.9. Add Policy 10.9 references to the
      descriptions. Reported by Piotr Engelking. (Closes: #365452)
    + [RA] Add a request to the descriptions of setuid and setgid tags to
      add a lintian override for documentation if the permissions are
      intentional.
    + [RA] Report a more specific tag for binaries that are owned by group
      games but are not setgid.
    + [RA] Remove the check for files in /usr/lib/cgi-bin. This policy
      change was reverted.
    + [RA] Allow files installed in /usr/include/X11 and /usr/lib/X11 but
      require Pre-Depends on x11-common (>= 1:7.0.0). Remove the
      duplicate check for files in /usr/bin/X11 since it no longer adds
      additional information.
  * checks/menus{.desc,}:
    + [RA] Check that all files referenced in doc-base control files are
      present in the package, based on a patch by Robert Luberda. Also
      check that Index references only one file and that Format names a
      known format. (Closes: #196122)
    + [RA] Fix incomplete diagnosis of missing calls to update-menus.
    + [RA] Change postrm to prerm in the check for a useless install-docs
      call; calling install-docs in postrm is always a warning and useless
      calls in prerm were not being diagnosed.
  * checks/po-debconf{.desc,}:
    + [RA] Exempt packages that use yada from the POTFILES.in check and
      from checking for up-to-date templates, since yada does this at
      build time. Reported by Piotr Roszatycki. (Closes: #321139)
    + [RA] Check for stray debconf-mergetemplate files in packages
      using po-debconf. Thanks, Martin Quinson. (Closes: #232442)
    + [RA] General cleanup of tag descriptions for grammar and markup.
      Move man page references into Ref fields.
  * checks/shared-libs.desc:
    + [RA] Document that exceptions to the -fPIC rule for shared libraries
      are possible and ask that such exceptions be documented with lintian
      overrides.
  * checks/standards-version:
    + [RA] Update to 3.7.2. (Closes: #366233)
    + [RA] Report the current standards version when warning about too old
      or too new versions. Thanks, Jari Aalto. (Closes: #366104)
  * debian/control:
    + [RA] Update standards version to 3.7.2 (no changes required).
    + [RA] Update description to note calibration for Policy 3.7.2.
  The "Policy 3.7.0" release
  * checks/fields{.desc,}:
    + [RA] python-all-dev also satisfies dh_python's requirements.
      Thanks, Marc Dequènes (Duck). (Closes: #364943)
    + [RA] Allow python in Build-Depends if it's invoked explicitly in the
      clean rule. Thanks, Marc Dequènes (Duck). (Closes: #365030)
    + [RA] Recognize the CDBS included rule files that indicate dpatch or
      quilt will be used, check those dependencies, and require that they
      be in Build-Depends since they're used for clean. Thanks, Marc
      Dequènes (Duck). (Closes: #365041)
  * checks/files{.desc,}:
    + [RA] Add the references to Policy for the deprecation of X11R6
      directories now that Policy has been updated in 3.7.0.0.
    + [RA] Policy now mandates FHS 2.3. Update tag descriptions.
    + [RA] Warn about files installed in /usr/lib/cgi-bin. Policy now
      states they should be installed in /usr/lib/cgi-lib.
    + [RA] Warn about scripts installed on the user's PATH with names that
      include language extensions (.sh, .pl, .py), per Policy 10.4.
    + [RA] Report directories under /usr/share/man that don't match the
      directory layout specified in the FHS. (Closes: #176683)
    + [RA] Fix a very long-standing bug that caused the check for
      executable manpages to be silently skipped.
  * checks/scripts:
    + [RA] Debian etch release policy explicitly forbids scripts without
      #! magic and they rely on being run from a shell. Revert the change
      that permitted the Perl magic without a #! line. Thanks to Piotr
      Engelking and Steve Langasek for pointing this out.
    + [RA] Don't syntax-check *.dpatch scripts in /usr/src. bash -n
      doesn't stop at exit 0 and then may choke on the patch. Thanks,
      Matthias Klose. (Closes: #364521)
  * checks/scripts.desc:
    + [RA] Using invoke-rc.d is now required by Policy.
  * checks/standards-version:
    + [RA] Update to 3.7.0.
  * debian/control:
    + [RA] Update standards version to 3.7.0 (no changes required).
    + [RA] Update description to note calibration for Policy 3.7.0.
  The "brown paper Python" release
  * checks/fields{.desc,}:
    + [RA] Redo handling of build dependencies to allow a custom tag to be
      specified and to allow a general dependency string to be required
      rather than a simple package name. As a result, dh_python handling
      is no longer a buggy special case. Allow either python or
      python-dev for dh_python and the cdbs Python rules. Thanks, Torsten
      Merek and Aaron M. Ucko. (Closes: #364297, #364330)
    + [RA] Require at least quilt 0.40 if /usr/share/quilt/quilt.make is
      included. Thanks, Michele Baldessari.
    + [RA] Packages using dh_installxfonts must build-depend on 5.0.31 or
      later of debhelper for the X.Org 7 transition.
  The "happy Nanaimo hacking" release
  * checks/binaries:
    + [RA] Detect klibc binaries from their requested interpreter and
      allow them to appear static. (Closes: #328850)
  * checks/common_data.pm:
    + [RA] Include all combinations of cpu and os from the dpkg cputable
      and ostable files (as of dpkg 1.13.16). (Closes: #337034, #357433)
    + [RA] Include a list of known X metapackages.
  * checks/control-file{.desc,}:
    + [RA] Warn if debian/control in a source package is a symlink.
  * checks/copyright-file{.desc,}:
    + [RA] Don't assume mentions of GPL or GNU General Public License
      after what look like mail headers are referring to the license of
      the package. Be a bit more specific in the old FSF address check
      to avoid false positives on other Cambridge, MA addresses. Reported
      by Adam C. Powell IV. (Closes: #205934)
  * checks/debconf:
    + [RA] Allow Indices as a template field. cdebconf uses it and
      debconf ignores it. Reported by Frans Pop. (Closes: #361986)
  * checks/debdiff{.desc,}:
    + [RA] Warn if the diff contains debian/substvars. Based on a patch
      by Michael Ablassmeier. (Closes: #359646)
  * checks/debhelper.desc:
    + [RA] When explaining the warning about deprecated debhelper
      compatibility versions, mention that debhelper defaults to version 1
      if not set anywhere. (Closes: #360711)
    + [RA] Move simple man page references from Info into Ref.
  * checks/fields{.desc,}:
    + [RA] Allow dpatch in Build-Depends for arch-independent packages if
      it is invoked in clean, build-arch, or binary-arch.
    + [RA] Only list examples of non-standard architectures, since there
      are now too many combinations to list completely.
    + [RA] Catch dependencies on X metapackages, based on a patch by Josh
      Triplett. No packages are allowed to build-depend, and only
      packages that look like metapackages (arch: all, no files outside of
      /usr/share/doc) are allowed to depend. (Closes: #347169)
    + [RA] Look for an explicit section of unknown, probably left over
      from dh_make templates, and diagnose it with an error rather than a
      warning. Reported by Jari Aalto. (Closes: #355032)
    + [RA] Reorganize dependency checking based on debian/rules analysis.
      Diagnose missing build dependencies on the helper packages we know
      about, catch cases where Build-Depends-Indep should be Build-Depends
      because of the clean target, and make sure users of dh_python
      build-depend on python. yada is no longer a special case.
      (Closes: #242789, #278290)
    + [RA] Check for conflicting with dependencies and build-conflicting
      with build dependencies. (Closes: #122760)
    + [RA] Allow xfonts-utils in dependencies. It's not actually an X
      font package.
  * checks/files{.desc,}:
    + [RA] For the X.Org 7 transition, add explicit checks for fonts and
      binaries installed in /usr/X11R6. Rename the existing check for
      other files in /usr/X11R6 since the tag had a pluralization error
      and we want package maintainers to see the error again and
      reconsider whether to ignore it. No packages should be installing
      files in /usr/X11R6 going forward. Remove the policy cross-refs for
      right now until policy catches up.
  * checks/manpages:
    + [RA] Use system_env instead of system and sanitize the environment
      before running man -l out of caution and to avoid extraneous output
      when CDPATH is set. Reported by Marc Haber. (Closes: #360217)
  * checks/nmu{.desc,}:
    + [RA] Warn if debian/changelog in a native source package is a
      symlink and skip checks rather than aborting if it was a symlink to
      a file we didn't unpack. (Closes: #257650)
  * checks/po-debconf:
    + [RA] Use system_env instead of system out of caution and to avoid
      extraneous output when CDPATH is set.
  * checks/rules{.desc,}:
    + [RA] A new set of checks that parses debian/rules and checks for
      required rules, debian/rules as a symlink, and the correct first
      line. Based heavily on previous work by René van Bevern.
      (Closes: #294926, #311786)
  * checks/scripts{.desc,}:
    + [RA] Ignore text inside single quotes and, for most checks, text
      inside double quotes when checking for bashisms. Reported by Frank
      Küster. (Closes: #344266)
    + [RA] Change canonical zsh path to /bin/zsh at the request of the zsh
      maintainer. (Closes: #360534)
    + [RA] Change the check for broken error handling with invoke-rc.d to
      maintainer-script-hides-init-failure to be more generic and explain
      what the test looks at. Add the script name and line number and fix
      a typo. Thanks, Marc Haber. (Closes: #360214, #360216)
    + [RA] Warn when maintainer scripts run init scripts directly and
      don't use invoke-rc.d. Thanks, Lars Wirzenius. (Closes: #353659)
    + [RA] Find missing ucf dependencies and restructure the code to allow
      easier addition of similar checks. (Closes: #261891)
    + [RA] Add python2.5, lua50, gbx, and gbx2 to the list of valid
      interpreters. (Closes: #361601, #361644, #362566)
  * checks/shared-libs:
    + [RA] Limit shlib-without-PT_GNU_STACK-section to only those
      architectures where gcc always adds the section. Thanks to Frans
      Pop for the report and Bastian Blank for the architecture list.
      (Closes: #357636)
  * collection/objdump-info:
    + [RA] Unset CDPATH before running cd to avoid strange effects from
      the user's environment.
    + [RA] Run readelf -l to collect interpreter information.
  * lib/Dep.pm:
    + [RA] Add initial support for analyzing architecture information in
      dependencies instead of ignoring it.
  * lib/Read_taginfo.pm:
    + [RA] Add support for formatting man page references from Ref.
  * lib/Util.pm:
    + [RA] Add system_env, like system but sanitizing the environment.
  * man/lintian.1:
    + [RA] Mention the new rules check class.

a9ec9c4... by Matthias Klose on 2006-04-12

Import patches-unapplied version 1.23.16ubuntu2 to ubuntu/dapper

Imported using git-ubuntu import.

Changelog parent: b92ef277e2944cffebbf01775e967c09ac6455ea

New changelog entries:
  * Depend on the dpkg version, having the -q option for dpkg-source.

b92ef27... by Matthias Klose on 2006-04-09

Import patches-unapplied version 1.23.16ubuntu1 to ubuntu/dapper

Imported using git-ubuntu import.

Changelog parent: 293d58f3276cea559f882755ebfd3a6756d5f138

New changelog entries:
  * Synchronize with Debian unstable.
  * Add python2.5 to the list of known interpreters.
  The "What's this Russ guy up to?" release
  * checks/binaries{.desc,}:
    + [RA] Add a check for the new "Invalid operation" error from
      objdump -T. Skip shared-lib-without-dependency-information for
      files in /usr/lib/debug.
  * checks/changelog-file:
    + [FL] Add line number to output of wrong-bug-number-in-closes.
      Inspired by #349761 from Steinar H. Gunderson.
  * checks/common_data.pm:
    + [FL] Add armeb to %non_standard_archs as requested by
      Martin Michlmayr. (Closes: #350653)
  * checks/debconf:
    + [RA] Packages that depend on dbconfig-common are allowed to have
      config scripts without templates or an explicit debconf dependency.
      Reported by Marcus Better. (Closes: #344421)
  * checks/debconf.desc:
    + [RA] Clarify the necessary dependencies for packages using SETTITLE.
      (Closes: #349616)
  * checks/debhelper:
    + [RA] Recognize setting DH_COMPAT with := in addition to = in
      debian/rules. (Closes: #349272)
    + [RA] CDBS sets DH_COMPAT to 4 but doesn't export it. It does create
      debian/compat with that value if none was present. Reflect this
      behavior to avoid spurious compat level warnings when using CDBS.
      Based on a patch by Jay Berkenbilt. (Closes: #350228)
  * checks/fields:
    + [RA] Allow a quilt build-dependency for arch-independent packages if
      the quilt makefile rules are included. (Closes: #349273)
    + [RA] If clean depends on a rule that calls dh_clean rather than
      calling it directly, still allow debhelper in Build-Depends for
      arch-independent packages. Reported by Michael Stilkerich.
    + [JvW] Commented that Uploaders no longer will hit the multiline field
      issue, updated testsuite accordingly
  * checks/manpages:
    + [FL] Ignore more warnings ("cannot adjust line", "can't break
      line") in non-English manpages. (Closes: #349792)
    + [RA] cd into the parent directory before checking man pages with man
      so that .so inclusions are processed correctly. Based on a patch by
      Nicolas François. (Closes: #349614)
  * checks/menu-format:
    + [RA] Look for binaries in /usr/X11R6/bin, not /usr/bin/X11, per
      Policy 11.8.7. Thanks, Matej Vela. (Closes: #354890)
  * checks/menu-format.desc:
    + [RA] Use "menu manual" rather than "menu" for references to more
      clearly distinguish from the Debian Menu Policy. (Closes: #347510)
  * checks/po-debconf:
    + [RA] If there are template files in debian, assume the package uses
      debconf; don't require a dependency or config script. Patch by
      Thomas Huriaux. (Closes: #353294)
  * checks/scripts:
    + [RA] Allow /tmp in variable settings. It's likely to be a false
      positive. Reported by Frank Küster. (Closes: #344998)
    + [RA] Make the syntax checking of shell scripts more robust against
      filenames containing shell metacharacters. Reported by Michael
      Stilkerich.
    + [RA] Add fish and expectk to the list of valid interpreters.
      (Closes: #351624, #353770)
    + [RA] /usr/bin/tcl is provided by tclx8.3, not tcl. Reported by
      James R. Van Zandt. (Closes: #351324)
    + [RA] Allow more variations on leading magic to invoke some
      interpreter rather than then shell. Bypass the ELF magic check for
      scripts using magic that relies on having no leading #! line.
      Reported by Frank Küster. (Closes: #344269)
    + [JvW] Add check against package suffering from debhelper bug #337664,
      per Joey Hess, which had broken error detection (Closes: #358523)
  * checks/shared-libs:
    + [JvW] Fix postinst-must-call-ldconfig to also get emitted when there is
      no postinst at all, instead of just one lacking a ldconfig call
    + [JvW] Implement checks for "udeb:" lines in shlibs files
      (Closes: #357541)
    + [JvW] Consider also the soname version for shlibs checking, preventing
      some bogus 'duplicate' warnings, and actually throw a warning when
      soname version doesn't match
    + [JvW] Added error when udeb postinst calls ldconfig, that must never
      happen (thanks to Frans Pop for noticing, see #203056)
  * debian/{control,copyright}:
    + [RA] Add Russ Allbery to Uploaders and copyright.
    + [JvW] Version dpkg-dev requirement to >= 1.13.17, for
      unpack/unpack-srcpkg-l2
  * frontends/lintian-info:
    + [RA] Avoid Perl uninitialized value warnings when given output that
      looks like lintian messages without tags. (Closes: #352606)
  * collection/objdump-info:
    + [RA] Pass "Invalid operation" errors from objdump -T on to the check
      scripts instead of failing. (Closes: #249435)
  * man/lintian.1:
    + [RA] Add references to dh_make, debhelper, dpkg-buildpackage, and
      linda in new reference sections. (Closes: #322288)
  * man/{lintian.1,lintian-info.1}:
    + [RA] Left-justify and disable hyphenation for readability.
  * unpack/unpack-srcpkg-l2:
    + [JvW] Use -q with dpkg-source to surpress warnings about unsigned source
      packages. Requires dpkg-dev 1.13.17

  * The "www.no-name-yet.eu" release

  * debian/changelog:
    + [FL] Fix wrapping of last changelog entry (Closes: #344899)
  * checks/common_data.pm:
    + [FL] Add xlibs-dev and debmake to %known_obsolete_packages
  * checks/debconf:
    + [CW] Show template name for empty-translated-choices,
      mismatch-translated-choices, and unknown-field-in-templates.
  * checks/debhelper:
    + [FL] Also check for debhelper build-dependency in debhelper-using
      cdbs based packages
    + [FL] Indicate where we found which compat version in
      declares-possibly-conflicting-debhelper-compat-versions
      (Closes: #329953)
    + [FL] Add dh_installtexfonts to list of commands that modfiy
      the maintainer scripts
    + [FL] Try a little harder to find the DH_COMPAT setting in debian/rules
      (Closes: #348380)
  * checks/fields:
    + [FL] Allow version numbers of 0 by correctly checking the output
      of _valid_version for definedness and not the boolean value
      (Closes: #345005)
    + [FL] Better check for false postives of build-depends-without-arch-dep.
      Should fix false positives for cdbs, dbs, dpatch and yada. Based on
      a patch by Russ Allbery (Closes: #344609, #321135, #339750)
    + [FL] Also check for build-dependencies on obsolete packages not
      only dependencies (Closes: #234531)
  * checks/fields.desc:
    + [JvW] Fix typo in description
  * checks/init.d:
    + [FL] Only try to validate update-rc.d calls where the name of the
      script matches [\w.-]+. That accounts for all today known init
      scripts and eliminates false positives like shell variables in the
      name (Closes: #343865)
  * checks/manpages:
    + [FL] Fix stupid mistake in regex to strip of filenames from roff
      output (which was hidden by another stupid mistake in the test
      suite). Patch by Nicolas François (Closes: #347999)
  * checks/scripts:
    + [FL] Make mknod-in-maintainer-script an error since this is now
      a must in policy. Pointed out by Bartosz Fenski (Closes: #344928)
    + [FL] dpkg --print-installation-architecture is deprecated
      so delete dpkg-print-architecture-in-maintainer-script
    + [FL] Add parrot to list of valid interpreters (Closes: #346335)