ubuntu/+source/lintian:ubuntu/feisty

Last commit made on 2006-12-20
Get this branch:
git clone -b ubuntu/feisty https://git.launchpad.net/ubuntu/+source/lintian
Members of Ubuntu Server Dev import team can upload to this branch. Log in for directions.

Branch merges

Branch information

Name:
ubuntu/feisty
Repository:
lp:ubuntu/+source/lintian

Recent commits

e87e131... by Colin Watson on 2006-12-20

Import patches-unapplied version 1.23.27ubuntu1 to ubuntu/feisty

Imported using git-ubuntu import.

Changelog parent: 669d5be71076f5538a3b00487f64e3e0805500c6

New changelog entries:
  * Resynchronise with Debian. Remaining changes:
    - frontend/lintian: Allow warty, hoary, breezy, dapper, edgy, feisty,
      *-proposed, *-updates, and *-backports distributions.
  The "we haven't run this against the whole archive in a while" release
  * checks/binaries{.desc,}:
    + [RA] Tag unrecognized ELF binaries as apparently corrupted rather
      than failing with a note that binutils-multiarch is required. Some
      packages have had ELF binaries recognized by file but unreadable.
      Reported by Bill Allombert. (Closes: #399456)
  * checks/infofiles:
    + [RA] Don't consider /usr/share/infon to be an info directory.
      Reported by Joachim Breitner. (Closes: #399857)
  * checks/md5sums:
    + [RA] Also don't complain about missing md5sums for files in
      /var/lib/ispell as they're changed after installation. Thanks,
      Agustin Martin. (Closes: #401070)
  * checks/po-debconf:
    + [RA] gettext 0.16's msgcmp requires --use-untranslated when checking
      for newer templates than PO files or it gives false positives for
      every package. Thanks, Damyan Ivanov. (Closes: #400957)
    + [RA] Don't consider directories to be stray template files even if
      named template. Thanks, Thomas Huriaux. (Closes: #401442)
  * checks/shared-libs:
    + [RA] Don't report shlib-with-non-pic-code unless we're sure that
      we're looking at a shared library. Otherwise, we get many false
      positives on some platforms where text relocations are normal for
      binaries. Reported by Bill Allombert. (Closes: #399525)
  * collection/file-info:
    + [RA] Unescape non-ASCII characters escaped by tar before running
      file on the resulting filename. Otherwise, file can't find the
      file, exits with an error, and lintian aborts. Reported by Bill
      Allombert. (Closes: #399392)
  * collection/objdump-info:
    + [RA] Include unrecognized format errors from objdump in the output
      rather than aborting; some packages contain apparently corrupt ELF
      binaries.
  * debian/control:
    + [RA] Depend on gettext 0.16 or later for --use-untranslated.
  * lib/Lab.pm:
    + [RA] Preserve the old package lists when setting up a static lab so
      that the unpack programs can build a list of changed packages and
      incremental mode works. Thanks, Bill Allmobert. (Closes: #400342)
  * unpack/list-udebpkg:
    + [RA] Handle compressed udeb Packages files. Thanks, Bill
      Allombert. (Closes: #400338)
  * checks/binaries{.desc,}:
    + [RA] Add a policy reference for unstripped-binary-or-object.
      Thanks, Bas Wijnen. (Closes: #394419)
    + [RA] Add a special exception to the shared library dependency check
      for the dynamic loader itself.
  * checks/changelog-file.desc:
    + [RA] Downgrade to a warning several errors with changelog files,
      including compression and a text version of HTML changelogs, that
      are only shoulds in Policy. (Closes: #289723)
    + [RA] Cleaned up language and use of unbalanced single quotes in
      numerous descriptions.
  * checks/control-file{.desc,}:
    + [RA] Diagnose a control file that creates binary packages in a
      different archive category from the source package or the other
      binary packages. Idea from Yann Dirson. (Closes: #394720)
    + [RA] Close opened files.
    + [RA] Add info-level check for Section in the source section of the
      control file. (Closes: #322244)
  * checks/cruft{.desc,}:
    + [RA] Tighten the timestamp check on config.{sub,guess} to look for
      files dated 2004 or newer, since that's when x86_64 was added.
      Increase to an error at the request of Ryan Murray since we already
      suppress this warning of config.{guess,sub} are modified by the
      Debian patch or if the package build-depends on autotools-dev.
      (Closes: #190897)
  * checks/debconf{.desc,}:
    + [RA] Take into account comma escaping when checking the number of
      translated choices. Reported by Frans Pop. (Closes: #395028)
    + [RA] Only require debconf be loaded in the postinst script if a
      config script exists. Reported by Josselin Mouette.
    + [RA] Require pre-depends on debconf if debconf is used in the
      preinst script. Update the long description to deprecate only
      depending on debconf and falling back on another configuration
      system. Reported by Josselin Mouette. (Closes: #395468)
    + [RA] Warn of debconf notes displayed with low or medium priority,
      with an exception for Policy-required device file warnings. Based
      on a patch by Thomas Huriaux. (Closes: #389070)
    + [RA] Close files after opening them, fixing incorrect line numbers
      when reporting problems with config scripts.
  * checks/debdiff{.desc,}:
    + [RA] Check for creation of ~ and .xxx.swp backup files in the Debian
      diff, but only at the info level for now since they cause no harm.
      (Closes: #332770)
  * checks/fields{.desc,}:
    + [RA] Clarify in missing-build-dependency why lintian does not take
      into account transitive build dependencies. (Closes: #393975)
    + [RA] Avoid Perl warning when diagnosing a Python-Version of the form
      "all, >= 2.4". Thanks, Thijs Kinkhorst. (Closes: #394104)
    + [RA] Teach the debian/rules parsing about make conditionals and
      don't require build dependencies for lines encountered inside a
      conditional (in other words, assume people using conditionals know
      what they're doing). Fixes a false positive due to the unusual
      arch-specific build dependencies for openoffice.org, reported by
      Rene Engelhard. (Closes: #380286)
  * checks/files{.desc,}:
    + [RA] Check for vim .swp files in the package.
    + [RA] Split the warning for NFS temporary files into a separate tag
      from the warning for editor backup files.
  * checks/infofiles:
    + [RA] Close opened files.
    + [RA] debhelper no longer adds a --section flag to install-info, so
      don't warn about any install-info invocation without --section.
      Instead, check each info file for INFO-DIR-SECTION and diagnose
      calling install-info without --section if any info file is missing
      this information. (Closes: #97502, #398670)
    + [RA] Checks for the compression and suffixes of info files were not
      being run due to a mistake in specifying either /usr/info or
      /usr/share/info as an info directory. Re-enable them.
  * checks/md5sums{.desc,}:
    + [RA] Add a tag for a missing md5sums control file, but only at info
      level, at least for now. (Closes: #133027)
    + [RA] Do better syntax checking of the md5sums control file and
      report malformed lines as a tag rather than aborting lintian.
    + [RA] Downgrade file-missing-in-md5sums to a warning since it doesn't
      break the package or debsums and may be intentional.
  * checks/menu.desc:
    + [RA] Remove stray commas in Ref strings since the reporting code
      considers commas to be separating two different references.
  * checks/menu-format{.desc,}:
    + [RA] Support the sux, gksu, and kdesu wrappers in menu commands as
      well as su-to-root. (Closes: #360227)
    + [RA] Fix tag name for menu-icon-cannot-be-parsed. Thanks, Bill
      Allombert. (Closes: #399245)
  * checks/po-debconf{.desc,}:
    + [RA] Check for misnamed PO files in debian/po, which cause
      translations to be merged into the template with the wrong names and
      not found. Based on a patch by Thomas Huriaux. (Closes: #387360)
  * checks/shared-libs:
    + [RA] Calling ldconfig is also required for libraries installed in
      various subdirectories of its standard search path based on hardware
      capabilities. Reported by Aurelien Jarno. (Closes: #396278)
  * debian/rules:
    + [RA] Exclude testset/diffs/binary.c~ from dh_clean.
  * frontend/lintian:
    + [RA] Add --fail-on-warning option to exit with non-zero status if
      any warnings were found. Thanks, Daniel Bonniot. (Closes: #189656)
  * man/lintian.1:
    + [RA] Document --fail-on-warning.

669d5be... by Colin Watson on 2006-10-27

Import patches-unapplied version 1.23.25ubuntu1 to ubuntu/feisty

Imported using git-ubuntu import.

Changelog parent: e38f16e5bf8db6d1fb6982c14f427d00f34c0406

New changelog entries:
  * Resynchronise with Debian.
  * debian/control: Drop dpkg-dev versioned dependency change; lintian now
    requires Edgy's dpkg-dev.
  * frontend/lintian: Allow feisty and *-proposed distributions.
  The "dependency and debconf" release
  * checks/debconf:
    + [CW] Don't trigger partially-translated-question when Choices-C exists
      but not Description-C.
    + [RA] Remove select-with-translated-default-field since there are
      cases where this is correct and we can perform a better check
      against the source package. Patch from Thomas Huriaux.
    + [RA] Fix Perl warnings when a template has no type.
  * checks/debdiff:
    + [RA] Remove the source-tar-is-posix-tar tag. This was only a
      problem for woody and earlier, and woody support is no longer
      needed. Reported by Loïc Minier. (Closes: #385833)
  * checks/fields{.desc,}:
    + [RA] Improve the long descriptions of the warnings about dependencies
      on essential or build-essential packages to make it clearer that the
      correct resolution is normally to omit the dependency and why.
    + [RA] Add a check for duplicate build dependencies. (Closes: #359178)
  * checks/files:
    + [RA] Don't consider files named license.rb to be extraneous
      licenses. Patch from NIIBE Yutaka. (Closes: #387269)
  * checks/init.d:
    + [RA] Correctly handle LSB keywords which are present but have an
      empty value. Reported by Erich Schubert. (Closes: #386968)
  * checks/lintian.desc:
    + [RA] Add tags for missing and bad Urgency fields in *.changes files.
    + [RA] Improve the no-description-in-changes-file information.
  * checks/md5sums:
    + [RA] aspell dictionary packages may ship files in /var/lib/aspell
      that should not have MD5 checksums in md5sums because they change
      after installation. Don't complain that those files are missing.
  * checks/po-debconf:
    + [RA] Avoid Perl warnings on .po files that don't contain msgstr
      lines. Patch from Thomas Huriaux. (Closes: #387357)
    + [RA] Check templates for a translatable Default or DefaultChoice
      field and warn if there isn't a translator comment. Patch from
      Thomas Huriaux. (Closes: #388824)
  * checks/scripts:
    + [RA] Add /usr/bin/gosh from the gauche package to the list of valid
      interpreters. Thanks, Tatsuya Kinoshita. (Closes: #386798)
    + [RA] Add a separate tag for tclsh dependencies to explain about the
      virtual package and improve the description of the wish virtual
      package in its tag. Fix inverted logic that got the wish dependency
      backwards. Reported by Hamish Moffatt. (Closes: #387845)
    + [RA] Allow tcsh to satisfy a csh dependency. Reported by Yann
      Dirson. (Closes: #389615)
    + [RA] Improve the check for shell scripts that are actually exec
      wrappers around scripts written in another language.
    + [RA] Allow update-inetd to fulfill the dependency requirements for
      the update-inetd script. Thanks, Michael Holzt. (Closes: #389960)
  * frontend/lintian:
    + [RA] Check the existence and value of the Urgency field in *.changes
      files. (Closes: #384219)
  * lib/Dep.pm:
    + [RA] Improve the dependency resolution engine so that it can prove
      aa|bb implies aa|bb|cc. Fix the comparison of dependencies for
      inverse implication to catch many more cases. (The latter code
      isn't currently used in lintian.)
    + [RA] Add an unparse function to take an internal representation and
      convert it back to human-readable text.
    + [RA] Significantly improve and rewrite the get_dups function to only
      find relations that imply each other and to return the complete
      duplicate dependencies in sets.
  * man/lintian.1:
    + [RA] Document setting TMPDIR to change the location of lintian's
      temporary lab. (Closes: #388786)
  The "LSB init script" release
  * checks/control-files:
    + [RA] perm2oct definition moved to Util.pm.
  * checks/cruft{.desc,}:
    + [RA] Remove the (info-level) check for .cvsignore files in the
      source tarball. This isn't an error; those files contain metadata
      that may be useful for people making modifications and it's quite
      common to distribute them.
  * checks/debconf{.desc,}:
    + [RA] Diagnose unknown priorities in db_input and db_text
      invocations. Patch from Thomas Huriaux. (Closes: #386014)
  * checks/fields{.desc,}:
    + [RA] Depending on versioned variants of python-minimal is also an
      error. Thanks, Adeodato Simó. (Closes: #384476)
  * checks/files:
    + [RA] perm2oct definition moved to Util.pm.
  * checks/init.d{.desc,}:
    + [RA] Added a warning for init scripts missing an LSB keyword
      section, checks of the syntax of such a section if present, and
      some basic semantic checks of the easiest fields. Based on initial
      work by Carlos Villegas. (Closes: #377740)
  * checks/menus:
    + [RA] perm2oct definition moved to Util.pm.
  * checks/scripts:
    + [RA] Properly concatenate the dependencies for a package when
      checking whether the dependency for an interpreter is included.
      Thanks, Vincent Danjean. (Closes: #385178)
  * checks/shared-libs:
    + [RA] perm2oct definition moved to Util.pm.
  * lib/Util.pm:
    + [RA] Move perm2oct to here and improve recognition of s, S, t, and T
      characters. Thanks to Justin B. Rye for patch. (Closes: #376119)
  The "new Python policy" release
  * checks/binaries.desc:
    + [RA] Greatly expand the binary-or-shlib-defines-rpath long
      description based on recent discussion in debian-policy. Add a
      reference to the wiki page. (Closes: #378054, #378055)
  * checks/changelog-file{.desc,}:
    + [RA] Diagnose changelog files that are symlinks, using the new way
      the changelog-file collection script processes them.
  * checks/common_data.pm:
    + [RA] Add Python-Version as a known source and binary field.
  * checks/copyright-file:
    + [RA] Catch "<fill in http/ftp site>" as well as the string without
      "http/". Thanks, Jari Aalto. (Closes: #374167)
  * checks/deb-format{.desc,}:
    + [RA] Remove deb-created-with-broken-tar; the bug was actually in
      dpkg, and the dpkg in stable has been fixed. Thanks Jari Aalto and
      Thijs Kinkhorst. (Closes: #375638, #376030)
  * checks/debconf:
    + [RA] Diagnose a missing template description only once and avoid
      Perl warnings. Thanks, Thomas Huriaux. (Closes: #377654)
  * checks/debhelper:
    + [RA] Use the standard control file parser rather than a custom
      parser that can't handle continuation lines.
    + [RA] Warn if dh_python is used without debian/pycompat in non-CDBS
      packages and check for the debhelper version required for Python
      policy. Thanks, Raphaël Hertzog. (Closes: #375318)
  * checks/fields{.desc,}:
    + [RA] Don't warn virtual-package-depends-without-real-package-depends
      for Recommends and rewrite the tag description to be more accurate.
      Thanks to Martin F. Krafft for the report. (Closes: #370720)
    + [RA] ~ is now permitted in version numbers. (Closes: #381965)
    + [RA] Catch and check dependencies correctly for debconf-updatepo run
      from the clean target. Thanks, James Westby. (Closes: #380399)
    + [RA] Warn when encountering an aspell dictionary package that isn't
      arch: all. Thanks, Piotr Engelking. (Closes: #374899)
    + [RA] Check the syntax of the new Python-Version field.
    + [RA] Check for missing build dependencies on python-central or
      python-support. Thanks, Raphaël Hertzog.
    + [RA] Check for old << dependencies on Python in Python packages that
      lack a Python-Version control field, as these are probably packages
      that don't follow the new Python policy. Thanks, Raphaël Hertzog.
  * checks/files{.desc,}:
    + [RA] Provide a better explanation of why Debian packages shouldn't
      ship files in /srv. (Closes: #379176)
    + [RA] Warn about files installed into /etc/gconf/schemas.
    + [RA] Warn about files in /usr/lib/site-python. Thanks, Thomas
      Viehmann and Raphaël Hertzog. (Closes: #372748)
  * checks/manpages{.desc,}:
    + [RA] Warn about manpage short descriptions of the form "manual page
      for program" (usually generated by help2man).
  * checks/menu:
    + [RA] Ignore trailing whitespace in doc-base files. Patch from Bas
      Zoetekouw. (Closes: #379749)
  * checks/nmu{.desc,}:
    + [RA] When checking for an NMU changelog entry, require "NMU" be
      surrounded by word boundaries.
    + [RA] Warn if the changelog incorrectly indicates an NMU. Thanks to
      George Danchev for the report.
  * checks/scripts{.desc,}:
    + [RA] Except mkstemp from possibly-insecure-handling-of-tmp-files for
      maintainer scripts written in Perl.
    + [RA] Mention [[ ]] explicitly in the possible-bashism long
      description as requiring a Korn shell and make it clearer that the
      primary arbiter of this test is the POSIX shell specification.
      (Closes: #381800 by clarification)
    + [RA] Use the Dep library to check dependencies. Add php5 to the
      interpreter list and correctly handle the dependencies for
      version-less PHP scripts. (Closes: #379558)
    + [RA] Check for proper dependencies if gconf-schemas is called in
      maintainer scripts and diagnose calling gconftool(-2) directly.
      Thanks, Josselin Mouette. (Closes: #333311)
  * checks/version-substvars{.desc,}:
    + [RA] New check from Adeodato Simó for proper use of substvars for
      versioned dependencies between packages built from the same source
      package so that NMUs will work properly. Also catch use of such a
      substvar for a versioned dependency on a package not built from the
      same source. (Closes: #377141, #376596)
  * collection/changelog-file:
    + [RA] Be much more careful about changelog files that are symlinks.
      Don't skip over changelog symlinks just because they point to
      non-existant files, mark unsafe symlinks or symlinks to non-existent
      files by creating copyright as a symlink to a non-existent file in
      the lab, and don't create an empty dummy changelog if we couldn't
      find a changelog. Correctly handle changelog files that are
      symlinks to other files in the same directory.
  * debian/copyright:
    + [RA] Add Subversion repository location.
  * frontend/lintian:
    + [JvW] Give error if there is no "Description" field in .changes, this is
      required by dak
  * frontend/lintian-info:
    + [RA] Add the -t or --tags option that, given a tag name, prints out
      the description. (Closes: #376109)
  * lib/Tags.pm:
    + [RA] If a tag has been overriden via any mechanism, do not add it to
      any of the statistics (tag, severity, or significance). Before, the
      override only suppressed a record for the specific statistic the
      override was based on, meaning that classic tag-based overrides
      didn't suppress severity statistics. Overridden error tags would
      therefore cause lintian to exit with non-zero status. Thanks,
      Andree Leidenfrost and Martin F. Krafft. (Closes: #377182, #374314)
  * man/lintian.1:
    + [RA] Better document the --archivedir and --dist options and how
      lintian constructs the path to an archive. (Closes: #383203)
    + [RA] Document new version-substvars check script.
  * man/lintian-info.1:
    + [RA] Document the new -t or --tags option.
  * reporting/html_reports:
    + [RA] Include the lintian version in HTML page footers. Thanks,
      Thijs Kinkhorst. (Closes: #377616)

e38f16e... by Reinhard Tartler on 2006-07-09

Import patches-unapplied version 1.23.22ubuntu1 to ubuntu/edgy

Imported using git-ubuntu import.

Changelog parent: e8e8b0a1eab4ab93a3ce2db14eaca8885581208f

New changelog entries:
  * Merge from debian unstable.
  * checks/debconf:
    + [JvW] Teach lintian to know about the 'error' debconf template
      question type. (Closes: #374399)
    + [RA] Exclude debconf templates with "for internal use" in the short
      description from style checks and document this in the log
      description of the tags most likely to trigger on internal
      templates. (Closes: #368206)
  * checks/common_data.pm:
    + [RA] Add amd64 to the standard architectures. (Closes: #367324)
  * checks/debhelper:
    + [RA] Use the Dep library to check debhelper build dependencies
      rather than parsing Build-Depends with regexes. This avoids false
      positives due to matching package names ending in debhelper.
      Reported by Fabio Tranchitella. (Closes: #366531)
  * checks/fields:
    + [RA] Allow build-depend on quilt if clean depends on the xsfclean
      rule, for packages maintained by the X Strike Force.
    + [RA] CDBS packages that use the python-distutils class should list
      Python in Build-Depends, not Build-Depends-Indep, since CDBS wants
      to use it in debian/rules clean. Thanks, Jan Lübbe.
    + [HE] Add check for build-deps on build-essential. Yes, people do that.
    + [RA] Recognize direct invocations of quilt in clean rules and allow
      Build-Depends on quilt in that case. Reported by Sam Hocevar.
      (Closes: #374878)
    + [RA] Fix handling of versioned Build-Depends to avoid spurious
      build-depends-without-arch-dep warnings. Reported by Marcus
      Better.
    + [RA] Don't require Build-Depends on perl even if run explicitly in
      debian/rules clean, since perl-base may be sufficient. Catch more
      ways perl could be run, including the common idiom for packages that
      use Build.PL.
    + [RA] Downgrade build-depends-without-arch-dep to info from warning.
      Policy doesn't require using Build-Depends-Indep for
      arch-independent packages and the test has a lot of false positives.
    + [RA] Require ant in Build-Depends when using the CDBS ant rule.
    + [RA] Bypass the build-depends-without-arch-dep check entirely when
      using ant, since determining which Java dependencies are then
      permissible in Build-Depends is too complex to do a proper job.
      Reported by Peter Eisentraut. (Closes: #372190)
    + [RA] Only allow patch in Build-Depends for yada unpatch, don't
      require it, since yada depends on patch. (Closes: #375479)
  * checks/po-debconf:
    + [RA] Don't consider templates.in to be a stray translated template
      file. Thanks, Thomas Huriaux. (Closes: #367534)
  * lib/Util.pm:
    + [RA] Pass the --wildcards option to tar, now required by a change in
      the default tar semantics. (Closes: #375246)

e8e8b0a... by Reinhard Tartler on 2006-06-28

Import patches-unapplied version 1.23.21ubuntu1 to ubuntu/edgy

Imported using git-ubuntu import.

Changelog parent: a9ec9c456808b468e8798d57a4707cef5e23bea4

New changelog entries:
  * Merge from debian unstable.
  * add edgy to frontend
  * checks/menus:
    + [RA] Tell Perl where common_data.pm is since we're now including it.
      Doh. Thanks, Nelson A. de Oliveira. (Closes: #366481)
  The "Policy backlog clearing is a wonderful sight" release
  * checks/debconf{.desc,}:
    + [RA] Add checks for the Developer's Reference guidelines for debconf
      templates. Based on a patch by Thomas Huriaux. (Closes: #362145)
  * checks/fields{.desc,}:
    + [RA] xfonts-encodings is also not an xfont package. Thanks, Drew
      Parsons. (Closes: #365503)
    + [RA] Report errors for dependencies on python-minimal. Thanks to
      Steve Langasek for the analysis.
    + [RA] Allow a build-dependency on patchutils when using CDBS with one
      of the patch systems, as patchutils may be optionally used to check
      for bad patches. Thanks, Marc Dequènes (Duck). (Closes: #365466)
    + [RA] Since some packages should be in Build-Depends and some should
      be in Build-Depends-Indep, report all of the misplaced ones rather
      than just the first one. That way, users know which to move.
    + [RA] Allow perl in Build-Depends if invoked in clean rules.
    + [RA] Allow patch in Build-Depends if yada unpatch is invoked in
      clean rules.
  * checks/files{.desc,}:
    + [RA] Add an explicit check for non-world-readable executables to
      provide a more detailed explanation and tighten the accepted
      permissions of setuid and setgid executables to just the permissions
      mentioned in Policy 10.9. Add Policy 10.9 references to the
      descriptions. Reported by Piotr Engelking. (Closes: #365452)
    + [RA] Add a request to the descriptions of setuid and setgid tags to
      add a lintian override for documentation if the permissions are
      intentional.
    + [RA] Report a more specific tag for binaries that are owned by group
      games but are not setgid.
    + [RA] Remove the check for files in /usr/lib/cgi-bin. This policy
      change was reverted.
    + [RA] Allow files installed in /usr/include/X11 and /usr/lib/X11 but
      require Pre-Depends on x11-common (>= 1:7.0.0). Remove the
      duplicate check for files in /usr/bin/X11 since it no longer adds
      additional information.
  * checks/menus{.desc,}:
    + [RA] Check that all files referenced in doc-base control files are
      present in the package, based on a patch by Robert Luberda. Also
      check that Index references only one file and that Format names a
      known format. (Closes: #196122)
    + [RA] Fix incomplete diagnosis of missing calls to update-menus.
    + [RA] Change postrm to prerm in the check for a useless install-docs
      call; calling install-docs in postrm is always a warning and useless
      calls in prerm were not being diagnosed.
  * checks/po-debconf{.desc,}:
    + [RA] Exempt packages that use yada from the POTFILES.in check and
      from checking for up-to-date templates, since yada does this at
      build time. Reported by Piotr Roszatycki. (Closes: #321139)
    + [RA] Check for stray debconf-mergetemplate files in packages
      using po-debconf. Thanks, Martin Quinson. (Closes: #232442)
    + [RA] General cleanup of tag descriptions for grammar and markup.
      Move man page references into Ref fields.
  * checks/shared-libs.desc:
    + [RA] Document that exceptions to the -fPIC rule for shared libraries
      are possible and ask that such exceptions be documented with lintian
      overrides.
  * checks/standards-version:
    + [RA] Update to 3.7.2. (Closes: #366233)
    + [RA] Report the current standards version when warning about too old
      or too new versions. Thanks, Jari Aalto. (Closes: #366104)
  * debian/control:
    + [RA] Update standards version to 3.7.2 (no changes required).
    + [RA] Update description to note calibration for Policy 3.7.2.
  The "Policy 3.7.0" release
  * checks/fields{.desc,}:
    + [RA] python-all-dev also satisfies dh_python's requirements.
      Thanks, Marc Dequènes (Duck). (Closes: #364943)
    + [RA] Allow python in Build-Depends if it's invoked explicitly in the
      clean rule. Thanks, Marc Dequènes (Duck). (Closes: #365030)
    + [RA] Recognize the CDBS included rule files that indicate dpatch or
      quilt will be used, check those dependencies, and require that they
      be in Build-Depends since they're used for clean. Thanks, Marc
      Dequènes (Duck). (Closes: #365041)
  * checks/files{.desc,}:
    + [RA] Add the references to Policy for the deprecation of X11R6
      directories now that Policy has been updated in 3.7.0.0.
    + [RA] Policy now mandates FHS 2.3. Update tag descriptions.
    + [RA] Warn about files installed in /usr/lib/cgi-bin. Policy now
      states they should be installed in /usr/lib/cgi-lib.
    + [RA] Warn about scripts installed on the user's PATH with names that
      include language extensions (.sh, .pl, .py), per Policy 10.4.
    + [RA] Report directories under /usr/share/man that don't match the
      directory layout specified in the FHS. (Closes: #176683)
    + [RA] Fix a very long-standing bug that caused the check for
      executable manpages to be silently skipped.
  * checks/scripts:
    + [RA] Debian etch release policy explicitly forbids scripts without
      #! magic and they rely on being run from a shell. Revert the change
      that permitted the Perl magic without a #! line. Thanks to Piotr
      Engelking and Steve Langasek for pointing this out.
    + [RA] Don't syntax-check *.dpatch scripts in /usr/src. bash -n
      doesn't stop at exit 0 and then may choke on the patch. Thanks,
      Matthias Klose. (Closes: #364521)
  * checks/scripts.desc:
    + [RA] Using invoke-rc.d is now required by Policy.
  * checks/standards-version:
    + [RA] Update to 3.7.0.
  * debian/control:
    + [RA] Update standards version to 3.7.0 (no changes required).
    + [RA] Update description to note calibration for Policy 3.7.0.
  The "brown paper Python" release
  * checks/fields{.desc,}:
    + [RA] Redo handling of build dependencies to allow a custom tag to be
      specified and to allow a general dependency string to be required
      rather than a simple package name. As a result, dh_python handling
      is no longer a buggy special case. Allow either python or
      python-dev for dh_python and the cdbs Python rules. Thanks, Torsten
      Merek and Aaron M. Ucko. (Closes: #364297, #364330)
    + [RA] Require at least quilt 0.40 if /usr/share/quilt/quilt.make is
      included. Thanks, Michele Baldessari.
    + [RA] Packages using dh_installxfonts must build-depend on 5.0.31 or
      later of debhelper for the X.Org 7 transition.
  The "happy Nanaimo hacking" release
  * checks/binaries:
    + [RA] Detect klibc binaries from their requested interpreter and
      allow them to appear static. (Closes: #328850)
  * checks/common_data.pm:
    + [RA] Include all combinations of cpu and os from the dpkg cputable
      and ostable files (as of dpkg 1.13.16). (Closes: #337034, #357433)
    + [RA] Include a list of known X metapackages.
  * checks/control-file{.desc,}:
    + [RA] Warn if debian/control in a source package is a symlink.
  * checks/copyright-file{.desc,}:
    + [RA] Don't assume mentions of GPL or GNU General Public License
      after what look like mail headers are referring to the license of
      the package. Be a bit more specific in the old FSF address check
      to avoid false positives on other Cambridge, MA addresses. Reported
      by Adam C. Powell IV. (Closes: #205934)
  * checks/debconf:
    + [RA] Allow Indices as a template field. cdebconf uses it and
      debconf ignores it. Reported by Frans Pop. (Closes: #361986)
  * checks/debdiff{.desc,}:
    + [RA] Warn if the diff contains debian/substvars. Based on a patch
      by Michael Ablassmeier. (Closes: #359646)
  * checks/debhelper.desc:
    + [RA] When explaining the warning about deprecated debhelper
      compatibility versions, mention that debhelper defaults to version 1
      if not set anywhere. (Closes: #360711)
    + [RA] Move simple man page references from Info into Ref.
  * checks/fields{.desc,}:
    + [RA] Allow dpatch in Build-Depends for arch-independent packages if
      it is invoked in clean, build-arch, or binary-arch.
    + [RA] Only list examples of non-standard architectures, since there
      are now too many combinations to list completely.
    + [RA] Catch dependencies on X metapackages, based on a patch by Josh
      Triplett. No packages are allowed to build-depend, and only
      packages that look like metapackages (arch: all, no files outside of
      /usr/share/doc) are allowed to depend. (Closes: #347169)
    + [RA] Look for an explicit section of unknown, probably left over
      from dh_make templates, and diagnose it with an error rather than a
      warning. Reported by Jari Aalto. (Closes: #355032)
    + [RA] Reorganize dependency checking based on debian/rules analysis.
      Diagnose missing build dependencies on the helper packages we know
      about, catch cases where Build-Depends-Indep should be Build-Depends
      because of the clean target, and make sure users of dh_python
      build-depend on python. yada is no longer a special case.
      (Closes: #242789, #278290)
    + [RA] Check for conflicting with dependencies and build-conflicting
      with build dependencies. (Closes: #122760)
    + [RA] Allow xfonts-utils in dependencies. It's not actually an X
      font package.
  * checks/files{.desc,}:
    + [RA] For the X.Org 7 transition, add explicit checks for fonts and
      binaries installed in /usr/X11R6. Rename the existing check for
      other files in /usr/X11R6 since the tag had a pluralization error
      and we want package maintainers to see the error again and
      reconsider whether to ignore it. No packages should be installing
      files in /usr/X11R6 going forward. Remove the policy cross-refs for
      right now until policy catches up.
  * checks/manpages:
    + [RA] Use system_env instead of system and sanitize the environment
      before running man -l out of caution and to avoid extraneous output
      when CDPATH is set. Reported by Marc Haber. (Closes: #360217)
  * checks/nmu{.desc,}:
    + [RA] Warn if debian/changelog in a native source package is a
      symlink and skip checks rather than aborting if it was a symlink to
      a file we didn't unpack. (Closes: #257650)
  * checks/po-debconf:
    + [RA] Use system_env instead of system out of caution and to avoid
      extraneous output when CDPATH is set.
  * checks/rules{.desc,}:
    + [RA] A new set of checks that parses debian/rules and checks for
      required rules, debian/rules as a symlink, and the correct first
      line. Based heavily on previous work by René van Bevern.
      (Closes: #294926, #311786)
  * checks/scripts{.desc,}:
    + [RA] Ignore text inside single quotes and, for most checks, text
      inside double quotes when checking for bashisms. Reported by Frank
      Küster. (Closes: #344266)
    + [RA] Change canonical zsh path to /bin/zsh at the request of the zsh
      maintainer. (Closes: #360534)
    + [RA] Change the check for broken error handling with invoke-rc.d to
      maintainer-script-hides-init-failure to be more generic and explain
      what the test looks at. Add the script name and line number and fix
      a typo. Thanks, Marc Haber. (Closes: #360214, #360216)
    + [RA] Warn when maintainer scripts run init scripts directly and
      don't use invoke-rc.d. Thanks, Lars Wirzenius. (Closes: #353659)
    + [RA] Find missing ucf dependencies and restructure the code to allow
      easier addition of similar checks. (Closes: #261891)
    + [RA] Add python2.5, lua50, gbx, and gbx2 to the list of valid
      interpreters. (Closes: #361601, #361644, #362566)
  * checks/shared-libs:
    + [RA] Limit shlib-without-PT_GNU_STACK-section to only those
      architectures where gcc always adds the section. Thanks to Frans
      Pop for the report and Bastian Blank for the architecture list.
      (Closes: #357636)
  * collection/objdump-info:
    + [RA] Unset CDPATH before running cd to avoid strange effects from
      the user's environment.
    + [RA] Run readelf -l to collect interpreter information.
  * lib/Dep.pm:
    + [RA] Add initial support for analyzing architecture information in
      dependencies instead of ignoring it.
  * lib/Read_taginfo.pm:
    + [RA] Add support for formatting man page references from Ref.
  * lib/Util.pm:
    + [RA] Add system_env, like system but sanitizing the environment.
  * man/lintian.1:
    + [RA] Mention the new rules check class.

a9ec9c4... by Matthias Klose on 2006-04-12

Import patches-unapplied version 1.23.16ubuntu2 to ubuntu/dapper

Imported using git-ubuntu import.

Changelog parent: b92ef277e2944cffebbf01775e967c09ac6455ea

New changelog entries:
  * Depend on the dpkg version, having the -q option for dpkg-source.

b92ef27... by Matthias Klose on 2006-04-09

Import patches-unapplied version 1.23.16ubuntu1 to ubuntu/dapper

Imported using git-ubuntu import.

Changelog parent: 293d58f3276cea559f882755ebfd3a6756d5f138

New changelog entries:
  * Synchronize with Debian unstable.
  * Add python2.5 to the list of known interpreters.
  The "What's this Russ guy up to?" release
  * checks/binaries{.desc,}:
    + [RA] Add a check for the new "Invalid operation" error from
      objdump -T. Skip shared-lib-without-dependency-information for
      files in /usr/lib/debug.
  * checks/changelog-file:
    + [FL] Add line number to output of wrong-bug-number-in-closes.
      Inspired by #349761 from Steinar H. Gunderson.
  * checks/common_data.pm:
    + [FL] Add armeb to %non_standard_archs as requested by
      Martin Michlmayr. (Closes: #350653)
  * checks/debconf:
    + [RA] Packages that depend on dbconfig-common are allowed to have
      config scripts without templates or an explicit debconf dependency.
      Reported by Marcus Better. (Closes: #344421)
  * checks/debconf.desc:
    + [RA] Clarify the necessary dependencies for packages using SETTITLE.
      (Closes: #349616)
  * checks/debhelper:
    + [RA] Recognize setting DH_COMPAT with := in addition to = in
      debian/rules. (Closes: #349272)
    + [RA] CDBS sets DH_COMPAT to 4 but doesn't export it. It does create
      debian/compat with that value if none was present. Reflect this
      behavior to avoid spurious compat level warnings when using CDBS.
      Based on a patch by Jay Berkenbilt. (Closes: #350228)
  * checks/fields:
    + [RA] Allow a quilt build-dependency for arch-independent packages if
      the quilt makefile rules are included. (Closes: #349273)
    + [RA] If clean depends on a rule that calls dh_clean rather than
      calling it directly, still allow debhelper in Build-Depends for
      arch-independent packages. Reported by Michael Stilkerich.
    + [JvW] Commented that Uploaders no longer will hit the multiline field
      issue, updated testsuite accordingly
  * checks/manpages:
    + [FL] Ignore more warnings ("cannot adjust line", "can't break
      line") in non-English manpages. (Closes: #349792)
    + [RA] cd into the parent directory before checking man pages with man
      so that .so inclusions are processed correctly. Based on a patch by
      Nicolas François. (Closes: #349614)
  * checks/menu-format:
    + [RA] Look for binaries in /usr/X11R6/bin, not /usr/bin/X11, per
      Policy 11.8.7. Thanks, Matej Vela. (Closes: #354890)
  * checks/menu-format.desc:
    + [RA] Use "menu manual" rather than "menu" for references to more
      clearly distinguish from the Debian Menu Policy. (Closes: #347510)
  * checks/po-debconf:
    + [RA] If there are template files in debian, assume the package uses
      debconf; don't require a dependency or config script. Patch by
      Thomas Huriaux. (Closes: #353294)
  * checks/scripts:
    + [RA] Allow /tmp in variable settings. It's likely to be a false
      positive. Reported by Frank Küster. (Closes: #344998)
    + [RA] Make the syntax checking of shell scripts more robust against
      filenames containing shell metacharacters. Reported by Michael
      Stilkerich.
    + [RA] Add fish and expectk to the list of valid interpreters.
      (Closes: #351624, #353770)
    + [RA] /usr/bin/tcl is provided by tclx8.3, not tcl. Reported by
      James R. Van Zandt. (Closes: #351324)
    + [RA] Allow more variations on leading magic to invoke some
      interpreter rather than then shell. Bypass the ELF magic check for
      scripts using magic that relies on having no leading #! line.
      Reported by Frank Küster. (Closes: #344269)
    + [JvW] Add check against package suffering from debhelper bug #337664,
      per Joey Hess, which had broken error detection (Closes: #358523)
  * checks/shared-libs:
    + [JvW] Fix postinst-must-call-ldconfig to also get emitted when there is
      no postinst at all, instead of just one lacking a ldconfig call
    + [JvW] Implement checks for "udeb:" lines in shlibs files
      (Closes: #357541)
    + [JvW] Consider also the soname version for shlibs checking, preventing
      some bogus 'duplicate' warnings, and actually throw a warning when
      soname version doesn't match
    + [JvW] Added error when udeb postinst calls ldconfig, that must never
      happen (thanks to Frans Pop for noticing, see #203056)
  * debian/{control,copyright}:
    + [RA] Add Russ Allbery to Uploaders and copyright.
    + [JvW] Version dpkg-dev requirement to >= 1.13.17, for
      unpack/unpack-srcpkg-l2
  * frontends/lintian-info:
    + [RA] Avoid Perl uninitialized value warnings when given output that
      looks like lintian messages without tags. (Closes: #352606)
  * collection/objdump-info:
    + [RA] Pass "Invalid operation" errors from objdump -T on to the check
      scripts instead of failing. (Closes: #249435)
  * man/lintian.1:
    + [RA] Add references to dh_make, debhelper, dpkg-buildpackage, and
      linda in new reference sections. (Closes: #322288)
  * man/{lintian.1,lintian-info.1}:
    + [RA] Left-justify and disable hyphenation for readability.
  * unpack/unpack-srcpkg-l2:
    + [JvW] Use -q with dpkg-source to surpress warnings about unsigned source
      packages. Requires dpkg-dev 1.13.17

  * The "www.no-name-yet.eu" release

  * debian/changelog:
    + [FL] Fix wrapping of last changelog entry (Closes: #344899)
  * checks/common_data.pm:
    + [FL] Add xlibs-dev and debmake to %known_obsolete_packages
  * checks/debconf:
    + [CW] Show template name for empty-translated-choices,
      mismatch-translated-choices, and unknown-field-in-templates.
  * checks/debhelper:
    + [FL] Also check for debhelper build-dependency in debhelper-using
      cdbs based packages
    + [FL] Indicate where we found which compat version in
      declares-possibly-conflicting-debhelper-compat-versions
      (Closes: #329953)
    + [FL] Add dh_installtexfonts to list of commands that modfiy
      the maintainer scripts
    + [FL] Try a little harder to find the DH_COMPAT setting in debian/rules
      (Closes: #348380)
  * checks/fields:
    + [FL] Allow version numbers of 0 by correctly checking the output
      of _valid_version for definedness and not the boolean value
      (Closes: #345005)
    + [FL] Better check for false postives of build-depends-without-arch-dep.
      Should fix false positives for cdbs, dbs, dpatch and yada. Based on
      a patch by Russ Allbery (Closes: #344609, #321135, #339750)
    + [FL] Also check for build-dependencies on obsolete packages not
      only dependencies (Closes: #234531)
  * checks/fields.desc:
    + [JvW] Fix typo in description
  * checks/init.d:
    + [FL] Only try to validate update-rc.d calls where the name of the
      script matches [\w.-]+. That accounts for all today known init
      scripts and eliminates false positives like shell variables in the
      name (Closes: #343865)
  * checks/manpages:
    + [FL] Fix stupid mistake in regex to strip of filenames from roff
      output (which was hidden by another stupid mistake in the test
      suite). Patch by Nicolas François (Closes: #347999)
  * checks/scripts:
    + [FL] Make mknod-in-maintainer-script an error since this is now
      a must in policy. Pointed out by Bartosz Fenski (Closes: #344928)
    + [FL] dpkg --print-installation-architecture is deprecated
      so delete dpkg-print-architecture-in-maintainer-script
    + [FL] Add parrot to list of valid interpreters (Closes: #346335)

293d58f... by Michael Vogt on 2005-12-28

Import patches-unapplied version 1.23.14ubuntu1 to ubuntu/dapper

Imported using git-ubuntu import.

Changelog parent: 818562525820c10db5f1bb603f527de91237048f

New changelog entries:
  * Resynchronise with Debian.

  * The "fix those frontend regressions" release
  * frontend/lintian:
    + [FL] Fix exit status computing so that we exit with 1 again
      if we found any error. (Closes: #329458)
    + [FL] Re-enable reporting unused overrides.

  * lib/Tags.pm:
    + [FL] Some fixes to the statistics code to make the fixes
      in frontend/lintian possible

  * checks/binaries{.desc,}:
    + [FL] support c2a suffix in soname check, too (Closes: #340856)
    + [FL] fix typo in description of package-name-doesnt-match-sonames (Closes: #339360)
    + [FL] The Debian specific patches from coreutils to call strip with --remove-section
      arguments on install -s have been dropped. Adapt description of binary-has-unneeded-section
      accordingly and demote it to "info" because many packages will get this now.
  * checks/debconf{.desc,}:
    + [FL] drop seen-flag-requires-versioned-depends and multiselect-without-dependency and
      drop version requirement from missing-debconf-dependency-for-preinst. All due to the
      fact that woody shipped with 1.0.x and therefor versioned depends on versions lesser than
      that don't make much sense anymore (Closes: #333736)
  * checks/debhelper:
    + [FL] debhelper compat level 3 is deprecated as well now (Closes: #340222)
  * checks/files:
    + [FL] forgot /lib(32|64) (more #328612 fixes)
  * checks/menu-format:
    + [FL] Drop su-to-root-with-usr-bin and su-to-root-without-usr-sbin, and add
      su-to-root-with-usr-sbin to adapt to current menu package and policy (Closes: #332400)
  * checks/po-debconf:
    + [FL] Fix logical error in search for files (Closes: #342707)
  * checks/scripts{.desc,}:
    + [FL] Drop install-fvwmgenmenu as valid interpreter. Was dropped from menu package before sarge.
      (also for #332400, see checks/menu-format)
    + [FL] Change path for install-menu from /usr/sbin to /usr/bin (also for #332400)
    + [FL] Merge most of the wrong-path-for-* and *-script-but-no-*-dep tags to two tags
      wrong-path-for-interpreter and missing-dep-for-interpreter. This makes maintaining the
      list of valid interpreters way easier. Some tags with special text have been special
      cased (php\d? and (m|g)awk).
    + [FL] Add speedy and slsh to list of valid interpreters (Closes: #333955, #336700)
  * checks/shared-libs:
    + [FL] forgot /lib(32|64) (hopefully finally closes: #328612)

8185625... by Daniel Holbach on 2005-10-26

Import patches-unapplied version 1.23.13ubuntu1 to ubuntu/dapper

Imported using git-ubuntu import.

Changelog parent: 43ea43d691f6fa06994a605d1d1ef6695bd2e533

New changelog entries:
  * frontend/lintian:
    - added warty, hoary, breezy, dapper, -updates and -backports.
  * The "doesn't contain all the fixes I would like but that's no
    reason to let the others wait forever" release

  * debian/control:
    + [FL] Fix typo in description. Noted by Bill Allombert
      (Closes: #327859)

  * checks/copyright-file:
    + [JvW] Demote FSF address check to warning
  * checks/description:
    + [HE] Change description-synopsis-is-duplicated to only be emitted if
      the synopsis is copied without being extended. (Closes: #316523)
  * checks/files:
    + [FL] Add some formats to the exception list for extra-license-file
      (jpe?g, gif and svg) (Closes: #324944)
    + [FL] Don't complain about lib(32|64) as unusual directories. Noted
      by Matthias Klose (partly fixes #328612, see checks/shared-libs for
      the rest)
  * checks/infofiles:
    + [FL] Don't issue install-info-not-called-with-section-option if
      the call in postinst is really a removal. Experienced by Ben Pfaff
      in autoconf (Closes: #329170)
  * checks/po-debconf:
    + [FL] Previously we only run the checks if we found a templates file
      and a debconf dependency. Since the latter is mostly generated by
      ${misc:Depends} nowadays, we now also run the checks if we find
      a templates and a config file. (Closes: #331672)
  * checks/scripts:
    + [FL] PythonX.Y dependency can also be satisfied with pythonX.Y-minimal.
      Noted by Matthias Klose (Closes: #326643)
    + [FL] Only match 'local' at the beginning of a line. The check is too
      ambigious otherwise. Reported by Marc Haber (Closes: #330548)
    + [FL] Better reflect the current discussions wether some of the
      XSI:sms should be allowed in shell scripts by moving some of
      them to a separate check possible-non-posix-code-in-maintainer-script.
      Not doing that for kill -NAME as reuqested since -s NAME is available
      and should be perfectly portable. (Closes: #323053)
  * checks/shared-libs:
    + [HE] Apply patch from Bastian Blank to check for executable stacks in
      binaries. New checks are called shlib-without-PT_GNU_STACK-section,
      shlib-with-executable-stack, thanks waldi. (Closes: #321750)
    + [FL] Add lib(32|64) to ldso directories. Pointed out by
      Matthias Klose (Closes: #328612)
  * The "bad, bad SONAME check" release

  * all files:
    + [FL] Update FSF address

  * debian/control:
    + [FL] Depend on dpkg-dev since we use dpkg-source. How old exactly is
      this bug? (Closes: #324673)

  * checks/binaries:
    + [FL] Only use sonames from files in common library directories for
      the soname checks. This avoids many false positives. Patch by
      Russ Allbery (Closes: #321564)
    + [FL] Convert the SONAME to lower case before comparing with
      package name. Suggested by Josh Triplett (Closes: #321206, #325225)
    + [FL] Try to remove strings added for transition purposes from
      library package names before comparing package name with SONAME.
      Pointed out by Rene Engelhard (Closes: #322241, #324121)
    + [FL] Also remove -udeb strings and substitute lib64 with lib in
      package name before comparing with SONAME
    + [FL] Replace any occurence of _ in the SONAME with - since the
      former isn't allowed in package names but occasionally used in
      sonames
    + [FL] Remove trailing .so from SONAMEs
    + [FL] Also ignore static binaries in sub directories of /boot,
      not only in /boot itself. Patch by Guillem Jover
      (Closes: #320382)
  * checks/changelog-file:
    + [FL] Detect old FSF address additionally to the even older
      one
  * checks/{cruft,files}{,.desc}:
    + [FL] Also check for .arch-ids/ {arch}/ .arch-inventory and .bzr/
      in packages and sources (Closes: #324255)
  * checks/debhelper{,.desc}:
    + [FL] Warn about using debhelper compat version lower than 3
      like debhelper itself
    + [FL] Drop package-lacks-versioned-build-depends-on-debhelper
      tag for compat versions < 5. With debhelper 4 even in oldstable
      issuing an error here is silly
    + [FL] Fix typo (s,debian/control,debian/compat,) in description of
      declares-possibly-conflicting-debhelper-compat-versions
  * checks/description{,.desc}:
    + [FL] Avoid double warning about description-is-dh_make-template
      in the same way we do it for the corresponding debmake tag
    + [FL] Policy section of Description field has changed
  * checks/fields{,.desc}:
    + [FL] Fix a lot of off-by-one errors in the policy references
      (caused by the addition of the Uploaders field). Unknowningly
      pointed out by Russ Allbery
    + [FL] Also use non_standards_archs when checking source package
      relations. Patch by Russ Allbery (Closes: #322291)
  * checks/manpages:
    + [FL] Don't issue warnings about 8bit characters in translated
      man pages. Patch by Denis Barbier (Closes: #321650)
  * checks/scripts:
    + [FL] Don't issue bashism warning on POSIX character classes ([[:foo:]]).
      Noted by Stephen Gran (Closes: #323098)
    + [FL] Remove some useless groupings in the bashism regexes
  * frontend/lintian:
    + [FL] Don't use dpkg --print-installation-architecture since
      it is deprecated, use dpkg --print-architecture instead.

  * debian/control:
    + [FL] Depend on libparse-debianchangelog-perl, require
      >= 0.6 since prior versions have bugs regarding parse
      error handling

  * checks/binaries:
    + [FL] Check that the package name of a shared library matches
      the SONAME as defined in the "Library Packaging guide"
      (Closes: #305575, #313118)
  * checks/changelog-file{,.desc}:
    + [FL] Use libparse-debianchangelog-perl to parse the changelog,
      which detects a lot of syntax errors
    + [FL] Add a new tag debian-changelog-file-missing-or-wrong-name
      which is issued if we found no Debian changelog but an upstream
      changelog since the further checks will treat the
      latter file as the Debian changelog and only issuing
      debian-changelog-file-missing would be confusing then
      (Closes: #285152)
    + [FL] Detect closes: statements with non-valid bugnumbers,
      suggested by martin f. krafft (Closes: #294409)
  * checks/common_data.pm:
    + [FL] Fix typo (hurd-386 -> hurd-i386) from last release
      that lead to spurious warnings about unknown architectures
      (Closes: #318110)
  * checks/control-file:
    + [CW] Break control paragraphs at lines containing only whitespace, not
      just on zero-length lines. (Closes: #319370)
  * checks/fields:
    + [FL] Actually mention which architecture we're complaining about
  * checks/manpages:
    + [FL] Report errors from man when parsing man pages. Based on
      a patch by Kevin Ryde (Closes: #285540)
  * checks/po-debconf:
    + [FL] Abort check if the package doesn't seem to use debconf to
      avoid false positives in case maintainers use debian/po for
      other Debian specific strings (Closes: #262749)
  * checks/scripts:
    + [FL] increase search limit for exec hack by not counting comments
      and empty lines (Closes: #294661)
    + [FL] detect more bashisms, suggested by Clint Adams and
      martin f krafft (Closes: #253498, #296233 and addresses #253012
      partly).
    + [FL] Adjust check for positional arguments after ". file" to detect
      more shell control and piping commands that are all allowed.
      Noted by Thomas Hood. (Closes: #319212)

  * reporting/html_reports:
    + [FL] Fix counting of binary package names
    + [FL] Generate mostly valid HTML (id and name attributes still
      aren't valid in all cases)
  * The "Ah, it's LinuxTag and I still have free time!" release
  * debian/control:
    + [HE] Updated description to say that we're calibrated for Policy
      version 3.6.2. As the changes between 3.6.{1,2} aren't stuff we
      (can) check, this is actually true! (Closes: #317049)
  * testset/runtests:
    + [HE] Fix symlinking of original tarballs to allow run directories
      outside the lintian source tree.
  * checks/control-file
    + [HE] Check for duplicated fields. (Closes: #299792)
  * checks/fields:
    + [HE] Change unknown-architecture a bit: We don't complain about
      "known" non-standard archs (like amd64, ppc64, *bsd-i386) and only
      print out an info message for those. (Closes: #253405, #311471)
  * checks/files:
    + [HE] Allow backupninja configuration files in /etc/backup.d/ to be
      0600. (Closes: #307639)
  * checks/scripts:
    + [HE] Allow Scripts in /etc/Xsession.d/ to be not executable, as they're
      not directly called, but only sourced. (Closes: #309203)
    + [HE] Check for use of adduser and update-inetd and warn if the package
      has no (pre-)dependency on adduser/netbase. Patch by Russ Allbery,
      thanks for the work. (Closes: #308569)
    + [HE] Check for use of "." as a deprecated separator between user and
      group names in chown call. (Closes: #88340)
    + [HE] Fix to work $interpreter-script-but-no-$pkg-dep with more than one
      dependency if needed. First use case is depending on build-essential
      to provide /usr/bin/make. (Closes: #294894)
    + [HE] Add lefty as a valid interpreter and check for a correct dependency
      on graphviz. (Closes: #295093)
  * checks/shared-libs:
    + [HE] Don't allow non-PIC shared libraries. This conforms to the new
      etch release policy. Thanks for the report and patch to Kurt Roeckx
      <email address hidden>. (Closes: #309220)
  * The "Wow, so much time at hand" release

  * [FL] Convert build process to debhelper
    - debian/rules - adapted
    - debian/compat - new
    - debian/dirs - new
    - debian/docs - new
    - debian/control - add build depends
    - debian/postinst - remove (Closes: #292981)
    - debian/conffiles- remove
    - debian/prerm - adapted
  * debian/control:
    + [FL] Update Standards-Version to 3.6.2

  * checks/conffiles:
    + [JvW] Warn on /var files being a conffile too (Closes: #293443)
  * checks/debconf:
    + [FL] Also report postinst-does-not-load-confmodule and
      postrm-does-not-purge-debconf if the related files don't
      exist at all. Spotted by Gerfried Fuchs (Closes: #301056)
  * checks/menus:
    + [FL] New check menu-file-in-usr-lib because /usr/lib/menu is
      deprecated
    + [FL] Also find menu files in /usr/share/menu (Closes: #314187)
    + [FL] Rename executable-in-usr-lib-menu to executable-menu-file
  * checks/menu-format:
    + [FL] Adapt to changes in collections/menu-files
  * checks/standards-version:
    + [FL] Update to 3.6.2 (Closes: #314879)
  * collections/menu-files:
    + [FL] Also collect files from /usr/share/menu

  The "Hm, this is the team's one year anniversery of maintaining lintian"
  release[1], and still using the "temporary" subversion repository...
  Featuring Steve "R." Langasek in a guest appearance.
  [1] http://lists.debian.org/debian-lint-maint/2004/01/msg00014.html
  * checks/*.desc,doc/lintian.sgml:
    + [JvW] Stop bugging us for exceptions, mmkay, just install overrides.
      Hints like this should be in the general documentation anyway, not in
      per-tag descriptions. The general documentation will now only ask to
      contact us if in doubt
  * checks/changelog-file{,desc}:
    + [JvW] (new test) Bark on @toplevel email signatures in changelogs
    + [JvW] Display invalid debmake email address upon detection
  * checks/common_data.pm:
    + [CW] Add tclx8.4 to %known_tclxs.
  * checks/description:
    + [SRL] Do not generate warnings when a short description starts with an
      article; this is good grammar and should not be discouraged.
      (Closes: #290505)
    + [JvW] Drop description-synopsis-starts-with-a-capital-letter by popular
      demand (Closes: #288568)
  * checks/files{,.desc}:
    + [JvW] Warn only for hardlinks in /etc or amongst different directories
      (Closes: #288634)
    + [JvW] Only check for desktop files in GNOME's and KDE's obsolete places,
      not in all the package, as KDE uses .desktop files also for other
      purposes (Closes: #289773)
  * checks/nmu.desc:
    + [JvW] Be more precise in explaining why lintian thinks this is a NMU,
      and copy explanation to changelog-should-mention-nmu
  * checks/scripts{,.desc}:
    + [CW] Add checks for tclsh8.4 and wish8.4. (Closes: #288287)
  * lib/Lab.pm:
    + Fixed creation of static lab if the directory already existed, this
      failed in 1.23.6
    + In temporary lab mode, try to create the directory several
      times before giving up

  * testset/runtests: Extend the static lab test
  The "Let's see if I can upload myself now" release, made by Marc, Frank and
  Colin, uploaded by Jeroen.
  * checks/description
    + [HE] Warn if the short description start with an article or a capital
      letter. Patch by Tobias Toedter <email address hidden>, thanks. (Closes:
      #258824)
  * checks/fields:
    + [HE] Warn if the debian revision has three parts, as this is the sign of
      a binary NMU. New check's name is binary-nmu-debian-revision-in-source.
      (Closes: #244830)
    + [HE] Warn if people use the Bugs field to refer to the Debian BTS, the
      new check is called redundant-bugs-field. (Closes: #245883)
  * checks/files:
    + [HE] Check that .desktop files are placed in /usr/share/applications.
      This seems to be the standard place for those files that are used
      to create menus. The check is called desktop-file-in-wrong-dir.
      (Closes: #200171)
  * checks/manpages:
    + [HE] Don't compare the manpage filename extension and the content of
      .TH case-sensitive. Report + patch by Jay Berkenbilt <email address hidden>,
      thanks. (Closes: #285335)
    + [HE] Emit binary-without-english-manpage if a package only provides
      translated manpages for a binary. (Closes: #259227)
    + [HE] Skip all comment lines when checking for .so links in manpages.
      Thanks for the report and fix suggestion to Steinar H. Gunderson
      <email address hidden>. (Closes: #284662)
  * checks/md5sums:
    + [HE] Strip off ./ at the beginning of the filenames in md5sums
      files (this seems to happen on some systems, though we don't know
      how). (Closes: #284728)
  * checks/standards-version:
    + [CW] By definition, udebs aren't required to conform to policy, so
      don't issue no-standards-version-field for them. (If they happen to
      have a Standards-Version field anyway, we still check that it's
      valid.)

  * lib/Lab.pm, frontend/lintian:
    SECURITY (CAN-2004-1000):
    + [FL] Overhaul lab directory handling. This also fixes the issue
      of removing a lab that never was created (Closes: #286681)
  The "learn how to use intltool-debian correctly the hard way" release

  * checks/po-debconf: Set INTLTOOL_EXTRACT to fix invocation
    of intltool-update (Closes: #285419, #285471)
  The "A little pause from the sarge release work" release.

  * checks/changelog-file:
    + [FL] file has apparently changed its output format for
      symlinks sometime in the past. This broke symlink detection.
      (Closes: #276504)
  * checks/deb-format, unpack/unpack-binpkg-l1, unpack/unpack-binpkg-l2:
    + [CW] Fix binary package data member extraction to work with arbitrary
      compression algorithms instead of hardcoding data.tar.gz.
  * checks/debconf{,.desc}:
    + [FL] The SETTITLE command was introduced in debconf version
      1.3.22. Check the depends for that (Closes: #261890)
    + [FL] Warn about incorrect usage of commas in translated Choices
      fields. Patch by Denis Barbier after a suggestion by Andreas
      Metzler (Closes: #282030)
  * checks/debhelper:
    + [FL] Update list of debhelper scripts that modify maintainer
      scripts
  * checks/menu-format.desc:
    + [FL] Adjust references to the menu documentation. Noted by
      Jack Moffitt (Closes: #277393)
  * checks/po-debconf{,.desc}:
    + [FL] Check for outdated .pot files when using po-debconf.
      This requires a new dependency on intltool-debian. Patch
      by Denis Barbier with corrections by JvW (Closes: #242345)
  * checks/scripts{,.desc}:
    + [FL] Fix copy-and-paste error in description
      of wrong-path-for-gnuplot (Closes: #276945)
      Thanks to Lionel Elie Mamane for reporting.
    + [FL] Add tclsh8.3 to list of valid interpreters as it is used
      in at least one package. (Closes: #280080)
    + [FL] Issue wrong-path-for-{ruby,python} even if the path contained
      a version number. Change the description of the tag to reflect that.
      (Closes: #257904)

  * frontend/lintian-info:
    + [FL] Overrides start with O:, not with 0:, d'oh!
      (Closes: #258815)

  * lib/Tags.pm:
    + [FL] Add missing "use Util;", noted by Robert Luberda
      (Closes: #278513)

  * testset/debconf/*,testset/tags.debconf:
    + [FL] New test package for debconf and udeb tests
  * testset/diffs:
    + [JvW] Remove the shipped ELF binary, can be compiled at test-time
  * testset/runtests:
    + [FL] Make checks of udeb packages possible

  The ``the others must be busy releasing Sarge or something'' release,
  prepared by yours truly
  * checks/conffiles.desc:
    + Note the most likely cause for duplicate-conffile in the description
      (thanks Chris Anderson for running into this problem and asking me
      about it)
  * checks/copyright-file:
    + Revert the extra pedantic check introduced in 1.23.0 that
      complained about unstrict dependencies when one as a
      /usr/share/doc/<package> that is a symlink (Closes: #249414)
  * checks/debconf:
    + Don't warn when the Choices field of a debconf question is
      not translated, often it makes no sense to translate it
      (Closes: #262649)
  * checks/debhelper:
    + dh-make also creates sample files named .EX, so make that check
      case-insensitive (Closes: #251262)
  * checks/fields.desc:
    + Adjust package-has-a-duplicate-relation to warning, and note that
      this sometimes happens to you when using ${shlibs:Depends}, and you
      shouldn't bother too much if that's the case (Closes: #274286)
      Thanks Peter Eisentraut for the suggestion
    + Fix English language depends-on-essential-package-without-using-version,
      thanks to Peter Eisentrautf for noticing (Closes: #261603)
    + [FL] Clone depends-on-essential-package-without-using-version as
      build-depends-on-essential-package-without-using-version to give
      correct policy reference (Closes: #261602)
  * checks/init.d:
    + Don't warn for missing init.d scripts in package and conffile list
      if a variable is used instead of a real name (Closes: #264218)
  * checks/manpages.desc:
    + Demote binary-without-manpage to warning, and adjust description,
      to be consistent with policy, which says a manpage should be available
      (and doesn't use "must" for it). Thanks to Robert Millan for his patch
      (Closes: #271014)
  * checks/nmu.desc:
    + Note in source-nmu-has-incorrect-version-number's description that
      the mistake could also be the other way around (Closes: #258604)
  * checks/po-debconf:
    + Don't give missing-file-from-potfile-in on empty lines
      (Thanks Adam Conrad for noticing)
  * checks/scripts:
    + The php commandline interpreter is now provided by php4-cli, and
      not php4-cgi, update dependency check accordingly (Closes: #268077)
    + Give an error if the 'config' script uses a non-essential
      interpreter (Closes: #274832)
  * checks/shared-libraries:
    + Ignore comments in shlibs files (Closes: #275124)
  * doc/lintian.sgml:
    + Document that you can use comments in overrides (Closes: #87805)
  * frontend/lintian:
    + Fix overrides so that they allow all of (1) <package> <type>:,
      (2) <package>:, and (3) <nothing> as prefix to tags you want to
      override, and modify documentation accordingly. This used to be buggy
      (Closes: #261435)
  * The "of course it had to go wrong on my first own lintian
    upload" release.
  * Tigthen versioned Build-Depends on sed to (>= 4.1-4) to avoid
    be hitten by a bug in sed that changes the permissions of files
    when processed with sed -i (Closes: #259109)
  The ``Now featuring over 500 checks'' release, prepared by the usual
  suspects.
  * checks/*:
    + [JvW] Changed from executables to check-plugins
    + [HE] Drop the misuse of charset when we want to say "encoding".
      Renamed 2 tests for that:
      unknown-charset-in-po-file -> unknown-encoding-in-po-file
      debian-changelog-file-uses-obsolete-national-charset ->
      debian-changelog-file-uses-obsolete-national-encoding
      (Closes: #248194)
  * checks/binaries:
    + [FL] Change check for binary-compiled-with-profiling-enabled on
      hppa to look for _mcount instead of __gmon_start__ since the
      latter can't be used as an indicator on that arch (Closes: #207063)
    + [JvW] Exempt ocaml binaries from the 'is the binary stripped?' test,
      since they cannot be stripped harmlessly. See #256900 (Closes: #252695)
    + [JvW] Parse the output of file a little bit more strict, and make it
      consequent across checks (Closes: #257898)
  * checks/changelog-files{,.desc}:
    + [HE] New check latest-debian-changelog-entry-without-new-date, comparing
      the dates of the last 2 changelog entries. (Closes: #111215)
    + [FL] New tag invalid-date-in-changelog which is issued if
      latest-debian-changelog-entry-without-new-date encounters a
      parse error
  * checks/common-data.pm:
    + [JvW] Add libgl(u)-dev to list of virtual packages (Closes: #255595)
    + [JvW] Added amd64 to list of known architectures, as the name has
      settled and it'll likely enter the archive soonish (Closes: #257503)
  * checks/control-file{,.desc}:
    + [HE] Introduced new check script. New checks:
      - build-info-in-binary-control-file-section, triggered
        by a Build-* field in a binary section (Closes: #94928)
      - debian-control-file-uses-obsolete-national-encoding, stolen from
        changelog-file (Closes: #247197)
  * checks/cruft{,.desc}:
    + [JvW] cvsignore-file-in-source is now info, because it happens so often
      by upstream, and is only very minor in size
    + [HE] New check: source-contains-cvs-conflict-copy, triggered by
      .#file.version files. They are created by cvs when it tries to merge
      local changes and an update from the repo. (Closes: #246060)
    + [JvW] Also check for source-contains-svn-conflict-copy (for .r123 and
      .mine files)
  * checks/debhelper:
    + [FL] Avoid Perl warning about undefined values. Noted by JvW.
  * checks/fields{,.desc}:
    + [JvW] Added debian-revision-should-not-be-zero, suggested by Adam
      Conrad
    + [FL] Downgrade build-depends-without-arch-dep to warning as it's
      heuristic. Reword explanation. This partly handles #247171.
    + [JvW] For build-depends-without-arch-dep, fix detection of debhelper
      usage in clean when used by means of CDBS (combined with above change,
      now fully closes: #247171)
    + [HE] Check Build-Depends(-Indep) for virtual packages without a
      real dependency. Fix based on patch by Steinar H. Gunderson
      <email address hidden>. (Closes: #255593)
    + [HE] Don't issue virtual-package-depends-without-real-package-depends
      if this happens in Suggests. (Closes: #254367)
    + [FL] Allow whitespace in relations after the version number
  * checks/huge-usr-share:
    + [FL] Skip check for packages that don't have usr/share at all
      (Closes: #247708)
  * checks/manpages:
    + [FL] Comment check for no-manpage-in-correct-directory out until
      I know if it's worth keeping it at all (Closes: #253011)
      Thanks to Stephen Stafford for pointing this out.
  * checks/menus:
    + [FL] Fix regex which checks for update-menus calls (missing
      whitespace) and allow path before executable name (perhaps this
      should be another warning, though?) (Closes: #254420)
    + [FL] Some clean-up and warn that wm-menu-config is deprecated
      (Closes: #248997)
    + [FL] Demote executable-in-usr-lib-menu to warning as executables
      are supported (but seldomly used) (Closes: #254498)
  * checks/menu-format:
    + [FL] Fix su-to-root checks to cope with the new -X option and
      improve the option parsing to better handle unknown options
    + [FL] Allow a comma separated list in the package test. Pointed
      out by Gerfried Fuchs (Closes: #246507) Change incorrect-package-test
      to pkg-not-in-package-test which is issued when the package is
      not in the list. Don't issue menu-command-not-in-package when
      we have a list.
    + [FL] Commands for window manager's modules can't be expected
      to be available as executables, so don't issue
      menu-command-not-in-package in this case. Thanks to
      Manoj Srivastava for reporting (Closes: #247805)
    + [HE] Change menu-command-not-in-package to also look into the standard
      PATH. (Closes: #255155)
  * checks/po-debconf:
    + [JvW] Simply fail if stuff from gettext is missing.
  * checks/scripts:
    + [FL] Don't issue executable-not-elf-or-script for files
      that are named *.exe (Closes: #251075, #255083)
    + [CW] Add python2.4 as a valid interpreter (Closes: #254482)
    + [FL] Add ruby1.[68] as valid interpreters, introduce new
      ruby-script-but-no-ruby-dep error, copied from the python stuff
    + [FL] Don't issue script-not-executable for menu-methods. There
      are reasons why they are sometimes not executable (Closes: #250632)
    + [FL] 'and' and 'or' are no bash keywords (Closes: #194283)
  * checks/shared-libs:
    + [FL] Don't report shlib-with-executable-bit and
      shlib-with-bad-permissions on symbolic links to such files
    + [JvW] Fix the pic-detection code (Closes: #185816)
  * debian/{control,rules}, frontend/lintian:
    + [JvW] Insert version number at package build time, no need to commit a
      change to frontend/lintian on every version number change... Requires
      sed version 4 at build-time.
    + [JvW] Start depending on gettext.
    + [JvW] Start depending on libdigest-md5-perl on woody, for using md5 on
      files.
  * frontend/lintian:
    + [JvW] Partial rewrite: checks are now plugins loaded into lintian,
      rather than executed as separate executables. Makes it easy to make
      common functions available, tags are done centrally, etc etc. Should
      also save quite a number of forks, thus more speedier.

  * lib/Util.pm:
    + [FL] dpkg supports comments in control files now, handle them
      correctly
    + [FL] a space after the colon is not mandatory in dpkg control
      files

  * man/lintian.1:
    + [FL] Document new control-file check script

  * reporting/harness:
    + [FL] Correctly support udeb packages
  * reporting/html_reports:
    + [FL] Correctly support udeb packages
    + [FL] Remove some unused code for bug references
  * reporting/bug.status:
    + [FL] Remove

  * testset/filenames:
    + [JvW] Fix two lintian warnings in lintian itself by touching files only
      on clean target, and not distributing them in the source

  * unpack/list-srcpkg:
    + [FL] Some packages don't specifiy a standards-version, e.g. d-i ones.
      Prevent Perl warnings.
  * unpack/list-udebpkg:
    + [FL] Fix sort of copy & paste error which caused the whole
      script to behave ill
  * unpack/unpack-binpkg-l2:
    + [FL] While fixing permissions, also enable write access
      so we get no problems on removal. Disable group write
      permissions, we need nobody to interfere with us.

43ea43d... by Debian Lintian Maintainers <email address hidden> on 2004-04-23

Import patches-unapplied version 1.23.0 to ubuntu/warty

Imported using git-ubuntu import.