ubuntu/+source/lintian:applied/ubuntu/edgy-devel

Last commit made on 2006-07-09
Get this branch:
git clone -b applied/ubuntu/edgy-devel https://git.launchpad.net/ubuntu/+source/lintian
Members of Ubuntu Server Dev import team can upload to this branch. Log in for directions.

Branch merges

Branch information

Name:
applied/ubuntu/edgy-devel
Repository:
lp:ubuntu/+source/lintian

Recent commits

fbfcb2b... by Reinhard Tartler on 2006-07-09

Import patches-applied version 1.23.22ubuntu1 to applied/ubuntu/edgy

Imported using git-ubuntu import.

Changelog parent: ba17318b241d0e4fae2fbadd5ee9b519c8d3b792
Unapplied parent: e38f16e5bf8db6d1fb6982c14f427d00f34c0406

New changelog entries:
  * Merge from debian unstable.
  * checks/debconf:
    + [JvW] Teach lintian to know about the 'error' debconf template
      question type. (Closes: #374399)
    + [RA] Exclude debconf templates with "for internal use" in the short
      description from style checks and document this in the log
      description of the tags most likely to trigger on internal
      templates. (Closes: #368206)
  * checks/common_data.pm:
    + [RA] Add amd64 to the standard architectures. (Closes: #367324)
  * checks/debhelper:
    + [RA] Use the Dep library to check debhelper build dependencies
      rather than parsing Build-Depends with regexes. This avoids false
      positives due to matching package names ending in debhelper.
      Reported by Fabio Tranchitella. (Closes: #366531)
  * checks/fields:
    + [RA] Allow build-depend on quilt if clean depends on the xsfclean
      rule, for packages maintained by the X Strike Force.
    + [RA] CDBS packages that use the python-distutils class should list
      Python in Build-Depends, not Build-Depends-Indep, since CDBS wants
      to use it in debian/rules clean. Thanks, Jan Lübbe.
    + [HE] Add check for build-deps on build-essential. Yes, people do that.
    + [RA] Recognize direct invocations of quilt in clean rules and allow
      Build-Depends on quilt in that case. Reported by Sam Hocevar.
      (Closes: #374878)
    + [RA] Fix handling of versioned Build-Depends to avoid spurious
      build-depends-without-arch-dep warnings. Reported by Marcus
      Better.
    + [RA] Don't require Build-Depends on perl even if run explicitly in
      debian/rules clean, since perl-base may be sufficient. Catch more
      ways perl could be run, including the common idiom for packages that
      use Build.PL.
    + [RA] Downgrade build-depends-without-arch-dep to info from warning.
      Policy doesn't require using Build-Depends-Indep for
      arch-independent packages and the test has a lot of false positives.
    + [RA] Require ant in Build-Depends when using the CDBS ant rule.
    + [RA] Bypass the build-depends-without-arch-dep check entirely when
      using ant, since determining which Java dependencies are then
      permissible in Build-Depends is too complex to do a proper job.
      Reported by Peter Eisentraut. (Closes: #372190)
    + [RA] Only allow patch in Build-Depends for yada unpatch, don't
      require it, since yada depends on patch. (Closes: #375479)
  * checks/po-debconf:
    + [RA] Don't consider templates.in to be a stray translated template
      file. Thanks, Thomas Huriaux. (Closes: #367534)
  * lib/Util.pm:
    + [RA] Pass the --wildcards option to tar, now required by a change in
      the default tar semantics. (Closes: #375246)

e38f16e... by Reinhard Tartler on 2006-07-09

Import patches-unapplied version 1.23.22ubuntu1 to ubuntu/edgy

Imported using git-ubuntu import.

Changelog parent: e8e8b0a1eab4ab93a3ce2db14eaca8885581208f

New changelog entries:
  * Merge from debian unstable.
  * checks/debconf:
    + [JvW] Teach lintian to know about the 'error' debconf template
      question type. (Closes: #374399)
    + [RA] Exclude debconf templates with "for internal use" in the short
      description from style checks and document this in the log
      description of the tags most likely to trigger on internal
      templates. (Closes: #368206)
  * checks/common_data.pm:
    + [RA] Add amd64 to the standard architectures. (Closes: #367324)
  * checks/debhelper:
    + [RA] Use the Dep library to check debhelper build dependencies
      rather than parsing Build-Depends with regexes. This avoids false
      positives due to matching package names ending in debhelper.
      Reported by Fabio Tranchitella. (Closes: #366531)
  * checks/fields:
    + [RA] Allow build-depend on quilt if clean depends on the xsfclean
      rule, for packages maintained by the X Strike Force.
    + [RA] CDBS packages that use the python-distutils class should list
      Python in Build-Depends, not Build-Depends-Indep, since CDBS wants
      to use it in debian/rules clean. Thanks, Jan Lübbe.
    + [HE] Add check for build-deps on build-essential. Yes, people do that.
    + [RA] Recognize direct invocations of quilt in clean rules and allow
      Build-Depends on quilt in that case. Reported by Sam Hocevar.
      (Closes: #374878)
    + [RA] Fix handling of versioned Build-Depends to avoid spurious
      build-depends-without-arch-dep warnings. Reported by Marcus
      Better.
    + [RA] Don't require Build-Depends on perl even if run explicitly in
      debian/rules clean, since perl-base may be sufficient. Catch more
      ways perl could be run, including the common idiom for packages that
      use Build.PL.
    + [RA] Downgrade build-depends-without-arch-dep to info from warning.
      Policy doesn't require using Build-Depends-Indep for
      arch-independent packages and the test has a lot of false positives.
    + [RA] Require ant in Build-Depends when using the CDBS ant rule.
    + [RA] Bypass the build-depends-without-arch-dep check entirely when
      using ant, since determining which Java dependencies are then
      permissible in Build-Depends is too complex to do a proper job.
      Reported by Peter Eisentraut. (Closes: #372190)
    + [RA] Only allow patch in Build-Depends for yada unpatch, don't
      require it, since yada depends on patch. (Closes: #375479)
  * checks/po-debconf:
    + [RA] Don't consider templates.in to be a stray translated template
      file. Thanks, Thomas Huriaux. (Closes: #367534)
  * lib/Util.pm:
    + [RA] Pass the --wildcards option to tar, now required by a change in
      the default tar semantics. (Closes: #375246)

ba17318... by Reinhard Tartler on 2006-06-28

Import patches-applied version 1.23.21ubuntu1 to applied/ubuntu/edgy

Imported using git-ubuntu import.

Changelog parent: 464379319a18ae30019f7eaf0064bfb3bb8929a3
Unapplied parent: e8e8b0a1eab4ab93a3ce2db14eaca8885581208f

New changelog entries:
  * Merge from debian unstable.
  * add edgy to frontend
  * checks/menus:
    + [RA] Tell Perl where common_data.pm is since we're now including it.
      Doh. Thanks, Nelson A. de Oliveira. (Closes: #366481)
  The "Policy backlog clearing is a wonderful sight" release
  * checks/debconf{.desc,}:
    + [RA] Add checks for the Developer's Reference guidelines for debconf
      templates. Based on a patch by Thomas Huriaux. (Closes: #362145)
  * checks/fields{.desc,}:
    + [RA] xfonts-encodings is also not an xfont package. Thanks, Drew
      Parsons. (Closes: #365503)
    + [RA] Report errors for dependencies on python-minimal. Thanks to
      Steve Langasek for the analysis.
    + [RA] Allow a build-dependency on patchutils when using CDBS with one
      of the patch systems, as patchutils may be optionally used to check
      for bad patches. Thanks, Marc Dequènes (Duck). (Closes: #365466)
    + [RA] Since some packages should be in Build-Depends and some should
      be in Build-Depends-Indep, report all of the misplaced ones rather
      than just the first one. That way, users know which to move.
    + [RA] Allow perl in Build-Depends if invoked in clean rules.
    + [RA] Allow patch in Build-Depends if yada unpatch is invoked in
      clean rules.
  * checks/files{.desc,}:
    + [RA] Add an explicit check for non-world-readable executables to
      provide a more detailed explanation and tighten the accepted
      permissions of setuid and setgid executables to just the permissions
      mentioned in Policy 10.9. Add Policy 10.9 references to the
      descriptions. Reported by Piotr Engelking. (Closes: #365452)
    + [RA] Add a request to the descriptions of setuid and setgid tags to
      add a lintian override for documentation if the permissions are
      intentional.
    + [RA] Report a more specific tag for binaries that are owned by group
      games but are not setgid.
    + [RA] Remove the check for files in /usr/lib/cgi-bin. This policy
      change was reverted.
    + [RA] Allow files installed in /usr/include/X11 and /usr/lib/X11 but
      require Pre-Depends on x11-common (>= 1:7.0.0). Remove the
      duplicate check for files in /usr/bin/X11 since it no longer adds
      additional information.
  * checks/menus{.desc,}:
    + [RA] Check that all files referenced in doc-base control files are
      present in the package, based on a patch by Robert Luberda. Also
      check that Index references only one file and that Format names a
      known format. (Closes: #196122)
    + [RA] Fix incomplete diagnosis of missing calls to update-menus.
    + [RA] Change postrm to prerm in the check for a useless install-docs
      call; calling install-docs in postrm is always a warning and useless
      calls in prerm were not being diagnosed.
  * checks/po-debconf{.desc,}:
    + [RA] Exempt packages that use yada from the POTFILES.in check and
      from checking for up-to-date templates, since yada does this at
      build time. Reported by Piotr Roszatycki. (Closes: #321139)
    + [RA] Check for stray debconf-mergetemplate files in packages
      using po-debconf. Thanks, Martin Quinson. (Closes: #232442)
    + [RA] General cleanup of tag descriptions for grammar and markup.
      Move man page references into Ref fields.
  * checks/shared-libs.desc:
    + [RA] Document that exceptions to the -fPIC rule for shared libraries
      are possible and ask that such exceptions be documented with lintian
      overrides.
  * checks/standards-version:
    + [RA] Update to 3.7.2. (Closes: #366233)
    + [RA] Report the current standards version when warning about too old
      or too new versions. Thanks, Jari Aalto. (Closes: #366104)
  * debian/control:
    + [RA] Update standards version to 3.7.2 (no changes required).
    + [RA] Update description to note calibration for Policy 3.7.2.
  The "Policy 3.7.0" release
  * checks/fields{.desc,}:
    + [RA] python-all-dev also satisfies dh_python's requirements.
      Thanks, Marc Dequènes (Duck). (Closes: #364943)
    + [RA] Allow python in Build-Depends if it's invoked explicitly in the
      clean rule. Thanks, Marc Dequènes (Duck). (Closes: #365030)
    + [RA] Recognize the CDBS included rule files that indicate dpatch or
      quilt will be used, check those dependencies, and require that they
      be in Build-Depends since they're used for clean. Thanks, Marc
      Dequènes (Duck). (Closes: #365041)
  * checks/files{.desc,}:
    + [RA] Add the references to Policy for the deprecation of X11R6
      directories now that Policy has been updated in 3.7.0.0.
    + [RA] Policy now mandates FHS 2.3. Update tag descriptions.
    + [RA] Warn about files installed in /usr/lib/cgi-bin. Policy now
      states they should be installed in /usr/lib/cgi-lib.
    + [RA] Warn about scripts installed on the user's PATH with names that
      include language extensions (.sh, .pl, .py), per Policy 10.4.
    + [RA] Report directories under /usr/share/man that don't match the
      directory layout specified in the FHS. (Closes: #176683)
    + [RA] Fix a very long-standing bug that caused the check for
      executable manpages to be silently skipped.
  * checks/scripts:
    + [RA] Debian etch release policy explicitly forbids scripts without
      #! magic and they rely on being run from a shell. Revert the change
      that permitted the Perl magic without a #! line. Thanks to Piotr
      Engelking and Steve Langasek for pointing this out.
    + [RA] Don't syntax-check *.dpatch scripts in /usr/src. bash -n
      doesn't stop at exit 0 and then may choke on the patch. Thanks,
      Matthias Klose. (Closes: #364521)
  * checks/scripts.desc:
    + [RA] Using invoke-rc.d is now required by Policy.
  * checks/standards-version:
    + [RA] Update to 3.7.0.
  * debian/control:
    + [RA] Update standards version to 3.7.0 (no changes required).
    + [RA] Update description to note calibration for Policy 3.7.0.
  The "brown paper Python" release
  * checks/fields{.desc,}:
    + [RA] Redo handling of build dependencies to allow a custom tag to be
      specified and to allow a general dependency string to be required
      rather than a simple package name. As a result, dh_python handling
      is no longer a buggy special case. Allow either python or
      python-dev for dh_python and the cdbs Python rules. Thanks, Torsten
      Merek and Aaron M. Ucko. (Closes: #364297, #364330)
    + [RA] Require at least quilt 0.40 if /usr/share/quilt/quilt.make is
      included. Thanks, Michele Baldessari.
    + [RA] Packages using dh_installxfonts must build-depend on 5.0.31 or
      later of debhelper for the X.Org 7 transition.
  The "happy Nanaimo hacking" release
  * checks/binaries:
    + [RA] Detect klibc binaries from their requested interpreter and
      allow them to appear static. (Closes: #328850)
  * checks/common_data.pm:
    + [RA] Include all combinations of cpu and os from the dpkg cputable
      and ostable files (as of dpkg 1.13.16). (Closes: #337034, #357433)
    + [RA] Include a list of known X metapackages.
  * checks/control-file{.desc,}:
    + [RA] Warn if debian/control in a source package is a symlink.
  * checks/copyright-file{.desc,}:
    + [RA] Don't assume mentions of GPL or GNU General Public License
      after what look like mail headers are referring to the license of
      the package. Be a bit more specific in the old FSF address check
      to avoid false positives on other Cambridge, MA addresses. Reported
      by Adam C. Powell IV. (Closes: #205934)
  * checks/debconf:
    + [RA] Allow Indices as a template field. cdebconf uses it and
      debconf ignores it. Reported by Frans Pop. (Closes: #361986)
  * checks/debdiff{.desc,}:
    + [RA] Warn if the diff contains debian/substvars. Based on a patch
      by Michael Ablassmeier. (Closes: #359646)
  * checks/debhelper.desc:
    + [RA] When explaining the warning about deprecated debhelper
      compatibility versions, mention that debhelper defaults to version 1
      if not set anywhere. (Closes: #360711)
    + [RA] Move simple man page references from Info into Ref.
  * checks/fields{.desc,}:
    + [RA] Allow dpatch in Build-Depends for arch-independent packages if
      it is invoked in clean, build-arch, or binary-arch.
    + [RA] Only list examples of non-standard architectures, since there
      are now too many combinations to list completely.
    + [RA] Catch dependencies on X metapackages, based on a patch by Josh
      Triplett. No packages are allowed to build-depend, and only
      packages that look like metapackages (arch: all, no files outside of
      /usr/share/doc) are allowed to depend. (Closes: #347169)
    + [RA] Look for an explicit section of unknown, probably left over
      from dh_make templates, and diagnose it with an error rather than a
      warning. Reported by Jari Aalto. (Closes: #355032)
    + [RA] Reorganize dependency checking based on debian/rules analysis.
      Diagnose missing build dependencies on the helper packages we know
      about, catch cases where Build-Depends-Indep should be Build-Depends
      because of the clean target, and make sure users of dh_python
      build-depend on python. yada is no longer a special case.
      (Closes: #242789, #278290)
    + [RA] Check for conflicting with dependencies and build-conflicting
      with build dependencies. (Closes: #122760)
    + [RA] Allow xfonts-utils in dependencies. It's not actually an X
      font package.
  * checks/files{.desc,}:
    + [RA] For the X.Org 7 transition, add explicit checks for fonts and
      binaries installed in /usr/X11R6. Rename the existing check for
      other files in /usr/X11R6 since the tag had a pluralization error
      and we want package maintainers to see the error again and
      reconsider whether to ignore it. No packages should be installing
      files in /usr/X11R6 going forward. Remove the policy cross-refs for
      right now until policy catches up.
  * checks/manpages:
    + [RA] Use system_env instead of system and sanitize the environment
      before running man -l out of caution and to avoid extraneous output
      when CDPATH is set. Reported by Marc Haber. (Closes: #360217)
  * checks/nmu{.desc,}:
    + [RA] Warn if debian/changelog in a native source package is a
      symlink and skip checks rather than aborting if it was a symlink to
      a file we didn't unpack. (Closes: #257650)
  * checks/po-debconf:
    + [RA] Use system_env instead of system out of caution and to avoid
      extraneous output when CDPATH is set.
  * checks/rules{.desc,}:
    + [RA] A new set of checks that parses debian/rules and checks for
      required rules, debian/rules as a symlink, and the correct first
      line. Based heavily on previous work by René van Bevern.
      (Closes: #294926, #311786)
  * checks/scripts{.desc,}:
    + [RA] Ignore text inside single quotes and, for most checks, text
      inside double quotes when checking for bashisms. Reported by Frank
      Küster. (Closes: #344266)
    + [RA] Change canonical zsh path to /bin/zsh at the request of the zsh
      maintainer. (Closes: #360534)
    + [RA] Change the check for broken error handling with invoke-rc.d to
      maintainer-script-hides-init-failure to be more generic and explain
      what the test looks at. Add the script name and line number and fix
      a typo. Thanks, Marc Haber. (Closes: #360214, #360216)
    + [RA] Warn when maintainer scripts run init scripts directly and
      don't use invoke-rc.d. Thanks, Lars Wirzenius. (Closes: #353659)
    + [RA] Find missing ucf dependencies and restructure the code to allow
      easier addition of similar checks. (Closes: #261891)
    + [RA] Add python2.5, lua50, gbx, and gbx2 to the list of valid
      interpreters. (Closes: #361601, #361644, #362566)
  * checks/shared-libs:
    + [RA] Limit shlib-without-PT_GNU_STACK-section to only those
      architectures where gcc always adds the section. Thanks to Frans
      Pop for the report and Bastian Blank for the architecture list.
      (Closes: #357636)
  * collection/objdump-info:
    + [RA] Unset CDPATH before running cd to avoid strange effects from
      the user's environment.
    + [RA] Run readelf -l to collect interpreter information.
  * lib/Dep.pm:
    + [RA] Add initial support for analyzing architecture information in
      dependencies instead of ignoring it.
  * lib/Read_taginfo.pm:
    + [RA] Add support for formatting man page references from Ref.
  * lib/Util.pm:
    + [RA] Add system_env, like system but sanitizing the environment.
  * man/lintian.1:
    + [RA] Mention the new rules check class.

e8e8b0a... by Reinhard Tartler on 2006-06-28

Import patches-unapplied version 1.23.21ubuntu1 to ubuntu/edgy

Imported using git-ubuntu import.

Changelog parent: a9ec9c456808b468e8798d57a4707cef5e23bea4

New changelog entries:
  * Merge from debian unstable.
  * add edgy to frontend
  * checks/menus:
    + [RA] Tell Perl where common_data.pm is since we're now including it.
      Doh. Thanks, Nelson A. de Oliveira. (Closes: #366481)
  The "Policy backlog clearing is a wonderful sight" release
  * checks/debconf{.desc,}:
    + [RA] Add checks for the Developer's Reference guidelines for debconf
      templates. Based on a patch by Thomas Huriaux. (Closes: #362145)
  * checks/fields{.desc,}:
    + [RA] xfonts-encodings is also not an xfont package. Thanks, Drew
      Parsons. (Closes: #365503)
    + [RA] Report errors for dependencies on python-minimal. Thanks to
      Steve Langasek for the analysis.
    + [RA] Allow a build-dependency on patchutils when using CDBS with one
      of the patch systems, as patchutils may be optionally used to check
      for bad patches. Thanks, Marc Dequènes (Duck). (Closes: #365466)
    + [RA] Since some packages should be in Build-Depends and some should
      be in Build-Depends-Indep, report all of the misplaced ones rather
      than just the first one. That way, users know which to move.
    + [RA] Allow perl in Build-Depends if invoked in clean rules.
    + [RA] Allow patch in Build-Depends if yada unpatch is invoked in
      clean rules.
  * checks/files{.desc,}:
    + [RA] Add an explicit check for non-world-readable executables to
      provide a more detailed explanation and tighten the accepted
      permissions of setuid and setgid executables to just the permissions
      mentioned in Policy 10.9. Add Policy 10.9 references to the
      descriptions. Reported by Piotr Engelking. (Closes: #365452)
    + [RA] Add a request to the descriptions of setuid and setgid tags to
      add a lintian override for documentation if the permissions are
      intentional.
    + [RA] Report a more specific tag for binaries that are owned by group
      games but are not setgid.
    + [RA] Remove the check for files in /usr/lib/cgi-bin. This policy
      change was reverted.
    + [RA] Allow files installed in /usr/include/X11 and /usr/lib/X11 but
      require Pre-Depends on x11-common (>= 1:7.0.0). Remove the
      duplicate check for files in /usr/bin/X11 since it no longer adds
      additional information.
  * checks/menus{.desc,}:
    + [RA] Check that all files referenced in doc-base control files are
      present in the package, based on a patch by Robert Luberda. Also
      check that Index references only one file and that Format names a
      known format. (Closes: #196122)
    + [RA] Fix incomplete diagnosis of missing calls to update-menus.
    + [RA] Change postrm to prerm in the check for a useless install-docs
      call; calling install-docs in postrm is always a warning and useless
      calls in prerm were not being diagnosed.
  * checks/po-debconf{.desc,}:
    + [RA] Exempt packages that use yada from the POTFILES.in check and
      from checking for up-to-date templates, since yada does this at
      build time. Reported by Piotr Roszatycki. (Closes: #321139)
    + [RA] Check for stray debconf-mergetemplate files in packages
      using po-debconf. Thanks, Martin Quinson. (Closes: #232442)
    + [RA] General cleanup of tag descriptions for grammar and markup.
      Move man page references into Ref fields.
  * checks/shared-libs.desc:
    + [RA] Document that exceptions to the -fPIC rule for shared libraries
      are possible and ask that such exceptions be documented with lintian
      overrides.
  * checks/standards-version:
    + [RA] Update to 3.7.2. (Closes: #366233)
    + [RA] Report the current standards version when warning about too old
      or too new versions. Thanks, Jari Aalto. (Closes: #366104)
  * debian/control:
    + [RA] Update standards version to 3.7.2 (no changes required).
    + [RA] Update description to note calibration for Policy 3.7.2.
  The "Policy 3.7.0" release
  * checks/fields{.desc,}:
    + [RA] python-all-dev also satisfies dh_python's requirements.
      Thanks, Marc Dequènes (Duck). (Closes: #364943)
    + [RA] Allow python in Build-Depends if it's invoked explicitly in the
      clean rule. Thanks, Marc Dequènes (Duck). (Closes: #365030)
    + [RA] Recognize the CDBS included rule files that indicate dpatch or
      quilt will be used, check those dependencies, and require that they
      be in Build-Depends since they're used for clean. Thanks, Marc
      Dequènes (Duck). (Closes: #365041)
  * checks/files{.desc,}:
    + [RA] Add the references to Policy for the deprecation of X11R6
      directories now that Policy has been updated in 3.7.0.0.
    + [RA] Policy now mandates FHS 2.3. Update tag descriptions.
    + [RA] Warn about files installed in /usr/lib/cgi-bin. Policy now
      states they should be installed in /usr/lib/cgi-lib.
    + [RA] Warn about scripts installed on the user's PATH with names that
      include language extensions (.sh, .pl, .py), per Policy 10.4.
    + [RA] Report directories under /usr/share/man that don't match the
      directory layout specified in the FHS. (Closes: #176683)
    + [RA] Fix a very long-standing bug that caused the check for
      executable manpages to be silently skipped.
  * checks/scripts:
    + [RA] Debian etch release policy explicitly forbids scripts without
      #! magic and they rely on being run from a shell. Revert the change
      that permitted the Perl magic without a #! line. Thanks to Piotr
      Engelking and Steve Langasek for pointing this out.
    + [RA] Don't syntax-check *.dpatch scripts in /usr/src. bash -n
      doesn't stop at exit 0 and then may choke on the patch. Thanks,
      Matthias Klose. (Closes: #364521)
  * checks/scripts.desc:
    + [RA] Using invoke-rc.d is now required by Policy.
  * checks/standards-version:
    + [RA] Update to 3.7.0.
  * debian/control:
    + [RA] Update standards version to 3.7.0 (no changes required).
    + [RA] Update description to note calibration for Policy 3.7.0.
  The "brown paper Python" release
  * checks/fields{.desc,}:
    + [RA] Redo handling of build dependencies to allow a custom tag to be
      specified and to allow a general dependency string to be required
      rather than a simple package name. As a result, dh_python handling
      is no longer a buggy special case. Allow either python or
      python-dev for dh_python and the cdbs Python rules. Thanks, Torsten
      Merek and Aaron M. Ucko. (Closes: #364297, #364330)
    + [RA] Require at least quilt 0.40 if /usr/share/quilt/quilt.make is
      included. Thanks, Michele Baldessari.
    + [RA] Packages using dh_installxfonts must build-depend on 5.0.31 or
      later of debhelper for the X.Org 7 transition.
  The "happy Nanaimo hacking" release
  * checks/binaries:
    + [RA] Detect klibc binaries from their requested interpreter and
      allow them to appear static. (Closes: #328850)
  * checks/common_data.pm:
    + [RA] Include all combinations of cpu and os from the dpkg cputable
      and ostable files (as of dpkg 1.13.16). (Closes: #337034, #357433)
    + [RA] Include a list of known X metapackages.
  * checks/control-file{.desc,}:
    + [RA] Warn if debian/control in a source package is a symlink.
  * checks/copyright-file{.desc,}:
    + [RA] Don't assume mentions of GPL or GNU General Public License
      after what look like mail headers are referring to the license of
      the package. Be a bit more specific in the old FSF address check
      to avoid false positives on other Cambridge, MA addresses. Reported
      by Adam C. Powell IV. (Closes: #205934)
  * checks/debconf:
    + [RA] Allow Indices as a template field. cdebconf uses it and
      debconf ignores it. Reported by Frans Pop. (Closes: #361986)
  * checks/debdiff{.desc,}:
    + [RA] Warn if the diff contains debian/substvars. Based on a patch
      by Michael Ablassmeier. (Closes: #359646)
  * checks/debhelper.desc:
    + [RA] When explaining the warning about deprecated debhelper
      compatibility versions, mention that debhelper defaults to version 1
      if not set anywhere. (Closes: #360711)
    + [RA] Move simple man page references from Info into Ref.
  * checks/fields{.desc,}:
    + [RA] Allow dpatch in Build-Depends for arch-independent packages if
      it is invoked in clean, build-arch, or binary-arch.
    + [RA] Only list examples of non-standard architectures, since there
      are now too many combinations to list completely.
    + [RA] Catch dependencies on X metapackages, based on a patch by Josh
      Triplett. No packages are allowed to build-depend, and only
      packages that look like metapackages (arch: all, no files outside of
      /usr/share/doc) are allowed to depend. (Closes: #347169)
    + [RA] Look for an explicit section of unknown, probably left over
      from dh_make templates, and diagnose it with an error rather than a
      warning. Reported by Jari Aalto. (Closes: #355032)
    + [RA] Reorganize dependency checking based on debian/rules analysis.
      Diagnose missing build dependencies on the helper packages we know
      about, catch cases where Build-Depends-Indep should be Build-Depends
      because of the clean target, and make sure users of dh_python
      build-depend on python. yada is no longer a special case.
      (Closes: #242789, #278290)
    + [RA] Check for conflicting with dependencies and build-conflicting
      with build dependencies. (Closes: #122760)
    + [RA] Allow xfonts-utils in dependencies. It's not actually an X
      font package.
  * checks/files{.desc,}:
    + [RA] For the X.Org 7 transition, add explicit checks for fonts and
      binaries installed in /usr/X11R6. Rename the existing check for
      other files in /usr/X11R6 since the tag had a pluralization error
      and we want package maintainers to see the error again and
      reconsider whether to ignore it. No packages should be installing
      files in /usr/X11R6 going forward. Remove the policy cross-refs for
      right now until policy catches up.
  * checks/manpages:
    + [RA] Use system_env instead of system and sanitize the environment
      before running man -l out of caution and to avoid extraneous output
      when CDPATH is set. Reported by Marc Haber. (Closes: #360217)
  * checks/nmu{.desc,}:
    + [RA] Warn if debian/changelog in a native source package is a
      symlink and skip checks rather than aborting if it was a symlink to
      a file we didn't unpack. (Closes: #257650)
  * checks/po-debconf:
    + [RA] Use system_env instead of system out of caution and to avoid
      extraneous output when CDPATH is set.
  * checks/rules{.desc,}:
    + [RA] A new set of checks that parses debian/rules and checks for
      required rules, debian/rules as a symlink, and the correct first
      line. Based heavily on previous work by René van Bevern.
      (Closes: #294926, #311786)
  * checks/scripts{.desc,}:
    + [RA] Ignore text inside single quotes and, for most checks, text
      inside double quotes when checking for bashisms. Reported by Frank
      Küster. (Closes: #344266)
    + [RA] Change canonical zsh path to /bin/zsh at the request of the zsh
      maintainer. (Closes: #360534)
    + [RA] Change the check for broken error handling with invoke-rc.d to
      maintainer-script-hides-init-failure to be more generic and explain
      what the test looks at. Add the script name and line number and fix
      a typo. Thanks, Marc Haber. (Closes: #360214, #360216)
    + [RA] Warn when maintainer scripts run init scripts directly and
      don't use invoke-rc.d. Thanks, Lars Wirzenius. (Closes: #353659)
    + [RA] Find missing ucf dependencies and restructure the code to allow
      easier addition of similar checks. (Closes: #261891)
    + [RA] Add python2.5, lua50, gbx, and gbx2 to the list of valid
      interpreters. (Closes: #361601, #361644, #362566)
  * checks/shared-libs:
    + [RA] Limit shlib-without-PT_GNU_STACK-section to only those
      architectures where gcc always adds the section. Thanks to Frans
      Pop for the report and Bastian Blank for the architecture list.
      (Closes: #357636)
  * collection/objdump-info:
    + [RA] Unset CDPATH before running cd to avoid strange effects from
      the user's environment.
    + [RA] Run readelf -l to collect interpreter information.
  * lib/Dep.pm:
    + [RA] Add initial support for analyzing architecture information in
      dependencies instead of ignoring it.
  * lib/Read_taginfo.pm:
    + [RA] Add support for formatting man page references from Ref.
  * lib/Util.pm:
    + [RA] Add system_env, like system but sanitizing the environment.
  * man/lintian.1:
    + [RA] Mention the new rules check class.

4643793... by Matthias Klose on 2006-04-12

Import patches-applied version 1.23.16ubuntu2 to applied/ubuntu/dapper

Imported using git-ubuntu import.

Changelog parent: f36ac11862ef791be63dfd4cc0afdf752fffa987
Unapplied parent: a9ec9c456808b468e8798d57a4707cef5e23bea4

New changelog entries:
  * Depend on the dpkg version, having the -q option for dpkg-source.

a9ec9c4... by Matthias Klose on 2006-04-12

Import patches-unapplied version 1.23.16ubuntu2 to ubuntu/dapper

Imported using git-ubuntu import.

Changelog parent: b92ef277e2944cffebbf01775e967c09ac6455ea

New changelog entries:
  * Depend on the dpkg version, having the -q option for dpkg-source.

f36ac11... by Matthias Klose on 2006-04-09

Import patches-applied version 1.23.16ubuntu1 to applied/ubuntu/dapper

Imported using git-ubuntu import.

Changelog parent: c09d92e3745df74a19fc7aa76310df55dc61dea1
Unapplied parent: b92ef277e2944cffebbf01775e967c09ac6455ea

New changelog entries:
  * Synchronize with Debian unstable.
  * Add python2.5 to the list of known interpreters.
  The "What's this Russ guy up to?" release
  * checks/binaries{.desc,}:
    + [RA] Add a check for the new "Invalid operation" error from
      objdump -T. Skip shared-lib-without-dependency-information for
      files in /usr/lib/debug.
  * checks/changelog-file:
    + [FL] Add line number to output of wrong-bug-number-in-closes.
      Inspired by #349761 from Steinar H. Gunderson.
  * checks/common_data.pm:
    + [FL] Add armeb to %non_standard_archs as requested by
      Martin Michlmayr. (Closes: #350653)
  * checks/debconf:
    + [RA] Packages that depend on dbconfig-common are allowed to have
      config scripts without templates or an explicit debconf dependency.
      Reported by Marcus Better. (Closes: #344421)
  * checks/debconf.desc:
    + [RA] Clarify the necessary dependencies for packages using SETTITLE.
      (Closes: #349616)
  * checks/debhelper:
    + [RA] Recognize setting DH_COMPAT with := in addition to = in
      debian/rules. (Closes: #349272)
    + [RA] CDBS sets DH_COMPAT to 4 but doesn't export it. It does create
      debian/compat with that value if none was present. Reflect this
      behavior to avoid spurious compat level warnings when using CDBS.
      Based on a patch by Jay Berkenbilt. (Closes: #350228)
  * checks/fields:
    + [RA] Allow a quilt build-dependency for arch-independent packages if
      the quilt makefile rules are included. (Closes: #349273)
    + [RA] If clean depends on a rule that calls dh_clean rather than
      calling it directly, still allow debhelper in Build-Depends for
      arch-independent packages. Reported by Michael Stilkerich.
    + [JvW] Commented that Uploaders no longer will hit the multiline field
      issue, updated testsuite accordingly
  * checks/manpages:
    + [FL] Ignore more warnings ("cannot adjust line", "can't break
      line") in non-English manpages. (Closes: #349792)
    + [RA] cd into the parent directory before checking man pages with man
      so that .so inclusions are processed correctly. Based on a patch by
      Nicolas François. (Closes: #349614)
  * checks/menu-format:
    + [RA] Look for binaries in /usr/X11R6/bin, not /usr/bin/X11, per
      Policy 11.8.7. Thanks, Matej Vela. (Closes: #354890)
  * checks/menu-format.desc:
    + [RA] Use "menu manual" rather than "menu" for references to more
      clearly distinguish from the Debian Menu Policy. (Closes: #347510)
  * checks/po-debconf:
    + [RA] If there are template files in debian, assume the package uses
      debconf; don't require a dependency or config script. Patch by
      Thomas Huriaux. (Closes: #353294)
  * checks/scripts:
    + [RA] Allow /tmp in variable settings. It's likely to be a false
      positive. Reported by Frank Küster. (Closes: #344998)
    + [RA] Make the syntax checking of shell scripts more robust against
      filenames containing shell metacharacters. Reported by Michael
      Stilkerich.
    + [RA] Add fish and expectk to the list of valid interpreters.
      (Closes: #351624, #353770)
    + [RA] /usr/bin/tcl is provided by tclx8.3, not tcl. Reported by
      James R. Van Zandt. (Closes: #351324)
    + [RA] Allow more variations on leading magic to invoke some
      interpreter rather than then shell. Bypass the ELF magic check for
      scripts using magic that relies on having no leading #! line.
      Reported by Frank Küster. (Closes: #344269)
    + [JvW] Add check against package suffering from debhelper bug #337664,
      per Joey Hess, which had broken error detection (Closes: #358523)
  * checks/shared-libs:
    + [JvW] Fix postinst-must-call-ldconfig to also get emitted when there is
      no postinst at all, instead of just one lacking a ldconfig call
    + [JvW] Implement checks for "udeb:" lines in shlibs files
      (Closes: #357541)
    + [JvW] Consider also the soname version for shlibs checking, preventing
      some bogus 'duplicate' warnings, and actually throw a warning when
      soname version doesn't match
    + [JvW] Added error when udeb postinst calls ldconfig, that must never
      happen (thanks to Frans Pop for noticing, see #203056)
  * debian/{control,copyright}:
    + [RA] Add Russ Allbery to Uploaders and copyright.
    + [JvW] Version dpkg-dev requirement to >= 1.13.17, for
      unpack/unpack-srcpkg-l2
  * frontends/lintian-info:
    + [RA] Avoid Perl uninitialized value warnings when given output that
      looks like lintian messages without tags. (Closes: #352606)
  * collection/objdump-info:
    + [RA] Pass "Invalid operation" errors from objdump -T on to the check
      scripts instead of failing. (Closes: #249435)
  * man/lintian.1:
    + [RA] Add references to dh_make, debhelper, dpkg-buildpackage, and
      linda in new reference sections. (Closes: #322288)
  * man/{lintian.1,lintian-info.1}:
    + [RA] Left-justify and disable hyphenation for readability.
  * unpack/unpack-srcpkg-l2:
    + [JvW] Use -q with dpkg-source to surpress warnings about unsigned source
      packages. Requires dpkg-dev 1.13.17

  * The "www.no-name-yet.eu" release

  * debian/changelog:
    + [FL] Fix wrapping of last changelog entry (Closes: #344899)
  * checks/common_data.pm:
    + [FL] Add xlibs-dev and debmake to %known_obsolete_packages
  * checks/debconf:
    + [CW] Show template name for empty-translated-choices,
      mismatch-translated-choices, and unknown-field-in-templates.
  * checks/debhelper:
    + [FL] Also check for debhelper build-dependency in debhelper-using
      cdbs based packages
    + [FL] Indicate where we found which compat version in
      declares-possibly-conflicting-debhelper-compat-versions
      (Closes: #329953)
    + [FL] Add dh_installtexfonts to list of commands that modfiy
      the maintainer scripts
    + [FL] Try a little harder to find the DH_COMPAT setting in debian/rules
      (Closes: #348380)
  * checks/fields:
    + [FL] Allow version numbers of 0 by correctly checking the output
      of _valid_version for definedness and not the boolean value
      (Closes: #345005)
    + [FL] Better check for false postives of build-depends-without-arch-dep.
      Should fix false positives for cdbs, dbs, dpatch and yada. Based on
      a patch by Russ Allbery (Closes: #344609, #321135, #339750)
    + [FL] Also check for build-dependencies on obsolete packages not
      only dependencies (Closes: #234531)
  * checks/fields.desc:
    + [JvW] Fix typo in description
  * checks/init.d:
    + [FL] Only try to validate update-rc.d calls where the name of the
      script matches [\w.-]+. That accounts for all today known init
      scripts and eliminates false positives like shell variables in the
      name (Closes: #343865)
  * checks/manpages:
    + [FL] Fix stupid mistake in regex to strip of filenames from roff
      output (which was hidden by another stupid mistake in the test
      suite). Patch by Nicolas François (Closes: #347999)
  * checks/scripts:
    + [FL] Make mknod-in-maintainer-script an error since this is now
      a must in policy. Pointed out by Bartosz Fenski (Closes: #344928)
    + [FL] dpkg --print-installation-architecture is deprecated
      so delete dpkg-print-architecture-in-maintainer-script
    + [FL] Add parrot to list of valid interpreters (Closes: #346335)

b92ef27... by Matthias Klose on 2006-04-09

Import patches-unapplied version 1.23.16ubuntu1 to ubuntu/dapper

Imported using git-ubuntu import.

Changelog parent: 293d58f3276cea559f882755ebfd3a6756d5f138

New changelog entries:
  * Synchronize with Debian unstable.
  * Add python2.5 to the list of known interpreters.
  The "What's this Russ guy up to?" release
  * checks/binaries{.desc,}:
    + [RA] Add a check for the new "Invalid operation" error from
      objdump -T. Skip shared-lib-without-dependency-information for
      files in /usr/lib/debug.
  * checks/changelog-file:
    + [FL] Add line number to output of wrong-bug-number-in-closes.
      Inspired by #349761 from Steinar H. Gunderson.
  * checks/common_data.pm:
    + [FL] Add armeb to %non_standard_archs as requested by
      Martin Michlmayr. (Closes: #350653)
  * checks/debconf:
    + [RA] Packages that depend on dbconfig-common are allowed to have
      config scripts without templates or an explicit debconf dependency.
      Reported by Marcus Better. (Closes: #344421)
  * checks/debconf.desc:
    + [RA] Clarify the necessary dependencies for packages using SETTITLE.
      (Closes: #349616)
  * checks/debhelper:
    + [RA] Recognize setting DH_COMPAT with := in addition to = in
      debian/rules. (Closes: #349272)
    + [RA] CDBS sets DH_COMPAT to 4 but doesn't export it. It does create
      debian/compat with that value if none was present. Reflect this
      behavior to avoid spurious compat level warnings when using CDBS.
      Based on a patch by Jay Berkenbilt. (Closes: #350228)
  * checks/fields:
    + [RA] Allow a quilt build-dependency for arch-independent packages if
      the quilt makefile rules are included. (Closes: #349273)
    + [RA] If clean depends on a rule that calls dh_clean rather than
      calling it directly, still allow debhelper in Build-Depends for
      arch-independent packages. Reported by Michael Stilkerich.
    + [JvW] Commented that Uploaders no longer will hit the multiline field
      issue, updated testsuite accordingly
  * checks/manpages:
    + [FL] Ignore more warnings ("cannot adjust line", "can't break
      line") in non-English manpages. (Closes: #349792)
    + [RA] cd into the parent directory before checking man pages with man
      so that .so inclusions are processed correctly. Based on a patch by
      Nicolas François. (Closes: #349614)
  * checks/menu-format:
    + [RA] Look for binaries in /usr/X11R6/bin, not /usr/bin/X11, per
      Policy 11.8.7. Thanks, Matej Vela. (Closes: #354890)
  * checks/menu-format.desc:
    + [RA] Use "menu manual" rather than "menu" for references to more
      clearly distinguish from the Debian Menu Policy. (Closes: #347510)
  * checks/po-debconf:
    + [RA] If there are template files in debian, assume the package uses
      debconf; don't require a dependency or config script. Patch by
      Thomas Huriaux. (Closes: #353294)
  * checks/scripts:
    + [RA] Allow /tmp in variable settings. It's likely to be a false
      positive. Reported by Frank Küster. (Closes: #344998)
    + [RA] Make the syntax checking of shell scripts more robust against
      filenames containing shell metacharacters. Reported by Michael
      Stilkerich.
    + [RA] Add fish and expectk to the list of valid interpreters.
      (Closes: #351624, #353770)
    + [RA] /usr/bin/tcl is provided by tclx8.3, not tcl. Reported by
      James R. Van Zandt. (Closes: #351324)
    + [RA] Allow more variations on leading magic to invoke some
      interpreter rather than then shell. Bypass the ELF magic check for
      scripts using magic that relies on having no leading #! line.
      Reported by Frank Küster. (Closes: #344269)
    + [JvW] Add check against package suffering from debhelper bug #337664,
      per Joey Hess, which had broken error detection (Closes: #358523)
  * checks/shared-libs:
    + [JvW] Fix postinst-must-call-ldconfig to also get emitted when there is
      no postinst at all, instead of just one lacking a ldconfig call
    + [JvW] Implement checks for "udeb:" lines in shlibs files
      (Closes: #357541)
    + [JvW] Consider also the soname version for shlibs checking, preventing
      some bogus 'duplicate' warnings, and actually throw a warning when
      soname version doesn't match
    + [JvW] Added error when udeb postinst calls ldconfig, that must never
      happen (thanks to Frans Pop for noticing, see #203056)
  * debian/{control,copyright}:
    + [RA] Add Russ Allbery to Uploaders and copyright.
    + [JvW] Version dpkg-dev requirement to >= 1.13.17, for
      unpack/unpack-srcpkg-l2
  * frontends/lintian-info:
    + [RA] Avoid Perl uninitialized value warnings when given output that
      looks like lintian messages without tags. (Closes: #352606)
  * collection/objdump-info:
    + [RA] Pass "Invalid operation" errors from objdump -T on to the check
      scripts instead of failing. (Closes: #249435)
  * man/lintian.1:
    + [RA] Add references to dh_make, debhelper, dpkg-buildpackage, and
      linda in new reference sections. (Closes: #322288)
  * man/{lintian.1,lintian-info.1}:
    + [RA] Left-justify and disable hyphenation for readability.
  * unpack/unpack-srcpkg-l2:
    + [JvW] Use -q with dpkg-source to surpress warnings about unsigned source
      packages. Requires dpkg-dev 1.13.17

  * The "www.no-name-yet.eu" release

  * debian/changelog:
    + [FL] Fix wrapping of last changelog entry (Closes: #344899)
  * checks/common_data.pm:
    + [FL] Add xlibs-dev and debmake to %known_obsolete_packages
  * checks/debconf:
    + [CW] Show template name for empty-translated-choices,
      mismatch-translated-choices, and unknown-field-in-templates.
  * checks/debhelper:
    + [FL] Also check for debhelper build-dependency in debhelper-using
      cdbs based packages
    + [FL] Indicate where we found which compat version in
      declares-possibly-conflicting-debhelper-compat-versions
      (Closes: #329953)
    + [FL] Add dh_installtexfonts to list of commands that modfiy
      the maintainer scripts
    + [FL] Try a little harder to find the DH_COMPAT setting in debian/rules
      (Closes: #348380)
  * checks/fields:
    + [FL] Allow version numbers of 0 by correctly checking the output
      of _valid_version for definedness and not the boolean value
      (Closes: #345005)
    + [FL] Better check for false postives of build-depends-without-arch-dep.
      Should fix false positives for cdbs, dbs, dpatch and yada. Based on
      a patch by Russ Allbery (Closes: #344609, #321135, #339750)
    + [FL] Also check for build-dependencies on obsolete packages not
      only dependencies (Closes: #234531)
  * checks/fields.desc:
    + [JvW] Fix typo in description
  * checks/init.d:
    + [FL] Only try to validate update-rc.d calls where the name of the
      script matches [\w.-]+. That accounts for all today known init
      scripts and eliminates false positives like shell variables in the
      name (Closes: #343865)
  * checks/manpages:
    + [FL] Fix stupid mistake in regex to strip of filenames from roff
      output (which was hidden by another stupid mistake in the test
      suite). Patch by Nicolas François (Closes: #347999)
  * checks/scripts:
    + [FL] Make mknod-in-maintainer-script an error since this is now
      a must in policy. Pointed out by Bartosz Fenski (Closes: #344928)
    + [FL] dpkg --print-installation-architecture is deprecated
      so delete dpkg-print-architecture-in-maintainer-script
    + [FL] Add parrot to list of valid interpreters (Closes: #346335)

c09d92e... by Michael Vogt on 2005-12-28

Import patches-applied version 1.23.14ubuntu1 to applied/ubuntu/dapper

Imported using git-ubuntu import.

Changelog parent: d8db5fb90b41094e27fce7b5c58b6c03bdf5e98d
Unapplied parent: 293d58f3276cea559f882755ebfd3a6756d5f138

New changelog entries:
  * Resynchronise with Debian.

  * The "fix those frontend regressions" release
  * frontend/lintian:
    + [FL] Fix exit status computing so that we exit with 1 again
      if we found any error. (Closes: #329458)
    + [FL] Re-enable reporting unused overrides.

  * lib/Tags.pm:
    + [FL] Some fixes to the statistics code to make the fixes
      in frontend/lintian possible

  * checks/binaries{.desc,}:
    + [FL] support c2a suffix in soname check, too (Closes: #340856)
    + [FL] fix typo in description of package-name-doesnt-match-sonames (Closes: #339360)
    + [FL] The Debian specific patches from coreutils to call strip with --remove-section
      arguments on install -s have been dropped. Adapt description of binary-has-unneeded-section
      accordingly and demote it to "info" because many packages will get this now.
  * checks/debconf{.desc,}:
    + [FL] drop seen-flag-requires-versioned-depends and multiselect-without-dependency and
      drop version requirement from missing-debconf-dependency-for-preinst. All due to the
      fact that woody shipped with 1.0.x and therefor versioned depends on versions lesser than
      that don't make much sense anymore (Closes: #333736)
  * checks/debhelper:
    + [FL] debhelper compat level 3 is deprecated as well now (Closes: #340222)
  * checks/files:
    + [FL] forgot /lib(32|64) (more #328612 fixes)
  * checks/menu-format:
    + [FL] Drop su-to-root-with-usr-bin and su-to-root-without-usr-sbin, and add
      su-to-root-with-usr-sbin to adapt to current menu package and policy (Closes: #332400)
  * checks/po-debconf:
    + [FL] Fix logical error in search for files (Closes: #342707)
  * checks/scripts{.desc,}:
    + [FL] Drop install-fvwmgenmenu as valid interpreter. Was dropped from menu package before sarge.
      (also for #332400, see checks/menu-format)
    + [FL] Change path for install-menu from /usr/sbin to /usr/bin (also for #332400)
    + [FL] Merge most of the wrong-path-for-* and *-script-but-no-*-dep tags to two tags
      wrong-path-for-interpreter and missing-dep-for-interpreter. This makes maintaining the
      list of valid interpreters way easier. Some tags with special text have been special
      cased (php\d? and (m|g)awk).
    + [FL] Add speedy and slsh to list of valid interpreters (Closes: #333955, #336700)
  * checks/shared-libs:
    + [FL] forgot /lib(32|64) (hopefully finally closes: #328612)

293d58f... by Michael Vogt on 2005-12-28

Import patches-unapplied version 1.23.14ubuntu1 to ubuntu/dapper

Imported using git-ubuntu import.

Changelog parent: 818562525820c10db5f1bb603f527de91237048f

New changelog entries:
  * Resynchronise with Debian.

  * The "fix those frontend regressions" release
  * frontend/lintian:
    + [FL] Fix exit status computing so that we exit with 1 again
      if we found any error. (Closes: #329458)
    + [FL] Re-enable reporting unused overrides.

  * lib/Tags.pm:
    + [FL] Some fixes to the statistics code to make the fixes
      in frontend/lintian possible

  * checks/binaries{.desc,}:
    + [FL] support c2a suffix in soname check, too (Closes: #340856)
    + [FL] fix typo in description of package-name-doesnt-match-sonames (Closes: #339360)
    + [FL] The Debian specific patches from coreutils to call strip with --remove-section
      arguments on install -s have been dropped. Adapt description of binary-has-unneeded-section
      accordingly and demote it to "info" because many packages will get this now.
  * checks/debconf{.desc,}:
    + [FL] drop seen-flag-requires-versioned-depends and multiselect-without-dependency and
      drop version requirement from missing-debconf-dependency-for-preinst. All due to the
      fact that woody shipped with 1.0.x and therefor versioned depends on versions lesser than
      that don't make much sense anymore (Closes: #333736)
  * checks/debhelper:
    + [FL] debhelper compat level 3 is deprecated as well now (Closes: #340222)
  * checks/files:
    + [FL] forgot /lib(32|64) (more #328612 fixes)
  * checks/menu-format:
    + [FL] Drop su-to-root-with-usr-bin and su-to-root-without-usr-sbin, and add
      su-to-root-with-usr-sbin to adapt to current menu package and policy (Closes: #332400)
  * checks/po-debconf:
    + [FL] Fix logical error in search for files (Closes: #342707)
  * checks/scripts{.desc,}:
    + [FL] Drop install-fvwmgenmenu as valid interpreter. Was dropped from menu package before sarge.
      (also for #332400, see checks/menu-format)
    + [FL] Change path for install-menu from /usr/sbin to /usr/bin (also for #332400)
    + [FL] Merge most of the wrong-path-for-* and *-script-but-no-*-dep tags to two tags
      wrong-path-for-interpreter and missing-dep-for-interpreter. This makes maintaining the
      list of valid interpreters way easier. Some tags with special text have been special
      cased (php\d? and (m|g)awk).
    + [FL] Add speedy and slsh to list of valid interpreters (Closes: #333955, #336700)
  * checks/shared-libs:
    + [FL] forgot /lib(32|64) (hopefully finally closes: #328612)