ubuntu/+source/lighttpd:applied/ubuntu/trusty-security

Last commit made on 2019-01-31
Get this branch:
git clone -b applied/ubuntu/trusty-security https://git.launchpad.net/ubuntu/+source/lighttpd
Members of Ubuntu Server Dev import team can upload to this branch. Log in for directions.

Branch merges

Branch information

Name:
applied/ubuntu/trusty-security
Repository:
lp:ubuntu/+source/lighttpd

Recent commits

2a7b492... by Paulo Flabiano Smorigo on 2019-01-25

Import patches-applied version 1.4.33-1+nmu2ubuntu2.1 to applied/ubuntu/trusty-security

Imported using git-ubuntu import.

Changelog parent: 51baf46e7683d3143091a5677cae0320fa0ea591
Unapplied parent: 62124361003fba2253d82766d0e52e169216b578

New changelog entries:
  * SECURITY UPDATE: Fix vulnerabilities in mod_sql and HTTPoxy.
    - debian/patches/CVE-2014-2323-CVE-2014-2324.patch: Fix SQL injection
      vulnerability in mod_mysql_vhost.c.
    - debian/patches/CVE-2016-1000212.patch: Mitigation for HTTPoxy
      vulnerability.
    - CVE-2014-2323
    - CVE-2014-2324
    - CVE-2016-1000212

6212436... by Paulo Flabiano Smorigo on 2019-01-25

CVE-2016-1000212.patch

No DEP3 Subject or Description header found

Gbp-Pq: CVE-2016-1000212.patch.

e5622e9... by Paulo Flabiano Smorigo on 2019-01-25

CVE-2014-2323-CVE-2014-2324.patch

No DEP3 Subject or Description header found

Gbp-Pq: CVE-2014-2323-CVE-2014-2324.patch.

cdee795... by Paulo Flabiano Smorigo on 2019-01-25

Add lighttpd.pc to ac_config_files to make sure its being built

Gbp-Pq: add-lighttpd.pc-configure.patch.

a200685... by Paulo Flabiano Smorigo on 2019-01-25

cve-2013-4560.patch

No DEP3 Subject or Description header found

Gbp-Pq: cve-2013-4560.patch.

c9e3d14... by Paulo Flabiano Smorigo on 2019-01-25

cve-2013-4559.patch

No DEP3 Subject or Description header found

Gbp-Pq: cve-2013-4559.patch.

5496ec9... by Paulo Flabiano Smorigo on 2019-01-25

cve-2013-4508.patch

No DEP3 Subject or Description header found

Gbp-Pq: cve-2013-4508.patch.

2d5d5a1... by Paulo Flabiano Smorigo on 2019-01-25

build-dev-package.patch

No DEP3 Subject or Description header found

Gbp-Pq: build-dev-package.patch.

feb4492... by Paulo Flabiano Smorigo on 2019-01-25

Import patches-unapplied version 1.4.33-1+nmu2ubuntu2.1 to ubuntu/trusty-security

Imported using git-ubuntu import.

Changelog parent: e79002ce1d244ba731c2b9f2e4c146987b60d505

New changelog entries:
  * SECURITY UPDATE: Fix vulnerabilities in mod_sql and HTTPoxy.
    - debian/patches/CVE-2014-2323-CVE-2014-2324.patch: Fix SQL injection
      vulnerability in mod_mysql_vhost.c.
    - debian/patches/CVE-2016-1000212.patch: Mitigation for HTTPoxy
      vulnerability.
    - CVE-2014-2323
    - CVE-2014-2324
    - CVE-2016-1000212

51baf46... by Andreas Moog on 2014-01-28

Import patches-applied version 1.4.33-1+nmu2ubuntu2 to applied/ubuntu/trusty-proposed

Imported using git-ubuntu import.

Changelog parent: 068fcb36b48524abd45565070cc4e15eb26ef82f
Unapplied parent: 195523eb75f7a147190ce0f3f19d7f805f9b2fee

New changelog entries:
  * Use dh-autoreconf to regenerate autotools files, fixes FTBFS with
    automake 1.14.1 (Closes: #726934)
  * Add lighttpd.pc to ac_config_files to fix FTBFS:
    make[3]: *** No rule to make target `lighttpd.pc', needed by `all-am'.