ubuntu/+source/lighttpd:applied/ubuntu/disco

Last commit made on 2019-01-28
Get this branch:
git clone -b applied/ubuntu/disco https://git.launchpad.net/ubuntu/+source/lighttpd
Members of Ubuntu Server Dev import team can upload to this branch. Log in for directions.

Branch merges

Branch information

Name:
applied/ubuntu/disco
Repository:
lp:ubuntu/+source/lighttpd

Recent commits

e2bbf86... by Gianfranco Costamagna on 2019-01-28

Import patches-applied version 1.4.53-1ubuntu1 to applied/ubuntu/disco-proposed

Imported using git-ubuntu import.

Changelog parent: 5cd7c88df051c2151edb97402a5fe0bd54317818
Unapplied parent: 9c23e71dda9d68d67931ee1d520f37e237556f95

New changelog entries:
  * Merge from Debian unstable. Remaining changes:
    - debian/control, debian/lighttpd-dev.install:
      + Add lighttpd-dev package.
    - debian/index.html:
      + Corrected BTS Ubuntu link and branding on the default page.
    - debian/lighttpd.conf:
      + Comment 'use-ipv6.pl' by default, which causes failure
        to bind port in ipv4.
    - debian/control:
      + Build-Depends on libgamin-dev rather than libfam-dev
        to fix startup warning.
    - debian/rules:
      + Add override_dh_installinit to set "defaults 91 09" to not
        start before apache2 but in the same runlevel with
        the same priority.
    - debian/lighttpd.dirs, debian/control, debian/rules,
      debian/lighttpd.ufw.profile:
      + Add the UFW profile.
    + Make the application build sanely:
      - Remove duplicate override on dh_install
      - Remove duplicate outdated NEWS file
      - Install updated upstream NEWS file and fix
        cp: cannot stat /debian/tmp/changelog thingy to
        fix FTBFS when built twice in a row.

9c23e71... by Gianfranco Costamagna on 2019-01-28

Add lighttpd.pc to ac_config_files to make sure its being built

Gbp-Pq: add-lighttpd.pc-configure.patch.

e85bd46... by Gianfranco Costamagna on 2019-01-28

build-dev-package.patch

No DEP3 Subject or Description header found

Gbp-Pq: build-dev-package.patch.

32754c5... by Gianfranco Costamagna on 2019-01-28

Import patches-unapplied version 1.4.53-1ubuntu1 to ubuntu/disco-proposed

Imported using git-ubuntu import.

Changelog parent: fd7d34d06c021c464f0a5292eddbc05ac37bd295

New changelog entries:
  * Merge from Debian unstable. Remaining changes:
    - debian/control, debian/lighttpd-dev.install:
      + Add lighttpd-dev package.
    - debian/index.html:
      + Corrected BTS Ubuntu link and branding on the default page.
    - debian/lighttpd.conf:
      + Comment 'use-ipv6.pl' by default, which causes failure
        to bind port in ipv4.
    - debian/control:
      + Build-Depends on libgamin-dev rather than libfam-dev
        to fix startup warning.
    - debian/rules:
      + Add override_dh_installinit to set "defaults 91 09" to not
        start before apache2 but in the same runlevel with
        the same priority.
    - debian/lighttpd.dirs, debian/control, debian/rules,
      debian/lighttpd.ufw.profile:
      + Add the UFW profile.
    + Make the application build sanely:
      - Remove duplicate override on dh_install
      - Remove duplicate outdated NEWS file
      - Install updated upstream NEWS file and fix
        cp: cannot stat /debian/tmp/changelog thingy to
        fix FTBFS when built twice in a row.

5cd7c88... by Helmut Grohne <email address hidden> on 2019-01-28

Import patches-applied version 1.4.53-1 to applied/debian/sid

Imported using git-ubuntu import.

Changelog parent: bd4c218074288a9bb4adad51133b85bb6248ab88
Unapplied parent: fd7d34d06c021c464f0a5292eddbc05ac37bd295

New changelog entries:
  * QA Upload.
  * Disable libunwind support by default (unavailable on s390x).
    Rebuild with DEB_BUILD_PROFILES=pkg.lighttpd.libunwind to use it.
  * Checked compliance with policy version 4.3.0.
  * New upstream release.
    + Drop all patches.
    + debian/tests/defconfig: Require no warnings.
  * Add php to Build-Depends to increase test coverage.
  * Support parallel building.
  * As we now serve /usr/lib/cgi-bin, create the directory.

fd7d34d... by Helmut Grohne <email address hidden> on 2019-01-28

Import patches-unapplied version 1.4.53-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: f7d56601349544006d35ba864e5ca8296fccce64

New changelog entries:
  * QA Upload.
  * Disable libunwind support by default (unavailable on s390x).
    Rebuild with DEB_BUILD_PROFILES=pkg.lighttpd.libunwind to use it.
  * Checked compliance with policy version 4.3.0.
  * New upstream release.
    + Drop all patches.
    + debian/tests/defconfig: Require no warnings.
  * Add php to Build-Depends to increase test coverage.
  * Support parallel building.
  * As we now serve /usr/lib/cgi-bin, create the directory.

bd4c218... by Helmut Grohne <email address hidden> on 2019-01-25

Import patches-applied version 1.4.52-5 to applied/debian/sid

Imported using git-ubuntu import.

Changelog parent: cf975837ed8f571ea50f96f79df4ff544fe619f8
Unapplied parent: 35b769227762b436865be875e66f609a531190a3

New changelog entries:
  * QA Upload.
  * Fix arch-indep build. (Closes: #920448)

f7d5660... by Helmut Grohne <email address hidden> on 2019-01-25

Import patches-unapplied version 1.4.52-5 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 2489df6479a30a46d16dd9184bc8fa58afd8d346

New changelog entries:
  * QA Upload.
  * Fix arch-indep build. (Closes: #920448)

35b7692... by Helmut Grohne <email address hidden> on 2019-01-25

cross.patch

No DEP3 Subject or Description header found

Gbp-Pq: cross.patch.

f64320f... by Helmut Grohne <email address hidden> on 2019-01-25

connection_close.patch

No DEP3 Subject or Description header found

Gbp-Pq: connection_close.patch.