ubuntu/+source/libvirt:debian/stretch

Last commit made on 2019-09-07
Get this branch:
git clone -b debian/stretch https://git.launchpad.net/ubuntu/+source/libvirt
Members of Ubuntu Server Dev import team can upload to this branch. Log in for directions.

Branch merges

Branch information

Name:
debian/stretch
Repository:
lp:ubuntu/+source/libvirt

Recent commits

af7f336... by Guido Günther on 2019-06-12

Import patches-unapplied version 3.0.0-4+deb9u4 to debian/stretch

Imported using git-ubuntu import.

Changelog parent: 8b68b09941cb86ad99a9d37da02fea77b20db7c3

New changelog entries:
  * Fix CVEs related to privilege escalations on R/O connections.
    - CVE-2019-10161:
      CVE-2019-10161-api-disallow-virDomainSaveImageGetXMLDesc-.patch
    - CVE-2019-10167:
      api-disallow-virConnectGetDomainCapabilities-on-read-only.patch
  * cpu_map: Define md-clear CPUID bit.
    CVE-2018-12126, CVE-2018-12127, CVE-2018-12130, CVE-2019-11091
  * Add spec-ctrl and ibpb CPU features and ibrs CPU models.
    CVE-2017-5753, CVE-2017-5715
  * Add ssbd CPU feature.
    CVE-2018-3639

8b68b09... by Guido Günther on 2018-03-12

Import patches-unapplied version 3.0.0-4+deb9u3 to debian/stretch

Imported using git-ubuntu import.

Changelog parent: d245b7bbe01ba277c1669f378d1551453293669c

New changelog entries:
  * gbp: switch branch to stretch
  * CVE-2018-1064: qemu: avoid denial of service reading from QEMU guest agent
  * CVE-2018-6764: virlog: determine the hostname on startup
    (Closes: #889839)

d245b7b... by Guido Günther on 2018-01-20

Import patches-unapplied version 3.0.0-4+deb9u2 to debian/stretch

Imported using git-ubuntu import.

Changelog parent: 3d812ddd6ca9f02c7a92f3d6c0b1e1503c98f113

New changelog entries:
  * CVE-2018-5748: qemu: avoid denial of service reading from QEMU monitor
    (Closes: #887700)
  * qemu: shared disks with cache=directsync should be safe for migration.
    Thanks to Carsten Burkhardt (Closes: #883208)

3d812dd... by Guido Günther on 2017-10-16

Import patches-unapplied version 3.0.0-4+deb9u1 to debian/stretch

Imported using git-ubuntu import.

Changelog parent: 6cb7fd94cc910051eea36ec4bc164c6d2dc5cd9a

New changelog entries:
  * CVE-2017-1000256: qemu: ensure TLS clients always verify the server
    certificate (Closes: #878799)

6cb7fd9... by Guido Günther on 2017-03-17

Import patches-unapplied version 3.0.0-4 to debian/sid

Imported using git-ubuntu import.

Changelog parent: a6159efc553a9d95d8ca9dfdb9aea4622adb8272

New changelog entries:
  * [2a23b23] qemu: skip QMP probing of CPU definitions when missing.
    Don't probe CPU definitions if we lack the monitor command. This
    unbreaks e.g. mips based VMs. (Closes: #85412)
  * [21bc332] apprarmor: unbreak lbvirt invoking qemu-bridge-helpers
    This makes VM creation in gnome-boxes work with apparmor enabled.

a6159ef... by Guido Günther on 2017-02-27

Import patches-unapplied version 3.0.0-3 to debian/sid

Imported using git-ubuntu import.

Changelog parent: f4499ccccfbf24f582988379f6b0d56fbae543e0

New changelog entries:
  * [62ad289] Debianize virtlogd
  * [cb216b5] CVE-2017-2635: qemu: Don't update physical storage size of empty drives
    (Closes: #856313)

f4499cc... by Guido Günther on 2017-01-25

Import patches-unapplied version 3.0.0-2 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 1aadad5e89c1da3aa3751e1068e832ff1b318919

New changelog entries:
  * Upload to unstable
  * [8ce689d] Add pt_BR debconf translation.
    Thanks to Adriano Rafael Gomes (Closes: #852446)

1aadad5... by Guido Günther on 2017-01-19

Import patches-unapplied version 3.0.0-1 to debian/experimental

Imported using git-ubuntu import.

Changelog parent: 7a7c3e2d37dd2731e76ce8b2fffe47ce08e4506c

New changelog entries:
  * [bf2fdf7] New upstream version 3.0.0
  * [95b1359] New upstream version 3.0.0-rc1
  * [57baa73] lxc smoketest: drop emulator path
    so it's simpler to reuse this on other distros to reproduce test
    failures.
    Thanks to Cedric Bosdonnat
  * [5be8cad] lxc: ensure libvirt_lxc and qemu-nbd move into systemd machine
    slice (Closes: #848317)
  * [5c36b50] nl debconf translation.
    Thanks to Frans Spiesschaert (Closes: #850737)
  * [458b927] Add Danish debconf translation.
    Thanks to Joe Dalton (Closes: #850872)
  * [cbe5cd0] Add fr debconf translation.
    Thanks to Alban VIDAL (Closes: #850938)
  * [7c3b026] Rediff patches.
    Dropped patches fixed upstream
      apparmor-pass-attach_disconnected.patch
      lxc-ensure-libvirt_lxc-and-qemu-nbd-move-into-systemd-mac.patch
      AppArmor-policy-support-merged-usr.patch
  * [baf4b1f] Bump symbol versions
  * [80ef821] Add de translation.
    Thanks to Markus Hiereth for the initial draft
  * [2be70b3] Work around lack of /dev/ptmx access in pbuilder
    test-posix_openpt-don-t-fail-on-EPERM.patch
    openpty-Skip-test-if-no-pty-is-available.patch
  * [43e4ddc] Disable use of qemu mount namespaces by default. The
    code is not complete yet.

7a7c3e2... by Guido Günther on 2016-12-23

Import patches-unapplied version 2.5.0-3 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 550a80abe88cfbdc87664e4697676991cc27a520

New changelog entries:
  * [ba9fcb8] Invoke db_stop.
    Thanks to Raphaël Halimi (Closes: #849201)

550a80a... by Guido Günther on 2016-12-22

Import patches-unapplied version 2.5.0-2 to debian/sid

Imported using git-ubuntu import.

Changelog parent: f5bb297542fd505c3c33ba5ed54cda2e0a8e8993

New changelog entries:
  [ Guido Günther ]
  * Upload to unstable
  * [14eee94] Make debconf template translatable
  * [13afd29] Adjust doc-base due to new upstream doc layouer
  * [fd7c2bb] Skip any debconf prompting if user and group are already there
    to not interfere with existing intallations
  * [1afd876] Depend on iptables of firewalld (Closes: #846321)
  * autopkgtests cleanups. Thanks to Christian Ehrhardt
    (Closes: #848247)
  [ intrigeri ]
  * [d64731a] Apparmor fixes for merged /usr
  [ Mauricio Faria de Oliveira ]
  * [f4b33d0] Use a fixed uid/gid for libvirt-qemu usr to avoid permission
    issues on network filesystems like NFS. On new installations warn via
    debconf if uid/gid are already taken.
    (Closes: #844339)