ubuntu/+source/liburi-perl:debian/squeeze

Last commit made on 2010-10-26
Get this branch:
git clone -b debian/squeeze https://git.launchpad.net/ubuntu/+source/liburi-perl
Members of Ubuntu Server Dev import team can upload to this branch. Log in for directions.

Branch merges

Branch information

Name:
debian/squeeze
Repository:
lp:ubuntu/+source/liburi-perl

Recent commits

8bc4075... by gregor herrmann on 2010-10-25

Import patches-unapplied version 1.54-2 to debian/squeeze

Imported using git-ubuntu import.

Changelog parent: 508b3869282358d7959f303039693861858cb85f

New changelog entries:
  * Don't run online tests (closes: #601116).

508b386... by gregor herrmann on 2010-04-01

Import patches-unapplied version 1.54-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: ed62be9afae95b6c1de153118212a2affc14160d

New changelog entries:
  * New upstream release.
  * Add /me to Uploaders.

ed62be9... by Jonathan Yu <email address hidden> on 2010-03-19

Import patches-unapplied version 1.53-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: b48eb9a8bb57a12a7b1d0aaadb470fcca3c6bc35

New changelog entries:
  * New upstream release
  * Use new 3.0 (quilt) source format
  * Standards-Version 3.8.4 (no changes)
  * Drop libwww-perl version dep and Conflicts (version 5.41 is no
    longer available in Debian)
  * Remove patch which was applied upstream

b48eb9a... by Jonathan Yu <email address hidden> on 2010-01-15

Import patches-unapplied version 1.52-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 0d253f2a2e28bc8805ef4b37cd9b244d76e4f942

New changelog entries:
  * New upstream release
  * Add a patch to fix wide character warnings

0d253f2... by Jonathan Yu <email address hidden> on 2009-11-21

Import patches-unapplied version 1.50-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: cd551fb7b21b5d557f00f510262e01de281cb63b

New changelog entries:
  [ Jonathan Yu ]
  * New upstream release
  * Add myself to Uploaders and Copyright
  * Remove repackaging since RFC has been removed
  * Remove outdated README.debian; especially since repacking isn't
    needed anymore, and the previous entry was from 1999
  * Rewrote control description
  * Update debhelper rules file using new short format
  * Remove quilt (there is no patch here)
  * Remove 'dirs' file, doesn't seem to be needed
  [ Ryan Niebur ]
  * New upstream release
  * Add myself to Uploaders
  * Debian Policy 3.8.1
  * Update ryan52's email address
  [ Nathan Handler ]
  * debian/watch: Update to ignore development releases.
  [ Iulian Udrea ]
  * New upstream release (closes: #556007)
  * Run dh-make-perl --refresh.
  * debian/control:
    - Bump Standards-Version to 3.8.3.
      + The requirement for Perl modules to have a versioned Depend and
        Build-Depend on perl >= 5.6.0-16 has been removed.
    - Improve the single line synopsis.
    - Add myself to Uploaders.
  * debian/copyright:
    - Update to new format
      (http://wiki.debian.org/Proposals/CopyrightFormat?action=recall&rev=196).
  [ gregor herrmann ]
  * debian/control: remove "data-dumper" from Depends, there's no such
    package, and Data::Dumper is in perl anyway.
  * debian/copyright: update years of upstream copyright.

cd551fb... by Kees Cook on 2008-12-04

Import patches-unapplied version 1.37+dfsg-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 28f2470a36ec68077e64a64d9dc4c46dffe4545a

New changelog entries:
  [ Kees Cook ]
  * New upstream release (Closes: #507286)
    + Closes: #386007 -- Undefined subroutine uri_escape_utf8
    + Closes: #429540 -- URI::_query does not handle ; in URI correctly
  * debian/control:
    - Take over for the Debian Perl Group, with permission from Stefan
      Hornburg.
    - Clean up long description (Closes: #433968).
    - Bump standards version to 3.8.0 (added Homepage, README.source).
  * debian/{control,rules}:
    - Add quilt for patch management.
  * debian/{watch,repack.sh,rules}: handle repacking to remove rfc2396.txt
    (non-redistributable):
    - http://rt.cpan.org/Ticket/Display.html?id=41418
  * debian/rules:
    - Enable tests.
    - Correctly handle missing Makefile in "clean" rule.
  * debian/copyright: updated and clarified to match URI.pm and README.
  * debian/control: Added: ${misc:Depends} to Depends: field.
  [ Damyan Ivanov ]
  * do not ship README containing information about installing the module
  * rules: converted to debhelper 7; adjusted compat and control
  * add libbusiness-isbn-perl to B-D-I, enabling additional test

28f2470... by Stefan Hornburg (Racke) on 2007-06-19

Import patches-unapplied version 1.35.dfsg.1-1 to debian/lenny

Imported using git-ubuntu import.