ubuntu/+source/libtool:ubuntu/wily-devel

Last commit made on 2014-10-14
Get this branch:
git clone -b ubuntu/wily-devel https://git.launchpad.net/ubuntu/+source/libtool
Members of Ubuntu Server Dev import team can upload to this branch. Log in for directions.

Branch merges

Branch information

Name:
ubuntu/wily-devel
Repository:
lp:ubuntu/+source/libtool

Recent commits

c162920... by Matthias Klose on 2014-10-14

Import patches-unapplied version 2.4.2-1.11 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 0650bb80330e4247c39d9b4244f47b5055885467

New changelog entries:
  * Non-maintainer upload.
  * Drop libtool's dependency on libtool-bin.
  * Add libtool-bin dependency on libtool.
  * Make libtool Multi-Arch: foreign. Closes: #682045.
  * Bump standards version to 3.9.6.

0650bb8... by Matthias Klose on 2014-08-19

Import patches-unapplied version 2.4.2-1.10 to debian/sid

Imported using git-ubuntu import.

Changelog parent: a78f104f500d0eb095eda0f0945362e5c06bedd6

New changelog entries:
  * Run the tests in the build target, not the install target.

a78f104... by Matthias Klose on 2014-08-19

Import patches-unapplied version 2.4.2-1.9 to debian/sid

Imported using git-ubuntu import.

Changelog parent: d77126e89bea1407be991d048fc415e1e07c459e

New changelog entries:
  * Non-maintainer upload.
  * Fix the architecture only build.
  * Non-maintainer upload with maintainer's permission.
  * Split-out the libtool binary into a libtool-bin package, let libtool
    still depend on the libtool-bin package.
  * Set the architecture for libtool to `all'.
  * The next steps are:
    - Fix package builds with libtool's dependency on libtool-bin removed,
      either by changing the package build not to require libtool or by
      adding a build dependency on libtool-bin.
    - Drop libtool's dependency on libtool-bin.
  * Build using dpkg-buildflags.
  * Fix some lintian warnings. Closes: #711521.
  * Only ship the complete upstream changelogs in the -doc package.
  * Move texinfo to Build-Depends-Indep (Daniel Schepler). Closes: #737941.
  * Build-depend on most recent autoconf and automake versions to minimize
    the risk of mismatching files in the libltdl-dev M-A: same package.
    Closes: #733935.

d77126e... by Matthias Klose on 2014-02-10

Import patches-unapplied version 2.4.2-1.7 to debian/sid

Imported using git-ubuntu import.

Changelog parent: c29927c9259b9aa828eaa7eb0a51bfcdb054c654

New changelog entries:
  * Non-maintainer upload.
  * Fix typo in in the ppc64el guessing in config.guess.

c29927c... by Matthias Klose on 2014-01-02

Import patches-unapplied version 2.4.2-1.6 to debian/sid

Imported using git-ubuntu import.

Changelog parent: fba17d57452fe56267103fd15f4468d189bc6371

New changelog entries:
  * Non-maintainer upload.
  * Rebuild using the recent automake 1.14.1 version. Closes: #733935.
  * Non-maintainer upload.
  * Update the powerpc little endian support, outdated in the Debian
    patch in #726404.

fba17d5... by Matthias Klose on 2014-01-01

Import patches-unapplied version 2.4.2-1.4 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 70d3bef655fff7673bd3a2217a33b77f1be4c5f5

New changelog entries:
  * Non-maintainer upload with maintainer's permission.
  * Add powerpc little endian updates. Closes: #726404.
  * Build-conflict with and suggest gcj-jdk instead of gcj.

70d3bef... by Colin Watson on 2013-07-01

Import patches-unapplied version 2.4.2-1.3 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 15bcfb702d82bedcdde56a944b326871247c782d

New changelog entries:
  * Non-maintainer upload.
  * Build-depend on help2man (closes: #712413).

15bcfb7... by Daniel Schepler <email address hidden> on 2012-11-23

Import patches-unapplied version 2.4.2-1.2 to debian/sid

Imported using git-ubuntu import.

Changelog parent: b6de72641c8a39c571515ff1d9e44eed8e6e41d3

New changelog entries:
  * Non-maintainer upload with maintainer's permission.
  * Backport support for x32 from upstream git. Closes: #692222.

b6de726... by Samuel Thibault <email address hidden> on 2012-06-11

Import patches-unapplied version 2.4.2-1.1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 16b2aef95774be14d5b454adae9afa22b8779a27

New changelog entries:
  * Non-maintainer upload.
  * Apply upstream fix for hurd-i386 linker flags (Closes: #648514).

16b2aef... by Kurt Roeckx on 2011-10-29

Import patches-unapplied version 2.4.2-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 2c772db3f1bb5f4c05e7c96d9b89cde761dd6c82

New changelog entries:
  * New upstream release
    Remove patches applied upstream:
    - define_shlibpath_overrides_runpath4hurd.patch
    - tagdemo-libfoo.patch
  * Remove disable_cmdline_wrap4hurd.patch as it never really was
    needed in the first place. The other tests failing made the
    cmdline_wrap test fail.
  * Add multiarch support. Patch from
    Steve Langasek <email address hidden> (Closes: #646771)