ubuntu/+source/libtool:ubuntu/quantal-devel

Last commit made on 2012-10-05
Get this branch:
git clone -b ubuntu/quantal-devel https://git.launchpad.net/ubuntu/+source/libtool
Members of Ubuntu Server Dev import team can upload to this branch. Log in for directions.

Branch merges

Branch information

Name:
ubuntu/quantal-devel
Repository:
lp:ubuntu/+source/libtool

Recent commits

c5e18a7... by Colin Watson on 2012-10-05

Import patches-unapplied version 2.4.2-1ubuntu2 to ubuntu/quantal

Imported using git-ubuntu import.

Changelog parent: 8bc04403d57edf3857f7e28048048a5295a7238c

New changelog entries:
  * Rebuild for new armel compiler default of ARMv5t.

8bc0440... by Steve Langasek on 2011-11-12

Import patches-unapplied version 2.4.2-1ubuntu1 to ubuntu/precise

Imported using git-ubuntu import.

Changelog parent: 16b2aef95774be14d5b454adae9afa22b8779a27

New changelog entries:
  * Merge from Debian testing. Remaining changes:
    - Mark Java convenience test as an expected failure, due to
      http://gcc.gnu.org/bugzilla/show_bug.cgi?id=42143.
    - Mark libtool Multi-Arch: foreign; needed because it's a
      build-dependency.
  * Dropped changes, included in Debian:
    - Build libltdl for multiarch.
  * Dropped changes:
    - Fix the 'clean' target for the case where tests are not run: this
      seems to be solved upstream, clean works fine after a
      DEB_BUILD_OPTIONS=nocheck run without this.

16b2aef... by Kurt Roeckx on 2011-10-29

Import patches-unapplied version 2.4.2-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 2c772db3f1bb5f4c05e7c96d9b89cde761dd6c82

New changelog entries:
  * New upstream release
    Remove patches applied upstream:
    - define_shlibpath_overrides_runpath4hurd.patch
    - tagdemo-libfoo.patch
  * Remove disable_cmdline_wrap4hurd.patch as it never really was
    needed in the first place. The other tests failing made the
    cmdline_wrap test fail.
  * Add multiarch support. Patch from
    Steve Langasek <email address hidden> (Closes: #646771)

2c772db... by Kurt Roeckx on 2011-08-24

Import patches-unapplied version 2.4-4 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 0034d9dd9ffa1025161136558fb8248250fad712

New changelog entries:
  * dpkg-dev decided to also reverse apply the arm change, so remove
    the revert (Closes: #632614)

0034d9d... by Kurt Roeckx on 2011-07-29

Import patches-unapplied version 2.4-3 to debian/sid

Imported using git-ubuntu import.

Changelog parent: c27e7d2fbd1198b903e1663d0465e4ff9a4e7fd1

New changelog entries:
  * Also cat test-suite.log (Closes: #632613)
  * Also disable broken tests with non-PIC code on arm. (Closes: #632614)

c27e7d2... by Kurt Roeckx on 2011-04-07

Import patches-unapplied version 2.4-2 to debian/sid

Imported using git-ubuntu import.

Changelog parent: a3268e63b71be33473dd6d479228397bbf910c2d

New changelog entries:
  * Add support for hurd (Closes: #612204)
    Patches from Svante Signell <email address hidden> and
    Pino Toscano <email address hidden>

a3268e6... by Kurt Roeckx on 2011-04-02

Import patches-unapplied version 2.4-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 4a9278122da7acc0efacd5b4512e25adc6803452

New changelog entries:
  * New upstream release
    - Update build-depends to automake (>= 1:1.11.1), autoconf (>= 2.62)
    - Update patches to apply to current version:
      - link_all_deplibs.patch
      - deplib_binary.patch
  * convert to a 3.0 (quilt) source format, and drop quilt build-dependency.
  * Make tagdemo link to libfoo (Closes: #619845)

4a92781... by Kurt Roeckx on 2010-06-17

Import patches-unapplied version 2.2.10-1 to debian/experimental

Imported using git-ubuntu import.

Changelog parent: 3b451d2939679248e2e1a399f27110f5bfce9d00

New changelog entries:
  * New upstream release (Closes: #586246)
    - Change license of documentation to GFDL 1.3
    - Upstream now provides manpages for libtool and libtoolize, use
      those instead of our own.
    - drop lt_dlopenext.patch, bogus_directory.patch,
      skip_setlocale.patch, kopensolaris.patch and
      gold_symbol_versioning.patch applied upstream.

3b451d2... by Kurt Roeckx on 2009-12-09

Import patches-unapplied version 2.2.6b-2 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 4148f7b32edddde36b192a6365d0ea62ade82f5e

New changelog entries:
  * Add build depedency on zlib1g-dev needed by the search-path.at
    testsuite test. (Closes: #560219)

4148f7b... by Kurt Roeckx on 2009-12-09

Import patches-unapplied version 2.2.6b-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 52d7606bfb0f97c73c5fd765bffde05cd04e379b

New changelog entries:
  * New upstream release
    - Fixes CVE-2009-3736 (Closes: #559797)
  * Skip demo-deplibs.test. This is basicly the same as
    deplibs_test_disable.patch from the 1.5.26 version.
  * Skip the link-order2.at test. It has the same problem
    as the deplibs test.
  * Since deplibs-ident.at now passes, just let it return that
    the result is ok.
  * Skip localization test when setlocale is not functional.
  * Renable test suite.
  * Remove the "Apps/" part of the doc-base entry.
  * Change debhelper compatibilty to 7.
  * Replace dh_clean -k with dh_prep
  * Change build dependency of automake to 1.10.1 (Closes: #542190)
  * Add support for GNU/kOpenSolaris (Closes: #545687)
  * Update Standards-Version from 3.8.1 to 3.8.3: No changes required.
  * Add ${misc:Depends} to libtool-doc's Depends so we have proper
    depedencies for it.
  * Build-Conflict against gcj for now, to avoid a regression test
    failure. See #555801.
  * Symbol versioning works with the GNU gold linker now. (Closes: #554821)