ubuntu/+source/libshout:ubuntu/disco

Last commit made on 2018-02-05
Get this branch:
git clone -b ubuntu/disco https://git.launchpad.net/ubuntu/+source/libshout
Members of Ubuntu Server Dev import team can upload to this branch. Log in for directions.

Branch merges

Branch information

Name:
ubuntu/disco
Repository:
lp:ubuntu/+source/libshout

Recent commits

bfe2948... by Dimitri John Ledkov on 2018-02-05

Import patches-unapplied version 2.4.1-2build1 to ubuntu/bionic-proposed

Imported using git-ubuntu import.

Changelog parent: 8a00066f006acdd26109f17b51f79cdf36f4ff3d

New changelog entries:
  * No change rebuild against openssl1.1.

8a00066... by James Cowgill on 2017-11-26

Import patches-unapplied version 2.4.1-2 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 773a77e4ad10560eb8c674ef1a42c02a7a8cc830

New changelog entries:
  * Team upload.
  * Switch to OpenSSL 1.1. (Closes: #873647)
    Thanks to Sebastian Andrzej Siewior for the patch.
  * Bump standards version to 4.1.1 (no changes).

773a77e... by Jonas Smedegaard <email address hidden> on 2017-08-29

Import patches-unapplied version 2.4.1-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 4693bdb62f5f228e9b46f108320657230816245b

New changelog entries:
  [ upstream ]
  * New release(s).
  [ Jonas Smedegaard ]
  * Update copyright info:
    + Extend and merge most upstream Files sections, now relicensed to
      LGPL-2+.
    + Extend and refine coverage of autotools.
  * Build-depend on libssl1.0-dev.
  * Drop patches: Adopted/addressed upstream.
  * Update symbols.
  * Tighten lintian overrides regarding License-Reference.
  * Update copyright info:
    + Add alternative git source URL.
    + Use SPDX License shortnames.
    + Extend coverage for myself.
    + Use License-Grant and License-Reference fields.
      Thanks to Ben Finney.
    + Fix add Files section licensed as GPL-2.
  * Modernize cdbs:
    + Do copyright-check in maintainer script (not during build).
      Stop build-depend on devscripts.
  * Add lintian overrides regarding License-Reference.
  * Advertise DEP-3 format in patch headers.
  * Use debhelper compatibility level 9.
  * Modernize Vcs-* fields:
    + Use https protocol.
    + Use git (not gitweb) in path.
  * Declare compliance with Debian Policy 4.1.0.
  * Update git-buildpackage config:
    + Add usage comment.
    + Filter any .git* files.
  * Use newest autotools.
    Build-depend on automake (not automake1.11).
    Closes: Bug#865186. Thanks to Simon McVittie
  * Stop pre-depend on multiarch.
    Closes: Bug#870425, #870515. Thanks to Jörg-Volker Peetz and
    Aurelien Jarno.
  * Update watch file:
    + Bump format version.
    + Mention gbp --uscan in usage comment.
    + Tighten version regex.
  * Add symbols file.
  * Track symbols using pkgkde-symbolshelper.
    Build-depend on pkg-kde-tools.

4693bdb... by Jonas Smedegaard <email address hidden> on 2013-05-09

Import patches-unapplied version 2.3.1-3 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 922f75e954f159201a24655e71e5990333caac23

New changelog entries:
  * Bump dephelper compatibility level to 8.
  * Use anonscm.debian.org URL for Vcs-Git.
  * Bump policy compliance to standards-version 3.9.4.

922f75e... by Jonas Smedegaard <email address hidden> on 2013-05-09

Import patches-unapplied version 2.3.1-2 to debian/experimental

Imported using git-ubuntu import.

Changelog parent: 73a71271f6a247d17fcf4ec3de5ddaea710a77e5

New changelog entries:
  * Drop unneeded build-dependency on libopus-dev.
  * Update copyright file:
    + Fix add Files section for opus.c: New copyright holder, same
      licensing as main project.
    + Bump packaging license to GPL-3+.
    + Extend coverage of packaging to include recent years.
  * Ensure order of library install targets. Thanks to Vasudev Kamath.
  * Update package relations:
    + Fix pre-depend on multiarch-support only for lib package.
    + Build-depend (again) on dh-buildinfo: Multiarch-compliant
      nowadays.
    + Build-depend (again) on devscripts: No longer complicates
      backporting.
    + Tighten build-dependency on cdbs: Needed for simplified cruft
      handing.
  * Update README.source to emphasize control.in file as *not* a
    show-stopper for contributions, referring to wiki page for details.
  * Simplify watch file.
  * Simplify rules file, using CDBS DEB_UPSTREAM_CRUFT_MOVE.

73a7127... by Jonas Smedegaard <email address hidden> on 2012-06-05

Import patches-unapplied version 2.3.1-1 to debian/experimental

Imported using git-ubuntu import.

Changelog parent: f2ae70fd1b3f40d09e02a6041f56e963afac66d4

New changelog entries:
  * New upstream release.
    + Opus support.
  * Build-depend on libopus-dev.
  * Thanks to Ron Lee for coordinating this release.

f2ae70f... by Jonas Smedegaard <email address hidden> on 2012-03-25

Import patches-unapplied version 2.3.0-1 to debian/experimental

Imported using git-ubuntu import.

Changelog parent: 8d0b77df27616e163a936c5a9a7791ffb17a65cd

New changelog entries:
  * New upstream release.
  * Bump standards-version to 3.9.3.
  * Use anonscm.debian.org URL in Vcs-Browser field.
  * Simplify install path, thanks to debhelper compatibility level 7.
  * Update copyright file:
    + Bump format to 1.0.
    + Fix double-indent in Copyright fields as per Policy §5.6.13.
    + Extend copyright years.
    + Include disclaimers in GAP licenses.
  * Update package relations:
    + Relax build-depend unversioned on debhelper: Needed version
      satisfied even in oldstable.
  * Improve multiarch quirks to ease backporting.
  * Update patches:
    + Drop patch 1002 to link against libspeex: Applied upstream.
    + Change patch 1001 to apply to master autotools files (not
      autogenerated ones).
    + Refresh patch 1003 with shortening quilt options.
    + Add DEP3 patch headers.
  * Autogenerate autotools during build.

8d0b77d... by Alessio Treglia on 2012-02-15

Import patches-unapplied version 2.2.2-8 to debian/sid

Imported using git-ubuntu import.

Changelog parent: a2de8dc415554c2479e489b3adf84ce99032377b

New changelog entries:
  * Team upload.
  [ Alessio Treglia ]
  * Introduce MultiArch support. Thanks to Steve Langasek for
    the original patch: (Closes: #652504)
    - debian/control:
      + Bump cdbs minimum requirement to 0.4.93~.
      + Don't build-depend on dh-buildinfo, which is non multiarch-safe.
      + Regenerate.
    - debian/rules:
      + Move pkgconfig files into multiarch path.
      + Don't set DH_COMPAT in debian/rules.
  [ Jonas Smedegaard ]
  * Add README.source, documenting use of git-buildpackage and CDBS
    (replacing README.cdbs-tweaks).

a2de8dc... by Jonas Smedegaard <email address hidden> on 2011-12-19

Import patches-unapplied version 2.2.2-7 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 71937b20fd67d791e03b18a3a7722f8099e82c26

New changelog entries:
  * Modernize CDBS:
    + Drop local snippets: Now upstream.
    + Suppress optional snippets to ease backporting.
    + Declare build-dependencies recursively expanded (using = not := ).
    + Stop build-dependency tidying (done upstream now).
  * Update package relations:
    + Relax to build-depend unversioned when satisfied even in
      oldstable:
      - cdbs
      - debhelper
      - libogg-dev
      - libvorbis-dev
      - libtheora-dev
      - d-shlibs
    + Drop obsolete/superfluous build-dependencies:
      - devscripts
      - quilt
      - patchutils
  * Stop cleanup of debian subdir: superfluous with source format 3.0.
  * Improve d-shlibs handling:
    + Add local ld1-dev quirk (duplicating recent upstream quirk, to
      ease backporting).
      Closes: bug#650546. Thanks to Samuel Thibault.
    + Stop using local hacked copy (libspeex1-dev quirk now upstream).
    + Drop superfluously invoking d-devlibdeps (done implicitly by
      d-shlibmove).
    + Tighten rules to ensure invoked only once.
  * Bump debhelper compatilibity level to 7.
  * Bump Policy compliance to standards-version 3.9.2.
  * Drop dpkg local-options hints from packaging source: now defaults.
  * Add proper licensing header to debian/rules, and extend coverage.
  * Update copyright file:
    + Rewrite using draft DEP-5 format.
  * Stop installing obsolete *.la file (not only strip dependency_libs).

71937b2... by Alessio Treglia on 2011-11-29

Import patches-unapplied version 2.2.2-6 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 31576808ed16d558500017aa020d59195c7c23c1

New changelog entries:
  * Team upload.
  * Change Maintainer since the Debian Icecast team is merging
    with the Debian Multimedia Maintainers team.
  * Add git-buildpackage config file.
  * One-dep-per-line style.
  * Bump Standards.
  * Regenerate debian/control file.
  * Switch to 3.0 (quilt) format.
  * Clean-up dependency_libs in .la files (Closes: #633311).