ubuntu/+source/libnih:ubuntu/raring-devel

Last commit made on 2013-03-14
Get this branch:
git clone -b ubuntu/raring-devel https://git.launchpad.net/ubuntu/+source/libnih
Members of Ubuntu Server Dev import team can upload to this branch. Log in for directions.

Branch merges

Branch information

Name:
ubuntu/raring-devel
Repository:
lp:ubuntu/+source/libnih

Recent commits

fba0aa6... by James Hunt on 2013-03-14

Import patches-unapplied version 1.0.3-4ubuntu16 to ubuntu/raring-proposed

Imported using git-ubuntu import.

Changelog parent: 1193c755acf4d93b549a07d4e7947ceece9b8fdb

New changelog entries:
  * debian/{libnih1.postinst,libnih-dbus1.postinst}: Force an upgrade to
    restart Upstart (to pick up new package version) if the running
    instance supports it.
  * Merge of important fixes from lp:~upstart-devel/libnih/nih
    (LP: #776532, LP: #777097, LP: #834813, LP: #1123588).

1193c75... by Dimitri John Ledkov on 2013-01-08

Import patches-unapplied version 1.0.3-4ubuntu15 to ubuntu/raring-proposed

Imported using git-ubuntu import.

Changelog parent: e9653ec7e42fc999669a67cf3e518374cefdfe01

New changelog entries:
  * Enable cross-building, sans adding :native build-dependencies.
    See comments in debian/control.
  * Lintian fixes.

e9653ec... by St├ęphane Graber on 2012-12-13

Import patches-unapplied version 1.0.3-4ubuntu14 to ubuntu/raring-proposed

Imported using git-ubuntu import.

Changelog parent: 7ef4e6f9e8795454f8faab2696f1425928137e5b

New changelog entries:
  * Update dbus code generator to allow for empty lists for type 'as'.
    This drops the != NULL check for NULL terminated arrays and moves the
    iteration loop inside an 'if' statement.

7ef4e6f... by Dimitri John Ledkov on 2012-12-11

Import patches-unapplied version 1.0.3-4ubuntu13 to ubuntu/raring-proposed

Imported using git-ubuntu import.

Changelog parent: 91b3325afc8a3ccf0bf366f74ee69eab8a5252c3

New changelog entries:
  [ Petr Lautrbach <email address hidden>, Dmitrijs Ledkovs ]
  * Fallback to lstat, if dirent.d_type is not available (not portable)
    (LP: #672643) (Closes: #695604)

91b3325... by James Hunt on 2012-10-25

Import patches-unapplied version 1.0.3-4ubuntu12 to ubuntu/raring

Imported using git-ubuntu import.

Changelog parent: d6c73b88d8c7487ffdabd8cd9d91087445099206

New changelog entries:
  * nih/logging.c: Use our own __nih_abort_msg rather than the (e)glibc
    private symbol __abort_msg to avoid upgrade issues (LP: #997359).
  * nih/tests/test_logging.c: Update tests for __nih_abort_msg.

d6c73b8... by James Hunt on 2012-10-03

Import patches-unapplied version 1.0.3-4ubuntu11 to ubuntu/quantal

Imported using git-ubuntu import.

Changelog parent: ccd690295cfc67e9f4b326ef2161592af275e43e

New changelog entries:
  * Addition of debian/libnih-dbus1.postinst and
    debian/libnih1.postinst to force Upstart re-exec on shutdown
    to avoid unmounting disks uncleanly (LP: #740390).

ccd6902... by Wookey on 2012-10-01

Import patches-unapplied version 1.0.3-4ubuntu10 to ubuntu/quantal

Imported using git-ubuntu import.

Changelog parent: 76212c8eb16da248c9aca83005c6a56467524ff1

New changelog entries:
  * Update config.guess,sub for aarch64

76212c8... by Steve Langasek on 2012-02-16

Import patches-unapplied version 1.0.3-4ubuntu9 to ubuntu/precise

Imported using git-ubuntu import.

Changelog parent: 403ae017d037f005e925d50c0f875efbd53b9a98

New changelog entries:
  * Mark the nih-dbus-tool package Multi-Arch: foreign so it can be used as
    a build-dependency of upstart when cross-building.

403ae01... by Steve Langasek on 2012-02-10

Import patches-unapplied version 1.0.3-4ubuntu8 to ubuntu/precise

Imported using git-ubuntu import.

Changelog parent: c991d3106a3a9e1b429bdc9fae61e56e955234f3

New changelog entries:
  * libnih1 needs a versioned Pre-Depend on libc6 instead of just a Depend,
    because libc6 itself uses runlevel from the upstart package in its
    preinst, which in turn uses libnih1, which needs to be loadable (i.e.,
    its symbol references resolve). We therefore need to ensure that
    libnih1's dependencies are always unpacked before libnih1 itself is
    unpacked. While having something further up the stack (such as upstart,
    or something on top of upstart) being marked Essential: yes and with the
    necessary pre-depends would let apt handle this for us with its
    "immediate configuration" support, but for various reasons we don't want
    to make upstart essential. LP: #508083.

c991d31... by Matthias Klose on 2012-02-08

Import patches-unapplied version 1.0.3-4ubuntu7 to ubuntu/precise

Imported using git-ubuntu import.

Changelog parent: 1cd579aed88d219d25acdd533c580dc59d5f7305

New changelog entries:
  * Relax dependency on libc6.