ubuntu/+source/libnih:ubuntu/precise

Last commit made on 2012-02-16
Get this branch:
git clone -b ubuntu/precise https://git.launchpad.net/ubuntu/+source/libnih
Members of Ubuntu Server Dev import team can upload to this branch. Log in for directions.

Branch merges

Branch information

Name:
ubuntu/precise
Repository:
lp:ubuntu/+source/libnih

Recent commits

76212c8... by Steve Langasek on 2012-02-16

Import patches-unapplied version 1.0.3-4ubuntu9 to ubuntu/precise

Imported using git-ubuntu import.

Changelog parent: 403ae017d037f005e925d50c0f875efbd53b9a98

New changelog entries:
  * Mark the nih-dbus-tool package Multi-Arch: foreign so it can be used as
    a build-dependency of upstart when cross-building.

403ae01... by Steve Langasek on 2012-02-10

Import patches-unapplied version 1.0.3-4ubuntu8 to ubuntu/precise

Imported using git-ubuntu import.

Changelog parent: c991d3106a3a9e1b429bdc9fae61e56e955234f3

New changelog entries:
  * libnih1 needs a versioned Pre-Depend on libc6 instead of just a Depend,
    because libc6 itself uses runlevel from the upstart package in its
    preinst, which in turn uses libnih1, which needs to be loadable (i.e.,
    its symbol references resolve). We therefore need to ensure that
    libnih1's dependencies are always unpacked before libnih1 itself is
    unpacked. While having something further up the stack (such as upstart,
    or something on top of upstart) being marked Essential: yes and with the
    necessary pre-depends would let apt handle this for us with its
    "immediate configuration" support, but for various reasons we don't want
    to make upstart essential. LP: #508083.

c991d31... by Matthias Klose on 2012-02-08

Import patches-unapplied version 1.0.3-4ubuntu7 to ubuntu/precise

Imported using git-ubuntu import.

Changelog parent: 1cd579aed88d219d25acdd533c580dc59d5f7305

New changelog entries:
  * Relax dependency on libc6.

1cd579a... by Matthias Klose on 2012-02-08

Import patches-unapplied version 1.0.3-4ubuntu6 to ubuntu/precise

Imported using git-ubuntu import.

Changelog parent: 544c863555a50e23cea50d03dd1871082891db63

New changelog entries:
  * Rebuild with libc6-dev (>= 2.15~).

544c863... by Steve Langasek on 2011-11-06

Import patches-unapplied version 1.0.3-4ubuntu5 to ubuntu/precise

Imported using git-ubuntu import.

Changelog parent: 32efccb562069e82fb46caf91c50d4bc53b4dba4

New changelog entries:
  * Mark libnih-dev and libnih-dbus-dev Multi-Arch: same as well.

32efccb... by James Hunt on 2011-11-01

Import patches-unapplied version 1.0.3-4ubuntu4 to ubuntu/precise

Imported using git-ubuntu import.

Changelog parent: d06ed8245d62454d9196ddc540068a504843065b

New changelog entries:
  * Make libnih1 and libnih-dbus1 installable using multi-arch.

d06ed82... by Matthias Klose on 2011-10-14

Import patches-unapplied version 1.0.3-4ubuntu3 to ubuntu/precise

Imported using git-ubuntu import.

Changelog parent: 3131e6d1b64f68a3707fadfd887d8f5120e70ca1

New changelog entries:
  * Build to install with eglibc-2.15.

3131e6d... by Matthias Klose on 2011-06-15

Import patches-unapplied version 1.0.3-4ubuntu2 to ubuntu/oneiric

Imported using git-ubuntu import.

Changelog parent: 6b7dfef4b1bc0d99605bfb2c8d4bd8dae77871e1

New changelog entries:
  * Use dpkg-buildflags to get the build flags.
  * Build with the default build flags, don't hard-code -Os. LP: #791315.

6b7dfef... by James Hunt on 2011-05-23

Import patches-unapplied version 1.0.3-4ubuntu1 to ubuntu/oneiric

Imported using git-ubuntu import.

Changelog parent: 85668afcc0940da432b252f30988b3d1381d397c

New changelog entries:
  * Merge from debian unstable. Retained Ubuntu Build-Depends and Priority.

85668af... by Matthias Klose on 2011-02-18

Import patches-unapplied version 1.0.3-1ubuntu1 to ubuntu/natty

Imported using git-ubuntu import.

Changelog parent: 056c5793e290d44d1ab7a4085a2d33b17018584c

New changelog entries:
  * Rebuild with libc6-dev (>= 2.13~).
  * New upstream release:
    - Added support for passing file descriptors over D-Bus to nih-dbus-tool
  * Revert the previous upload. It is never acceptable to simply disable
    tests, especially when it turns out that the test that was disabled
    was failing because there was a serious bug that could cause kernel
    panics for people on boot.
    Test suites are here for a reason.
  * Bumped libdbus Build-Dependency to the version with the bug fix that
    caused the test suite to fail.
  * Disable some tests on ppc64 to build an initial package.
  * Re-add -fPIE to the testsuite on armel, removing all armel-specific tests;
    current gcc-4.4 don't seem affected by the ICE anymore (see LP #398403).
  * Rebuild with libc6-dev (>= 2.12~), after checking that
    __abort_msg is available with the same signature in eglibc 2.12.
  * Don't build the testsuite with -fPIE on armel; LP: #398403.
  * New upstream release:
    - Rename AC_COPYRIGHT to NIH_COPYRIGHT to avoid conflict with other
      packages.
    - Add serial to libnih.m4
    - Add NIH_WITH_LOCAL_LIBNIH macro.
  * Fix use of ${Source-Version} to be ${binary:Version}
  * Add debian/source/format with "1.0" to be future compatible.
  * Bump standards version.
  * New upstream release:
    - Add missing __nih_* symbols to linker version script so that we
      can link Upstart's test suite.
    - Glibc __abort_msg symbol now only linked as a weak symbol.
  * Rebuild to pick up relaxed dependency on libc6, after checking that
    __abort_msg is available with the same signature in eglibc 2.11.
    LP: #508702.
  * debian/control: Add build-dependency on dbus so the test suite can
    pass on the buildds.
  * First upstream release. Previously this code was included in the
    upstart, mountall and ureadahead source packages.