ubuntu/+source/libnih:applied/ubuntu/quantal-devel

Last commit made on 2012-10-04
Get this branch:
git clone -b applied/ubuntu/quantal-devel https://git.launchpad.net/ubuntu/+source/libnih
Members of Ubuntu Server Dev import team can upload to this branch. Log in for directions.

Branch merges

Branch information

Name:
applied/ubuntu/quantal-devel
Repository:
lp:ubuntu/+source/libnih

Recent commits

0e9c637... by James Hunt on 2012-10-03

Import patches-applied version 1.0.3-4ubuntu11 to applied/ubuntu/quantal

Imported using git-ubuntu import.

Changelog parent: dce84f2deeb1ccd99ba655efa6cfd3a74b2e4cf4
Unapplied parent: d6c73b88d8c7487ffdabd8cd9d91087445099206

New changelog entries:
  * Addition of debian/libnih-dbus1.postinst and
    debian/libnih1.postinst to force Upstart re-exec on shutdown
    to avoid unmounting disks uncleanly (LP: #740390).

d6c73b8... by James Hunt on 2012-10-03

Import patches-unapplied version 1.0.3-4ubuntu11 to ubuntu/quantal

Imported using git-ubuntu import.

Changelog parent: ccd690295cfc67e9f4b326ef2161592af275e43e

New changelog entries:
  * Addition of debian/libnih-dbus1.postinst and
    debian/libnih1.postinst to force Upstart re-exec on shutdown
    to avoid unmounting disks uncleanly (LP: #740390).

dce84f2... by Wookey on 2012-10-01

Import patches-applied version 1.0.3-4ubuntu10 to applied/ubuntu/quantal

Imported using git-ubuntu import.

Changelog parent: e35d69ce2359771537ff52e591491f3557772387
Unapplied parent: ccd690295cfc67e9f4b326ef2161592af275e43e

New changelog entries:
  * Update config.guess,sub for aarch64

ccd6902... by Wookey on 2012-10-01

Import patches-unapplied version 1.0.3-4ubuntu10 to ubuntu/quantal

Imported using git-ubuntu import.

Changelog parent: 76212c8eb16da248c9aca83005c6a56467524ff1

New changelog entries:
  * Update config.guess,sub for aarch64

e35d69c... by Steve Langasek on 2012-02-16

Import patches-applied version 1.0.3-4ubuntu9 to applied/ubuntu/precise

Imported using git-ubuntu import.

Changelog parent: cbd6a2f3587380a23d1d9a49774cabade31c6daa
Unapplied parent: 76212c8eb16da248c9aca83005c6a56467524ff1

New changelog entries:
  * Mark the nih-dbus-tool package Multi-Arch: foreign so it can be used as
    a build-dependency of upstart when cross-building.

76212c8... by Steve Langasek on 2012-02-16

Import patches-unapplied version 1.0.3-4ubuntu9 to ubuntu/precise

Imported using git-ubuntu import.

Changelog parent: 403ae017d037f005e925d50c0f875efbd53b9a98

New changelog entries:
  * Mark the nih-dbus-tool package Multi-Arch: foreign so it can be used as
    a build-dependency of upstart when cross-building.

cbd6a2f... by Steve Langasek on 2012-02-10

Import patches-applied version 1.0.3-4ubuntu8 to applied/ubuntu/precise

Imported using git-ubuntu import.

Changelog parent: 9dbd86d6499b04157ca278a30c7a64bbdc817be6
Unapplied parent: 403ae017d037f005e925d50c0f875efbd53b9a98

New changelog entries:
  * libnih1 needs a versioned Pre-Depend on libc6 instead of just a Depend,
    because libc6 itself uses runlevel from the upstart package in its
    preinst, which in turn uses libnih1, which needs to be loadable (i.e.,
    its symbol references resolve). We therefore need to ensure that
    libnih1's dependencies are always unpacked before libnih1 itself is
    unpacked. While having something further up the stack (such as upstart,
    or something on top of upstart) being marked Essential: yes and with the
    necessary pre-depends would let apt handle this for us with its
    "immediate configuration" support, but for various reasons we don't want
    to make upstart essential. LP: #508083.

403ae01... by Steve Langasek on 2012-02-10

Import patches-unapplied version 1.0.3-4ubuntu8 to ubuntu/precise

Imported using git-ubuntu import.

Changelog parent: c991d3106a3a9e1b429bdc9fae61e56e955234f3

New changelog entries:
  * libnih1 needs a versioned Pre-Depend on libc6 instead of just a Depend,
    because libc6 itself uses runlevel from the upstart package in its
    preinst, which in turn uses libnih1, which needs to be loadable (i.e.,
    its symbol references resolve). We therefore need to ensure that
    libnih1's dependencies are always unpacked before libnih1 itself is
    unpacked. While having something further up the stack (such as upstart,
    or something on top of upstart) being marked Essential: yes and with the
    necessary pre-depends would let apt handle this for us with its
    "immediate configuration" support, but for various reasons we don't want
    to make upstart essential. LP: #508083.

9dbd86d... by Matthias Klose on 2012-02-08

Import patches-applied version 1.0.3-4ubuntu7 to applied/ubuntu/precise

Imported using git-ubuntu import.

Changelog parent: 3c9d2c212eccc0813d505b81148bbe3b7ff78714
Unapplied parent: c991d3106a3a9e1b429bdc9fae61e56e955234f3

New changelog entries:
  * Relax dependency on libc6.

c991d31... by Matthias Klose on 2012-02-08

Import patches-unapplied version 1.0.3-4ubuntu7 to ubuntu/precise

Imported using git-ubuntu import.

Changelog parent: 1cd579aed88d219d25acdd533c580dc59d5f7305

New changelog entries:
  * Relax dependency on libc6.