ubuntu/+source/libmoose-perl:applied/ubuntu/zesty-devel

Last commit made on 2016-12-26
Get this branch:
git clone -b applied/ubuntu/zesty-devel https://git.launchpad.net/ubuntu/+source/libmoose-perl
Members of Ubuntu Server Dev import team can upload to this branch. Log in for directions.

Branch merges

Branch information

Name:
applied/ubuntu/zesty-devel
Repository:
lp:ubuntu/+source/libmoose-perl

Recent commits

5646fa1... by gregor herrmann on 2016-12-26

Import patches-applied version 2.1807-1 to applied/debian/sid

Imported using git-ubuntu import.

Changelog parent: 935783eec5ac26f21c5627c109b06a8913f17d5b
Unapplied parent: 5248d6d092e75f58a37746bccb6584a5b0f37411

New changelog entries:
  * Import upstream version 2.1807.

5248d6d... by gregor herrmann on 2016-12-26

Fixes manpage-has-errors-from-man

Gbp-Pq: 02_fix-manpages-errors.patch.

b7f0f30... by gregor herrmann on 2016-12-26

[PATCH] Work around a numification problem on ia64

Gbp-Pq: 0001-Work-around-a-numification-problem-on-ia64.patch.

7570915... by gregor herrmann on 2016-12-26

Import patches-unapplied version 2.1807-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 82fb0045b7d80500069f8152203a071c07f5220e

New changelog entries:
  * Import upstream version 2.1807.

82fb004... by gregor herrmann on 2016-10-30

Import patches-unapplied version 2.1806-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: d8ae75b4299d7def391bf4cd7eb930710795a6cf

New changelog entries:
  * Import upstream version 2.1806.
  * Refresh 02_fix-manpages-errors.patch (offset).

d8ae75b... by gregor herrmann on 2016-08-29

Import patches-unapplied version 2.1805-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 2a10ae12cd1a355a902daded39e2d753d694c01e

New changelog entries:
  * Remove Brian Cassidy, Iulian Udrea, Jonathan Yu, Jose Luis Rivas,
    Rene Mayorga, Ryan Niebur from Uploaders. Thanks for your work!
  * Import upstream version 2.1805.
  * debian/copyright: remove paragraph about inc/Config.pm which was
    removed from the tarball.

2a10ae1... by gregor herrmann on 2016-07-23

Import patches-unapplied version 2.1804-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 462f73966e43b0b3d1df1a46743bf815088a15e7

New changelog entries:
  * Import upstream version 2.1804.
  * Update Build-Depends, Depends, Recommends, Breaks according to
    new upstream requirements.
  * Remove version constraints from (build) dependencies which are already
    satisfied in oldstable.
  * Remove Breaks/Replaces on libclass-mop-perl.
    Class::MOP was merged into Moose in 2011, and the separate package removed
    in 2011. It's not even in oldstable anymore.
  * Add info about new third-party files to debian/copyright.
  * Run more smoke tests under autopkgtest.

462f739... by intrigeri on 2016-07-08

Import patches-unapplied version 2.1605-2 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 74dc23368e4a57011a631cb73cc974dd9e67454e

New changelog entries:
  * Team upload.
  [ gregor herrmann ]
  * Change bugtracker URL(s) to HTTPS.
  * debian/copyright: change Copyright-Format 1.0 URL to HTTPS.
  * debian/upstream/metadata: use HTTPS for GitHub URLs.
  [ intrigeri ]
  * Enable all hardening build flags.
  * Declare compliance with Standards-Version 3.9.8.

74dc233... by gregor herrmann on 2016-02-19

Import patches-unapplied version 2.1605-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: fb7ea03a4e4b9a4d7c56d3abac5c8bcf4e9829db

New changelog entries:
  [ Salvatore Bonaccorso ]
  * debian/control: Use HTTPS transport protocol for Vcs-Git URI
  [ gregor herrmann ]
  * Import upstream version 2.1605.
  * Update years of packaging copyright.
  * Add (build) dependency on JSON::PP 2.27300.
  * Declare compliance with Debian Policy 3.9.7.

fb7ea03... by gregor herrmann on 2015-11-08

Import patches-unapplied version 2.1604-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: bccaae8e3141a2edccae3ba4c8807bf048670f6a

New changelog entries:
  * Import upstream version 2.1604.
  * Bump versioned build dependency on libcpan-meta-check-perl.