ubuntu/+source/libmoose-perl:applied/ubuntu/cosmic

Last commit made on 2018-06-23
Get this branch:
git clone -b applied/ubuntu/cosmic https://git.launchpad.net/ubuntu/+source/libmoose-perl
Members of Ubuntu Server Dev import team can upload to this branch. Log in for directions.

Branch merges

Branch information

Name:
applied/ubuntu/cosmic
Repository:
lp:ubuntu/+source/libmoose-perl

Recent commits

48bd6ce... by gregor herrmann on 2018-06-23

Import patches-applied version 2.2011-1 to applied/debian/sid

Imported using git-ubuntu import.

Changelog parent: 8df5561e3586259f994e9de10159f917936e6184
Unapplied parent: 45aa7ff7e89343108f71ec099c1eb6379344172c

New changelog entries:
  * Import upstream version 2.2011.
  * Refresh 02_fix-manpages-errors.patch (offset).
  * Update years of packaging copyright.
  * Declare compliance with Debian Policy 4.1.4.
  * Bump debhelper compatibility level to 10.

45aa7ff... by gregor herrmann on 2018-06-23

Fixes manpage-has-errors-from-man

Gbp-Pq: 02_fix-manpages-errors.patch.

82ee6a8... by gregor herrmann on 2018-06-23

[PATCH] Work around a numification problem on ia64

Gbp-Pq: 0001-Work-around-a-numification-problem-on-ia64.patch.

1645f02... by gregor herrmann on 2018-06-23

Import patches-unapplied version 2.2011-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: f76fcf7874463c7e333ec97f5a7283d07400b0d0

New changelog entries:
  * Import upstream version 2.2011.
  * Refresh 02_fix-manpages-errors.patch (offset).
  * Update years of packaging copyright.
  * Declare compliance with Debian Policy 4.1.4.
  * Bump debhelper compatibility level to 10.

f76fcf7... by Damyan Ivanov on 2018-03-18

Import patches-unapplied version 2.2010-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 55898535e286ea1e10d7906403090587c40a2807

New changelog entries:
  [ Damyan Ivanov ]
  * declare conformance with Policy 4.1.3 (no changes needed)
  [ Salvatore Bonaccorso ]
  * Update Vcs-* headers for switch to salsa.debian.org
  [ Damyan Ivanov ]
  * New upstream version 2.2010
  * bump libdevel-overload-info-perl (build-) dependency to 0.005

5589853... by Damyan Ivanov on 2017-12-21

Import patches-unapplied version 2.2009-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 7570915b840185fd7c3606098415f9242b284579

New changelog entries:
  [ gregor herrmann ]
  * Drop debian/tests/pkg-perl/smoke-tests, handled by pkg-perl-
    autopkgtest now.
  [ Alex Muntada ]
  * Remove inactive pkg-perl members from Uploaders.
  [ Damyan Ivanov ]
  * New upstream version 2.2009
  * update versions of (build) dependencies
  * declare conformance with Policy 4.1.2 (no changes)

7570915... by gregor herrmann on 2016-12-26

Import patches-unapplied version 2.1807-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 82fb0045b7d80500069f8152203a071c07f5220e

New changelog entries:
  * Import upstream version 2.1807.

82fb004... by gregor herrmann on 2016-10-30

Import patches-unapplied version 2.1806-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: d8ae75b4299d7def391bf4cd7eb930710795a6cf

New changelog entries:
  * Import upstream version 2.1806.
  * Refresh 02_fix-manpages-errors.patch (offset).

d8ae75b... by gregor herrmann on 2016-08-29

Import patches-unapplied version 2.1805-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 2a10ae12cd1a355a902daded39e2d753d694c01e

New changelog entries:
  * Remove Brian Cassidy, Iulian Udrea, Jonathan Yu, Jose Luis Rivas,
    Rene Mayorga, Ryan Niebur from Uploaders. Thanks for your work!
  * Import upstream version 2.1805.
  * debian/copyright: remove paragraph about inc/Config.pm which was
    removed from the tarball.

2a10ae1... by gregor herrmann on 2016-07-23

Import patches-unapplied version 2.1804-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 462f73966e43b0b3d1df1a46743bf815088a15e7

New changelog entries:
  * Import upstream version 2.1804.
  * Update Build-Depends, Depends, Recommends, Breaks according to
    new upstream requirements.
  * Remove version constraints from (build) dependencies which are already
    satisfied in oldstable.
  * Remove Breaks/Replaces on libclass-mop-perl.
    Class::MOP was merged into Moose in 2011, and the separate package removed
    in 2011. It's not even in oldstable anymore.
  * Add info about new third-party files to debian/copyright.
  * Run more smoke tests under autopkgtest.