ubuntu/+source/libmail-dkim-perl:applied/ubuntu/devel

Last commit made on 2019-09-17
Get this branch:
git clone -b applied/ubuntu/devel https://git.launchpad.net/ubuntu/+source/libmail-dkim-perl
Members of Ubuntu Server Dev import team can upload to this branch. Log in for directions.

Branch merges

Branch information

Name:
applied/ubuntu/devel
Repository:
lp:ubuntu/+source/libmail-dkim-perl

Recent commits

fc02e26... by Magnus Holmgren on 2019-09-16

Import patches-applied version 0.56-1 to applied/debian/sid

Imported using git-ubuntu import.

Changelog parent: 2e31fa1f182a16eb9e27e29699a571b0ecc699ef
Unapplied parent: 651b6733bbe1d9ccdf8d6f54ce8fb8e038fc1f5f

New changelog entries:
  * New upstream release (Closes: #927005).
  * Add libmail-authenticationresults-perl dependency.
  * Move packaging to salsa.debian.org and maintainership to the Perl
    group with myself as uploader.
  * Add upstream metadata.
  * Reorder dependencies to match between Build-Depends and Depends, drop
    very old version requirements, drop Breaks/Replaces on dkimproxy, mark
    Perl module build dependencies as test-only, and mark package as
    autopkgtest-able.
  * Switch to Debhelper compat level 12 by build-depending on
    debhelper-compat (= 12).
  * pod_errors.patch: Fix minor POD error that Lintian's been warning
    about for some time.
  * README.Debian: Update patent claim info and URL to DKIM homepage.
  * Include some more documentation files from the source package.
  * Add NEWS.gz as symlink to Changes in accordance with policy 12.7 since
    version 4.2.0 and restore ChangeLog as changelog.gz.
  * Mention ARC in package description.

651b673... by Magnus Holmgren on 2019-09-16

Delete spurious =back that causes pod2man warning

Gbp-Pq: pod_errors.patch.

0e8c929... by Magnus Holmgren on 2019-09-16

Import patches-unapplied version 0.56-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: dd94c8e90093e07974213ef440acb107ba57cf0d

New changelog entries:
  * New upstream release (Closes: #927005).
  * Add libmail-authenticationresults-perl dependency.
  * Move packaging to salsa.debian.org and maintainership to the Perl
    group with myself as uploader.
  * Add upstream metadata.
  * Reorder dependencies to match between Build-Depends and Depends, drop
    very old version requirements, drop Breaks/Replaces on dkimproxy, mark
    Perl module build dependencies as test-only, and mark package as
    autopkgtest-able.
  * Switch to Debhelper compat level 12 by build-depending on
    debhelper-compat (= 12).
  * pod_errors.patch: Fix minor POD error that Lintian's been warning
    about for some time.
  * README.Debian: Update patent claim info and URL to DKIM homepage.
  * Include some more documentation files from the source package.
  * Add NEWS.gz as symlink to Changes in accordance with policy 12.7 since
    version 4.2.0 and restore ChangeLog as changelog.gz.
  * Mention ARC in package description.

2e31fa1... by Magnus Holmgren on 2018-12-04

Import patches-applied version 0.54-1 to applied/debian/sid

Imported using git-ubuntu import.

Changelog parent: cebde54c773ba96f4f3ae4000e1d30bb57a5846f
Unapplied parent: dd94c8e90093e07974213ef440acb107ba57cf0d

New changelog entries:
  * New upstream release.
  * Build-depend on libnet-dns-resolver-mock-perl to enable tests to
    succeed.

dd94c8e... by Magnus Holmgren on 2018-12-04

Import patches-unapplied version 0.54-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 38acae5fff90597725343a08047c47f82062883a

New changelog entries:
  * New upstream release.
  * Build-depend on libnet-dns-resolver-mock-perl to enable tests to
    succeed.

cebde54... by Magnus Holmgren on 2018-06-24

Import patches-applied version 0.53-1 to applied/debian/sid

Imported using git-ubuntu import.

Changelog parent: db20ccd40e8c18e46805b97231ad2b73ee37d79a
Unapplied parent: 38acae5fff90597725343a08047c47f82062883a

New changelog entries:
  * New upstream release.
  * Update debian/copyright.
  * Update debian/watch to use metacpan.org instead of search.cpan.org.
  * Add dependencies libyaml-libyaml-perl, libtest-requiresinternet-perl
    for tests.
  * Ensure that the shebang of the sign and verify scripts is just
    "#!/usr/bin/perl" (policy 10.4). Increase Standards-Version to 4.1.4.

38acae5... by Magnus Holmgren on 2018-06-24

Import patches-unapplied version 0.53-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 051523192bf086d1b0eb53d9dc1f044514818481

New changelog entries:
  * New upstream release.
  * Update debian/copyright.
  * Update debian/watch to use metacpan.org instead of search.cpan.org.
  * Add dependencies libyaml-libyaml-perl, libtest-requiresinternet-perl
    for tests.
  * Ensure that the shebang of the sign and verify scripts is just
    "#!/usr/bin/perl" (policy 10.4). Increase Standards-Version to 4.1.4.

db20ccd... by Magnus Holmgren on 2017-10-21

Import patches-applied version 0.44-1 to applied/debian/sid

Imported using git-ubuntu import.

Changelog parent: e8164bfb84a055699ad64ca59d8dbd2182458f31
Unapplied parent: 051523192bf086d1b0eb53d9dc1f044514818481

New changelog entries:
  * New upstream release.
  * Bump Standards-Version to 4.1.1.

0515231... by Magnus Holmgren on 2017-10-21

Import patches-unapplied version 0.44-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: d281103a29790c99602b8661154d03127b2b71b3

New changelog entries:
  * New upstream release.
  * Bump Standards-Version to 4.1.1.

e8164bf... by Magnus Holmgren on 2017-09-16

Import patches-applied version 0.42-1 to applied/debian/sid

Imported using git-ubuntu import.

Changelog parent: 072bf9ae48bada846a864a3c3b1e0d6bb4062efa
Unapplied parent: d281103a29790c99602b8661154d03127b2b71b3

New changelog entries:
  * New upstream release.
  * Switch to Debhelper compat level 9 and convert debian/rules to dh
    style.
  * debian/docs: Include doc/policies.txt and doc/dkim_errata.txt. README
    is now README.md.
  * Bump Standards-Version to 4.1.0.