ubuntu/+source/libktorrent:ubuntu/devel

Last commit made on 2017-09-01
Get this branch:
git clone -b ubuntu/devel https://git.launchpad.net/ubuntu/+source/libktorrent
Members of Ubuntu Server Dev import team can upload to this branch. Log in for directions.

Branch merges

Branch information

Name:
ubuntu/devel
Repository:
lp:ubuntu/+source/libktorrent

Recent commits

5a714c0... by Rik Mills on 2017-09-01

Import patches-unapplied version 2.1.0-0ubuntu1 to ubuntu/artful-proposed

Imported using git-ubuntu import.

Changelog parent: bee26a1e58b035017819bd2b17f4052d86622027

New changelog entries:
  * New upstream release (2.1.0)

bee26a1... by Rik Mills on 2017-08-21

Import patches-unapplied version 2.0.90-0ubuntu1 to ubuntu/artful-proposed

Imported using git-ubuntu import.

Changelog parent: 19633ec18d81ed87d378ad4056e764eb8cb69d48

New changelog entries:
  * New upstream RC release (2.0.90)
  * Switch kio depends to new KF5 name: kio-dev -> libkf5kio-dev
  * wrap-and-sort
  * Update symbols from build logs
  * Libraries and development files now have KF5 style paths and names,
    so update install files accordingly.
  * debian/patches: drop cmake-gcrypt-version.diff as similar fix applied
    in upstream master

19633ec... by Pino Toscano <email address hidden> on 2016-07-03

Import patches-unapplied version 2.0.1-1 to debian/experimental

Imported using git-ubuntu import.

Changelog parent: 6be88cce3a462af721974521c4e43edc867bd2e6

New changelog entries:
  * Team upload.
  * New upstream release.
  * Update the build dependencies following the port to Frameworks:
    - remove kdelibs5-dev and libqca2-dev
    - add extra-cmake-modules, qtbase5-dev, libkf5archive-dev, libkf5crash-dev,
      libkf5i18n-dev, kio-dev, libkf5solid-dev, and libqca-qt5-2-dev
  * Use the right dh addon:
    - switch from kde to kf5 dh addon
    - bump the pkg-kde-tools build dependency to >= 0.15.16
  * Rename libktorrent5 to libktorrent6, following the SONAME bump.
  * Update the patches:
    - upstream_don-t-include-circular_buffer-in-moc-run.patch: drop,
      backported from upstream
    - set-pathmax.diff: refresh
  * Fix extraction in cmake of the libcrypt version; patch
    cmake-gcrypt-version.diff.
  * Update install files.
  * Update symbols file.
  * Remove libktorrent-dbg in favour of the -dbgsym packages.
  * Update dependencies in libktorrent-dev.
  * Update Vcs-* fields.
  * Switch Homepage away from the dead ktorrent.org.
  * Add a watch file.
  * Bump Standards-Version to 3.9.8, no changes required.
  * Mark libktorrent6 as "Multi-Arch: same".
  * Small updates in the descriptions.
  * Replace (build) dependencies with non-transitional packages:
    - libgmp3-dev -> libgmp-dev
    - libgcrypt11-dev -> libgcrypt20-dev
  * Minor copyright update.

6be88cc... by Scott Kitterman on 2015-08-30

Import patches-unapplied version 1.3.1-5 to debian/sid

Imported using git-ubuntu import.

Changelog parent: a8f1b68af90dceea77378b2e0abd2628dc5e6519

New changelog entries:
  * Team upload.
  * Update symbols from build logs
  * Add definition of PATH_MAX when not otherwise defined to fix FTBFS on
    hurd-i386 (Closes: #762581)
    - Thanks to Svante Signell for the patch

a8f1b68... by Scott Kitterman on 2015-08-30

Import patches-unapplied version 1.3.1-4 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 9f4f56c098426ab8d94dfd49e4c1a974ddb6af46

New changelog entries:
  * Team upload.
  [ Matthias Klose ]
  * Update symbols file for GCC 5. (Closes: #777954)
  [ Harald Sitter ]
  * Add upstream_don-t-include-circular_buffer-in-moc-run.patch from upstream
    to not include the circular_buffer boost header during meta object
    compilation as it causes Qt4's MOC to fail on BOOST_JOIN which it cannot
    process due to implementation limitations.
  [ Adam Conrad ]
  * Build-depend on libgcrypt11-dev
  [ Scott Kitterman ]
  * Backport gcc5 and boost1.58 changes from Ubuntu
  * Bump standards version to 3.9.6 without further change

9f4f56c... by Modestas Vainius <email address hidden> on 2013-11-06

Import patches-unapplied version 1.3.1-3 to debian/sid

Imported using git-ubuntu import.

Changelog parent: bb342528111130abff14db5795d76205eaeaf688

New changelog entries:
  * Confirm symbols file on all arches, fixes FTBFSes.

bb34252... by Modestas Vainius <email address hidden> on 2013-01-27

Import patches-unapplied version 1.3.1-2 to debian/sid

Imported using git-ubuntu import.

Changelog parent: f7943d68f7a08d9769e7d5d3a90343ab25860c5b

New changelog entries:
  * Make libktorrent suggest greater or equal version of -l10n.
  * Bump Standards-Version to 3.9.5: no further changes needed.
  * Update Vcs URL in debian/control to canonical ones.
  * Update symbols file for boost 1.54 and gcc 4.8.
  * Build with hardening flags.
  * Upload to unstable.

f7943d6... by Modestas Vainius <email address hidden> on 2013-01-27

Import patches-unapplied version 1.3.1-1 to debian/experimental

Imported using git-ubuntu import.

Changelog parent: 34889c0ab4fd2032bab7531659e656969c809ae2

New changelog entries:
  * New upstream release.

34889c0... by Modestas Vainius <email address hidden> on 2012-09-29

Import patches-unapplied version 1.3.0-1 to debian/experimental

Imported using git-ubuntu import.

Changelog parent: 4f6ae3cef5c3efa44be60a5d0e87ec7479c83f03

New changelog entries:
  * New upstream release.
  * SOVERSION changed to 5, make appropriate changes in packaging.
  * Update symbol file, all symbols are at version 1.3.0 now.
  * Bump Standards-Version to 3.9.4: no changes needed.

4f6ae3c... by Modestas Vainius <email address hidden> on 2012-06-21

Import patches-unapplied version 1.2.1-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: e45777761cc02d97200b4850e6ca2e4473a6b20b

New changelog entries:
  * New upstream release.
  * Confirm symbol file on all arches.
  * Update symbol file for 1.2.1.