ubuntu/+source/libindi:ubuntu/eoan-proposed

Last commit made on 2019-08-04
Get this branch:
git clone -b ubuntu/eoan-proposed https://git.launchpad.net/ubuntu/+source/libindi
Members of Ubuntu Server Dev import team can upload to this branch. Log in for directions.

Branch merges

Branch information

Name:
ubuntu/eoan-proposed
Repository:
lp:ubuntu/+source/libindi

Recent commits

a016024... by Steve Langasek on 2019-08-04

Import patches-unapplied version 1.7.5+dfsg-1build1 to ubuntu/eoan-proposed

Imported using git-ubuntu import.

Changelog parent: 4c90fecd1f7f9b420b244f3d07f38eb663bb90f4

New changelog entries:
  * No-change rebuild against libcfitsio8

4c90fec... by Pino Toscano <email address hidden> on 2018-11-24

Import patches-unapplied version 1.7.5+dfsg-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: fe09f640d8db7294d697c9d818ff12d4408c4533

New changelog entries:
  * New upstream release.
  * Bump Standards-Version to 4.2.1, no changes required.

fe09f64... by Pino Toscano <email address hidden> on 2018-08-21

Import patches-unapplied version 1.7.4+dfsg-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 61b01d051c0c317284ee5e5905b1c5aa9009b9cd

New changelog entries:
  * New upstream release.
  * Bump Standards-Version to 4.2.0, no changes required.

61b01d0... by Pino Toscano <email address hidden> on 2018-04-28

Import patches-unapplied version 1.7.2+dfsg-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 34c46e0ff368bdaad70a83c141697abcf55d1634

New changelog entries:
  * New upstream release.
  * Since we alre already repacking, exclude the upstream 'debian'
    subdirectory.
  * Run dh_missing with --fail-missing, to not miss any installed file.
  * Bump Standards-Version to 4.1.4, no changes required.

34c46e0... by Pino Toscano <email address hidden> on 2018-03-08

Import patches-unapplied version 1.6.2+dfsg-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 823701b3b4ccda4fcbfe8d0ce0f6dcaacdb8976a

New changelog entries:
  * New upstream release.
  * Update the patches:
    - upstream_cmake-rewrite-libusb-1.0-search.patch: drop, backported
      from upstream
    - upstream_Fix-libusb.h-include.patch: drop, backported from
      upstream
    - use_termios.diff: drop, fixed upstream
    - path_max.diff: refresh, and add new needed hunk to it
  * Give up on symbols files: upstream does not seem to keep any compatibility
    anyway, plus the libraries are built without hidden visibility (exposing
    all the symbols), so the work needed basically gives no gain. Just rely
    on the current shlib version as dependency for users of the libraries.
  * Add the libogg-dev, and libtheora-dev build dependencies.
  * Link in as-needed mode.
  * Bump Standards-Version to 4.1.3, no changes required.
  * Bump the debhelper compatibility to 11:
    - bump the debhelper build dependency to 11~
    - bump compat to 11
    - remove --parallel for dh, as now done by default
  * Switch Vcs-* fields to salsa.debian.org.

823701b... by Pino Toscano <email address hidden> on 2017-12-02

Import patches-unapplied version 1.4.1+dfsg-3 to debian/sid

Imported using git-ubuntu import.

Changelog parent: cbe0a25214fefa439c1d2d94461b216f2b7d2392

New changelog entries:
  * Upload to unstable.

cbe0a25... by Pino Toscano <email address hidden> on 2017-11-25

Import patches-unapplied version 1.4.1+dfsg-2 to debian/experimental

Imported using git-ubuntu import.

Changelog parent: b001d2f202d64da02c8372483ef69ca710a47e31

New changelog entries:
  * Backport upstream commit b6fc36c4e3df7321ba2fa41d4c1a9d91fc32eef3 to fix
    the cmake search for libusb-1.0 (most for non-Linux architectures); patch
    upstream_cmake-rewrite-libusb-1.0-search.patch.
  * Backport upstream commit 921b6a1a5536642967ea4c3d481a48fd8a2ed296 to fix
    one libusb.h include; patch upstream_Fix-libusb.h-include.patch.
  * Include termios.h instead of termio.h for portability; patch
    use_termios.diff.
  * Workaround PATH_MAX usages; patch path_max.diff.
  * Update symbols files.

b001d2f... by Pino Toscano <email address hidden> on 2017-11-24

Import patches-unapplied version 1.4.1+dfsg-1 to debian/experimental

Imported using git-ubuntu import.

Changelog parent: 73d93bb9cf024f0b13d73a1970121761b29825ec

New changelog entries:
  * New upstream release.
  * Update the patches:
    - freebsd_support: drop, applied/fixed upstream
  * Drop the libindi1 binary, as that shared library is not provided anymore.
  * Stop exporting CFLAGS, CXXFLAGS, and LDFLAGS in rules, as debhelper already
    exports them.
  * The actual indi sources are under a libindi subdirectory, so pass -Dlibindi
    to dh.
  * Do not define LIB_SUFFIX for cmake anymore, as the build system already
    respects the system default library directory.
  * Update symbols files.
  * Update copyright.
  * Exclude '3rdparty', and 'macosx' subdirectory from the upstream tarball:
    - mention these changes in copyright
    - use a +dfsg suffix for the version

73d93bb... by Pino Toscano <email address hidden> on 2017-11-23

Import patches-unapplied version 1.2.0-6 to debian/sid

Imported using git-ubuntu import.

Changelog parent: abc3c6500add110878fce4aa866f9f356e3c6c8d

New changelog entries:
  * Update symbols files.
  * Update watch file to point to GitHub.
  * Bump Standards-Version to 4.1.1, no changes required.

abc3c65... by Pino Toscano <email address hidden> on 2017-08-26

Import patches-unapplied version 1.2.0-5 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 1baef175479c3867c6975be543de99dc15a33631

New changelog entries:
  * Update symbols files.