ubuntu/+source/libgtop2:ubuntu/intrepid

Last commit made on 2008-10-17
Get this branch:
git clone -b ubuntu/intrepid https://git.launchpad.net/ubuntu/+source/libgtop2
Members of Ubuntu Server Dev import team can upload to this branch. Log in for directions.

Branch merges

Branch information

Name:
ubuntu/intrepid
Repository:
lp:ubuntu/+source/libgtop2

Recent commits

7d42263... by Martin Pitt on 2008-10-17

Import patches-unapplied version 2.24.0-0ubuntu2 to ubuntu/intrepid

Imported using git-ubuntu import.

Changelog parent: 9fcd73c2a4fabd5cd8b7f15c02090ceff80908c1

New changelog entries:
  * Rename source to libgtop2, as Debian did. The libgtop source will be
    removed, as in Debian.
  * New upstream version
  * New upstream version
  * New upstream version:
    - fixed parsing of huge /proc/stat.
  * New upstream version:
    linux:
    - fixed proc_kernel.
  * New upstream version:
    linux:
    - fixed smaps parsing on >= 2.6.24.x.
  * New upstream development release; no API change.
    - Upstream news:
      . freebsd:
        - fixed build on GNU/kfreebsd. Petr Salinger.
        - fixed procmem units. Kuang-che Wu.
      . New and updated translations.
  * Sync with Debian:
  * debian/changelog:
    - use upstream naming
  * debian/control.in:
    - use my ubuntu email address there
  * debian/libgtop2-dev.install:
    - install html documentation
  * New upstream version:
    * don't export _p/_s private symbols anymore.
      This is not an API/ABI breakage.
    * linux:
      - splitted fsusage and mountlist implementations;
      - smarter mountlist(allfs = False);
      - fixed some compile warning on 64bit;
  * New upstream release, with some API additions.
  * debian/control.in:
    + Remove libpopt-dev from build-depends.
  * debian/rules:
    + Bump shlibs to >= 2.20.0.
  * New upstream stable release, with some API and ABI removals of
    glibtop_init_*() functions which shouldn't have been public and are not
    known to be used by anything else.
  * Upload to unstable; drop check-dist include.
  * Add CVE id, GNOME bug id, and SVN rev to 2.14.8-1.
  * Bump up Debhelper compatibility level to 5; fix bogus /usr/include/gnome
    in libgtop2-dev.install.
  * Update watch file to track all stable branches and use HTTP.
  * Drop useless debian/libgtop-dev.postinst; cleanups.
  * Wrap build-deps and deps.
  * Include the new check-dist Makefile to prevent accidental uploads to
    unstable; bump build-dep on gnome-pkg-tools to >= 0.10.
  * New upstream stable releases.
    - 2.14.7 fixed CVE-2007-0235; GNOME #396477; SVN r2546.

9fcd73c... by Loïc Minier on 2007-01-14

Import patches-unapplied version 2.14.6-1 to ubuntu/feisty

Imported using git-ubuntu import.

Changelog parent: 84d4ed95f7fa4982f862fe1597b975e8eb1a09b9

New changelog entries:
  * Add a get-orig-source target to retrieve the upstream tarball.
  * New upstream release; no API or ABI change.
  * New upstream release.
    - Target at experimental.
    - Drop patch 10_kfreebsd, merged upstream.

84d4ed9... by Loïc Minier on 2006-11-19

Import patches-unapplied version 2.14.4-2 to ubuntu/feisty

Imported using git-ubuntu import.

Changelog parent: 52e62f58cb73d43bfdd3070bf78f0d47f9af9928

New changelog entries:
  * New patch, 10_kfreebsd, to build-depend and depend on libkvm-dev on
    kfreebsd, to update the m4 macros to detect __FreeBSD_kernel__, and to
    update configure; thanks Petr Salinger; closes: #399270.
  * New upstream release; no API change.
  * New upstream release; no API changes.
  * Build-depend on libxml-parser-perl.
  * New upstream release, with API additions.
    - Bump shlibs to >= 2.14.2.
  * Let libgtop2-common also replace the venerable libgtop2. (Closes: #380350)

52e62f5... by Dafydd Harries on 2006-07-04

Import patches-unapplied version 2.14.1-2 to ubuntu/edgy

Imported using git-ubuntu import.

Changelog parent: 6c6cf75a2ec20115d9a65944ff5eee519440a1f8

New changelog entries:
  * Make libgtop2-common arch: all instead of arch: any.

6c6cf75... by Loïc Minier on 2006-06-28

Import patches-unapplied version 2.14.1-1 to ubuntu/edgy

Imported using git-ubuntu import.