ubuntu/+source/libgnomecanvas:debian/jessie

Last commit made on 2013-12-29
Get this branch:
git clone -b debian/jessie https://git.launchpad.net/ubuntu/+source/libgnomecanvas
Members of Ubuntu Server Dev import team can upload to this branch. Log in for directions.

Branch merges

Branch information

Name:
debian/jessie
Repository:
lp:ubuntu/+source/libgnomecanvas

Recent commits

3a937c9... by Josselin Mouette <email address hidden> on 2013-12-27

Import patches-unapplied version 2.30.3-2 to debian/sid

Imported using git-ubuntu import.

Changelog parent: f2a883067cb36dac3aefafa8e63d4cccfec6c38b

New changelog entries:
  * Switch to multiarch. Closes: #695556.
    + Require a MA libglade.
    + Update build-dependencies.
    + Make library and devel packages MA: same, make -common MA:
      foreign.
    + Update installation paths.
  * Drop gnome:Version.
  * Move to section oldlibs.
  * Use dh-autoreconf.
  * 99_ltmain_as-needed.patch: dropped, obsolete.
  * 02_link.patch: new patch. Correctly link the demos.

f2a8830... by Michael Biebl on 2011-07-30

Import patches-unapplied version 2.30.3-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 913747deef88943139c80f486cf2c64cf1a1d73b

New changelog entries:
  [ Josselin Mouette ]
  * Fix -dbg package description. Closes: #588605.
  [ Michael Biebl ]
  * New upstream release. Closes: #629918
  * debian/watch:
    - Switch to .bz2 tarballs.
    - Don't run uupdate.
  * Switch to dpkg source format 3.0 (quilt).
  * Remove obsolete debian/libgnomecanvas2-{common,dev}.files.
  * Bump Standards-Version to 3.9.2. No further changes.
  * Remove old Conflicts/Replaces which are no longer necessary.
  * Bump debhelper compatibility level to 8.
    - Update Build-Depends on debhelper.
    - Strip debian/tmp/ from .install files.
  * Stop installing libtool .la files.
  * Small updates to the description synopsis.

913747d... by David Weinehall on 2010-04-01

Import patches-unapplied version 2.30.1-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: c836f5f1d205c887711876dd6b1654853792a0c7

New changelog entries:
  * New upstream release.
    + debian/patches/01_canvasassert.patch,
    + debian/patches/99_ltmain_as-needed.patch:
      - Refreshed.
    + debian/rules:
      - Added --enable-glade to DEB_CONFIGURE_EXTRA_FLAGS
  * debian/control.in:
    + Bump Standards version to 3.8.4 (No changes needed).
    + Build-Depend on debhelper (>= 5) since we use compat level 5.

c836f5f... by Josselin Mouette <email address hidden> on 2009-04-28

Import patches-unapplied version 2.26.0-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: e64e19b48277df9279c4e287f8f30b89f461fcb7

New changelog entries:
  [ Sven Arvidsson ]
  * Add a -dbg package (Closes: #286973)
  * Bump debhelper compatibility to v5.
  [ Emilio Pozuelo Monfort ]
  * debian/libgnomecanvas2-doc.doc-base: fix section.
  [ Josselin Mouette ]
  * Build-depend on libgail-dev 1.9.0. Closes: #506012.
  * Add libglib2.0-doc and libgtk2.0-doc to b-d-i to ensure proper
    xrefs.
  * New upstream release.
  * Update list of copyright holders.
  * 99_ltmain_as-needed.patch: updated for the new libtool version.
  * Fix section for debugging package.
  * Remove doc-base file, it duplicates the job of devhelp.
  * Don’t use -1 in build-dependencies.
  * Wrap dependencies, add missing ${misc:Depends} and fix some
    versions.

e64e19b... by Sebastian Dröge on 2007-10-25

Import patches-unapplied version 2.20.1.1-1 to debian/lenny

Imported using git-ubuntu import.