ubuntu/+source/libgnomecanvas:applied/debian/stretch

Last commit made on 2016-10-21
Get this branch:
git clone -b applied/debian/stretch https://git.launchpad.net/ubuntu/+source/libgnomecanvas
Members of Ubuntu Server Dev import team can upload to this branch. Log in for directions.

Branch merges

Branch information

Name:
applied/debian/stretch
Repository:
lp:ubuntu/+source/libgnomecanvas

Recent commits

6df7305... by Michael Biebl on 2016-10-21

Import patches-applied version 2.30.3-3 to applied/debian/sid

Imported using git-ubuntu import.

Changelog parent: 0f3fd90696f6469659df613232ea77cc8974402a
Unapplied parent: 81487bdb906ee7826ee7ef7162970e2e279b8dc5

New changelog entries:
  * Run wrap-and-sort -a.
  * Convert from cdbs to dh.
  * Switch to automatic dbgsym packages.
  * Bump debhelper compat level to 10.
  * Add Build-Depends on gnome-common and intltool. Required by autoreconf.
    (Closes: #837829)
  * Add Vcs-* fields.
  * Use xvfb to run the test-suite.
  * Bump Standards-Version to 3.9.8.

81487bd... by Michael Biebl on 2016-10-21

02_link.patch

No DEP3 Subject or Description header found

Gbp-Pq: 02_link.patch.

c092260... by Michael Biebl on 2016-10-21

01_canvasassert.patch

No DEP3 Subject or Description header found

Gbp-Pq: 01_canvasassert.patch.

c7f1d34... by Michael Biebl on 2016-10-21

Import patches-unapplied version 2.30.3-3 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 3a937c98ff6725bd68d3f6b5c6d0a53202995bfa

New changelog entries:
  * Run wrap-and-sort -a.
  * Convert from cdbs to dh.
  * Switch to automatic dbgsym packages.
  * Bump debhelper compat level to 10.
  * Add Build-Depends on gnome-common and intltool. Required by autoreconf.
    (Closes: #837829)
  * Add Vcs-* fields.
  * Use xvfb to run the test-suite.
  * Bump Standards-Version to 3.9.8.

0f3fd90... by Josselin Mouette <email address hidden> on 2013-12-27

Import patches-applied version 2.30.3-2 to applied/debian/sid

Imported using git-ubuntu import.

Changelog parent: 29388ec498c15334c0050047426dcee47fea4bce
Unapplied parent: c0d7755248cc3370f5ef36a9b2fabfeec6cef608

New changelog entries:
  * Switch to multiarch. Closes: #695556.
    + Require a MA libglade.
    + Update build-dependencies.
    + Make library and devel packages MA: same, make -common MA:
      foreign.
    + Update installation paths.
  * Drop gnome:Version.
  * Move to section oldlibs.
  * Use dh-autoreconf.
  * 99_ltmain_as-needed.patch: dropped, obsolete.
  * 02_link.patch: new patch. Correctly link the demos.

3a937c9... by Josselin Mouette <email address hidden> on 2013-12-27

Import patches-unapplied version 2.30.3-2 to debian/sid

Imported using git-ubuntu import.

Changelog parent: f2a883067cb36dac3aefafa8e63d4cccfec6c38b

New changelog entries:
  * Switch to multiarch. Closes: #695556.
    + Require a MA libglade.
    + Update build-dependencies.
    + Make library and devel packages MA: same, make -common MA:
      foreign.
    + Update installation paths.
  * Drop gnome:Version.
  * Move to section oldlibs.
  * Use dh-autoreconf.
  * 99_ltmain_as-needed.patch: dropped, obsolete.
  * 02_link.patch: new patch. Correctly link the demos.

c0d7755... by Josselin Mouette <email address hidden> on 2013-12-27

02_link.patch

No DEP3 Subject or Description header found

Gbp-Pq: 02_link.patch.

ddd7f1f... by Josselin Mouette <email address hidden> on 2013-12-27

01_canvasassert.patch

No DEP3 Subject or Description header found

Gbp-Pq: 01_canvasassert.patch.

29388ec... by Michael Biebl on 2011-07-30

Import patches-applied version 2.30.3-1 to applied/debian/sid

Imported using git-ubuntu import.

Changelog parent: 43ad349df2e486e6a0c6391eeb3ae98eaea6859a
Unapplied parent: 52ebd08277b09082574cd9ad3560bbb4cba1279d

New changelog entries:
  [ Josselin Mouette ]
  * Fix -dbg package description. Closes: #588605.
  [ Michael Biebl ]
  * New upstream release. Closes: #629918
  * debian/watch:
    - Switch to .bz2 tarballs.
    - Don't run uupdate.
  * Switch to dpkg source format 3.0 (quilt).
  * Remove obsolete debian/libgnomecanvas2-{common,dev}.files.
  * Bump Standards-Version to 3.9.2. No further changes.
  * Remove old Conflicts/Replaces which are no longer necessary.
  * Bump debhelper compatibility level to 8.
    - Update Build-Depends on debhelper.
    - Strip debian/tmp/ from .install files.
  * Stop installing libtool .la files.
  * Small updates to the description synopsis.

f2a8830... by Michael Biebl on 2011-07-30

Import patches-unapplied version 2.30.3-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 913747deef88943139c80f486cf2c64cf1a1d73b

New changelog entries:
  [ Josselin Mouette ]
  * Fix -dbg package description. Closes: #588605.
  [ Michael Biebl ]
  * New upstream release. Closes: #629918
  * debian/watch:
    - Switch to .bz2 tarballs.
    - Don't run uupdate.
  * Switch to dpkg source format 3.0 (quilt).
  * Remove obsolete debian/libgnomecanvas2-{common,dev}.files.
  * Bump Standards-Version to 3.9.2. No further changes.
  * Remove old Conflicts/Replaces which are no longer necessary.
  * Bump debhelper compatibility level to 8.
    - Update Build-Depends on debhelper.
    - Strip debian/tmp/ from .install files.
  * Stop installing libtool .la files.
  * Small updates to the description synopsis.