ubuntu/+source/libgcrypt20:ubuntu/eoan-updates

Last commit made on 2020-01-13
Get this branch:
git clone -b ubuntu/eoan-updates https://git.launchpad.net/ubuntu/+source/libgcrypt20
Members of Ubuntu Server Dev import team can upload to this branch. Log in for directions.

Branch merges

Branch information

Name:
ubuntu/eoan-updates
Repository:
lp:ubuntu/+source/libgcrypt20

Recent commits

dc1f272... by Marc Deslauriers on 2019-11-28

Import patches-unapplied version 1.8.4-5ubuntu2.1 to ubuntu/eoan-security

Imported using git-ubuntu import.

Changelog parent: affebdf55c257aff2a5007d95e8ba3a5c8501096

New changelog entries:
  * SECURITY UPDATE: ECDSA timing attack
    - debian/patches/CVE-2019-13627-1.patch: add mitigation against timing
      attack in cipher/ecc-ecdsa.c, mpi/ec.c.
    - debian/patches/CVE-2019-13627-2.patch: fix use of nonce, use larger
      one in cipher/dsa-common.c, cipher/dsa.c, cipher/ecc-ecdsa.c,
      cipher/ecc-gost.c, cipher/pubkey-internal.h.
    - CVE-2019-13627

affebdf... by Steve Langasek on 2019-10-01

Import patches-unapplied version 1.8.4-5ubuntu2 to ubuntu/eoan-proposed

Imported using git-ubuntu import.

Changelog parent: 313ec7da70628b9f2aa7459b241137d5fff54a2e

New changelog entries:
  * Build-depend on texlive-plain-generic instead of obsolete texlive-
    generic-recommended.

313ec7d... by Julian Andres Klode on 2019-04-23

Import patches-unapplied version 1.8.4-5ubuntu1 to ubuntu/eoan-proposed

Imported using git-ubuntu import.

Changelog parent: 9758c4deaa7dafa3e2eac20936f7ffb2dd487432

New changelog entries:
  * Merge from Debian unstable. Remaining changes:
    - Disable the library reading /proc/sys/crypto/fips_enabled file
      and going into FIPS mode. libgcrypt is not a FIPS certified library.
      (LP 1748310)
  * Fix spelling-error-in-patch-description "Decription" -> "Description"

9758c4d... by Andreas Metzler <email address hidden> on 2019-01-20

Import patches-unapplied version 1.8.4-5 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 8d465cc0ac92c1b9b88250fe6075438a985150c1

New changelog entries:
  * 30_doc-Fix-library-initialization-examples.patch from upstream
    LIBGCRYPT-1.8-BRANCH: Stop suggesting gcry_check_version (GCRYPT_VERSION)
    in documentation. Add some touch magic to still allow building without
    makeinfo. See #914009
  * [lintian] Minimize upstream/signing-key.asc.
  * Use dh v11 compatibility level.

8d465cc... by Andreas Metzler <email address hidden> on 2018-12-02

Import patches-unapplied version 1.8.4-4 to debian/sid

Imported using git-ubuntu import.

Changelog parent: e6f5b418e2ea0b217a910f6cccac091a56d64162

New changelog entries:
  * Run "wrap-and-sort --max-line-length=72 --short-indent" and add back
    autodeleted comments.
  * Drop libgcrypt11-dev transition package. Closes: #878654

e6f5b41... by Andreas Metzler <email address hidden> on 2018-10-28

Import patches-unapplied version 1.8.4-3 to debian/sid

Imported using git-ubuntu import.

Changelog parent: b82bdfa0d96d1dc0c7bdabed31993de21668b440

New changelog entries:
  * Fix arch-indep build error by running dh_auto_install for both -arch and
    -indep builds.

b82bdfa... by Andreas Metzler <email address hidden> on 2018-10-27

Import patches-unapplied version 1.8.4-2 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 82ccd862d67eca86db62a135a71be76a5432f9eb

New changelog entries:
  * Upload to unstable.
  * Use dh_missing.
  * Ship info files from installed tree (debian/tmp/) instead of from doc/.

82ccd86... by Andreas Metzler <email address hidden> on 2018-10-27

Import patches-unapplied version 1.8.4-1 to debian/experimental

Imported using git-ubuntu import.

Changelog parent: 4fe5530e673373f0d746e9edcfef16ff1518b288

New changelog entries:
  * New upstream bugfix release.
    + Drop 40-*.patch.

4fe5530... by Andreas Metzler <email address hidden> on 2018-10-26

Import patches-unapplied version 1.8.3-2 to debian/experimental

Imported using git-ubuntu import.

Changelog parent: d9cd194135e88869f20547f66cf0517c860f12ae

New changelog entries:
  * Update from LIBGCRYPT-1.8-BRANCH:
    + 40-01-Post-release-updates.patch
    + 40-02-random-Fix-hang-of-_gcry_rndjent_get_version.patch
    + 40-03-sexp-Fix-uninitialized-use-of-a-var-in-the-error-cas.patch
    + 40-04-ecc-Fix-potential-unintended-freeing-of-an-internal-.patch
    + 40-06-ecc-Fix-possible-memory-leakage-in-parameter-check-o.patch
    + 40-07-ecc-Fix-memory-leak-in-the-error-case-of-ecc_encrypt.patch
    + 40-08-Fix-memory-leak-in-secmem-in-out-of-core-conditions.patch
    + 40-09-doc-Update-yat2m.c-from-upstream-libgpg-error.patch
    + 40-10-build-Add-release-make-target.patch

d9cd194... by Andreas Metzler <email address hidden> on 2018-06-13

Import patches-unapplied version 1.8.3-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 74d8ea788f90a6d1c23674f258b80e07ae20a1f9

New changelog entries:
  * [lintian] Fix spelling-error-in-patch-description in
    15_multiarchpath_in_-L.diff.
  * New upstream version.
    + Use blinding for ECDSA signing to mitigate a novel side-channel
      attack. CVE-2018-0495
  * [lintian] Delete trailing empty lines in changelog.