ubuntu/+source/libfile-remove-perl:applied/ubuntu/quantal

Last commit made on 2012-03-19
Get this branch:
git clone -b applied/ubuntu/quantal https://git.launchpad.net/ubuntu/+source/libfile-remove-perl
Members of Ubuntu Server Dev import team can upload to this branch. Log in for directions.

Branch merges

Branch information

Name:
applied/ubuntu/quantal
Repository:
lp:ubuntu/+source/libfile-remove-perl

Recent commits

8bf8216... by gregor herrmann on 2012-03-19

Import patches-applied version 1.52-1 to applied/debian/sid

Imported using git-ubuntu import.

Changelog parent: 22ebe0ee521ad69c8a8e141a20ae6fb845fe408f
Unapplied parent: 76b43ab64f76769d0085f2672525f18af72f1770

New changelog entries:
  * New upstream release.
  * Update (build) dependencies (needs perl 5.10.1 now).
  * Bump Standards-Version to 3.9.3 (no changes).
  * Update years of upstream and packaging copyright.
  * debian/copyright: update to Copyright-Format 1.0.

76b43ab... by gregor herrmann on 2012-03-19

Import patches-unapplied version 1.52-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 7892227ab12f17e39f4338fe53fa00ee110c8980

New changelog entries:
  * New upstream release.
  * Update (build) dependencies (needs perl 5.10.1 now).
  * Bump Standards-Version to 3.9.3 (no changes).
  * Update years of upstream and packaging copyright.
  * debian/copyright: update to Copyright-Format 1.0.

22ebe0e... by Alessandro Ghedini on 2011-10-28

Import patches-applied version 1.51-1 to applied/debian/sid

Imported using git-ubuntu import.

Changelog parent: 376691abf518f1107ad76822da5542c930eb7eff
Unapplied parent: 7892227ab12f17e39f4338fe53fa00ee110c8980

New changelog entries:
  [ Jonathan Yu ]
  * New upstream release 1.49
  [ Fabrizio Regalli ]
  * New upstream release 1.50
  * Added myself to Uploaders and Copyright
  * Bump to 3.9.2 Standards-Version
  [ Ansgar Burchardt ]
  * debian/control: Convert Vcs-* fields to Git.
  * Drop (build-)dep on libfile-spec-perl as the version provided by perl
    is recent enough.
  [ Salvatore Bonaccorso ]
  * debian/copyright: Replace DEP5 Format-Specification URL from
    svn.debian.org to anonscm.debian.org URL.
  [ Alessandro Ghedini ]
  * New upstream release
  * Update copyright years for inc/Module/*

7892227... by Alessandro Ghedini on 2011-10-28

Import patches-unapplied version 1.51-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 2bda5fd2880916a33202155ef46bae2e34ee9ec8

New changelog entries:
  [ Jonathan Yu ]
  * New upstream release 1.49
  [ Fabrizio Regalli ]
  * New upstream release 1.50
  * Added myself to Uploaders and Copyright
  * Bump to 3.9.2 Standards-Version
  [ Ansgar Burchardt ]
  * debian/control: Convert Vcs-* fields to Git.
  * Drop (build-)dep on libfile-spec-perl as the version provided by perl
    is recent enough.
  [ Salvatore Bonaccorso ]
  * debian/copyright: Replace DEP5 Format-Specification URL from
    svn.debian.org to anonscm.debian.org URL.
  [ Alessandro Ghedini ]
  * New upstream release
  * Update copyright years for inc/Module/*

376691a... by Ansgar Burchardt on 2011-03-11

Import patches-applied version 1.48-1 to applied/debian/sid

Imported using git-ubuntu import.

Changelog parent: 04ee0b97f5d91260ac48ceec21ddd0504436d2f4
Unapplied parent: 2bda5fd2880916a33202155ef46bae2e34ee9ec8

New changelog entries:
  * Team upload.
  * New upstream release.

2bda5fd... by Ansgar Burchardt on 2011-03-11

Import patches-unapplied version 1.48-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 76e35f007cfd8de458641a24c486d92117657c0d

New changelog entries:
  * Team upload.
  * New upstream release.

04ee0b9... by Alessandro Ghedini on 2011-03-06

Import patches-applied version 1.46-1 to applied/debian/sid

Imported using git-ubuntu import.

Changelog parent: 0484a208b0217d1a558c635cc4bc16d1ddfa3bdb
Unapplied parent: 76e35f007cfd8de458641a24c486d92117657c0d

New changelog entries:
  [ Salvatore Bonaccorso ]
  * Update my email address.
  [ Alessandro Ghedini ]
  * New upstream release
    - Fix test failure with new Perl::MinimumVersion (remove
      fix_META.yml_min_required_perl_version.patch patch)
    - Remove B-D-I on libtest-minimumversion-perl, libtest-cpan-meta-perl,
      libtest-pod-perl, libpod-simple-perl (extra tests are not run)
    - Don't set AUTOMATED_TESTING=1 in debian/rules (extra tests are not run)
  * Switch to 3.0 (quilt)
    - Remove Build-Depends on quilt
    - Remove '--with quilt' from debian/rules
    - Remove debian/README.source file
  * Bump debhelper to 8
  * Bump Standards-Version (no changes needed)
  * Remove versioned Build-Depends for libpod-simple-perl (already in oldstable)
  * Update upstream copyright years
  * Replace 'Debian GNU/Linux' with just 'Debian' in debian/copyright
  * Fix copyright-refers-to-symlink-license lintian
  * Add myself to Uploaders
  [ gregor herrmann ]
  * debian/control: (build) depend on the now required File::Spec 3.2701.
  * debian/copyright: update years of copyright for inc/Module/*.

76e35f0... by Alessandro Ghedini on 2011-03-06

Import patches-unapplied version 1.46-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 871c3441f93692bb0b1cf288f5cf2a56c9bedbbf

New changelog entries:
  [ Salvatore Bonaccorso ]
  * Update my email address.
  [ Alessandro Ghedini ]
  * New upstream release
    - Fix test failure with new Perl::MinimumVersion (remove
      fix_META.yml_min_required_perl_version.patch patch)
    - Remove B-D-I on libtest-minimumversion-perl, libtest-cpan-meta-perl,
      libtest-pod-perl, libpod-simple-perl (extra tests are not run)
    - Don't set AUTOMATED_TESTING=1 in debian/rules (extra tests are not run)
  * Switch to 3.0 (quilt)
    - Remove Build-Depends on quilt
    - Remove '--with quilt' from debian/rules
    - Remove debian/README.source file
  * Bump debhelper to 8
  * Bump Standards-Version (no changes needed)
  * Remove versioned Build-Depends for libpod-simple-perl (already in oldstable)
  * Update upstream copyright years
  * Replace 'Debian GNU/Linux' with just 'Debian' in debian/copyright
  * Fix copyright-refers-to-symlink-license lintian
  * Add myself to Uploaders
  [ gregor herrmann ]
  * debian/control: (build) depend on the now required File::Spec 3.2701.
  * debian/copyright: update years of copyright for inc/Module/*.

0484a20... by Salvatore Bonaccorso on 2009-12-13

Import patches-applied version 1.42-3 to applied/debian/sid

Imported using git-ubuntu import.

Changelog parent: 78574f8e786efc7913e88d88cb607c1d307ed6b1
Unapplied parent: 871c3441f93692bb0b1cf288f5cf2a56c9bedbbf

New changelog entries:
  * Add myself to Uploaders.
  * Add patch bumping required Perl minimum version in META.yml. Some tests for
    libfile-remove-perl require 5.006, and the tests fail with newer
    libperl-minimumversion-perl (>= 1.22). Thanks to Lucas Nussbaum reporting
    the FTBFS (Closes: #560615).
  * Add quilt patch system for managing patches, update debian/rules with the
    --with quilt option passed to dh. Add README.source documenting use of
    quilt patch system.
  * debian/control:
    - Add quilt (>= 0.46-7) to Build-Depends.
    - Bump versioned Build-Depends on debhelper to (>= 7.0.8).
    - Replace versioned Build-Depends-Indep on perl with unversioned one since
      5.8.8-7 is in oldstable.
    - Add alternative Build-Depends-Indep on perl (>= 5.10.1) |
      libpod-simple-perl (>= 3.07).
    - Bump Standards-Version to 3.8.3.
  * debian/copyright: Update to the current revision of the DEP5 machine
    readable format-specification proposal.

871c344... by Salvatore Bonaccorso on 2009-12-13

Import patches-unapplied version 1.42-3 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 11910f466d44f50b2d3b4127de4687235781fc8b

New changelog entries:
  * Add myself to Uploaders.
  * Add patch bumping required Perl minimum version in META.yml. Some tests for
    libfile-remove-perl require 5.006, and the tests fail with newer
    libperl-minimumversion-perl (>= 1.22). Thanks to Lucas Nussbaum reporting
    the FTBFS (Closes: #560615).
  * Add quilt patch system for managing patches, update debian/rules with the
    --with quilt option passed to dh. Add README.source documenting use of
    quilt patch system.
  * debian/control:
    - Add quilt (>= 0.46-7) to Build-Depends.
    - Bump versioned Build-Depends on debhelper to (>= 7.0.8).
    - Replace versioned Build-Depends-Indep on perl with unversioned one since
      5.8.8-7 is in oldstable.
    - Add alternative Build-Depends-Indep on perl (>= 5.10.1) |
      libpod-simple-perl (>= 3.07).
    - Bump Standards-Version to 3.8.3.
  * debian/copyright: Update to the current revision of the DEP5 machine
    readable format-specification proposal.