ubuntu/+source/libfcgi:applied/ubuntu/artful

Last commit made on 2016-08-02
Get this branch:
git clone -b applied/ubuntu/artful https://git.launchpad.net/ubuntu/+source/libfcgi
Members of Ubuntu Server Dev import team can upload to this branch. Log in for directions.

Branch merges

Branch information

Name:
applied/ubuntu/artful
Repository:
lp:ubuntu/+source/libfcgi

Recent commits

2638b3d... by Helmut Grohne <email address hidden> on 2016-05-06

Import patches-applied version 2.4.0-8.4 to applied/debian/sid

Imported using git-ubuntu import.

Changelog parent: f6902efdb3fc25e61441697b59a1b76465246c71
Unapplied parent: f03dc9b22d6edc344f9f0d95abc76bddc90d0945

New changelog entries:
  * Non-maintainer upload.
  * Enable Multi-Arch: (Closes: #823600)
    + Switch to debhelper 9 to support multiarch paths.
      + dh option --with must come after sequence
    + Split cgi-fcgi to separate M-A:foreign package libfcgi-bin.
    + libfcgi0ldbl only Recommends libcgi-fcgi to avoid a circular dependency.

f03dc9b... by Helmut Grohne <email address hidden> on 2016-05-06

Fix up compiler warnings in codebase, including:

Gbp-Pq: fix_compiler_warnings.patch.

2a2f3fc... by Helmut Grohne <email address hidden> on 2016-05-06

use poll in os_unix.c instead of select to avoid problem with > 1024 connections

Gbp-Pq: poll.

6e2e06a... by Helmut Grohne <email address hidden> on 2016-05-06

Upstream changes introduced in version 2.4.0-8

Gbp-Pq: gcc44-fix-include.

24ec45b... by Helmut Grohne <email address hidden> on 2016-05-06

binutils-indirect-linking

No DEP3 Subject or Description header found

Gbp-Pq: binutils-indirect-linking.

382a6ad... by Helmut Grohne <email address hidden> on 2016-05-06

Import patches-unapplied version 2.4.0-8.4 to debian/sid

Imported using git-ubuntu import.

Changelog parent: e5bdd4b399b5e756169d81cb3bc0abcb6c3dd964

New changelog entries:
  * Non-maintainer upload.
  * Enable Multi-Arch: (Closes: #823600)
    + Switch to debhelper 9 to support multiarch paths.
      + dh option --with must come after sequence
    + Split cgi-fcgi to separate M-A:foreign package libfcgi-bin.
    + libfcgi0ldbl only Recommends libcgi-fcgi to avoid a circular dependency.

f6902ef... by Matthias Klose on 2014-08-08

Import patches-applied version 2.4.0-8.3 to applied/debian/sid

Imported using git-ubuntu import.

Changelog parent: 7fdfaa5fe680d41caf1a5872517c9abbec19771c
Unapplied parent: 5e0489964ffcbcd099496a11f7258d2aa18abe8b

New changelog entries:
  * Non-maintainer upload.
  [ James Page ]
  * d/patches/fix_compiler_warnings.patch: Fixup misc complier warnings
    in the codebase.
  * d/libfcgi0ldbl.manpages,rules: Don't install manpage using rules file.
  * d/libfcgi0ldbl.docs: Rationalized to prevent duplicate install of docs.
  * d/dirs: Dropped - not actually required and generates linitan warning.
  * d/control,rules: Drop use of quilt dh addon as this is provided by
    debhelper.
  * d/control: Bumped Standards-Version to 3.9.5:
    - d/copyright: Converted to machine readable format.
  [ Clint Byrum ]
  * Applying patch to use poll instead of select which helps handle
    more than 1024 connections. (LP: #933417). Thanks Anton Kortunov!
    Closes: #681591.
  [ Matthias Klose ]
  * Build with hardening defaults.
  * d/rules: Stop install .la files. Closes: #633182.

e5bdd4b... by Matthias Klose on 2014-08-08

Import patches-unapplied version 2.4.0-8.3 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 139890fc415c3e35115006acdbb59809e7fc2f0e

New changelog entries:
  * Non-maintainer upload.
  [ James Page ]
  * d/patches/fix_compiler_warnings.patch: Fixup misc complier warnings
    in the codebase.
  * d/libfcgi0ldbl.manpages,rules: Don't install manpage using rules file.
  * d/libfcgi0ldbl.docs: Rationalized to prevent duplicate install of docs.
  * d/dirs: Dropped - not actually required and generates linitan warning.
  * d/control,rules: Drop use of quilt dh addon as this is provided by
    debhelper.
  * d/control: Bumped Standards-Version to 3.9.5:
    - d/copyright: Converted to machine readable format.
  [ Clint Byrum ]
  * Applying patch to use poll instead of select which helps handle
    more than 1024 connections. (LP: #933417). Thanks Anton Kortunov!
    Closes: #681591.
  [ Matthias Klose ]
  * Build with hardening defaults.
  * d/rules: Stop install .la files. Closes: #633182.

5e04899... by Matthias Klose on 2014-08-08

Fix up compiler warnings in codebase, including:

Gbp-Pq: fix_compiler_warnings.patch.

7767bd2... by Matthias Klose on 2014-08-08

use poll in os_unix.c instead of select to avoid problem with > 1024 connections

Gbp-Pq: poll.