ubuntu/+source/libdbi:ubuntu/oneiric-devel

Last commit made on 2011-07-22
Get this branch:
git clone -b ubuntu/oneiric-devel https://git.launchpad.net/ubuntu/+source/libdbi
Members of Ubuntu Server Dev import team can upload to this branch. Log in for directions.

Branch merges

Branch information

Name:
ubuntu/oneiric-devel
Repository:
lp:ubuntu/+source/libdbi

Recent commits

6fa7e65... by Philipp Kern on 2011-07-22

Import patches-unapplied version 0.8.4-5.1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: e26074371240d99f2081a68de599f536fcad8ca8

New changelog entries:
  * Non-maintainer upload.
  * Drop the unneeded Replaces/Conflicts from libdbi1.
  * Drop the unneeded Breaks from libdbi-dev and fix the Replaces
    to state the right version. (Closes: #633484)
    Thanks to Angel Abad <email address hidden> for the help.

e260743... by Thomas Goirand <email address hidden> on 2011-07-11

Import patches-unapplied version 0.8.4-5 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 74d344b6b01fa3767c7f1d45503693513ac4834d

New changelog entries:
  * Now Replaces: libdbi (<< 0.8.4-2) and not <= (Closes: #633484).

74d344b... by Thomas Goirand <email address hidden> on 2011-07-11

Import patches-unapplied version 0.8.4-4 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 60eaf7c17918d61e0aba7f06f65024ddc827c23e

New changelog entries:
  * Now also Breaks: libdbi (<= 0.8.4-2) (Closes: #633484).

60eaf7c... by Thomas Goirand <email address hidden> on 2011-07-10

Import patches-unapplied version 0.8.4-3 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 17b26fd4f5931abfe333776e0f25c958f1f6acee

New changelog entries:
  * Added a Breaks: libdbi0 and Replaces: libdbi0 in the libdbi-dev so that the
  .a and .la files now in libdbi-dev will upgrade correctly (Closes: #633484).
  * Moves the .la and .a files in the -dev package (Closes: #632135).
  * Adds a Provides: libdbi0-dev to libdbi-dev.

17b26fd... by Thomas Goirand <email address hidden> on 2011-06-27

Import patches-unapplied version 0.8.4-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 53971bfed2e2d5dccd05dd821ee7829b19687a3a

New changelog entries:
  * New upstream release.
  * Recommits the changes bellow.
  * Standard-Version is now 3.9.2.
  * Renamed libdbi0-dev to libdbi-dev.
  * Renamed libdbi0 to libdbi1 as the soname increased (ABI incompatibility).
  * Removes dependency_libs as per
  http://wiki.debian.org/ReleaseGoals/LAFileRemoval.
  * Now building on a copy of all sources, as the build process really is
  too hard to clean, and upstream doesn't do it correctly.
  * As a consequence, autoreconf not needed anymore, so removed from
  build-dependss.

53971bf... by Thomas Goirand <email address hidden> on 2010-08-28

Import patches-unapplied version 0.8.3+really0.8.2-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 412f28be5b8b05f80eae6ff451fd71c9ba2912e5

New changelog entries:
  * This upload reverts back to 0.8.2 because of an ABI change in the error
    codes as per http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=594607
    this is only temporary and in SID only in order to not bother anyone that
    has dependencies to libdbi. My appologies to the release team, but to my
    defence, I trusted upstream saying that there was only bugfixes and no
    other change.
  * Still keeping <email address hidden> as maintainer email.

412f28b... by Thomas Goirand <email address hidden> on 2010-08-10

Import patches-unapplied version 0.8.3-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: c809fe2822ee16553b682726e3edbe23b738e631

New changelog entries:
  * New upstream release (Closes: #592447, #565562).
  * Now using my email <email address hidden> on the maintainer field.
  * Now depends on debhelper 7.
  * Added some missing Depends: ${misc:Depends}.
  * Now using Standards-Version 3.9.1.
  * Added Vcs-Browser: URL where I'll keep the Debian package source.
  * Added debian/source/format file, using 1.0 with autoreconf to avoid clean
    target head akes.
  * Not using dh_clean -k but dh_prep in debian/rules.
  * Removed the duplicate section fields.
  * Reviewed a bit short and long descriptions.
  * Now calls ./autogen.sh before ./configure, the package also
    Build-Depends on automake and libtool.
  * In debian/rules, added rm -rf debian/libdbi0/usr/lib/pkgconfig in the
    install target.

c809fe2... by Thomas Goirand on 2007-11-26

Import patches-unapplied version 0.8.2-3 to debian/lenny

Imported using git-ubuntu import.