ubuntu/+source/libcanberra:ubuntu/precise

Last commit made on 2012-04-06
Get this branch:
git clone -b ubuntu/precise https://git.launchpad.net/ubuntu/+source/libcanberra
Members of Ubuntu Server Dev import team can upload to this branch. Log in for directions.

Branch merges

Branch information

Name:
ubuntu/precise
Repository:
lp:ubuntu/+source/libcanberra

Recent commits

1245975... by Jeremy Bicha on 2012-04-06

Import patches-unapplied version 0.28-3ubuntu3 to ubuntu/precise

Imported using git-ubuntu import.

Changelog parent: 5dd1288a8aba68eab858029d4078e55b7e0fac15

New changelog entries:
  * debian/patches/04_nodisplay_autostart.patch:
    - Re-add Oneiric patch to hide from "Startup Applications" now
      that the login sound is disabled by default anyway (LP: #803917)
  * debian/patches/11_link-against-x11.patch:
    - Add missing link for libx11 (needed to build gnome-games
      from trunk)

5dd1288... by Steve Langasek on 2011-12-30

Import patches-unapplied version 0.28-3ubuntu2 to ubuntu/precise

Imported using git-ubuntu import.

Changelog parent: cdf8c6d9f978a1009fb83ca23d52cfb5fe9d07ac

New changelog entries:
  * Build for multiarch.
  * libcanberra-gtk-module and libcanberra-gtk3-module need hard-coded
    versioned dependencies on the minimum versions of gtk2/gtk3 that support
    lookups in the multiarch path.
  * Move canberra-gtk-play from libcanberra-gtk0 to gnome-session-canberra,
    since the latter is the only package which uses it; and make
    gnome-session-canberra Architecture: any.

cdf8c6d... by Jeremy Bicha on 2011-12-18

Import patches-unapplied version 0.28-3ubuntu1 to ubuntu/precise

Imported using git-ubuntu import.

Changelog parent: da89a01ae6e363dac64024c16598086fd23d5908

New changelog entries:
  * Sync with Debian. Remaining changes:
  * Set Ubuntu as default sound theme
  * debian/control:
    - Added breaks/replace for libcanberra-gtk-dev to new package
      libcanberra-gtk-common-dev that took some of its files
    - Have libcanberra0 depend on sound-theme-freedesktop
    - Have gnome-session-canberra recommend libcanberra-pulse
  * 01_link_canberra_play_with_gtk2.patch:
    - Dropped
  * 02_disable_login_sound.patch:
    - Disable the login sound by default, since it seems to be more
      disruptive than helpful especially with faster boots
  * 03_onlyshowin_unity.patch:
    - Add Unity to OnlyShowIn
  * 10_no_nonnative_crash.patch:
    - trap BadWindow (and similar) X errors when calling XGetWindowProperty()
  * 91-resolve-symbols.patch: Dropped, use Debian's patch instead

da89a01... by Laurent Bigonville on 2011-10-18

Import patches-unapplied version 0.28-3 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 5e9622aec61e9709c8fd5d269c87db6163c6891b

New changelog entries:
  * Team Upload
  * Rely on gnome-settings-daemon to load GTK module instead of Xsession.
    (Closes: #622992, #573757)
  * debian/control:
    - Add Add Homepage field
    - Bump Standards-Version to 3.9.2 (no further changes)
    - Correctly capitalized GTK+ (Closes: #612018)
    - Add libgconf2-dev to build-dependencies
    - Move gnome-session-canberra to Section: gnome
  * debian/rules:
    - Includes gnome.mk instead of autotools.mk to be sure dh_gconf is called

5e9622a... by Bart Martens on 2011-10-09

Import patches-unapplied version 0.28-2 to debian/sid

Imported using git-ubuntu import.

Changelog parent: a56ee89e32c23df0b8bb15e41220dd1d9fff707d

New changelog entries:
  * Build-Depends: libtdb-dev. Fixed FTBFS. Closes: #637977.
  * debian/patches/undefined_reference.diff: Fixed FTBFS. Closes: #555081.
  * Added manpage debian/canberra-gtk-play.1. Closes: #591353.
  * debian/control: Now use [linux-any]. Closes: #634663.
  * Fixed description-synopsis-starts-with-article.

a56ee89... by Sjoerd Simons on 2011-06-07

Import patches-unapplied version 0.28-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: cf4a402687685905827875d79cb8400e8057484b

New changelog entries:
  * New upstream release
  * d/p/0001-Don-t-use-gtk_quit_add-it-has-been-removed-from-gtk3.patch
    + Removed. merged upstream
  * debian/libcanberra0.lintian-overrides
    Add override for a false-positive of libcanberra embedding ltdl. It only
    embeds the error strings for some of its own utility functions, not the
    library itself

cf4a402... by Sjoerd Simons on 2011-02-19

Import patches-unapplied version 0.26-3 to debian/experimental

Imported using git-ubuntu import.

Changelog parent: 24933748033bd104e41b6530bb601265fe9230d5

New changelog entries:
  [ Emilio Pozuelo Monfort ]
  * Update for the new gtk+ 3 package names.

2493374... by Sjoerd Simons on 2011-01-12

Import patches-unapplied version 0.26-2 to debian/experimental

Imported using git-ubuntu import.

Changelog parent: 8a762da544fcbe142a1aa1265ca2b2c7c094ec07

New changelog entries:
  * Build against even newer gtk 3.0
  * d/p/0001-Don-t-use-gtk_quit_add-it-has-been-removed-from-gtk3.patch:
    Avoid using gtk_quit_add, it's no longer available in gtk3

8a762da... by Sjoerd Simons on 2010-11-20

Import patches-unapplied version 0.26-1 to debian/experimental

Imported using git-ubuntu import.

Changelog parent: 9fc4b4de5ac9fc64742813098400081255232417

New changelog entries:
  * New upstream release
  * debian/control
    - Add gtk3.0 support
  * Split header and vapi used for both gtk2 and gtk3 into
    libcanberra-gtk-common-dev
  * Various cleanups and updates based on the Ubuntu packaging
  * debian/control: Update standards version, 3.9.1
  * Remove the quilt build-dep, we're not applying any patches

9fc4b4d... by Sebastian Dröge on 2010-05-06

Import patches-unapplied version 0.24-1 to debian/squeeze

Imported using git-ubuntu import.

Changelog parent: 1910bd74a4269baccd7dd94a1a0e706bd69fb502

New changelog entries:
  * New upstream version:
    + debian/control:
      - Update GTK build dependency to >= 2.20.
  * debian/control:
    + Update Standards-Version to 3.8.4.
  * debian/rules:
    + Fix shlibs file by excluding the alsa module (Closes: #560120).
  * debian/libcanberra-dev.install,
    debian/libcanberra-gtk-dev.install:
    + Ship Vala bindings with the -dev packages (Closes: #556249).