ubuntu/+source/libarchive:applied/ubuntu/yakkety-security

Last commit made on 2017-03-09
Get this branch:
git clone -b applied/ubuntu/yakkety-security https://git.launchpad.net/ubuntu/+source/libarchive
Members of Ubuntu Server Dev import team can upload to this branch. Log in for directions.

Branch merges

Branch information

Name:
applied/ubuntu/yakkety-security
Repository:
lp:ubuntu/+source/libarchive

Recent commits

d657c51... by Marc Deslauriers on 2017-03-09

3.2.1-2ubuntu0.1 (patches applied)

Imported using git-ubuntu import.

10d1d5d... by Marc Deslauriers on 2017-03-09

[PATCH] Fail with negative lha->compsize in lha_read_file_header_1()

Gbp-Pq: CVE-2017-5601.patch.

85f086a... by Marc Deslauriers on 2017-03-09

[PATCH] Issue 761: Heap overflow reading corrupted 7Zip files

Gbp-Pq: CVE-2016-8689.patch.

bf53a21... by Marc Deslauriers on 2017-03-09

[PATCH] Issue 747 (and others?): Avoid OOB read when parsing

Gbp-Pq: CVE-2016-8688.patch.

6a47bae... by Marc Deslauriers on 2017-03-09

[PATCH] Issue #767: Buffer overflow printing a filename

Gbp-Pq: CVE-2016-8687.patch.

e6d1a51... by Marc Deslauriers on 2017-03-09

[PATCH] Correct the usage of PATH_MAX as reported in Issue #744.

Gbp-Pq: CVE-2016-5418-5.patch.

d6b902d... by Marc Deslauriers on 2017-03-09

[PATCH] Fix the test cases for Issue #745 and Issue #746

Gbp-Pq: CVE-2016-5418-4.patch.

f82181d... by Marc Deslauriers on 2017-03-09

[PATCH] Test cases for Github Issue #744, #745, and #746.

Gbp-Pq: CVE-2016-5418-3.patch.

3a32c0d... by Marc Deslauriers on 2017-03-09

[PATCH] Fixes for Issue #745 and Issue #746 from Doran Moppert.

Gbp-Pq: CVE-2016-5418-2.patch.

bae0e61... by Marc Deslauriers on 2017-03-09

[PATCH] Issue #744 (part of Issue #743): Enforce sandbox with very

Gbp-Pq: CVE-2016-5418-1.patch.