ubuntu/+source/lasso:applied/ubuntu/intrepid-security

Last commit made on 2009-01-15
Get this branch:
git clone -b applied/ubuntu/intrepid-security https://git.launchpad.net/ubuntu/+source/lasso
Members of Ubuntu Server Dev import team can upload to this branch. Log in for directions.

Branch merges

Branch information

Name:
applied/ubuntu/intrepid-security
Repository:
lp:ubuntu/+source/lasso

Recent commits

fd2354e... by Stefan Lesicnik on 2009-01-14

Import patches-applied version 2.2.0-1ubuntu0.1 to applied/ubuntu/intrepid-security

Imported using git-ubuntu import.

Changelog parent: 97de8fa8958c8f9c2c963431ab6eabe28a2d80ae
Unapplied parent: 7fb35c8102ed43740e1473ca205948735d612e88

New changelog entries:
  * SECURITY UPDATE: lasso does not properly check the return value from the
    OpenSSL DSA_verify function (LP: #317181).
    - lasso/xml/tools.c: Correctly check for signature validity.
    - CVE-2009-0050

7fb35c8... by Stefan Lesicnik on 2009-01-14

Import patches-unapplied version 2.2.0-1ubuntu0.1 to ubuntu/intrepid-security

Imported using git-ubuntu import.

Changelog parent: 2b5ce5dfc71932b6b96098b700b99eea0f5898c7

New changelog entries:
  * SECURITY UPDATE: lasso does not properly check the return value from the
    OpenSSL DSA_verify function (LP: #317181).
    - lasso/xml/tools.c: Correctly check for signature validity.
    - CVE-2009-0050

97de8fa... by Frederic Peters <email address hidden> on 2008-07-13

Import patches-applied version 2.2.0-1 to applied/ubuntu/intrepid

Imported using git-ubuntu import.

Changelog parent: 2e82d1daa9cf804318acb5535ccdea81143a44e7
Unapplied parent: 2b5ce5dfc71932b6b96098b700b99eea0f5898c7

New changelog entries:
  * New upstream release.
    * Acknowledge NMU.
    * Fixed missing quotes in configure.in (Closes: #487816)
  * debian/control:
    * Updated package descriptions,
    * Used new Homepage field.
    * Moved liblasso-perl to perl section.
  * debian/rules:
    * remove config.log on clean.
    * remove empty id-wsf include directory.
  * NMU.
  * Don't build-depend on gcj and gcj-4.3 on alpha, arm, hppa (same as for
    java-gcj-compat). Closes: #477870.
  * Adjust list of architectures for liblasso-java. Closes: #479737.
  * debian/rules: create control from control.in, so liblasso-java is not
    built on architectures lacking gcj.
  * debian/liblasso-perl.install: really fix building with Perl 5.10.
  * debian/liblasso-perl.install: use wildcard for minor version number; so it
    still works with Perl 5.10. (closes: #479065)
  * New upstream release (RC).
  * debian/control:
    * build new php5-lasso package.
    * limit liblasso-java to architecture with gcj (closes: #477870).
    * add Homepage field.
    * liblasso3-dev: Replace ${Source-Version} with ${binary:Version}
      (from Ubuntu patch)
  * debian/rules:
    * ignore liblasso-java package on architectures without gcj.
    * update to match new upstream language bindings layout.
    * don't ignore a make clean error. (from Ubuntu patch)
  * debian/rules: added call to dh_perl; debian/control: added ${perl:Depends}
    (closes: #463097)
  * configure(.ac): fixed gcj check to work with gcj-4.3; debian/control:
    updated build-deps for gcj 4.3 and added gcc-4.3; debian/rules: force
    gcc-4.3 so jni.h is found and the java interface is built.
    (closes: #464319)
  * debian/rules, debian/*.files: updated from dh_movefiles to dh_install
    * really install files in liblasso-perl package (closes: #446578)
  * New upstream release.
  * debian/control: added liblasso-perl, Perl bindings for the library.
  * debian/rules: --enable-perl
  * New upstream release.
  * debian/control: removes php4-lasso since PHP4 is no longer provided.
    (closes: #432422, #418268)

2b5ce5d... by Frederic Peters <email address hidden> on 2008-07-13

Import patches-unapplied version 2.2.0-1 to ubuntu/intrepid

Imported using git-ubuntu import.

Changelog parent: 7e023baba4bc9dfb722b78ec4fcba020a320755f

New changelog entries:
  * New upstream release.
    * Acknowledge NMU.
    * Fixed missing quotes in configure.in (Closes: #487816)
  * debian/control:
    * Updated package descriptions,
    * Used new Homepage field.
    * Moved liblasso-perl to perl section.
  * debian/rules:
    * remove config.log on clean.
    * remove empty id-wsf include directory.
  * NMU.
  * Don't build-depend on gcj and gcj-4.3 on alpha, arm, hppa (same as for
    java-gcj-compat). Closes: #477870.
  * Adjust list of architectures for liblasso-java. Closes: #479737.
  * debian/rules: create control from control.in, so liblasso-java is not
    built on architectures lacking gcj.
  * debian/liblasso-perl.install: really fix building with Perl 5.10.
  * debian/liblasso-perl.install: use wildcard for minor version number; so it
    still works with Perl 5.10. (closes: #479065)
  * New upstream release (RC).
  * debian/control:
    * build new php5-lasso package.
    * limit liblasso-java to architecture with gcj (closes: #477870).
    * add Homepage field.
    * liblasso3-dev: Replace ${Source-Version} with ${binary:Version}
      (from Ubuntu patch)
  * debian/rules:
    * ignore liblasso-java package on architectures without gcj.
    * update to match new upstream language bindings layout.
    * don't ignore a make clean error. (from Ubuntu patch)
  * debian/rules: added call to dh_perl; debian/control: added ${perl:Depends}
    (closes: #463097)
  * configure(.ac): fixed gcj check to work with gcj-4.3; debian/control:
    updated build-deps for gcj 4.3 and added gcc-4.3; debian/rules: force
    gcc-4.3 so jni.h is found and the java interface is built.
    (closes: #464319)
  * debian/rules, debian/*.files: updated from dh_movefiles to dh_install
    * really install files in liblasso-perl package (closes: #446578)
  * New upstream release.
  * debian/control: added liblasso-perl, Perl bindings for the library.
  * debian/rules: --enable-perl
  * New upstream release.
  * debian/control: removes php4-lasso since PHP4 is no longer provided.
    (closes: #432422, #418268)

2e82d1d... by Frederic Peters <email address hidden> on 2006-10-21

Import patches-applied version 0.6.5-3 to applied/ubuntu/feisty

Imported using git-ubuntu import.

Changelog parent: f3a6ce304a52b107c8f0c512665df25f6d42f9cd
Unapplied parent: 7e023baba4bc9dfb722b78ec4fcba020a320755f

New changelog entries:
  * Converted to new Python policy (merged from unreported Ubuntu patch)
    * debian/control: keep conflict on python2.4-lasso which is unnecessary
      for Debian but will reduce Ubuntu changes.
  * debian/control: adding libgcj-dev and fastjar to build-depends since
    liblasso-java is now built.
  * New upstream release.
    * Incorporates Ubuntu patch for phpapi version.
  * New upstream release.
  * debian/control: removed mono packages from build-depends since the -cil
    package is no longer built.
  * debian/control: fixed php depends line. (closes: #331710)
  * php/Makefile.am: don't patch autogenerated swig file if swig was not
    present (which implies the file has already been patched)
  * debian/rules: touch swig generated files after configure so swig is
    not called; even if available. (closes: #331699)
  * New upstream release.
  * debian/copyright: new FSF address.
  * debian/control: removed liblasso-cil package since the .net assembly
    doesn't work (and don't even compile anymore) (closes: #320898)
  * debian/rules: removed call to dh_makenetshlibs which is no longer shipped
    with Mono 1.1 packages. (closes: #311837)
  * debian/control, debian/rules: updated to new CLI policy.
  * New upstream release.
  * debian/control: fixed Depends line, this is no longer -zts.
  * debian/control: updated Build-depends to php4-dev (>= 4:4.3.10-10)
    (closes: #301330)
  * Rebuilt with PHP Zend Thread Safety disabled.
  * lasso/xml/lib_authn_request.c, lasso/id-ff/login.c: backported
    AssertionConsumerServiceID fix from CVS.
  * python/lasso_wrap.c, python/lasso.py: regenerated with SWIG 1.3.22;
    1.3.24 created a buggy binding.
  * debian/control: Build-depends on mono-utils (>= 1.0)
  * New upstream release.
  * lasso/id-ff/login.c: backported SAML 1.0 compatibility fix from CVS.
  * New upstream release.
  * Rebuilt with new PHP API. (closes: #294003)

7e023ba... by Frederic Peters <email address hidden> on 2006-10-21

Import patches-unapplied version 0.6.5-3 to ubuntu/feisty

Imported using git-ubuntu import.

Changelog parent: 20f5ce0275645fdf1264084775d1eb3db751302d

New changelog entries:
  * Converted to new Python policy (merged from unreported Ubuntu patch)
    * debian/control: keep conflict on python2.4-lasso which is unnecessary
      for Debian but will reduce Ubuntu changes.
  * debian/control: adding libgcj-dev and fastjar to build-depends since
    liblasso-java is now built.
  * New upstream release.
    * Incorporates Ubuntu patch for phpapi version.
  * New upstream release.
  * debian/control: removed mono packages from build-depends since the -cil
    package is no longer built.
  * debian/control: fixed php depends line. (closes: #331710)
  * php/Makefile.am: don't patch autogenerated swig file if swig was not
    present (which implies the file has already been patched)
  * debian/rules: touch swig generated files after configure so swig is
    not called; even if available. (closes: #331699)
  * New upstream release.
  * debian/copyright: new FSF address.
  * debian/control: removed liblasso-cil package since the .net assembly
    doesn't work (and don't even compile anymore) (closes: #320898)
  * debian/rules: removed call to dh_makenetshlibs which is no longer shipped
    with Mono 1.1 packages. (closes: #311837)
  * debian/control, debian/rules: updated to new CLI policy.
  * New upstream release.
  * debian/control: fixed Depends line, this is no longer -zts.
  * debian/control: updated Build-depends to php4-dev (>= 4:4.3.10-10)
    (closes: #301330)
  * Rebuilt with PHP Zend Thread Safety disabled.
  * lasso/xml/lib_authn_request.c, lasso/id-ff/login.c: backported
    AssertionConsumerServiceID fix from CVS.
  * python/lasso_wrap.c, python/lasso.py: regenerated with SWIG 1.3.22;
    1.3.24 created a buggy binding.
  * debian/control: Build-depends on mono-utils (>= 1.0)
  * New upstream release.
  * lasso/id-ff/login.c: backported SAML 1.0 compatibility fix from CVS.
  * New upstream release.
  * Rebuilt with new PHP API. (closes: #294003)

f3a6ce3... by Frederic Peters <email address hidden> on 2004-09-13

Import patches-applied version 0.4.1-3 to applied/ubuntu/hoary

Imported using git-ubuntu import.

Unapplied parent: 20f5ce0275645fdf1264084775d1eb3db751302d

20f5ce0... by Frederic Peters <email address hidden> on 2004-09-13

Import patches-unapplied version 0.4.1-3 to ubuntu/hoary

Imported using git-ubuntu import.