ubuntu/+source/lasso:applied/ubuntu/dapper-devel

Last commit made on 2009-01-15
Get this branch:
git clone -b applied/ubuntu/dapper-devel https://git.launchpad.net/ubuntu/+source/lasso
Members of Ubuntu Server Dev import team can upload to this branch. Log in for directions.

Branch merges

Branch information

Name:
applied/ubuntu/dapper-devel
Repository:
lp:ubuntu/+source/lasso

Recent commits

b6d1fe4... by Stefan Lesicnik on 2009-01-14

Import patches-applied version 0.6.3-4ubuntu1.1 to applied/ubuntu/dapper-security

Imported using git-ubuntu import.

Changelog parent: 01a64ce5752abf51c8c4a8b5a9de32cfa35169eb
Unapplied parent: 76d4b5aca853f3f7ca5425cfc1c0fffadf89c468

New changelog entries:
  * SECURITY UPDATE: lasso does not properly check the return value from the
    OpenSSL DSA_verify function (LP: #317181).
    - lasso/xml/tools.c: Correctly check for signature validity.
    - CVE-2009-0050

76d4b5a... by Stefan Lesicnik on 2009-01-14

Import patches-unapplied version 0.6.3-4ubuntu1.1 to ubuntu/dapper-security

Imported using git-ubuntu import.

Changelog parent: 499cf7db8e2ecd130f2e0602ca0331cceacb2acd

New changelog entries:
  * SECURITY UPDATE: lasso does not properly check the return value from the
    OpenSSL DSA_verify function (LP: #317181).
    - lasso/xml/tools.c: Correctly check for signature validity.
    - CVE-2009-0050

01a64ce... by Loic Pefferkorn <email address hidden> on 2005-11-25

Import patches-applied version 0.6.3-4ubuntu1 to applied/ubuntu/dapper

Imported using git-ubuntu import.

Changelog parent: f55cae3f52ad68ad29a2ab9dcd11df0d3b268327
Unapplied parent: 499cf7db8e2ecd130f2e0602ca0331cceacb2acd

New changelog entries:
  * Resynchronise with Debian.
  * debian/control: removed mono packages from build-depends since the -cil
    package is no longer built.
  * debian/control: fixed php depends line. (closes: #331710)
  * php/Makefile.am: don't patch autogenerated swig file if swig was not
    present (which implies the file has already been patched)
  * debian/rules: touch swig generated files after configure so swig is
    not called; even if available. (closes: #331699)
  * New upstream release.
  * debian/copyright: new FSF address.

499cf7d... by Loic Pefferkorn <email address hidden> on 2005-11-25

Import patches-unapplied version 0.6.3-4ubuntu1 to ubuntu/dapper

Imported using git-ubuntu import.

Changelog parent: 2d193f52e1cf7283b2f57f8c575b257a80be6f63

New changelog entries:
  * Resynchronise with Debian.
  * debian/control: removed mono packages from build-depends since the -cil
    package is no longer built.
  * debian/control: fixed php depends line. (closes: #331710)
  * php/Makefile.am: don't patch autogenerated swig file if swig was not
    present (which implies the file has already been patched)
  * debian/rules: touch swig generated files after configure so swig is
    not called; even if available. (closes: #331699)
  * New upstream release.
  * debian/copyright: new FSF address.

f55cae3... by Stephan RĂ¼gamer on 2005-09-16

Import patches-applied version 0.6.2-3ubuntu1 to applied/ubuntu/breezy

Imported using git-ubuntu import.

Changelog parent: f3a6ce304a52b107c8f0c512665df25f6d42f9cd
Unapplied parent: 2d193f52e1cf7283b2f57f8c575b257a80be6f63

New changelog entries:
  * debian/control: removed hardcoded php dependency, added php:Depends
    substvar
  * debian/rules: added phpapiver, added substitution of php:Depends
  * debian/control: removed liblasso-cil package since the .net assembly
    doesn't work (and don't even compile anymore) (closes: #320898)
  * debian/rules: removed call to dh_makenetshlibs which is no longer shipped
    with Mono 1.1 packages. (closes: #311837)
  * debian/control, debian/rules: updated to new CLI policy.
  * New upstream release.
  * debian/control: fixed Depends line, this is no longer -zts.
  * debian/control: updated Build-depends to php4-dev (>= 4:4.3.10-10)
    (closes: #301330)
  * Rebuilt with PHP Zend Thread Safety disabled.
  * lasso/xml/lib_authn_request.c, lasso/id-ff/login.c: backported
    AssertionConsumerServiceID fix from CVS.
  * python/lasso_wrap.c, python/lasso.py: regenerated with SWIG 1.3.22;
    1.3.24 created a buggy binding.
  * debian/control: Build-depends on mono-utils (>= 1.0)
  * New upstream release.
  * lasso/id-ff/login.c: backported SAML 1.0 compatibility fix from CVS.
  * New upstream release.
  * Rebuilt with new PHP API. (closes: #294003)

2d193f5... by Stephan RĂ¼gamer on 2005-09-16

Import patches-unapplied version 0.6.2-3ubuntu1 to ubuntu/breezy

Imported using git-ubuntu import.

Changelog parent: 20f5ce0275645fdf1264084775d1eb3db751302d

New changelog entries:
  * debian/control: removed hardcoded php dependency, added php:Depends
    substvar
  * debian/rules: added phpapiver, added substitution of php:Depends
  * debian/control: removed liblasso-cil package since the .net assembly
    doesn't work (and don't even compile anymore) (closes: #320898)
  * debian/rules: removed call to dh_makenetshlibs which is no longer shipped
    with Mono 1.1 packages. (closes: #311837)
  * debian/control, debian/rules: updated to new CLI policy.
  * New upstream release.
  * debian/control: fixed Depends line, this is no longer -zts.
  * debian/control: updated Build-depends to php4-dev (>= 4:4.3.10-10)
    (closes: #301330)
  * Rebuilt with PHP Zend Thread Safety disabled.
  * lasso/xml/lib_authn_request.c, lasso/id-ff/login.c: backported
    AssertionConsumerServiceID fix from CVS.
  * python/lasso_wrap.c, python/lasso.py: regenerated with SWIG 1.3.22;
    1.3.24 created a buggy binding.
  * debian/control: Build-depends on mono-utils (>= 1.0)
  * New upstream release.
  * lasso/id-ff/login.c: backported SAML 1.0 compatibility fix from CVS.
  * New upstream release.
  * Rebuilt with new PHP API. (closes: #294003)

f3a6ce3... by Frederic Peters <email address hidden> on 2004-09-13

Import patches-applied version 0.4.1-3 to applied/ubuntu/hoary

Imported using git-ubuntu import.

Unapplied parent: 20f5ce0275645fdf1264084775d1eb3db751302d

20f5ce0... by Frederic Peters <email address hidden> on 2004-09-13

Import patches-unapplied version 0.4.1-3 to ubuntu/hoary

Imported using git-ubuntu import.