ubuntu/+source/language-selector:ubuntu/natty

Last commit made on 2011-04-19
Get this branch:
git clone -b ubuntu/natty https://git.launchpad.net/ubuntu/+source/language-selector
Members of Ubuntu Server Dev import team can upload to this branch. Log in for directions.

Branch merges

Branch information

Name:
ubuntu/natty
Repository:
lp:ubuntu/+source/language-selector

Recent commits

6613e5e... by Martin Pitt on 2011-04-19

Import patches-unapplied version 0.33 to ubuntu/natty

Imported using git-ubuntu import.

Changelog parent: 8ec36e4a1aaab82648d2dc204504d7044d7479fc

New changelog entries:
  * dbus_backend/ls-dbus-backend: Actually look at the PolicyKit check result
    and only proceed if it succeeded. Thanks to Romain Perier for finding this
    and providing the patch! This fixes a local root privilege escalation, as
    this allows any authenticated user to write arbitrary shell commands into
    /etc/default/locale. (LP: #764397) [CVE-2011-0729]
  * dbus_backend/ls-dbus-backend: Reject locale names with invalid characters
    in it, to further prevent injecting shell code into /etc/default/locale
    for authenticated users. Thanks to Felix Geyer for the initial patch!
    (LP: #764397)
  * dbus_backend/com.ubuntu.LanguageSelector.conf: Allow access to standard
    D-BUS introspection and properties interfaces. There's no reason to deny
    it, and it causes warnings.
  * debian/language-selector-common.postinst: Stop running D-BUS backend on
    upgrade.

8ec36e4... by Gunnar Hjalmarsson on 2011-04-18

Import patches-unapplied version 0.32 to ubuntu/natty

Imported using git-ubuntu import.

Changelog parent: 13113cc46e6067a8006adc6385644cc5d0d858d0

New changelog entries:
  * help/C/language-selector.xml:
    - Description of how to open language-selector changed to also fit
      Unity.

13113cc... by Gunnar Hjalmarsson on 2011-04-11

Import patches-unapplied version 0.31 to ubuntu/natty

Imported using git-ubuntu import.

Changelog parent: 56e650d9573061030cf38810ddb827bc7d42b48b

New changelog entries:
  * help/C/language-selector.xml: Tweaking of help document, LP: #742857

56e650d... by Martin Pitt on 2011-04-08

Import patches-unapplied version 0.30 to ubuntu/natty

Imported using git-ubuntu import.

Changelog parent: 9e36044c602bfdf8a7f42f80435efb2457d83346

New changelog entries:
  * LanguageSelector/gtk/GtkLanguageSelector.py: Fix crash when
    double-clicking language row. (LP: #703097)

9e36044... by Gunnar Hjalmarsson on 2011-04-06

Import patches-unapplied version 0.29 to ubuntu/natty

Imported using git-ubuntu import.

Changelog parent: 17fde2a2cfc4073d177333561759008b7f58e72f

New changelog entries:
  [ Gunnar Hjalmarsson ]
  * help/C/language-selector.xml:
    - Addition of DocBook document with help about Ubuntu i18n handling
      in general and language-selector in particular (LP: #742857).
  * data/LanguageSelector.ui:
    - "Help" button added (LP: #742857).
    - Title of the main window changed to "Language Support", i.e.
      same as the name of the app/tool.
  * LanguageSelector/gtk/GtkLanguageSelector.py:
    - Modified code for setlocale() exception handling.
  * data/main-countries:
    - Changed the main country of English from GB to US. Not that the
      latter is more 'right' or something, but it may prevent failures
      in certain situations, since en_US locales are more widespread.
  [ Martin Pitt ]
  * data/pkg_depends: Add hunspell-sh.

17fde2a... by Martin Pitt on 2011-03-24

Import patches-unapplied version 0.28 to ubuntu/natty

Imported using git-ubuntu import.

Changelog parent: 8cc5c801b69247594ecf6eeb0401ff3b1bc56d7f

New changelog entries:
  * data/pkg_depends: Install openoffice.org-hyphenation for the languages
    that it supports, when libreoffice-common is installed.
  * data/pkg_depends: Add mythes-pl.
  * data/pkg_depends: Add hyphen-pl.

8cc5c80... by Martin Pitt on 2011-03-18

Import patches-unapplied version 0.27 to ubuntu/natty

Imported using git-ubuntu import.

Changelog parent: 5c21db89df27fe1885cc563c9ac5300ea1dffd09

New changelog entries:
  * data/pkg_depends: Update for libreoffice and changed thesaurus/hyphenation
    package names. Update test cases accordingly.
  * data/pkg_depends: Add poppler-data for Arabic, Chinese, Japanese, and
    Korean. (LP: #623825)

5c21db8... by Martin Pitt on 2011-03-10

Import patches-unapplied version 0.26 to ubuntu/natty

Imported using git-ubuntu import.

Changelog parent: 32ca6210b54dd8699edeea521d31257c1c96a66e

New changelog entries:
  * LanguageSelector/gtk/GtkLanguageSelector.py: Fix CONTROL_MASK constant.
    This brings back Ctrl+W to close the window. (LP: #732484)

32ca621... by Gunnar Hjalmarsson on 2011-03-09

Import patches-unapplied version 0.25 to ubuntu/natty

Imported using git-ubuntu import.

Changelog parent: 12001af6b1debd73afc960dd404388ba89b0fabb

New changelog entries:
  * data/LanguageSelector.ui:
    - Reinsertion of tooltips that were dropped in version 0.6.3.

12001af... by Martin Pitt on 2011-03-08

Import patches-unapplied version 0.24 to ubuntu/natty

Imported using git-ubuntu import.

Changelog parent: 44215cc392d70277bcf7004a2a41c765fe252f43

New changelog entries:
  * debian/rules: Drop NO_PKG_MANGLE. This is now fixed properly in
    pkgbinarymangler, and this fixes LP translations import.