ubuntu/+source/ktorrent:applied/ubuntu/focal

Last commit made on 2019-09-15
Get this branch:
git clone -b applied/ubuntu/focal https://git.launchpad.net/ubuntu/+source/ktorrent
Members of Ubuntu Server Dev import team can upload to this branch. Log in for directions.

Branch merges

Branch information

Name:
applied/ubuntu/focal
Repository:
lp:ubuntu/+source/ktorrent

Recent commits

e80e74a... by Pino Toscano <email address hidden> on 2019-09-14

Import patches-applied version 5.1.2-1 to applied/ubuntu/eoan-proposed

Imported using git-ubuntu import.

Changelog parent: 418d791cb17ffa711ad8c5b1560403d6a65ffa10
Unapplied parent: 38f1efbc44650352bccc182d8eb56d569d3c31ee

New changelog entries:
  * Team upload.
  * New upstream release.
  * Remove unused plasma-widget-ktorrent.install file.
  * Drop the migration from ktorrent-dbg, no more needed after two Debian
    stable releases.
  * Bump the libktorrent-dev build dependency to 2.1.1, to make sure to build
    against the newer version.
  * Bump Standards-Version to 4.4.0, no changes required.

38f1efb... by Pino Toscano <email address hidden> on 2019-09-14

Import patches-unapplied version 5.1.2-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: a43240616da1bdf004350ba95bf506b7ab1fbcd3

New changelog entries:
  * Team upload.
  * New upstream release.
  * Remove unused plasma-widget-ktorrent.install file.
  * Drop the migration from ktorrent-dbg, no more needed after two Debian
    stable releases.
  * Bump the libktorrent-dev build dependency to 2.1.1, to make sure to build
    against the newer version.
  * Bump Standards-Version to 4.4.0, no changes required.

418d791... by Pino Toscano <email address hidden> on 2018-09-04

Import patches-applied version 5.1.1-1 to applied/ubuntu/cosmic-proposed

Imported using git-ubuntu import.

Changelog parent: 30689c35b533062c1ae267c3d199a0fbbe293188
Unapplied parent: a43240616da1bdf004350ba95bf506b7ab1fbcd3

New changelog entries:
  * Team upload.
  * New upstream release:
    - fixes build with Qt >= 5.11 (Closes: #907328)
  * Update the patches:
    - upstream_QTimer-may-not-be-an-incomplete-type-as-it-is-used-a.patch:
      drop, backported from upstream
  * Remove the libkf5service-dev build dependency, no more needed.
  * Update Vcs-* fields.
  * Bump Standards-Version to 4.2.1, no changes required.

a432406... by Pino Toscano <email address hidden> on 2018-09-04

Import patches-unapplied version 5.1.1-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 5e05ba372036b400814bbfc8f90365f1f6aa1516

New changelog entries:
  * Team upload.
  * New upstream release:
    - fixes build with Qt >= 5.11 (Closes: #907328)
  * Update the patches:
    - upstream_QTimer-may-not-be-an-incomplete-type-as-it-is-used-a.patch:
      drop, backported from upstream
  * Remove the libkf5service-dev build dependency, no more needed.
  * Update Vcs-* fields.
  * Bump Standards-Version to 4.2.1, no changes required.

30689c3... by Pino Toscano <email address hidden> on 2018-04-28

Import patches-applied version 5.1.0-3 to applied/ubuntu/cosmic-proposed

Imported using git-ubuntu import.

Changelog parent: da01a017f10b20ac1f816d506d54916c1e1e7977
Unapplied parent: 2e10a8f8d094a4dc44c4b204b9c97f1006a838ac

New changelog entries:
  * Team upload.
  * Backport the upstream commit 672c5076de7e3a526d9bdbb484a69e9386bc49f8 to
    include <QTimer> where needed; patch
    upstream_QTimer-may-not-be-an-incomplete-type-as-it-is-used-a.patch.
    (Closes: #897113)
  * Switch Vcs-* fields to salsa.debian.org.
  * Bump the debhelper compatibility to 11:
    - bump the debhelper build dependency to 11~
    - bump compat to 11
    - remove --parallel for dh, as now done by default
  * Switch from dh_install to dh_missing for --fail-missing.
  * Remove trailing whitespaces in changelog.
  * Bump Standards-Version to 4.1.4, no changes required.
  * Switch watch file to https.

2e10a8f... by Pino Toscano <email address hidden> on 2018-04-28

[PATCH] QTimer may not be an incomplete type as it is used as a

Gbp-Pq: upstream_QTimer-may-not-be-an-incomplete-type-as-it-is-used-a.patch.

5e05ba3... by Pino Toscano <email address hidden> on 2018-04-28

Import patches-unapplied version 5.1.0-3 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 839be3b8de15d700828c6d04cb41eb8cbdae5e9f

New changelog entries:
  * Team upload.
  * Backport the upstream commit 672c5076de7e3a526d9bdbb484a69e9386bc49f8 to
    include <QTimer> where needed; patch
    upstream_QTimer-may-not-be-an-incomplete-type-as-it-is-used-a.patch.
    (Closes: #897113)
  * Switch Vcs-* fields to salsa.debian.org.
  * Bump the debhelper compatibility to 11:
    - bump the debhelper build dependency to 11~
    - bump compat to 11
    - remove --parallel for dh, as now done by default
  * Switch from dh_install to dh_missing for --fail-missing.
  * Remove trailing whitespaces in changelog.
  * Bump Standards-Version to 4.1.4, no changes required.
  * Switch watch file to https.

da01a01... by Pino Toscano <email address hidden> on 2017-09-05

Import patches-applied version 5.1.0-2 to applied/ubuntu/artful-proposed

Imported using git-ubuntu import.

Changelog parent: 28684e0d6c0b3d1ee5022adde8935984a92de67d
Unapplied parent: 839be3b8de15d700828c6d04cb41eb8cbdae5e9f

New changelog entries:
  * Team upload.
  * Upload to unstable.
  * Team upload.
  * New upstream release: (Closes: #821180)
    - the plugin system of Frameworks does not use sycoca anymore
      (Closes: #504271)
    - fixes a download order bug in queue (Closes: #763902)
    - the ipfilter plugin updates correctly from compressed files
      (Closes: #767218) (LP: #1207589)
    - switches from Qt4 (using QtWebKit) to Frameworks (Closes: #784487)
    - the switch to KF5 makes the scripting plugin work again, as krosspython
      was already switched to KF5 (Closes: #832547)
    - the search line edit is reset when closing it (Closes: #859250)
  * Update the build dependencies following the port to Frameworks:
    - remove libqt4-dev, kdelibs5-dev, libphonon-dev, kdepimlibs5-dev, and
      libqtwebkit-dev
    - add extra-cmake-modules, qtbase5-dev, qtscript5-dev, libphonon4qt5-dev,
      libphonon4qt5experimental-dev, libkf5archive-dev, libkf5completion-dev,
      libkf5config-dev, libkf5configwidgets-dev, libkf5coreaddons-dev,
      libkf5crash-dev, libkf5dbusaddons-dev, libkf5dnssd-dev,
      libkf5doctools-dev, libkf5i18n-dev, libkf5iconthemes-dev, libkf5kio-dev,
      libkf5itemviews-dev, libkf5notifications-dev, libkf5notifyconfig-dev,
      libkf5kcmutils-dev, libkf5parts-dev, libkf5plotting-dev,
      libkf5service-dev, libkf5solid-dev, libkf5textwidgets-dev,
      libkf5widgetsaddons-dev, libkf5windowsystem-dev, libkf5xmlgui-dev,
      libkf5webkit-dev, kross-dev, and libkf5syndication-dev
  * Update the patches:
    - dont_link_with_kutils.patch: drop, obsolete
    - upstream_Properly-support-x-scheme-handler-magnet-mimetype-an.patch:
      drop, backported from upstream
    - upstream_webinterface-rename-major-minor-to-major_version-min.patch:
      drop, backported from upstream
  * Use the right dh addon:
    - switch from kde to kf5 dh addon
    - bump the pkg-kde-tools build dependency to >= 0.15.16
  * Bump the libktorrent-dev build dependency to >= 2.1.
  * Update install files.
  * Update Vcs-Browser field.
  * Switch Homepage away from the dead ktorrent.org. (Closes: #837216)
  * Call dh_install with --fail-missing, so nothing is accidentally left
    uninstalled.
  * Update lintian overrides.
  * Remove obsolete not-installed file.
  * Suggest geoip-database, even if libgeoip1 already recommends it.
    (Closes: #778813)
  * Update the flags for cmake:
    - drop -DCMAKE_USE_RELATIVE_PATHS=ON, obsolete since cmake 3.2
    - switch -DKDE4_BUILD_TESTS=false to -DBUILD_TESTING=OFF, which is what
      ECM provides
  * Remove the libx11-dev build dependency, no more needed.
  * Drop all the pre-Jessie replaces/breaks.
  * Bump the cmake build dependency to >= 2.8.12.
  * Bump Standards-Version to 4.1.0, no changes required.

839be3b... by Pino Toscano <email address hidden> on 2017-09-05

Import patches-unapplied version 5.1.0-2 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 1ac820c87e8f33e9d3bf825b4e47691be798a1cb

New changelog entries:
  * Team upload.
  * Upload to unstable.

1ac820c... by Pino Toscano <email address hidden> on 2017-09-01

Import patches-unapplied version 5.1.0-1 to debian/experimental

Imported using git-ubuntu import.

Changelog parent: 05074f7b806453339f699014192962ae279d97b3

New changelog entries:
  * Team upload.
  * New upstream release: (Closes: #821180)
    - the plugin system of Frameworks does not use sycoca anymore
      (Closes: #504271)
    - fixes a download order bug in queue (Closes: #763902)
    - the ipfilter plugin updates correctly from compressed files
      (Closes: #767218) (LP: #1207589)
    - switches from Qt4 (using QtWebKit) to Frameworks (Closes: #784487)
    - the switch to KF5 makes the scripting plugin work again, as krosspython
      was already switched to KF5 (Closes: #832547)
    - the search line edit is reset when closing it (Closes: #859250)
  * Update the build dependencies following the port to Frameworks:
    - remove libqt4-dev, kdelibs5-dev, libphonon-dev, kdepimlibs5-dev, and
      libqtwebkit-dev
    - add extra-cmake-modules, qtbase5-dev, qtscript5-dev, libphonon4qt5-dev,
      libphonon4qt5experimental-dev, libkf5archive-dev, libkf5completion-dev,
      libkf5config-dev, libkf5configwidgets-dev, libkf5coreaddons-dev,
      libkf5crash-dev, libkf5dbusaddons-dev, libkf5dnssd-dev,
      libkf5doctools-dev, libkf5i18n-dev, libkf5iconthemes-dev, libkf5kio-dev,
      libkf5itemviews-dev, libkf5notifications-dev, libkf5notifyconfig-dev,
      libkf5kcmutils-dev, libkf5parts-dev, libkf5plotting-dev,
      libkf5service-dev, libkf5solid-dev, libkf5textwidgets-dev,
      libkf5widgetsaddons-dev, libkf5windowsystem-dev, libkf5xmlgui-dev,
      libkf5webkit-dev, kross-dev, and libkf5syndication-dev
  * Update the patches:
    - dont_link_with_kutils.patch: drop, obsolete
    - upstream_Properly-support-x-scheme-handler-magnet-mimetype-an.patch:
      drop, backported from upstream
    - upstream_webinterface-rename-major-minor-to-major_version-min.patch:
      drop, backported from upstream
  * Use the right dh addon:
    - switch from kde to kf5 dh addon
    - bump the pkg-kde-tools build dependency to >= 0.15.16
  * Bump the libktorrent-dev build dependency to >= 2.1.
  * Update install files.
  * Update Vcs-Browser field.
  * Switch Homepage away from the dead ktorrent.org. (Closes: #837216)
  * Call dh_install with --fail-missing, so nothing is accidentally left
    uninstalled.
  * Update lintian overrides.
  * Remove obsolete not-installed file.
  * Suggest geoip-database, even if libgeoip1 already recommends it.
    (Closes: #778813)
  * Update the flags for cmake:
    - drop -DCMAKE_USE_RELATIVE_PATHS=ON, obsolete since cmake 3.2
    - switch -DKDE4_BUILD_TESTS=false to -DBUILD_TESTING=OFF, which is what
      ECM provides
  * Remove the libx11-dev build dependency, no more needed.
  * Drop all the pre-Jessie replaces/breaks.
  * Bump the cmake build dependency to >= 2.8.12.
  * Bump Standards-Version to 4.1.0, no changes required.