ubuntu/+source/keystone:ubuntu/saucy-proposed

Last commit made on 2014-04-17
Get this branch:
git clone -b ubuntu/saucy-proposed https://git.launchpad.net/ubuntu/+source/keystone
Members of Ubuntu Server Dev import team can upload to this branch. Log in for directions.

Branch merges

Branch information

Name:
ubuntu/saucy-proposed
Repository:
lp:ubuntu/+source/keystone

Recent commits

3b07e1a... by Corey Bryant on 2014-04-04

Import patches-unapplied version 1:2013.2.3-0ubuntu1 to ubuntu/saucy-proposed

Imported using git-ubuntu import.

Changelog parent: 04869b0b9248682dd646d76aa34a49fc5a8bf362

New changelog entries:
  * Resynchronize with stable/havana (b85a531) (LP: #1302575):
    - [a96d1a4] User a more accurate max_delay for reconnects
    - [a120f25] Fix issue deleting ec2-credentials as non-admin user
    - [181c3c1] SQLAlchemy Change to support more strict dialect checking
    - [b6f0e26] Ensure tokens are added to both Trustor and Trustee indexes
    - [b85a531] Fix list_projects_for_endpoint failed bug

04869b0... by Chuck Short on 2014-02-25

Import patches-unapplied version 1:2013.2.2-0ubuntu1 to ubuntu/saucy-proposed

Imported using git-ubuntu import.

Changelog parent: e6aa233bf5258dfa9e9fc5cca816fcd1cb90bf35

New changelog entries:
  [ Chuck Short ]
  * Resynchronize with stable/havana (c22f2ed) (LP: #1284643):
    - [cecee8e] Keystone doesn't handle UTF8 in exceptions LP: 1253905
    - [2e9782b] Keystone doesn't handle UTF8 in exceptions LP: 1253905
    - [1091445] Have tox use pip upgrade when installing
    - [2724951] Orphan exchanges in Qpid and lack of option for making queues
      [un]durable LP: 1178375
    - [a5c7d23] List Trusts generates HTTP Error 500 LP: 1245590
    - [bd23600] publish_errors cfg option is broken LP: 1240349
    - [987e18e] Adds fixture package from oslo
    - [73968f7] Some Python requirements are not hosted on PyPI LP: 1266513
    - [9056b66] keystone.token.backends.sql list_revoked_tokens performs very
      poorly LP: 1253755
    - [c22f2ed] _update_user_list_with_cas causes significant overhead (when
      using memcached as token store backend) LP: 1251123
  [ James Page ]
  * d/control: Add new BD on python-fixtures.

e6aa233... by Adam Gandelman on 2013-12-18

Import patches-unapplied version 1:2013.2.1-0ubuntu1 to ubuntu/saucy-proposed

Imported using git-ubuntu import.

Changelog parent: 5a19cd2995cce017edfdae2e36228e8d25e5539e

New changelog entries:
  * Resynchronize with stable/havana (03ed8c3) (LP: #1262788):
    - [e6adb2f] Opening stable/havana
    - [4221b60] Removing role adds role with LDAP backend LP: 1242855
    - [3c25be5] Update memcache to match global requirements for stable/havana
    - [d927273] Keystone tests determine rootdir relative to pwd LP: 1241198
    - [64ac189] Updated from global requirements
    - [03ed8c3] [OSSA 2013-032] Keystone trust circumvention through EC2-style
      tokens (CVE-2013-6391) LP: 1242597
  * Dropped patches, applied upstream:
    - debian/patches/CVE-2013-4477.patch: [4221b60]
    - debian/patches/CVE-2013-6391.patch: [03ed8c3]
  * debian/patches/fix-ubuntu-tests.patch: Update to skip a test introduced
    with [03ed8c3] that requires a more recent version of
    python-keystoneclient.
  * debian/patches/revert-stable-havana-requirements.patch: Revert
    version bumps to dependencies in stable/havana back to what was
    shipped with Saucy.

5a19cd2... by Jamie Strandboge on 2013-12-19

Import patches-unapplied version 1:2013.2-0ubuntu1.2 to ubuntu/saucy-security

Imported using git-ubuntu import.

Changelog parent: 0855af80bf307f1ad6f2e5078a588a86976f6ad0

New changelog entries:
  * SECURITY UPDATE: Keystone trust circumvention through EC2-style tokens
    - debian/patches/CVE-2013-6391.patch: addjust to store the trust_id with
      the ec2 keypair and pass this with metadata when requesting v2 token
    - CVE-2013-6391
    - LP: #1242597

0855af8... by Jamie Strandboge on 2013-11-05

Import patches-unapplied version 1:2013.2-0ubuntu1.1 to ubuntu/saucy-security

Imported using git-ubuntu import.

Changelog parent: 2b013119ff8bb6fee4cd85d22787f91daf92519d

New changelog entries:
  * SECURITY UPDATE: don't add role when attempting to remove a non-existent
    role
    - debian/patches/CVE-2013-4477.patch: raise RoleNotFound with exception
      ldap.NO_SUCH_OBJECT
    - CVE-2013-4477
    - LP: #1242855

2b01311... by Chuck Short on 2013-10-17

Import patches-unapplied version 1:2013.2-0ubuntu1 to ubuntu/saucy-proposed

Imported using git-ubuntu import.

Changelog parent: a4b1114a2b8636b5e9575f3f67cea69022ef344b

New changelog entries:
  * New upstream release (LP: #1236462).

a4b1114... by Chuck Short on 2013-10-16

Import patches-unapplied version 1:2013.2~rc4-0ubuntu1 to ubuntu/saucy-proposed

Imported using git-ubuntu import.

Changelog parent: 34b06a776e5befc119eda3c7ce487595a67f00f3

New changelog entries:
  * New upstream release candidate (LP: #1240592).

34b06a7... by James Page on 2013-10-16

Import patches-unapplied version 1:2013.2~rc3-0ubuntu1 to ubuntu/saucy-proposed

Imported using git-ubuntu import.

Changelog parent: 9cc1fa5dfc3f40ebd061f6875a71daa7a901a9cd

New changelog entries:
  * New upstream release candidate (LP: #1240254).

9cc1fa5... by Chuck Short on 2013-10-15

Import patches-unapplied version 1:2013.2~rc2-0ubuntu1 to ubuntu/saucy-proposed

Imported using git-ubuntu import.

Changelog parent: 4879a81dc622457275d9ecc104f7b3c955f9a5b1

New changelog entries:
  * New upstream release candidate. (LP: #1239156)

4879a81... by Chuck Short on 2013-10-02

Import patches-unapplied version 1:2013.2~rc1-0ubuntu1 to ubuntu/saucy-proposed

Imported using git-ubuntu import.

Changelog parent: 3a6b036198280bc690a1474353cfed642addea74

New changelog entries:
  * New upstream version.
  * debian/control:
    - Add versioned dependencies to python-pbr, python-dogpile.cache,
      python-oslo.config, python-webob, python-pam, python-sqlalchemy,
      python-testtools, and python-requests.
    - Added python-greenlet, python-requests, python-netifaces,
      and python-setuptools as a build dependency.
    - Dropped python-swift, python-unittest, python-d2to1,
      as a build dependency.
    - Bumped versioned depends for python-keystoneclient.
  * debian/patches/disable-oauth2.patch: Refreshed