ubuntu/+source/kdesudo:ubuntu/lucid-updates

Last commit made on 2011-02-15
Get this branch:
git clone -b ubuntu/lucid-updates https://git.launchpad.net/ubuntu/+source/kdesudo
Members of Ubuntu Server Dev import team can upload to this branch. Log in for directions.

Branch merges

Branch information

Name:
ubuntu/lucid-updates
Repository:
lp:ubuntu/+source/kdesudo

Recent commits

e2bc6cf... by Felix Geyer on 2011-02-04

Import patches-unapplied version 3.4.2.3-0ubuntu1.1 to ubuntu/lucid-proposed

Imported using git-ubuntu import.

Changelog parent: d8741e6550d0a741e1c7c4df9afa1f028f4e58f3

New changelog entries:
  * Fix encoding of non-ASCII passwords. (LP: #400851)
    - kdesudo/kdesudo.cpp: replace toLatin1() calls with toLocal8Bit().

d8741e6... by Harald Sitter on 2009-10-27

Import patches-unapplied version 3.4.2.3-0ubuntu1 to ubuntu/lucid

Imported using git-ubuntu import.

Changelog parent: cf7103256a8cc5aeef9ca21e1783f3da523c2b5f

New changelog entries:
  * Add --desktop cmd line option to manually specify the desktop file used for
    resolving name and icon

cf71032... by Harald Sitter on 2009-09-15

Import patches-unapplied version 3.4.2.2-0ubuntu1 to ubuntu/karmic

Imported using git-ubuntu import.

Changelog parent: 6faf1bc243193fde773a2918174bb5e7cbf440b6

New changelog entries:
  [ Florian Reinhard ]
  * New upstream release
    - Closes LP: #422919 set bugAddress to lp
  [ Harald Sitter ]
  * Drop phony dpkg-divert
  * Introduce update-alternatives for kdesu vs. kdesudo (LP: #345776)
  * kdesudo pre-depends -runtime while -runtime conflicts and breaks kdesudo,
    this causes an intermediate removal of kdesudo until -runtime is fully
    configured, in addition to that -runtime will remove the kdesu diversion.
    All in all those 2 features should prevent any issue.
  * Replace CDBS' kde4.mk with kde.mk from pkg-kde-tools

6faf1bc... by Didier Raboud on 2009-08-04

Import patches-unapplied version 3.4.2.1-1ubuntu1 to ubuntu/karmic

Imported using git-ubuntu import.

Changelog parent: d0caed596282033ae48e662710bf837e3367ac30

New changelog entries:
  * New upstream release.
  * Merge Debian packaging stuff:
    - Merge debian/changelog entries.
    - Bump Standards to 3.8.2.

d0caed5... by Didier Raboud on 2009-08-04

Import patches-unapplied version 3.4.2.1-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: ef9b15ae6d08c6ae4d3494503ff95ec9b3279197

New changelog entries:
  * New upstream release.
    - Closes: #525292 way better: Use QProcess built-in pipes and get rid of the
      hackish shell.
    - Urgency high for re-fixing an RC bug.

ef9b15a... by Didier Raboud on 2009-08-03

Import patches-unapplied version 3.4.2-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 467f409a8a9175756989eed8b1282bbf9852ecb9

New changelog entries:
  * New upstream release.
    - Avoids using the now disabled SECURITY X extension (Closes: #525292),
      thanks to upstream inclusion of a Debian proposed patch.
    - Set high urgency for fixing an RC bug.
  * Bump Standards to 3.8.2.

467f409... by Didier Raboud on 2009-04-16

Import patches-unapplied version 3.4.1-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: e16d61fb58b662ebbd7f2ec0a5369c905e1add02

New changelog entries:
  * New upstream release for KDE 4 (Closes: #505858)
  * debian/rules
    - Rewrite from scratch using cdbs.
    - Write get-orig-source and print-version
  * debian/watch Add
  * debian/copyright
    - Add copyright holder of kdesudo/kcookie.cpp.
    - Update copyright paths (do not point to symlinks to satisfy pedantic
      lintian).
  * debian/control
    - Add Vcs-* fields.
    - Adapt Build-Depends to new upstream (migration to KDE 4, get rid of
      automake, autoconf and libtool, but gain cmake).
  * debian/{postrm,postinst}
    - Update to new location of kdesu in KDE 4.
  * debian/preinst
    - Add to manage update from KDE 3.
  * Manpage and translations (from Ubuntu/Launchpad/Rosetta) are now in the
    orig tarball. This was made on request by upstream (Anthony Mercantate).
    Many thanks!
  * Add two lintian overrides for diversion-for-unknown-file.
    The diversion is done on purpose and conditionally.
  * Acknowledge NMU. Thanks Christian¬†!
  * Fix "[INTL:ja] please add Japanese po-debconf template translation
    (ja.po)", thanks to Hideki Yamane (Closes: #510713)
  * Bump Standards to 3.8.1. No other changes needed.

e16d61f... by Christian Perrier on 2008-09-19

Import patches-unapplied version 2.4-1.1 to debian/lenny

Imported using git-ubuntu import.