ubuntu/+source/javatools:applied/ubuntu/saucy-devel

Last commit made on 2012-10-02
Get this branch:
git clone -b applied/ubuntu/saucy-devel https://git.launchpad.net/ubuntu/+source/javatools
Members of Ubuntu Server Dev import team can upload to this branch. Log in for directions.

Branch merges

Branch information

Name:
applied/ubuntu/saucy-devel
Repository:
lp:ubuntu/+source/javatools

Recent commits

bddb7e7... by Colin Watson on 2012-10-02

Import patches-applied version 0.43ubuntu2 to applied/ubuntu/quantal

Imported using git-ubuntu import.

Changelog parent: 61d866a49cf29fe389beb99a94cda5e00e391df8
Unapplied parent: bc4bda165b232b27f201926e9c4fa500d2213d82

New changelog entries:
  * jh_installeclipse: Allow any installed package to provide a .jar
    dependency, not just those with desired-state install.

bc4bda1... by Colin Watson on 2012-10-02

Import patches-unapplied version 0.43ubuntu2 to ubuntu/quantal

Imported using git-ubuntu import.

Changelog parent: 94cacab17681aa2d6e5c7fe32019333f96a8f97d

New changelog entries:
  * jh_installeclipse: Allow any installed package to provide a .jar
    dependency, not just those with desired-state install.

61d866a... by James Page on 2012-06-22

Import patches-applied version 0.43ubuntu1 to applied/ubuntu/quantal

Imported using git-ubuntu import.

Changelog parent: 1404cb6ca9c47aac97768b72ec27daa3f9e9af3c
Unapplied parent: 94cacab17681aa2d6e5c7fe32019333f96a8f97d

New changelog entries:
  * Merge from Debian unstable. Remaining changes:
    - Pre-generate tutorial.html; remove the build dependency on markdown.

94cacab... by James Page on 2012-06-22

Import patches-unapplied version 0.43ubuntu1 to ubuntu/quantal

Imported using git-ubuntu import.

Changelog parent: 0f354dd90ad554dafb102accfc796381a5d41b4a

New changelog entries:
  * Merge from Debian unstable. Remaining changes:
    - Pre-generate tutorial.html; remove the build dependency on markdown.

1404cb6... by Niels Thykier on 2012-06-20

Import patches-applied version 0.43 to applied/debian/sid

Imported using git-ubuntu import.

Changelog parent: 687be0c6c216e639525e15ffaba862e781fe37d1
Unapplied parent: 0f354dd90ad554dafb102accfc796381a5d41b4a

New changelog entries:
  * Make jh_build pass -source 1.5 by default to javadoc if
    no -source parameter is explicitly given.
  * Make jh_build pass -target 1.5 by default to javac if
    neither -source nor -target is explicitly given.

0f354dd... by Niels Thykier on 2012-06-20

Import patches-unapplied version 0.43 to debian/sid

Imported using git-ubuntu import.

Changelog parent: b267ed25a4d0d68e33cfa8de7cf605b2618a2fe1

New changelog entries:
  * Make jh_build pass -source 1.5 by default to javadoc if
    no -source parameter is explicitly given.
  * Make jh_build pass -target 1.5 by default to javac if
    neither -source nor -target is explicitly given.

687be0c... by Niels Thykier on 2012-06-19

Import patches-applied version 0.42 to applied/debian/sid

Imported using git-ubuntu import.

Changelog parent: 017cde943d0caae53c7d2d5662b134bbf431dc32
Unapplied parent: b267ed25a4d0d68e33cfa8de7cf605b2618a2fe1

New changelog entries:
  * Add support for Java7 in jh_depends. The jvm "open" now
    defaults to any OpenJDK version. The "open6" and "open7"
    values can be used to depend on a specific one.

b267ed2... by Niels Thykier on 2012-06-19

Import patches-unapplied version 0.42 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 101095fcce4bb2351844b78f557d2c248a94cccb

New changelog entries:
  * Add support for Java7 in jh_depends. The jvm "open" now
    defaults to any OpenJDK version. The "open6" and "open7"
    values can be used to depend on a specific one.

017cde9... by Niels Thykier on 2012-03-13

Import patches-applied version 0.41 to applied/debian/sid

Imported using git-ubuntu import.

Changelog parent: e00cd3f98cfa3d76e87691a6f39f7887d9447da7
Unapplied parent: 101095fcce4bb2351844b78f557d2c248a94cccb

New changelog entries:
  [ Sylvestre Ledru ]
  * jh_makepkg:
    - Switch the OpenJDK6 path to the multiarch one.
    - Remove the sun-java6 support since it has been
      removed from the archive
    - Provide the support for OpenJDK 7
    - Create the new package under the source format 3.0
    - -doc packages are now in the doc section.
  [ Niels Thykier ]
  * Produce a better error message when a non-existent Jar file is
    passed to jh_manifest.
  * Try to parse arguments passed via -O for jh_lib.sh as regular
    options, but ignore them if they are unknown. Previously, -O
    options was silently ignored.
  * Remove support for using the "sun" (and "sun6") JVM with
    jh_depends, as Debian is no longer ships the Sun/Oracle Java.
  * Bump libarchive-zip-perl depends as 1.30.5 was still affected
    by #654899.
  * jh_depends no longer emits dependencies with java-runtime or
    java2-runtime. The minimum generated dependency is now
    java5-runtime.
  * Corrected class version calculation on big-endian architectures.
    Thanks to Kai Ruschenburg for the report and the correction.
    (Closes: #661632)
  * Use Standards-Versions 3.9.3 and the new DEP-5 URI in jh_makepkg
    for newly generated packages.
  * Bumped Standards-Versions 3.9.3 - no changes required.
  * Ensure the test suite fails if the java-arch.sh test fails.

101095f... by Niels Thykier on 2012-03-13

Import patches-unapplied version 0.41 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 5c4f611f260f540e72a19e420f9af9f98c6bdaa7

New changelog entries:
  [ Sylvestre Ledru ]
  * jh_makepkg:
    - Switch the OpenJDK6 path to the multiarch one.
    - Remove the sun-java6 support since it has been
      removed from the archive
    - Provide the support for OpenJDK 7
    - Create the new package under the source format 3.0
    - -doc packages are now in the doc section.
  [ Niels Thykier ]
  * Produce a better error message when a non-existent Jar file is
    passed to jh_manifest.
  * Try to parse arguments passed via -O for jh_lib.sh as regular
    options, but ignore them if they are unknown. Previously, -O
    options was silently ignored.
  * Remove support for using the "sun" (and "sun6") JVM with
    jh_depends, as Debian is no longer ships the Sun/Oracle Java.
  * Bump libarchive-zip-perl depends as 1.30.5 was still affected
    by #654899.
  * jh_depends no longer emits dependencies with java-runtime or
    java2-runtime. The minimum generated dependency is now
    java5-runtime.
  * Corrected class version calculation on big-endian architectures.
    Thanks to Kai Ruschenburg for the report and the correction.
    (Closes: #661632)
  * Use Standards-Versions 3.9.3 and the new DEP-5 URI in jh_makepkg
    for newly generated packages.
  * Bumped Standards-Versions 3.9.3 - no changes required.
  * Ensure the test suite fails if the java-arch.sh test fails.